multi GPU OPENGL ROP

   769   3   0
User Avatar
Member
15 posts
Joined: Feb. 2015
Offline
Hi,

in the final stages of this project, the deadline draws nearer, which is when rendering comes into play.

i am rendering in opengl with pdg.
i want to make use of more gpu's, and currently am trying that via deadline. I have two workers on my machine each with its own GPU assigned. pdg submits all the jobs, unfortunately, each worker picks up the same gpu.
can it be that the OpenGL ROP node doesnt support that?

another way i am looking into is using the enviroment variables to set an OGL device per task filtered range, unfortunately i couldnt find any variable other then OCL_DEVICETYPE.

is there a correct way to control the GPU assignment in PDG?
Edited by doodlemaker - June 8, 2022 06:59:46
User Avatar
Member
15 posts
Joined: Feb. 2015
Offline
please see the image below.

the deadline scheduler is set to use gpu 0,1
the worker is set to have GPU1
the worker log validates that GPU0 wont be used

looking at the task manager, only GPU0 is being used...

could this be a bug? and would that be on deadline's side? or is there perhaps on houdini not being accepted?
Edited by doodlemaker - June 8, 2022 17:18:46

Attachments:
Capture.PNG (470.5 KB)

User Avatar
Staff
543 posts
Joined: May 2014
Offline
The Deadline parameters for setting GPU affinity only apply to Open CL jobs, and when rendering ROPs that expose a way to configure which GPU device to use (such as the Redshift ROP). The final GPU selection is exported to the $HOUDINI_OCL_DEVICENUMBER variable when the job is assigned to a machine. That parm won't have any affect on OpenGL jobs since the ROP itself doesn't have a way to configure which GPU to use.
User Avatar
Member
15 posts
Joined: Feb. 2015
Offline
hi
thanks for your clear reply.

i was always under the impression that deadline would start a process with the GPU the worker has assigned. sort of a seperate headless process with dedicated hardware.
i was trying out what could influence that behaviour.
this afternoon, for some unclear reason, the 2nd gpu kicked in, albeit the first didnt do anything. i dont know what the settings were anymore.

would it be possible to start a different houdini instance (headless or not) that can use a dedicated openGL card?
if i cant get it to work on deadline, perhaps just running 2 houdini instances would already suffice..
  • Quick Links