Karma render HDR environment texture?

   356   4   1
User Avatar
Member
5 posts
Joined: Aug. 2021
Offline
I've been exploring Solaris for a couple of weeks, love it!
But one problem I have is I can't get Karma to render out an environment texture background with domelight and HDR.
Redshift WILL render the HDR tex from the Solaris/Stage context. With Karma I just get the foreground and transparent background where the HDR tex should be seen.

I tried all options in Karma node.
I tried with a small 1k HDR.

The Karma (and Shadow) options are greyed out in domelight node.
The Karma options are greyed out in camera node.
There's no option to enable Karma in Edit>Preferences>Render, just Mantra, MaterialX, Renderman (which I don’t have) and Redshift.

And FWIW the Karma and Redshift settings are all greyed-out in the RenderGeometrySettings LOP as well. So I can't get at the Redshift Tesselation settings to get Displacement working in RS. (Works fine in karma.)

I suppose I could do a HDR background pass in Redshift, render the foreground objects WITH displacement in Karma, and comp the two together, but I'm interested in any feedback or advice!

Anyway, I'm sold on Solaris/USD, props to the SideFX team!
User Avatar
Member
5700 posts
Joined: Sept. 2011
Offline
Dome Light -> Karma tab -> Render Light Geometry
User Avatar
Member
5 posts
Joined: Aug. 2021
Offline
jsmack
Dome Light -> Karma tab -> Render Light Geometry
Thanks... but the problem is the Karma options in the LOP domelight node are all greyed out and I can't access them although I can see the (greyed out) Render Light Geometry checkbox. I'm running Houdini 19.0.622
Edited by norv2001 - yesterday 00:03:59
User Avatar
Member
5700 posts
Joined: Sept. 2011
Offline
norv2001
Thanks... but the problem is the Karma options in the LOP domelight node are all greyed out and I can't access them although I can see the (greyed out) Render Light Geometry checkbox. I'm running Houdini 19.0.622

They are grayed out when set to disabled. Turn them on with the little widget to the left. Change it from disabled to Set/Create.
User Avatar
Member
5 posts
Joined: Aug. 2021
Offline
jsmack
They are grayed out when set to disabled.
Ahaaaaaaaaaaaaaaaaaa!!!!!!!!!!!
Thanks so much @jsmack you just made my day! I had a suspicion it would be one innocuous little button right in front of me!
I'm only 10 months into Houdini. AND I'm disabled. Where's the widget that enables ME??
(We're allowed to laugh at our selves now and then... )
  • Quick Links