Fluid didn´t collision with Static Object

   777   4   0
User Avatar
Member
8 posts
Joined: April 2019
Offline
Hi, I have got a problem with a simulation.

I made a sphere that emits particles from it, very simple, but when I put a Static Object in my scene, these particles don´t collide with the object.

I attached here an image of this problem.

I use Houdini 19.0.657

Image Not Found
Edited by Willms - June 25, 2022 12:08:19

Attachments:
test.PNG (43.3 KB)
Viewport.PNG (1.9 MB)
simulation.PNG (35.0 KB)

User Avatar
Member
2253 posts
Joined: June 2008
Offline
The merge evaluates left-to-right. Rewire your inputs so the Static Object is on the left.
Using Houdini Indie 19.5.
Ubuntu 64GB Ryzen 16 core.
nVidia 3050RTX 8BG RAM.
User Avatar
Member
8 posts
Joined: April 2019
Offline
Hi enivob,
I rewired left-to-right and with a cube (polygon)it works well, but when I changes it for a custom mesh, I have the same problem:



Attachments:
Viewport.PNG (2.7 MB)
test.PNG (38.0 KB)
simulation.PNG (38.8 KB)

User Avatar
Member
2253 posts
Joined: June 2008
Offline
Yeah, you have to learn how to build your collision meshes to be "water-tight". The resoultion of the collision surface is based upon the particle separation value of the flip sim.
On the flipobject, activate the collision guide. This will give you a "true" representation of what your mesh derived collision object actually looks like. Turn off display mesh on the static object.
Edited by Enivob - June 25, 2022 12:41:38
Using Houdini Indie 19.5.
Ubuntu 64GB Ryzen 16 core.
nVidia 3050RTX 8BG RAM.
User Avatar
Member
8 posts
Joined: April 2019
Offline
Problem resolved

Thank you so much Enivob
Edited by Willms - June 25, 2022 14:34:40
  • Quick Links