Interior mapping on HDA

   793   4   1
User Avatar
Member
10 posts
Joined: Sept. 2013
Offline
Hi,

I am creating an HDA (Houdini Indie 19.0.652) to be used in Unreal 5.02.
When I add a material to the HDA it looks as expected but when I try an interior mapping shader ("the built in") there is a problem.
I have attached a gif showing the issue.

The first plane from the left is a standard plane (unreal primitive) and it behaves as expected.
The second plane is an fbx exported from Houdini, but generated from the same HDA that I am using in Unreal, it also looks fine.
The third is the HDA and the fourth is the baked HDA. As you can see it looks strange.

Have any one got any ideas how to fix this? It would be nice to be able to use the HDA directly in engine, without having to export an fbx.

Regards,
Johan

Attachments:
output_2022-07-01_01-20-37.gif (3.2 MB)

User Avatar
Member
1 posts
Joined: Oct. 2018
Offline
maybe you should set vertex attribute tangentu and tangentv: v@tangentu = set(0, 0, 0);v@tangentv = set(0, 0, 0)
User Avatar
Member
10 posts
Joined: Sept. 2013
Offline
Thanks Melt!

Following your advice made it work after I bake the HDA. Baking it makes both the baked result and the HDA work with the interior mapping.

Before it is baked (or if a parameter of the HDA is changed) it only shows the "x-axis". I have attached a gif showing the HDAin unreal. Does anyone know why it behaves like this?

Thanks,

/ Johan

Attachments:
output_2022-07-05_15-55-35.gif (6.7 MB)

User Avatar
Staff
524 posts
Joined: Sept. 2016
Offline
Hi,

Likely, this is because, by default, after cooking the plugin generates Proxy Meshes (note the Houdini Logo on top of it) and not Static Meshes.

Proxies are generated much faster, but don't have all the features SM have.

I'd assume that refining the proxy to Static Mesh also fixes the issue (right click > refine)
User Avatar
Member
10 posts
Joined: Sept. 2013
Offline
Hi dpernuit,

Thanks for the info, refine Houdini proxy meshes works perfect.
Out of curiosity, do you know why it is needed to set the tangentu and tangentv vertex attr to {0,0,0} to get the interior mapping to work?
  • Quick Links