Problem with Karma and materialX

   700   4   1
User Avatar
Member
5 posts
Joined: March 2020
Offline
Hello Magicians,


I am new to shading and have been doing some practice with the new MaterialX Standard Surface.

1- I am not sure why I get these artifacts on the rims and the glass. When I switch to XPU this resolves and is not present.

2- Another question I had was why is my glass not behaving as expected. It seems like it is very dark inside of the car, could it be that it is not letting enough light inside? How can I correct this?

Thank you in advance! Cheers!
User Avatar
Member
5 posts
Joined: March 2020
Offline
Here are the photos that I had to attach from the beginning

Attachments:
Screenshot 2022-08-08 173957.png (2.9 MB)
Screenshot 2022-08-08 174919.png (2.3 MB)

User Avatar
Member
356 posts
Joined: April 2018
Offline
Re: question number 2, try connecting a Karma Fake Caustics node after the glass material.
Watch Perceptarium on Amazon! https://www.amazon.com/dp/B0846GB3WG/ [www.amazon.com]

http://youtube.com/brianhanke [youtube.com]
http://twitter.com/brianhanke [twitter.com]
https://www.instagram.com/brianrhanke [www.instagram.com]
http://facebook.com/brianrhanke [facebook.com]
User Avatar
Member
6257 posts
Joined: Sept. 2011
Offline
da1to
1- I am not sure why I get these artifacts on the rims and the glass. When I switch to XPU this resolves and is not present.

Do you have UV coordinates that are just 0's?
User Avatar
Staff
334 posts
Joined: Sept. 2016
Offline
Hi, Can you please log a bug with your scene file? Thank you.
  • Quick Links