How to completely turn off bezier snapping in Curve2.0?

   271   2   0
User Avatar
Member
30 posts
Joined: June 2020
Offline
Is there any way to do this? Even in 19.5 it's still basically impossible to design a curve in 3d space unless I'm missing some combination of settings that need to be enabled or disabled.

I've tried all the snapping modes: axis aligned, camera plane, camera depth and using the transform handle (K) and no matter what the bezier handles always snap in some fashion making it impossible to adjust bezier handles from different viewpoints.

What am I missing here? Surely there must be a way to disable all forms of snapping?
Siavash Tehrani
Member
667 posts
Joined: July 2005
Online
Okay, as far as I can tell...

Draw your curve
Hit F to go into Edit Mode
Select a point to see some tangents
Hit K to toggle Transform Handles
SINGLE CLICK a tangent endpoint. Don't click-drag because that will just axis snap the tangent.
After you single-click and your handle has appeared you should be able to move it without any inadvertent snapping going on.


Yeah it sucks and is horribly error-prone. An RFE is probably in order.
User Avatar
Member
30 posts
Joined: June 2020
Offline
Wow thank you, the SINGLE CLICK is the secret sauce. Although this makes the UX slightly worse, at least it's actually usable.

This node would be the bomb-diggity if only there was a way to disable snapping while in Edit mode, since switching to a different handle in the first place seems kind of unnecessary.
  • Quick Links