Hide static object in dopnet from rendering

   1558   4   0
User Avatar
Member
11 posts
Joined: March 2022
Offline
Hello,
I have a simple setup with Vellum grain cube and sphere in the middle of it. When I play the simulation, the grains get pushed by the sphere and fly away as expected.
I am using Dopnet and I import the sphere using StaticObject and grain using VellumObject
However, when rendering the scene using Mantra to MPlay the big sphere is still visible in the render.
Can anybody please tell me how exactly can I stop this from happening?
I have searched the internet for a few hours to no avail.
I have included a .hip file so you can take a look.
Thanks a lot.

Attachments:
HideTheSphereStaticObject.hipnc (587.7 KB)

User Avatar
Member
1 posts
Joined: Feb. 2021
Offline
I believe you just turn off the display mode for the geo node of the sphere in obj level. It will be visible in the sim in the dop net but should be invisible in the render and outside the dopnet.
User Avatar
Member
575 posts
Joined: Nov. 2005
Offline
It is a good idea to import the dop objects back into sop level to render. there You can apply materials and You have finer control what You want to render.
User Avatar
Member
11 posts
Joined: March 2022
Offline
Thanks for the reply, hiding the geometry did not work.
Can you please look into the attached file?
I have already tried removing the display flag from the "HideThis" sphere as shown on image.
The dopnet is in the "box1" geometry.

Image Not Found

Image Not Found

Attachments:
Screenshot 2022-12-10 at 0.34.15.png (115.0 KB)

User Avatar
Member
11 posts
Joined: March 2022
Offline
I have found the solution.
The key is to type vel* into the object field of dopnet here is pdf guide and a sample file.

Image Not Found

Image Not Found
Edited by raketoplan - Dec. 11, 2022 14:46:12

Attachments:
hide-static-object.pdf (1.9 MB)
TheSphereStaticObjectHidden.hipnc (565.8 KB)

  • Quick Links