Loading file problem

   2629   0   0
User Avatar
63 posts
Joined: 7月 2005
I posted this over at 3dBuzz but thought I would like an answer from Sidefx or anyone who has an answer.

I had a file (a boat transformer) that I haven't worked on for about a month and tried to open it in version 6.1 and got a few errors on loading and part of my model was gone. So, it was suggested that I load it into the build that I initially worked in (which is 6.0). I decided to go back into the first build I had, 6.0.249, to make sure it would work half way decent. I still got some errors/warnings (different ones though) but I had some display flags off so I turned them on and saved and came back in and no errors/warnings and everything showed up. I know I have loaded a file with display flags off in the past with no problems!!!!! Another problem crept up though; I had grouped some primitives that had a transform appended to it for the animating, and the xform didn't recognize the group attached to it. I don't understand how this happened when it all worked long ago when I last worked on this. I had already started animating my boat and everything was working fine. Now I am going to have to really look at my file and fix things when I get back to it. I think this is a downfall of Houdini if you can't work on files made in an earlier build. What happens if you share your file with someone who has a later build? I can see if it was a totally new version (as version 5.5 is different than 6.0, I guess 6.0 is different than 6.1). Also, how can a file get ruined when it is just sitting minding its own business in your directory! I tried all my backup files in the 6.0.249 build with the same result. Maybe there is a problem with more than one build on your computer. Sorry for the rant but this is a major pain in the ??? in my view."

Now the continuation:

I took another look at my file and noticed that all my xforms that I had a group in front of, didn't work anymore. I will need to regroup everything (after I figure things out again; it's been awhile since I worked on this project) and re-align the transform sop etc. I am using the xform to animate the group and it doesn't anymore.

Does anyone have any idea what is happening here? If I finally get it working on my end, how will I know that it is going to work on Buzz's end after I hand my project in? After all, everything worked fine with it when I last worked on it (about a month ago) and now it doesn't. As I said, I get the same error on loadup with backup files I had on my other hard drive before the animating process. Could it be that there is a conflict with the different builds? I keep my files for version 6 in the same files directory (not version directory, I install the different builds in their own directories); I don't separate the files into different builds. Maybe I should separate them into different builds?????
  • Quick Links