speed difference of [cook frames as single work item] option

   369   4   3
User Avatar
Member
9 posts
Joined: 6月 2017
Offline
In ROP Fetch, there is a option named

If I turn off this option,render time become super slow

it takes 19min for 200images with simple simulation.

but if turn on this option, it take only 13 seconds

The result is totaly same with 200 images but duration is too different.

I don't understand why there is a huge difference.

there is the hip file below this post

thank you!
Edited by hamsteriscoming - 2020年2月8日 04:14:24

Attachments:
이미지 20200208_004.png (43.8 KB)
이미지 20200208_003.png (16.3 KB)
이미지 20200208_002.png (72.7 KB)
pdg_v01_02.hipnc (567.0 KB)

User Avatar
スタッフ
543 posts
Joined: 9月 2016
Offline
That option causes all the work to be done in one ‘batch’. This is usually a good option to use if the individual frames are fairly quick to cook because it eliminates the overhead of starting Houdini for each frame.
User Avatar
Member
9 posts
Joined: 6月 2017
Offline
chrisgreb
That option causes all the work to be done in one ‘batch’. This is usually a good option to use if the individual frames are fairly quick to cook because it eliminates the overhead of starting Houdini for each frame.

Thank you for answering

By the way, is there a way to get work items from exist files?

is so fast for render, so I thought

use this option first on first rop fetch node

and on second rop fetch node, change cache mode to

then I could get file already rendered to work items.

but when I did it, second node didn't get images but rendered same things again.

The reason that why I am trying this method, I want to use ffmpeg node after render.

but if I use option , I can't make video.

so I have to expand to seperated work items.

images are represents first and second node

sorry for my bad english

thank you

Attachments:
이미지 20200211_006.png (155.5 KB)
이미지 20200211_005.png (165.7 KB)

User Avatar
スタッフ
361 posts
Joined: 8月 2017
Offline
Enable the “All Frames in One Batch” option instead of the “Cook Frames as Single Work Item” option. (You will only need the first ROP Fetch when using this method).
User Avatar
Member
9 posts
Joined: 6月 2017
Offline
BrandonA
Enable the “All Frames in One Batch” option instead of the “Cook Frames as Single Work Item” option. (You will only need the first ROP Fetch when using this method).

thank you!
but that option doesn't work on rop fetch properly.
I used ropmantra node instead and it worked well
  • Quick Links