Houdini 19 on LInux help browser issue

   2002   17   5
User Avatar
Member
872 posts
Joined: 4月 2008
Offline
I can't get the help browser to show up in Fedora 35, it opens the window but nothing show up any tips?
Edited by mzigaib - 2022年3月12日 01:18:29

Attachments:
houdini_help.png (10.3 KB)

https://vimeo.com/user2163076 [vimeo.com]
User Avatar
Member
872 posts
Joined: 4月 2008
Offline
I already tried to disable the firewall and still the problem persists.

Anyone else having this issue?
https://vimeo.com/user2163076 [vimeo.com]
User Avatar
Member
872 posts
Joined: 4月 2008
Offline
So no one having issues with help browser on Linux?
https://vimeo.com/user2163076 [vimeo.com]
User Avatar
Member
25 posts
Joined: 5月 2019
Offline
You might be suffering from this issue
https://www.sidefx.com/forum/topic/82596/ [www.sidefx.com]
User Avatar
Member
872 posts
Joined: 4月 2008
Offline
monomon
You might be suffering from this issue
https://www.sidefx.com/forum/topic/82596/ [www.sidefx.com]
Thanks for the feedback!
I'll try that and keep you posted.
https://vimeo.com/user2163076 [vimeo.com]
User Avatar
Member
872 posts
Joined: 4月 2008
Offline
monomon
You might be suffering from this issue
https://www.sidefx.com/forum/topic/82596/ [www.sidefx.com]
It worked with the external browser thanks!
So the internal browser is busted on linux?
https://vimeo.com/user2163076 [vimeo.com]
User Avatar
Member
25 posts
Joined: 5月 2019
Offline
Actually we have it broken on Windows. Seems to be related to a specific version of Qt. I think it is caused by something in the environment, because it works on some machines.
jsmack
Member
6468 posts
Joined: 9月 2011
Offline
monomon
Actually we have it broken on Windows. Seems to be related to a specific version of Qt. I think it is caused by something in the environment, because it works on some machines.

It's worked all the linux and windows machines I've used.
jsmack
Member
6468 posts
Joined: 9月 2011
Offline
mzigaib
monomon
You might be suffering from this issue
https://www.sidefx.com/forum/topic/82596/ [www.sidefx.com]
It worked with the external browser thanks!
So the internal browser is busted on linux?

The internal browser works fine on Linux. Try disabling background indexing.

add this to the houdini.env:
HOUDINI_DISABLE_BACKGROUND_HELP_INDEXING=1
User Avatar
Member
872 posts
Joined: 4月 2008
Offline
jsmack
mzigaib
monomon
You might be suffering from this issue
https://www.sidefx.com/forum/topic/82596/ [www.sidefx.com]
It worked with the external browser thanks!
So the internal browser is busted on linux?

The internal browser works fine on Linux. Try disabling background indexing.

add this to the houdini.env:
HOUDINI_DISABLE_BACKGROUND_HELP_INDEXING=1

Thanks for the tip I'll try that.
https://vimeo.com/user2163076 [vimeo.com]
User Avatar
Member
872 posts
Joined: 4月 2008
Offline
jsmack
monomon
Actually we have it broken on Windows. Seems to be related to a specific version of Qt. I think it is caused by something in the environment, because it works on some machines.

It's worked all the linux and windows machines I've used.

I have it working on Windows 11 but not on Fedora 35 on a dual boot machine, which distro are you using?

That is the first time I see this happening on Fedora.
Edited by mzigaib - 2022年3月17日 13:52:47
https://vimeo.com/user2163076 [vimeo.com]
jsmack
Member
6468 posts
Joined: 9月 2011
Offline
mzigaib
jsmack
monomon
Actually we have it broken on Windows. Seems to be related to a specific version of Qt. I think it is caused by something in the environment, because it works on some machines.

It's worked all the linux and windows machines I've used.

I have it working on Windows 11 but not on Fedora 35 on a dual boot machine, which distro are you using?

That is the first time I see this happening on Fedora.

CENTOS 7.6
User Avatar
Member
25 posts
Joined: 5月 2019
Offline
It does not seem related to the OS. There are reports from Windows 10 and various Linux distros.

Btw we contacted support about this and here is their response:
We can't upgrade Qt to the latest version because Houdini follows the VFX Reference Platform, which specifies to use Qt 5.15.X. However, it looks like the fix is in Qt 5.15.4 so it is possible for us to upgrade to that version at some point. However, upgrading Qt in Houdini even to a minor version is non-trivial. We will not be able to upgrade Qt in Houdini 19.0 and maybe not even for the next Houdini release since we are already deep in the development cycle.

According to the fix's commit revision and the various bug reports, the problem seems specific to the language and locale you are using. You can try playing with setting the LANG variable as mentioned in the bug reports and see if that helps as a workaround. The other workaround is to use an external help browser and avoid the embedded help browser. You can do that by setting HOUDINI_EXTERNAL_HELP_BROWSER=1 in the environment.
User Avatar
Member
872 posts
Joined: 4月 2008
Offline
jsmack
mzigaib
monomon
You might be suffering from this issue
https://www.sidefx.com/forum/topic/82596/ [www.sidefx.com]
It worked with the external browser thanks!
So the internal browser is busted on linux?

The internal browser works fine on Linux. Try disabling background indexing.

add this to the houdini.env:
HOUDINI_DISABLE_BACKGROUND_HELP_INDEXING=1

Does not work.
https://vimeo.com/user2163076 [vimeo.com]
User Avatar
Member
378 posts
Joined: 12月 2006
Offline
Help browser still does not work on Linux. Ubuntu 22.04 LTS

Adding QTWEBENGINE_DISABLE_SANDBOX=1 env variable fixed it.
Edited by SreckoM - 2022年10月14日 08:36:07
User Avatar
Member
218 posts
Joined: 10月 2016
Offline
Works with Debian11 (as with most things)
Edited by SWest - 2022年10月14日 09:02:10
IT-teacher (8y) / just for fun TD & artist / Debian11 XFCE / Houdini / Zbrush (Wine) / Blender / Python / VNC / networks / two small kids / BSc CS:CG / Stockholm
User Avatar
Member
1814 posts
Joined: 11月 2006
Offline
SreckoM
Help browser still does not work on Linux. Ubuntu 22.04 LTS

Adding QTWEBENGINE_DISABLE_SANDBOX=1 env variable fixed it.
I run Linux Mint 21 which is based off Ubuntu 22.04 and setting that is definitely the only way I've found to get the help browser to work these days (Houdini 19.5)
Graham Thompson, Pipeline Things
ajz3d
Member
318 posts
Joined: 8月 2014
Offline
Many thanks for the HOUDINI_EXTERNAL_HELP_BROWSER=1tip. I can finally enjoy reading local docs on Firefox instead of waiting ages for the bundled browser to load each page, never load them at all, or simply freeze Houdini. I wish I had known about it earlier.
  • Quick Links