UE5.1 Houdini Engine build

   4746   9   0
User Avatar
Member
131 posts
Joined: 11月 2015
Online
Hello!

I compiled the 5.1 Unreal Engine from source.
Now I would like to recompile the Houdini Engine Plugin from source like explained here:
Rebuild Plugins Instructions [dev.epicgames.com]

but it errors out every time

can anyone help or point me in the right direction please?
User Avatar
Member
131 posts
Joined: 11月 2015
Online
here is the whole error / warnings list...
Edited by chf - 2022年8月2日 11:53:16

Attachments:
houdiniEnginePluginBuildFail.txt (134.2 KB)

User Avatar
Member
10 posts
Joined: 5月 2016
Offline
chf
here is the whole error / warnings list...
Did you figure out how make it works?
User Avatar
Member
131 posts
Joined: 11月 2015
Online
Matvey_Khamidulin
chf
here is the whole error / warnings list...
Did you figure out how make it works?

not quite..

someone was kind enough to update the source code but I still can't get it to compile

Git Hub 5.1 branch [github.com]
Edited by chf - 2022年8月8日 05:41:35
User Avatar
Member
10 posts
Joined: 5月 2016
Offline
chf
not quite..
Thanks. I compiled it in c+ project. Got a lot of errors but it works now
User Avatar
Member
131 posts
Joined: 11月 2015
Online
Matvey_Khamidulin
chf
not quite..
Thanks. I compiled it in c+ project. Got a lot of errors but it works now

could you share the plugin?
User Avatar
Member
10 posts
Joined: 5月 2016
Offline
chf
could you share the plugin?
sent you in privat message
User Avatar
Member
3 posts
Joined: 3月 2016
Offline
I tried building from a 5.0 source but ended up getting a bunch of:

Cannot open include file: 'UnrealObjectInputRuntimeTypes.h': No such file or directory

errors.
User Avatar
Member
3 posts
Joined: 3月 2016
Offline
chibitotoro
I tried building from a 5.0 source but ended up getting a bunch of:

Cannot open include file: 'UnrealObjectInputRuntimeTypes.h': No such file or directory

errors.

Seems like the trick is to get the latest build off github at https://github.com/sideeffects/HoudiniEngineForUnreal [github.com] and then bring it into a C++ project first and try building. It will say that it can't find a specific version of Houdini installed. From that point you specifically installed that version. In my case it was the daily build from today at 19.5.442.

Once the versions are aligned the compile goes through.

Same thing goes for Houdini Niagara located at https://github.com/sideeffects/HoudiniNiagara/tree/UE5.00 [github.com].
User Avatar
Member
1 posts
Joined: 10月 2021
Offline
I am having the issue myself that after succesfully building the plugin it simply will still tell me it is outdated and i have to build it.
  • Quick Links