
LESSON ONE

Quickstart
Welcome to the world of Houdini. This tutorial offers an introduction to this amazing software which 
lets you build models, animate and create visual effects using an artist-friendly node-based workflow. 
In the introduction chapter, you had the chance to read about all the different ways in which Houdini 
is used and what toolsets are available for you to play with. Now it is time to roll up your sleeves and 
create your first Houdini scene. 
In this lesson you will explore a variety of modeling tools as well as tools for fracturing your 
objects using rigid body dynamics. You will soon see that it is just as much fun smashing 
up objects in the virtual world as it is in the real world. Lets get started!

LESSON GOAL
To model a circular arrangement of columns then smash them up  
using rigid body dynamic fracturing. 

WHAT YOU WILL LEARN
�� How to add detail to a box using the polyextrude and polybevel tools. 
�� How to use Houdini's node-based workflow to create and refine your work. 
�� How to utilize rotational and axial symmetries to model efficiently.
�� How to set up a rigid body dynamics simulation. 
�� How to make your objects breakable to create a smashing simulation. 
�� How to set up lights and cameras then render out your work as an image 
sequence or quicktime movie.

Along the way you will get to use different aspects of Houdini’s user interface. 
Be sure to refer to the overviews and quick reference guide in the introduc-
tion to remind yourself of how these UI elements work together.  
This lesson can be completed using Houdini Escape for the  
modeling and rendering of the columns and Houdini Master  
for the rigid body dynamics.
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WORK WITH 
MULTIPLE 
VIEWS
When Houdini opens, 
you are looking through 
a single 3D view. You can work 
with this view by tumbling 
around to review your work. 
Another option is to use the 
Views menu in the top right 
of the Scene view to choose a 
multi-view layout. 

Views Menu

These views let you look at your 
scene from the top and sides. 
You can then use spacebar-b to 
toggle between single and multi 
views.

Build the 
Base of the 

Column
To create the base of the  

column, you will start with a 
simple box then use polygon 

tools such as polyextrude and 
polybevel to give it shape. 
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1	 From the Create shelf, click on the Box tool. Move 
your cursor over the Scene view and press Enter to place it 
at the origin. The object appears with handles. Don't touch 
these handles because you want the object at the origin.
At the top left of the Scene view is the Operation Con-
trols bar. Next to the word Geometry, click on the Jump to 
Operator button  to dive into this object. This takes you 
to the Geometry level where you can shape your object. 
You can also press i to dive into the object.  

2	 In the Parameter pane, change Size Y to 0.15 and 
Center Y to 0.075. In the scene view, you can use 
Spacebar-LMB to tumble, Spacebar-MMB to track and 
Spacebar-RMB to dolly the view. When you finish, you can 
also press Spacebar-g to focus on the box. 
From the Scene view’s top right, change the shading to 
Smooth Wire Shaded. This will let you see all the model-
ing details of the surface as you work. 

3	 In the Views menu, [see sidebar tip] set the view layout 
to Four Views Split Left. This will show you one big 3D 
view, and three smaller orthogonal views. From the same 
menu, choose Link Ortho Views. You can now track and 
dolly in the ortho views and they all stay the same size. 
These views will help you as you work on the model.
Press s to get the Select tool. Click on the box’s top face to 
select it. Its edges are highlighted in yellow to indicate that 
it has been selected.

4	 From the Polygon shelf, click on PolyExtrude.  In the 
side view, use the vertical line at the center of the extrude 
handle to extrude the face up using along the Y axis. This 
restricts movement to the vertical axis.
Next, in the top view, click on the handle's outer arrow to 
scale the face in a bit. Scaling works here since the face is 
square, but if it were rectangular or n-sided then it would be 
better to use the Inset parameter which brings the extrude 
in evenly on all sides.

Shading Mode menu

Views menu
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5	 Press q to repeat the Polyextrude. Lift the new 
handle straight up to add another flat side. Press q again 
then lift and scale the new face to create another inset face. 
The q hotkey makes it easy to do many repetitive steps 
which often happens when modeling in 3D.
At this point, don't worry about matching what you see 
perfectly. In a couple of steps, you will use the nodes in the 
network to step back and tweak the results. For now you are 
simply putting all the parts in place.

6	 PolyExtrude again and move straight up along the Y 
axis by about 0.05.  PolyExtrude again. This time go to 
the Parameter pane and set the Translate value to exactly 
0.05 and Inset to 0.05. PolyExtrude one last time. Set 
Translate to 0.05 and Inset to -0.05. 
These last two polyextrudes create the top surface of the 
base. By using the Parameter pane, you can input exact 
values to get the size and shape that you need.

7	 In the Network view, you can see how each extrude 
creates a node. Make sure the Handle tool is active then 
select one of these nodes. In the Scene View, you can use 
the handle to refine the shape. 
As you can see, your changes affect the results of subse-
quent nodes. You can click through the various polyextrudes 
and either translate or scale to change the geometry's 
shape. You are using the nodes to affect the construction 
history of the geometry.  

8	 Keep refining the extrudes until you get a shape that 
looks like the above image. You can refer to the side view 
to make sure that the profile matches. If you ended up with 
too many extrude nodes then delete any extra ones and limit 
your model to six PolyExtrudes.
Very Important: When you are finished, be sure to select 
the last node before moving forward. The active node high-
lighted in yellow defines the working geometry in the Scene 
view and you need to work with the end of the chain. 

NODE  
FLAGS AND 
HIGHLIGHTS
Houdini nodes have sev-
eral different flags and 
highlight states which control 
how the node is viewed and how 
data flows through it. 
The display flag puts a small 
circle around the chosen node. 
The bigger circle denotes a ren-
der flag which typically moves 
with the display flag. To set the 
render flag on a different node 
then use the Alt key. 

The lock and bypass flags 
affect how data flows through 
the node. Lock ignores the 
nodes coming into the node and 
bypass ignores this node within 
the chain.
The currently selected node is 
highlighted in yellow indicating 
that it is active in the viewport 
even if the display node is some-
where else in the network. 

Display/Render Flag
Template Flag

Lock Flag
Bypass Flag
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SELECTING 
GEOMETRY  
IN THE 
VIEWPORT 
Working with geometry 
often involves making a selec-
tion, then acting on that selec-
tion. In Houdini, you can make 
the selection first and the tool 
will use that selection or you can 
start with nothing selected and 
the tool will prompt you.
The Select tool is the easiest 
way to make geometry selec-
tions in anticipation of another 
action. You can also make selec-
tions while using the transform 
tools and sometimes the handle 
tool. In these cases, you put 
yourself in selection mode once 
you start picking geometry.
Selecting options can be found 
by clicking and holding on the 
Select tool, clicking and holding 
on the current Selection mode 
and RMB-clicking in empty 
space. The RMB menu gives 
you the select menu which offers 
different tools such as edge 
loops or growing and shrinking 
selections. 

9	 Make sure you select the last node in the network 
which makes this the working geometry. In the Scene view, 
press 3 to go to edge selection. Select one of the edges 
shown above then RMB-click in the Scene view and select 
Select Loop to loop the selection. 
Press Shift to select one of the edges as shown above then 
press Shift-L to loop again. Whether you can loop around 
a piece of geometry will depend on its topology. Repeat for 
the third edge shown above.

10	 With the loops selected, go to the Polygon shelf and 
select Polybevel. Set Bevel type to High Density Round, 
Relative Inset to 0.7 and Repetitions to 4. This creates 
nice rounded bevels which add detail to the base.
The Relative inset uses the overall distance from one 
edge to the other to determine how much to bevel. Later 
you will use Absolute inset which lets you set a specific 
bevel amount. Which of these you use will depend on your 
particular situation. 

11	 Select one of the edges on the side of the base then 
press Shift-L to loop from the top to the bottom. Press 
Shift and select the next side edge then Shift-L to loop 
again. You may need to zoom in to find one of the edges.
Tumble and repeat for the other two sides. Don't forget to 
press Shift as you begin adding each edge then Shift-L 
to loop. Now you have all the sides of the base selected. 
You are going to bevel these later after you select some 
horizontal edges.

12	 Press Shift to select one of the middle edges then 
Shift-L to loop. Repeat for the Edge Just above it. Now 
Shift select all the edges on the top and bottom of the 
base's geometry. 
Since these edges are not interior edges, the looping does 
not work here. You will need to tumble around and Shift 
select these edges until you have them all. If you deselect 
by accident then you can Edit > Undo to go back to the 
selection.

1

2

3

1

4

2

3
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13	 Again select the Polybevel tool. This time set Bevel 
type to High Density Round, Absolute Inset to 0.0125 
and Repetitions to 2. By using an Absolute Inset, all of 
the selected edges bevel evenly. With Relative Inset, the 
bevel would be sized depending on the distance from the 
neighbouring edges. 
These bevels add a little detail and create nicely rounded 
edges. These work really well later when you are rendering 
and the rounded edges provide nice specular highlights.

14	 In the Scene view, press 4 to go to face selection then 
press a to select all the faces. From the Modify shelf, click 
on the Mirror tool. In the parameter pane, set the Direction 
to 0, 1, 0 and Distance to 2.5. 
This turns the base into a column capital which will cap 
off the central fluted column which you will create in the 
next section of this lesson. You will use these two pieces as 
guides to create a curve which you will revolve into the main 
body of the column.

15	 In the Network view you now have a couple of new 
nodes and just like before you can step back and make 
changes to nodes in this chain and the whole solution will 
flow forward. 
While this use of Houdini's nodes and networks for con-
struction history seems familiar that is because many apps 
use this kind of linear approach. In the next section, you will 
jump around the network more and take advantage of its 
procedural nature.

16	 Select File > Save As... and in the browser window, 
click on the Home folder. Find the folder called gopro_guide 
and then double-click on it to dive in. Double-click to go into 
the lesson1 folder then name the file columns_01.hip. Click 
on the Accept button to save.
The next time you save, Houdini will copy the previously 
saved file into a back-up folder then over-write your scene 
file. This protects your work although the folder will get full 
and will need to be cleaned out once in a while.

HOW TO  
RESELECT 
GEOMETRY
When you use a tool 
in Houdini, you first 
make a selection then a node is 
placed down which specifically 
references that selection. If you 
extruded the wrong face or bev-
elled the wrong edge, you can fix 
this without using undo.
In these cases, you select the 
node in question, then click and 
hold on the Select tool and from 
the menu choose Reselect For 
Current Tool. This shows you 
your current selection which you 
can then change using the Shift 
key to add or subtract geometry 
from the selection. 

Once you are finished, press 
Enter and the node is reworked 
using the new selection. This 
skill is worth learning because 
it can be a real life saver while 
working with geometry nodes in 
production scenarios.
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THE  
HANDLE  
TOOL
As you use tools from 
the shelf, you are gener-
ally placed into the Handle 
tool where you have access to 
a node's specific handles such 
as the Revolve node's handle 
shown on this page. 

Handle Tool

If you leave the Handle tool 
then you lose this handle. To get 
the handles back, click on the 
Handle tool, select the node 
in the network and then press 
Enter in the viewport. 

Model the 
Column

To create a fluted column 
between the mirrored base, you 

will start with a simple curve 
then create a partial revolve 

which you then rotate-duplicate 
to create the column shape. 

You will then use more  
polymodeling tools such as 

polybevel to create the details. 
You will use the columns  

rotational symmetry. 

1	 In the Scene view, mouse over the right view then 
press spacebar-b to expand this view then press 
spacebar-g to see all the geometry. This will let you focus 
on an orthographic view of the column base.
From the Create shelf, click on the Curve tool. In the right 
view, click once at the top left corner of the column base to 
create the first point of the curve. A new object is created 
and a new modeling network started with a curve node.

2	 Click again just under the mirrored base to place a 
point at the top left corner of the column. Press Enter to 
finish the line then use the handle to make sure the curve is 
vertical. Eyeballing this will be good enough for this lesson. 
With the Curve tool, you can click and edit any point on the 
curve. The one limit is that you can only edit one point at a 
time. If you want to edit more then you would need to select 
the points and use the transform tool which would add an 
edit node. That is not necessary for this simple curve.

3	 In the Scene view, press spacebar-b to go back 
to a four view layout. From the Model shelf, click on the 
Revolve tool. This revolves the curve to create a complete 
column shape. There is a handle available if you want to 
change the location and direction of the revolve axis but you 
won't need this because you are working around the Y axis. 
Now you could start adding detail to this geometry to create 
the fluting but it will be easier to start with a partial revolve 
then shape it and copy it later.

4	  In the Parameter pane, click on the Detail tab and 
set the Revolve Type to Open Arc, the Start Angle to 
-15 and the End Angle to 15. This creates a partial revolve 
which covers 30 degrees. Later you will rotate duplicate it 
12 times to recreate the column.
Next set the Divisions to 2 and the Order to 3. This gives 
you just enough detail to start modeling. The Order helps 
define the spline-based revolve which is then converted into 
polygons which is what you need for this model.
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WHY NOT  
DUPLICATE 
AND MIRROR 
AT THE END? 
In this lesson, it might 
make sense to save the dupli-
cate, mirror and fuse steps until 
the end of this section. 
The reason you are doing it now 
is to take advantage of Houdini's 
ability to step back and work 
with a node earlier in the chain 
then watch as the flow of the 
network carries forward your 
edits. This ability to display any 
node and work with different 
parts of a network is an impor-
tant skill you will use again and 
again with Houdini.

5	 In the Scene view, press a to select all the geometry 
then press the tab key and select Polygon > Clip. In the 
Parameter pane, set the Origin to 0, 2.5, 0. This cuts the 
geometry in half so that you can add detail to the top of the 
flute and then you mirror the results to the bottom. 
From the Modify shelf, click on the Duplicate tool. This 
adds a duplicate node to the network. In the Parameter 
pane, set Rotate Y to 30 then drag the slider next to Num-
ber of Copies until you have 11 copies. 

6	 Press a to select all the geometry then go to the 
Modify shelf and click on Mirror. Make sure the field next 
to Group is empty then set the Direction to 0, 1, 0 and the 
Distance to 2.5.  In the Network view, RMB-click on the 
output of the mirror node and select Polygon >Fuse. Set 
the Template flag on the fuse node and the Display flag 
on the clip node. 
DON'T FORGET: Make sure the clip node is highlighted 
yellow so that this geometry is your working geometry.

7	  Go to the Polygon shelf, click on the EdgeLoop tool 
and cut the surface near the top. This will create the upper 
edge of the flute. When you finish, you can set the Override 
Bias amount to a specific value to place the loop.
Press s to get the Select tool.  Click on the center line just 
under the cut you just made. You will start building the flute 
by working with this line.

8	 Click on the Polybevel tool. Set Bevel Type to High 
Density Round, Absolute Inset to 0.035 and Repeti-
tions to 1.  This defines the outer edges of the flute and 
creates a new centerline which you can use to add detail. 
You will add this detail with another bevel but first you need 
to remove the detail at the top of the first bevel. For the 
top of the flute you will carve and shape the polygons after 
creating the flute.  

After Setting the Flags 
Select THIS node 

[Highlighted in Yellow]
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9	 Press s again then 3 to get edge selection. Select the 
three lines at the top of the bevel and press the Delete key 
to remove them using a dissolve node. This removes the 
edges but not the connected points. Turn on Display points 
in the Display Options bar found at the right side of the 
Scene view.
You can see that there are still points where the edges used 
to meet the other edges. In the Parameter pane, turn on 
Remove Inline Points to get rid of these extra points. 

10	 Select the new center line. Press t to get the translate 
tool and push the line along the X axis. This puts down an 
edit node. You can set Translate X directly if needed. 
The edit node is used to reshape geometry. When you select 
geometry and use either the move, rotate or scale tools at 
the geometry level then an edit node is created. 
Note: If you drew your original curve in a Side view then 
you will need to translate this line along the Z axis.

11	 Now click on the Polybevel tool and set Bevel Type 
to High Density Round, Relative Inset to 0.766 and 
Repetitions of 2.  This gives you the basic shape of the 
column flute. 
Tumble around to make sure you like the shape. You may 
want to go back to the edit node to tweak the position of the 
center line to get the exact depth you want. You can also see 
that the flutes are being copied to the templated geometry 
from the fuse node.

12	 Dolly in and Tumble until you are looking at the top of 
the flute. From the Polygon shelf, click on Polysplit. Move 
your cursor to the peak of the triangle and when you see it 
highlighted with a little circle then click to place a point. 
If you have trouble finding the circle then tumble to another 
view. Since this is an n-sided polygon you may not always 
find the point. Next go down to the top of the flute's center 
line and once you see the circle then click again. Press En-
ter to finish. This splits the polygon along the chosen line. 

DISPLAY 
BAR
As you work with dif-
ferent selection modes, 
Houdini will show 
you points, edges or faces as 
needed. If you want to see these 
things even when you aren't 
selecting then you can use the 
Display options bar at the right 
side of the Viewport. 

Points

Point Normals

Point Numbers

Primitive Normals

Primitive Numbers 

In addition to showing points, 
you can also show point num-
bers, primitive numbers, normals 
and more. These display options 
can be very helpful when analyz-
ing the topology of a model.  
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13	 Press q then when you see a circle, click on the point 
at the top right edge of the flute. Next click on the centerline 
about a third of the way down when you see an x then at the 
point at the top left edge of the flute when you see a circle. 
Press Enter then q to add another polysplit as shown 
above. Just like before you may need to tumble to find the 
click points. The more cuts you make the easier it is to find 
the points because the n-sided polygon has been broken 
down into more manageable parts.

14	 Press q to repeat and split the top of the flute on the 
right side. In the Parameter pane, turn on the Override 
Bias and leave it at 0.5. Now split the left side as shown 
above and again turn on the Override Bias. This parameter 
lets you position the split at a specific point along the edge.
These splits add detail which will be used in subsequent 
steps to shape the top of the flute. Each polysplit adds to 
the topology and creates points which you can use to shape 
a nice rounded shape.

15	 Press s to get the Select tool. Press 2 to get point 
selection. Select the points at the top of the flute and lower 
them down. Next, select and edit the other points to create 
the proper flute shape. If you select points from both sides 
then be sure to use the scale handle to move points in or out 
and the transform handle to move them up and down.
You may want to use the multiple views to see this from the 
front and side to make sure you are doing it right. In the end 
you should have the shape shown above.

16	 Press 3 to get edge selection then click on the edge on 
the left side of the flute. Press the Shift key and select all 
the edges going around the flute. 
In the next step, you will bevel this edge to create a better 
transition from column to flute. The bevel will also provide 
a nice rounded edge which will pick up specular highlights 
when rendered.

THE EDIT 
NODE
The Edit node is a spe-
cial kind of node that 
works differently than 
other nodes. Where as most 
nodes take a very specific selec-
tion and act on that selection, 
the Edit node stores the results 
of multiple edits.  
This node works this way 
because there are times where 
you just need to tweak points 
and shape your model and you 
don't want a new node for every 
little move you make. Therefore 
the edit node lets you do lots of 
tweaking and the results are all 
stored in the one node.
This node also has sculpting 
tools which let you use a brush 
interface to manipulate points 
but that is not needed in this 
lesson.
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17	 Click on the Polybevel tool. Set Bevel Type to High 
Density Round, Absolute Inset to 0.0025 and Repeti-
tions to 2. This creates the nice rounded transition.
Now you need to cap the top of the column but you can't 
see it because of the base geometry. Choose Hide Other 
Objects from the menu at the top right of the Scene view. 
This hides geometry belonging to other objects. Up to this 
point they have been ghosted. 

18	 Turn on the Display flag on the duplicate node and se-
lect it to highlight it in yellow. Press 2 to get point selection. 
In the front view select the points at the top of the column. 
From the Polygon shelf, select Polycap. 
In the Scene view dolly in to see the cap. This gives you a 
closed shape which is needed later when you smash the 
column. Go back to Ghost Other Objects. Dolly out to see 
the whole column. 

19	 In the Network view, turn on the Fuse node's Display 
flag and turn off its Template flag. If you zoom in you will 
see that the top of the flute may have the detail changed 
because of the fuse. 
Select the fuse node and in the Parameter pane, set Dis-
tance to 0.0001. This setting makes sure that the points 
on the flute aren't being fused together which would alter 
the nice rounded edge you set up earlier. 

20	 Click on obj in the path at the top of the Scene view to 
go to Object level. Select the objects and from the Modify 
shelf, click on the Combine tool. Now all the geometry is 
contained in a single object and the two modeling networks 
have been merged into one. Go back to the object level and 
rename the object column. From the Shading menu, select  
Smooth shaded to take a look at the finished column.
Select File >Save As... and call it columns_02.hip. Now 
the fun begins as you start to smash things up.  

OBJECT  
LEVEL VS 
GEOMETRY 
LEVEL
As you work, you will be 
jumping up and down between 
the object level and the geom-
etry level. Generally you use the 
object level to position and ori-
ent the object and the geometry 
level to define its shape. 
Make sure you are aware which 
level you are working at. The 
Network view labels each level 
with either Geometry or Scene 
for objects. You can also use the 
path above each panel to tell you 
where you are. 
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Smash the 
Column with 
Dynamics
For Houdini to include objects in a 
dynamic simulation, they need to be 
tagged as dynamic objects. For the 
column, you are going to instance it 
to a circle to create an arrangement 
of columns. You will then add a 
sphere which will become the  
“hidden force” which tears down  
the columns and a ground plane  
to anchor everything. 

As you turn these into rigid  
body objects, extra nodes will be 
added to each object’s geometry 
network which connect the object 
to a dynamics network where all 
the fun takes place. As you work 
you will jump between the object, 
geometry and dynamics levels to 
access different nodes. 

1	 In the Scene view, press Spacebar-b over the per-
spective view to focus on this view then Spacebar-h to go 
to a home view. From the Create menu, select the Circle 
tool. Press Enter to place it at the origin. 
Press i to go into this object then set Primitive Type to 
Polygon, Orientation to ZX plane, Radius to 4.6, 4.6, 
and Divisions to 16. You will use this to create a circular 
arrangement of 16 columns. Press u to go back up to the 
object level.

2	 Make sure you are at frame 1. When working with dy-
namic tools, make sure to always adjust your scene at frame 
1. With the circle selected, go to the Rigid Bodies shelf and 
click on the RBD Point Object tool. Select the column and 
press Enter. Now you have a ring of columns. 
If you were just modeling then there are other ways to make 
copies of geometry such as the copy tool but since the goal 
is a rigid body simulation, this is the best tool for the job.

3	 Press Play in the timeline and you will see the columns 
start to fall down. They are dynamic objects with a gravity 
force applied to them. You need to add a ground surface to 
keep them from falling down.
In the Network view, you can see that a new node has been 
added called AutoDopNetwork which is where all the dy-
namic nodes will be placed. Later you will navigate into this 
network to work with the nodes directly.

4	 From the Rigid Bodies shelf, click on the Ground 
Plane tool. In the network edit, click on the Display flag to 
hide the ground plane. Even though it is hidden, it will still 
be used in the simulation. 
The ground plane extends in all directions despite its ap-
pearance and will keep all the objects grounded. Later when 
you dive into the AutoDopNetwork you will see that the 
ground plane is visible at that level.
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5	 From the Create shelf, click on the Sphere tool. 
Press Enter to place it at the origin. With the Handle tool 
active, you can use the Operation Controls at the top of 
the Scene view to set its Primitive Type to Polygon and 
Frequency to 4. This will eventually be the hidden object 
you use as a virtual wrecking ball to smash up the columns.
Use the handle to move it out to the edge of the circle then 
up off the ground. Move it just in front of the columns where 
you will use it to knock them down. 

6	 Select the Sphere. Go to the Rigid Bodies shelf and 
click the RBD Object tool. Set the frame range to 1-100 
using the white fields at the start and finish the playbar. Now 
press Play to start the simulation. 
The ball falls to the ground. Press Escape to stop the simu-
lation and then click on the Reset to First Frame button 
in the playbar. To make the sphere hit the columns you will 
now turn it into a wrecking ball by adding a pin constraint.

7	 Select the Sphere. From the Rigid Bodies shelf, click 
on the RBD Pin Constraint tool. Move your cursor to the 
Scene view then press Enter which takes you into the Aut-
oDopNetwork with the sphere object selected. Press Enter 
again to place the constraint at the origin. Use the handle to 
raise it up above the column. 
Press Play to try again. The ball should be knocking down 
some columns. If you don’t like how the columns are being 
hit then reposition the constraint and test the sim again. 

8	 Go to frame 1. In the AutoDopNetwork, select the 
sphere_object1 node. In the Parameter pane, click on the 
Physical tab. Set the Density to 100000 to increase the 
mass then go back to the object level. Move the sphere up 
and out then re-simulate to check out the results. 
You can now tweak the simulation by repositioning the 
sphere at the object level, by adjusting the constraint at the 
Dynamics level or changing the mass at the Dynamics level. 
Now lets make the columns breakable!

WHAT  
GOES ON  
IN THE  
DYNAMICS 
NETWORK?
As you start to turn objects  
into dynamic objects, the  
AutoDopNetwork appears 
wihich contains networks of 
dynamic nodes. This is where 
objects, forces and constraints 
are set up and the network 
defines how they interact. 
Each object you insert into the 
network gets a DOP [Dynamic 
Operator] import node added to 
the end of its chain. This node 
sends information about the 
object to the DOP network and 
then sends motion back to the 
object once the simulation is 
completed. 
This is why the DOP network 
itself is hidden at the object 
level because its resulting sim 
is handed back to the objects 
which orginally created it.
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9	 Go to frame 1. Select the columns. From the Rigid 
Bodies shelf, click on the Make Breakable tool. This will 
jump you back to the Dynamics level. With your cursor in 
the Scene view, press Enter to accept. The columns will 
now break up during the simulation. 
Press Play to test the simulation. The column geometry is 
altered with each frame in reaction to impact. The calcu-
lations take longer because this high quality sim reacts 
accurately to the collisions as they happen.

10	 Go to frame 1. In the network view, go inside the Aut-
oDopNetwork and select the fractureparms node. Set the 
Maximum Fractures to 2 then re-run the simulation. 
Now you are breaking the columns up into more pieces. You 
can tweak these values to adjust how the columns are being 
fractured dynamically.  

11	 When you finish, go to frame 1, go to the object level, 
and hide the sphere. Use your view tools to set up a view 
that you want to see it in camera. From the Scene view’s 
camera menu select New camera. 
The camera is placed based on the chosen view. You get 
some handles you can use to adjust the framing of the view 
to fit well with the aspect ratio. 

12	 Choose File > Save As... and rename the file col-
umns_03.hip. It is a good idea to save things under different 
names in case you want to go back to an earlier step.
Now click on the Flipbook button on the toolbar. Turn on 
Render Beauty Pass Only then set the Frame Range to 1, 
100 and under Size tab set Zoom to 75%. Click Accept 
and wait for the scene to flipbook the results. If you want 
to save the movie then select File > Export > Quicktime 
Movie Exporter and save the sequence as a .mov file. 

HOUDINI'S 
IMAGE  
VIEWER
When you create a 
flipbook or render an 
image or image sequence, you 
are often taken to Houdini's Im-
age Viewer called Mplay. This 
viewer lets you view different 
channels, compare shots and tin-
ker with brightness and contrast 
as you playback your sequences.  
The viewer can also incorporate 
sound and can open and save 
images out in different formats 
such as OpenEXR, TIFF, JPG 
or Quicktime. 
Mplay can also be opened 
independently to view your work.
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MATERIALS 
AND SHADING 
NETWORKS
The Materials in the 
palette can be used as 
shown. Each has parameters 
you can set and often fields for 
adding texture maps. In many 
cases these top-level controls 
are all you need.
As you dig deeper, you will learn 
how to dive into those materi-
als and work with their shading 
networks to create custom looks. 
For now materials will do the job 
for you. 

Rendering 
the Shot

To create a finished shot, you 
can now add cameras, lights 

and materials to your columns. 
You can then render out an im-
age sequence using Houdini's 

renderer called Mantra. This 
final movie can then be saved 

out as a Quicktime movie from 
Houdini's Image Viewer.

Before you start rendering, 
you will cache out a geometry 

sequence of the smashing 
columns to make the rendering 

process more interactive. 

1	 Double-click on the circle_object to dive into it. 
RMB-click on the output of the merge node and select 
Managers>ROP Output Driver and set Valid Frame 
Range to 1, 150.  This will create a longer simulation. 
Now you will cache the sim to make it easier to light and 
render the shot. Click on the chooser button next to Output 
File and create a new folder called sim_cache. Set the file 
name to columns_$F.bgeo and click Accept. Click on the 
Render button to cache the sim.  

2	 Press tab>Export>File and place down the node. Set 
Geometry File to $HIP/sim_cache/columns_$F.bgeo then 
set its Display flag. You can now scrub through the timeline 
to see the cached sim.  
If you want to change the sim, tweak the setup then use 
the rop_geometry node to re-cache. The cache can then be 
used to flipbook or render the scene. This will allow you to 
focus on lighting the shot and not on simulating every time 
you want to render.

3	 In the pane in the bottom left, click on the Material 
Palette tab. Drag a Mantra Surface and Stone material 
from the gallery to the palette work area. 
Click on the mantrasurface material and in the Parameter 
pane, click on the Reflect tab and set Specular Intensity 
to 0.1. Then click on the stone material and under the Dif-
fuse tab and Stone Pattern tab, set Stone Color to 1, 0, 
0. This way the stone shows up as red in the viewport and 
is easy to find when we first assign it.

4	 In the Scene view, press s to get the Select tool then 
1 to jump to Object selection. With the columns selected, 
click on mantrasurface in the Material palette then click As-
sign at the top of the palette work area. 
In the Parameter pane, click on the circle_object's Material 
palette. You can see that the mantrasurface material has 
been assigned to this object.
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5	 In the Network view, RMB-click on the output on the 
file node and select Material > Material. Place the node 
down and set its Display flag. Under Group type inside 
then click on the node selector next to Material. From the 
Choose Operator window, open shop and click on stone 
then click Accept. 
The inside group was created by the fracture solver and can 
be used to find these surfaces. In the viewport they look red 
because of the red color you set for the stone.

6	 From the Create shelf, click on the Grid tool and in 
the Scene view press Enter to place it at the origin. In the 
Operation Controls set Size to 50, 50.  
Click on the Material tab and use the node selector to as-
sign the mantrasurface material to the ground. Click on the 
grey arrow next to Material and select Create All Local 
Material Parameters. This adds all the parameters to the 
object. Click on the Surface tab then the Diffuse tab and 
set Base Color to a dark grey.

7	 In the Scene view, tumble until you are looking at the 
scene from above at a bit of an angle. From the Lights and 
Cameras tab, Ctrl[Cmd]-click on the Spot Light tool. 
This adds an spot light to your scene which is aiming in the 
direction of the view you were looking through. 
In the Parameter pane, under Light and Spot light op-
tions, set the Cone Angle to around 25. This will get you 
closer to you objects and create a more focused light cone.

8	 In the Scene view, tumble and dolly to a point where 
you are looking at the dark side of the columns. From the 
Lights and Cameras tab, Ctrl[Cmd]-click on the Point 
Light tool. This adds a fill light to your scene.
In the Parameter pane, under Light, set the Light Intensity 
to 0.25. This will provide a secondary light source for your 
shot.  If you want to reposition it then use the handles in the 
Scene view which work the same as the camera handles.

LOCAL  
MATERIALS 
PROPERTIES
In step 6, you create local 
material parameters for 
the ground surface. This speeds 
up rendering because each 
material can be processed once 
then used for multiple objects. 
It is also great for objects which 
need to look similar but require 
unique texture maps for object-
specific details. 

POSITIONING 
LIGHTS AND 
CAMERAS
As you work with lights 
and cameras, you can 
reposition them by look through 
the camera using the cam-
era menu in the Scene view. 
RMB-click on the menu to look 
through a light. 
You can then use the Lock 
Camera to View button on the 
display option bar and all view 
changes - tumble, dolly, track - 
will reposition the light/camera. 
Don't forget to turn off the lock 
button when you are finished.

Lock Camera 
to View

You can also select the light/
camera and use the viewport 
handles with the Handle tool. 
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9	 Save your Scene file. From the Render menu, select 
Create Render Node > Mantra. This node will use the 
camera you created earlier and will render the curent frame. 
Go to frame 50 then click on the Render button.
This will start a render in the Mplay image viewer. You can 
now go back and make changes such as choosing a color 
other than red for the inside surfaces, tweaking the specular 
highlights or adjusting the positioning and intensity of the 
lights. Re-render to test out your various creative choices.

10	 In the Network view, select your camera. Press Enter 
in the Scene view to go to the handle tool tumble round to 
see the camera from above. RMB-click on the handle and 
select Focus Handle. 
Drag the square handle to the columns at the front then drag 
the arrow handle to tighten the focus. This sets the Focus 
Distance and F-stop from the Sampling tab for render-
ing with depth of field. You will need to turn this on in the 
mantra node for depth of field to work properly.

11	 In the Parameter pane, click on the View tab and 
set Resolution to 1280, 960. Note: If you use the free 
Houdini Apprentice then you are limited to 720x576.
Next, go to the object level and select the circle_object node 
in the Network view. In the Parameter pane, click on the 
Render tab and then the Sampling tab and turn on Geom-
etry Velocity Blur. This will use velocity information from 
the geometry cache to create motion blur when that feature 
is turned on  in the mantra node.

12	 In the Parameter pane's path widget, LMB-click and 
from the menu select out. This selects the mantra node. Set 
Valid Frame Range to Render Frame Range and set the 
End frame to 150. You can also go to the Properties tab 
and the Sampling tab and turn on Enable Depth of Field.  
and Allow Motion Blur to turn on these features. 
Click Render. The depth of field and motion blur will add 
visual interest. When you are finished, you can export the 
results as a Quicktime movie.

MOTION BLUR 
AND DEPTH 
OF FIELD
Houdini's Mantra render-
er is able to render both 
Depth of field and Motion blur 
without making render times too 
long. These features can help 
add realism to your renders and 
are well worth utilizing in your 
final renders. 


