Wael Chams

Wallou

About Me

Expertise
Not Specified
Location
Not Specified
Website

Connect

Recent Forum Posts

Constantly changing particles points number issues Nov. 1, 2017, 1:10 p.m.

Ok soo it looks like it is working now Got an Id for my particles from realflow and as tamte suggested I checked the seed attribute from the attribute randomize node and it assigned the pscale based on the attribute. Thanks you Tamte

Would be interesting to know if you guys had other suggestions though if for instance I did not have an id attribute for my particles what would you have done ?

Constantly changing particles points number issues Nov. 1, 2017, 12:25 p.m.

hey tamte and thanks for your reply, well I do not have an id attribute from the realflow sim which is probably what is causing so much trouble. Even if I create an attribute named id and assign it a random number and then sort the point by attribute id it doesn't work it keeps jumping every few frames.

Constantly changing particles points number issues Oct. 31, 2017, 7:24 p.m.

Hi,

So I'm going to try and explain this problem as simply as possible. Basically I've imported a snow simulation sequence from Realflow to Houdini where I'm using the particles to create VDBs using VDB from particles.

This is all working fine but now the problem comes when the particles are animated (and get deleted), I've used a Pscale attribute to give random scale to the particles in the VDB which is working fine but as I skip through the sequence the individual particles change scale every frame which cause massive flicker in the render.

So I know this is happening because as soon as the particles get deleted then there point number changes and therefore the particles with the scale assigned to them are no longer in the same position.

Does anyone know a solution to this issue ? I'm sure there is a very simple work around but I've been looking and trying for hours and can't seem to fix it.

Thanks !