On this page

This viewer shows the sample data passing through channel nodes (CHOPs).

To...Do this

Scope a CHOP node in the network view

  • Click the node’s graph flag. Shift-click to add/remove the node to/from the scope.

Select channels to scope from a list

  1. Open the Options menu in the toolbar and turn on Scoping Tools.

  2. To add channels, choose them from the + pop-up menu. To remove channels, choose them from the - pop-up menu. To set channels, choose from the = pop-up menu.

Edit sample data

Add a text note to the graph

  1. Click the Frame Indicator icon in the toolbar to show the blue vertical "current frame" line.

  2. Drag the blue frame line to the frame you want to annotate.

  3. Click the Toggle Options icon in the toolbar to switch to the annotation toolbar.

  4. Choose the CHOP you want to annotate from the pop-up menu.

  5. Type the note in the text box and press Enter. The text will appear on the graph at the current frame.

Mouse shortcuts in the graph

⇧ Shift +

Set the current CHOP.

⌃ Ctrl +

Set the current frame.

Alt +

Set the current CHOP and frame to the nearest sample.

Scale the graph.

⇧ Shift +

Scale all graphs simultaneously.

⌃ Ctrl +

Constrain scaling to vertical or horizontal only.

Pans across the graph.

⇧ Shift +

Pans across all graphs simultaneously.

⌃ Ctrl +

Constrain panning to vertical or horizontal only.


Frame indicator

Click to show/hide a blue line indicating the current frame.

Auto scroll

Turn this on to have the viewer automatically follow the current frame during playback.

Graphs menu

Lets you arrange the scoped parameters in separate graphs.

Horizontal/Vertical adapt

When these options are on, the viewer automatically pans and zooms to show all intervals and ranges of the scoped parameters.

Home graph

Pans and zooms the view to show all intervals and ranges of the scoped parameters.

Vertical adapt options menu

Controls which vertical range to use for homing the Graph or the Vertical Adapt button. Auto (the default) uses the minimum and maximum values on the graph. Choose Other to set the range explicitly. The other choices specify common range presets.

Disable graph

When this option is on, the graph does not update. Use this to speed up Houdini when you don’t need the CHOP graph.

Toggle options

Switches between the toolbar and a text box you can use to annotate the current frame of a CHOP graph.

Curve/Bar display switch

Switches between displaying curves and sample bars.

Options toolbar menu


Show channel names.


Show handles on the channel data, allowing you to edit it directly.


Show dots at each sample point. This is useful for finding sampling errors by visually examining the individual channel values.

Extend Regions

Shows the values obtained when sampling the channels outside the CHOP’s range.

Raw Edit Tools

Scope Tools

Show menus for choosing scoped parameters.

Frames, Samples, Seconds

Sets the time unit used for the horizontal scale of the graph.

Grid Low, Grid Medium, Grid High

Sets the density of grid lines.

Edit raw samples

You can use the "raw edit" tools to directly set the values of sample data. This is sometimes faster and simpler than the alternative of fitting the data through smooth spline approximations, and then editing them in the Animation Editor.

First, set up the viewer for editing:

  1. Open the Options menu in the toolbar and turn on Raw Edit Tools to show the editing tools under the graph.

  2. Turn on Options ▸ Dots and Options ▸ Handles as well.

Then, you can use various tools to edit samples:

  • Click, Shift-click, and/or drag a marquee around samples to select them.

  • Drag a sample handle to change its value.

  • Use the buttons in the raw edit toolbar:


  1. Display three default Wave chops (one graph per CHOP). Turn on Dots, and click the Cubic icon. Turn on Col Select.

  2. Marquee select the first fifty frames of the first channel. The range is resampled as a cubic spline for all three channels.

  3. Drag a selected sample vertically, modifying the shape of the interpolation on all channels.

  4. Click the Copy Relative icon.

  5. Drag the selection to frame 100.

  6. Click an empty area of the graph to deselect. Click the Span Cubic icon again.

  7. Marquee select any area which appears to have a kink in it, and it will reinterpolate as a cubic shape.