Houdini 18.0 Shelf tools

Condensation shelf tool

Creates a particle simulation to mimic condensation on geometry.

On this page

This tool sets up a particle system to simulate liquid forming, flowing, and dripping off the surface of the selected object.

The created dynamics network contains the following components:

Note

This tool is designed for objects whose dimensions are in the ballpark of a single unit; simulation forces may need to be adjusted if the object’s size is considerably different.

Using Condensation

  1. Create a geometry object for the condensation to form around.

  2. Click the Condensation tool on the Particle Fluids shelf tab.

  3. Select your input geometry and press Enter to confirm the selection.

The distance between fluid particles in the simulation is controlled by Particle Separation on the POP Fluid node. Consider changing this value if you want a different density of points in your fluid.

Note

Emission (handled by the source_fluid node) accounts for Particle Separation when seeding particles.

Controlling Emission

The amount of condensation largely depends on the source points, which are generated in the selected object’s network. An effective way to gauge where liquid will be injected into the simulation is to inspect the emit attribute on these source points. You can do this by creating an attribute visualizer or looking at the geometry spreadsheet. SOURCE_OUT is a convenience null that holds the final source points.

The following list outlines some basic ways to control the emission of liquid. All nodes referenced below are located inside the object-level node of your selected geometry.

To...Do this

Change the number of droplets that appear

Change the Force Total Count parameter on the Scatter SOP (create_droplet_points). This parameter’s value controls the number of droplets that form over the entire simulation.

Control when the droplets form

Change the Min Value and Max Value parameters on the Attribute Randomize node (add_emission_frame). This node randomly selects the frame to activate each droplet on, and the aforementioned parameters specify the frame range within which droplets may appear.

Control how long droplets emit liquid

Tweak fade parameters under the Timings tab of the Attribute Fade node (fade_emission).

Modify the emission size for droplets

Change the Distance Threshold on the Attribute Transfer node (transfer_emission).

Change where the droplets appear

Modify the Global Seed parameter on the Scatter SOP (create_droplet_points).

Choose exactly where condensation will appear on your object

Replace the create_droplet_points, add_emission_frame, and fade_emission nodes with your own manually created points and wire them into the DROPLETS_OUT node. You must also create an attribute called emit on those points that will be picked up by the Attribute Transfer node (transfer_emission).

Note

As far as POP Fluid DOP is concerned, each simulation particle represents an equally massive chunk of liquid. This is very different from a FLIP simulation, where particles signal the presence, but not amount, of fluid. Placing a large number of particles in close proximity is akin to compressing a liquid, and will result in particles exploding outwards. Great care must be taken should you choose to modify sourcing parameters in the DOP network.

Changing the behavior of the condensation

To...Do this

Make the liquid drip off the object quicker

Lower the Strength Multiplier parameter on the Geometry Wrangle (adhesion_force). This parameter controls how strong the force is that holds the particles to the geometry. If this value is 0, the liquid will not follow the surface to the lowest point before dripping off. It will simply fall down as gravity pulls it.

Control how slowly the liquid flows over the object

The Friction parameter on the POP Object controls how the liquid moves along the surface of the object. This can be modified along with the Strength Multiplier parameter on the Geometry Wrangle node (adhesion_force) to control the behavior of the fluid along the surface of the object.

Shelf tools

Using the shelf

  • Customize the shelf

    How to change the look of the shelf, change and rearrange its contents, and create your own shelf tools.

Shelf tabs

  • Create tab

    Tools on the Create tab let you create and place primitives, curves, and null objects in the scene view.

  • Modify tab

    Tools on the Modify tab let you easily customize objects in the scene view.

  • Model tab

    Tools on the Model tab let you edit objects in the scene view.

  • Polygon tab

    Tools on the Polygon tab let you modify polygons in the scene view.

  • Deform tab

    Tools on the Deform tab let you deform objects in the scene view.

  • Texture tab

    Tools on the Texture tab let you texture objects in the scene view.

  • Rigging tab

    The Rigging tab contains tools for creating premade rigs.

  • Muscles tab

    The Muscles tab contains tools for creating muscles.

  • Characters tab

    Tools on the Character tab let you create characters in the scene view.

  • Constraints tab

    Tools on the Constraints tab create a constraint network where you can constrain objects to each other in the scene view.

  • Hair Utils tab

    Tools on the Hair Utils tab let you quickly set up hair and fur on objects.

  • Guide Process tab

    Tools on the Guide Process tab let you influence the placement and orientation of guide hairs by painting skin attributes.

  • Guide Brushes tab

    Tools on the Grooming tab let you add and directly manipulate hair.

  • Terrain FX shelf tab

  • Simple FX tab

    The Simple FX tab contains tools for creating dynamic simulations at the geometry level.

  • Cloud FX tab

    The Cloud FX tab contains tools for creating cloud effects.

  • Volume tab

    The Volume tab contains tools for creating volume effects.

  • Lights and Cameras tab

    Tools on the Lights and Cameras tab let you create and place lights and cameras in the scene view.

  • Collisions tab

    Tools on the Collisions tab let you create collision objects in the scene view.

  • Particles tab

    Tools on the Particles tab let you create dynamic particle simulations.

  • Grains tab

    The Grains tab contains tools for simulate grains of sand and other granular matter.

  • Vellum tab

    The Vellum tab contains tools for creating different types of vellum effects.

  • Rigid Bodies tab

    Tools on the Rigid Bodies tab let you create dynamic RBD objects in the scene view.

  • Particle Fluids tab

    Tools on the Particle Fluids tab let you create particle based liquids in the scene view.

  • Viscous Fluids tab

    Viscous fluids are FLIP simulations that use a temperature attribute to drive viscosity.

  • Oceans tab

    The Oceans tab contains tools for creating ocean simulations.

  • Fluid Containers tab

    The Fluid Containers tab contains tools for creating pyro, smoke, and liquid containers.

  • Populate Containers tab

    The Populate Containers tab contains tools for creating and removing fire, smoke, and liquid.

  • Container Tools tab

    The Container Tools tab contains tools for manipulating fire, smoke, and liquid.

  • Pyro FX tab

    Tools on the Pyro FX tab let you create simulated smoke and fire effects.

  • Sparse Pyro FX tab

    Tools on the Sparse Pyro FX tab let you create simulated smoke and fire effects.

  • Solid tab

    Tools on the Solid tab let you create and modify solid objects.

  • Wires tab

    Tools on the Wires tab let you create flexible dynamic objects in the scene view.

  • Crowds tab

    The Crowds tab contains tools for creating crowds, crowd behaviors, as well as examples.

  • Drive Simulation tab

    Tools on the Drive Simulation tab let you manipulate dynamic objects in the scene view.

Technical