Houdini 16.5 Shelf tools

Customize the shelf shelf tool

How to change the look of the shelf, change and rearrange its contents, and create your own shelf tools.

On this page

Overview

The shelf is the strip of icons along the top of the main window. It gives you quick access to commonly used functions. You can customize the shelf to set up your own tabs, as well as add your own scripts and digital assets to the shelf.

The shelf has three basic units of customization:

Shelf set

A set of tabs appearing in their own resizable partition of the shelf.

Tab

A set of tools appearing inside a shelf set. The same tab can be present in multiple shelf sets.

Tool

An icon hooked up to a script to activate a tool or perform some other action. The same tool can be present on multiple tabs.

Both tabs and shelf sets are saved to .shelf files. Tabs define the tab name/label and the tools to display in the correct order. Shelf sets contains the tabs and the order to display them.

All tools are saved in toolbar tabs. All toolbar tabs are saved in a single .shelf file on disk in a the $HOUDINI_TOOLBAR_PATH or in a toolbar directory within the $HOUDINI_PATH. Shelf sets are collections of toolbar tabs and are also saved in .shelf a file containing the references to the toolbar tabs.

Adding to and editing the shelf

To...Do this

Rearrange tools and tabs

  • Drag tools within a tab to rearrange them. You can also drag a tool onto a different tab to move it there.

  • Drag tabs to rearrange them in a shelf set. You can also drag tabs between shelf sets.

Create a new shelf item to run a script

See how to create a shelf item.

Create a new action that adds a node when clicked

  1. Create an example of the node you want in the network editor. Set its parameters to the settings you want the node to have when you add it using the shelf item.

  2. Drag the node from the network editor up to the shelf and drop it on the tab.

  3. Now when you click the new shelf item, if the network pane is showing the right kind of network, Houdini will create a copy of the node you dragged up to the shelf.

Edit an existing tool

Click the tool and choose Edit tool. See the Edit tool window for more information.

Add a tab to a shelf set

Click the tab options menu and choose New tab.

Edit which tools appear on a tab

Click the tab and choose Edit tab.

Add a shelf set to the shelf

Click the shelf menu and choose New shelf set.

Edit which tabs appear in a shelf set

Click the shelf menu in the shelf set’s partition and choose Edit shelf set.

Assign a global hotkey to a shelf tool

Hold ⇧ Shift + ⌃ Ctrl + Alt and click the shelf item.

For more information, see Configure hotkeys.

Rename a shelf set

Click the shelf menu, and choose Edit Shelf Set.

Showing and hiding tabs and shelf sets

To...Do this

Show or hide tabs in a shelf set

Click the tab options menu and use the lower menu of tabs to turn tabs on or off.

Show or hide a shelf set

Click the shelf menu and use the Shelf Sets submenu to turn shelf sets on or off.

Downloading shelf sets

  1. Click the tab options menu and choose Download Shelf.

  2. A dialog appears showing you available shelf sets on the Exchange.

  3. Select the package you want to install and click Download.

You can use the Install shelf to menu to choose the toolbar directory on the path into which you want to save the downloaded shelf information.

Customizing the Tab menu

You can make shelf items appear in the ⇥ Tab menu as well. See the section on the Tab menu for more information.

Shelf tools

Using the shelf

  • Customize the shelf

    How to change the look of the shelf, change and rearrange its contents, and create your own shelf tools.

Shelf tabs

  • Create tab

    Tools on the Create tab let you create and place primitives, curves, and null objects in the scene view.

  • Modify tab

    Tools on the Modify tab let you easily customize objects in the scene view.

  • Model tab

    Tools on the Model tab let you edit objects in the scene view.

  • Polygon tab

    Tools on the Polygon tab let you modify polygons in the scene view.

  • Deform tab

    Tools on the Deform tab let you deform objects in the scene view.

  • Texture tab

    Tools on the Texture tab let you texture objects in the scene view.

  • Rigging tab

    The Rigging tab contains tools for creating premade rigs.

  • Muscles tab

    The Muscles tab contains tools for creating muscles.

  • Characters tab

    Tools on the Character tab let you create characters in the scene view.

  • Constraints tab

    Tools on the Constraints tab create a constraint network where you can constrain objects to each other in the scene view.

  • Hair Utils tab

    Tools on the Hair Utils tab let you quickly set up hair and fur on objects.

  • Guide Process tab

    Tools on the Guide Process tab let you influence the placement and orientation of guide hairs by painting skin attributes.

  • Guide Brushes tab

    Tools on the Grooming tab let you add and directly manipulate hair.

  • Terrain FX shelf tab

  • Cloud FX tab

    The Cloud FX tab contains tools for creating cloud effects.

  • Volume tab

    The Volume tab contains tools for creating volume effects.

  • Lights and Cameras tab

    Tools on the Lights and Cameras tab let you create and place lights and cameras in the scene view.

  • Collisions tab

    Tools on the Collisions tab let you create collision objects in the scene view.

  • Particles tab

    Tools on the Particles tab let you create dynamic particle simulations.

  • Grains tab

    The Grains tab contains tools for simulate grains of sand and other granular matter.

  • Rigid Bodies tab

    Tools on the Rigid Bodies tab let you create dynamic RBD objects in the scene view.

  • Particle Fluids tab

    Tools on the Particle Fluids tab let you create particle based liquids in the scene view.

  • Viscous Fluids tab

    Viscous fluids are FLIP simulations that use a temperature attribute to drive viscosity.

  • Oceans tab

    The Oceans tab contains tools for creating ocean simulations.

  • Fluid Containers tab

    The Fluid Containers tab contains tools for creating pyro, smoke, and liquid containers.

  • Populate Containers tab

    The Populate Containers tab contains tools for creating and removing fire, smoke, and liquid.

  • Container Tools tab

    The Container Tools tab contains tools for manipulating fire, smoke, and liquid.

  • Pyro FX tab

    Tools on the Pryo FX tab let you create simulated smoke and fire effects.

  • Cloth tab

    Tools on the Cloth tab let you create and constrain cloth objects in the scene view.

  • Solid tab

    Tools on the Solid tab let you create and modify solid objects.

  • Wires tab

    Tools on the Wires tab let you create flexible dynamic objects in the scene view.

  • Crowds tab

    The Crowds tab contains tools for creating crowds, crowd behaviors, as well as examples.

  • Drive Simulation tab

    Tools on the Drive Simulation tab let you manipulate dynamic objects in the scene view.

Technical