On this page

Creating and editing shelf items

See customizing the shelf for information on rearranging the shelf.


To make a shelf item that creates a node or group of nodes, you don’t need to script the item yourself. Just drag the node or nodes from the network editor onto the shelf.

  1. In the shelf, right click the tab background and choose New tool, or right-click an existing icon and choose Edit tool.

  2. Set the item’s Name (an identifier that must be unique across all tabs), and Label (the human-readable label that will appear in the tooltip and when the shelf is set to display text).

Embedding tools in digital assets

The Tools tab of the type properties window lets you specify the options for item(s) that added to the tab menu for a digital asset. This lets you, for example, write a script, and specify a different submenu name (by default all digital assets show up in a submenu named "Digital Assets").

Window controls

Save to

The .shelf file to save the tool into. The default is $HOME/houdiniX.X/toolbar/default.shelf, which makes the tool available to you. To make the tool available for other people to put on their shelf, add it to a .shelf file in some central location.

Any shelf files you save should be in $HOUDINI_PATH in a toolbar folder, or in a directory in the the $HOUDINI_TOOLBAR_PATH if it is defined. Shelf files must have a .shelf extension.

You can load a .shelf file from the path by choosing it from the Shelf Sets submenu of the shelf menu.

Options tab


Internal name of the shelf item. This must be unique across all loaded shelf tools. Must start with a letter, can contain letters, numbers, and/or underscores.


The human-readable name of the shelf item, appears in the tab menu. The label should be relatively short (two to four words) but as descriptive as possible.


A reference to an icon file (SVG or image), in one of the following formats:

  • An opdef: path to an embedded file in the asset’s extra files.

  • A file path or URL for a file containing the icon.

  • The name of a built-in Houdini icon. For example, OBJ_geo or SHELF_candle.

Click the chooser button next to the field to browse for an icon. You can browse for a file on disk, or click opdef:/ in the chooser to browse embedded files, or hicon:/ to browse built-in icons.

If you choose a file on disk and Embed icon in operator is on, when you click Accept Houdini will automatically copy the file into the asset’s extra files and replace the Icon field with an opdef: reference to the embedded icon.

Script tab

Script language

The language of the script. This lets you write this script in HScript, but doing so does not offer any of the advantages of Python, and the script cannot be selection/context aware. We strongly encourage you to use Python instead.

External editor

Click Launch to edit the script in an external editing program (defined by the $EDITOR environment variable). When you save and quit the external editor, your changes will appear in the Edit tool window.


Enter the script to run when the user clicks the shelf item. See writing a tool script.

Help tab

You can write or paste wiki-formatted help for the the item here, or specify a URL the help should be loaded from.

This help is displayed when the user hovers over the item and presses F1. When you write the help in wiki format, Houdini uses its "summary" text as the item’s tooltip (see the wiki format documentation for information on summaries).

Context tab

The options on this tab control on which tab menus (in which network contexts) the item appears, when the user opens the tab menu in the viewer or network editor.

The Tab submenu path controls which sub-menu of the tab menu the item appears in. You aren’t restricted to the submenus containing the original Houdini tools – you can type a new name here and Houdini will create the corresponding submenu on the tab menu.

Hotkeys tab

This tab lets you specify hotkeys for the item. You can give the item a Global hotkey that works everywhere, and/or a hotkey that only works when the mouse is in the network editor pane, scene view pane, or compositing view pane.

Refer to the Hotkey editor to avoid possible conflicts with existing hotkeys.

See also