Houdini 16.5 Shelf tools

Sculpt shelf tool

Lets you interactively reshape a surface by brushing.

The deform mode lets you push or pull the geometry along its normals and the smooth mode smooths out the geometry. This tool is useful for adding detail to models.

Using Sculpt

  1. Select the object you want to sculpt, or in component mode, select a subset of the points in an object.

    When you select a subset of points, the Sculpt tool will only be able to modify the selected points. The unselected points will be protected from brushing.

  2. Click the Sculpt tool on the Model tab.

  3. Do any of the following:

    • Shift-drag to change the size of the brush, or use the Radius control on the operation toolbar (across the top of the viewer).

    • Right click to assign operations to and , change the brush shape, and set other options.

    • FD on the toolbar controls the amount of displacement caused by brushing with . BD controls the amount caused by brushing with . These are the same as the parameters in the LMB Displacement and MMB Displacement sub-tabs of the Operation tab in the parameter editor.

    • Opacity controls how much deformation or smoothing the tool will do with each brush-stroke. This is the same as the Opacity parameter on the Brush tab in the parameter editor.

    • Drag across the surface with or to perform the assigned operation on the selected points.

Tip

The brush casts through the surface and sometimes you may find that strokes on the surface deform points on the opposite side of the surface.

You can minimize this by enabling the Depth parameter on the Brush tab in the parameter editor. The Depth values limit how far above and below the surface the brush will cast.

You can copy the Radius parameter and paste it as a relative reference into both Depth fields to create a spherical/cubical (depending on brush shape) brush. This is usually sufficient to eliminate problems casting through, unless you are using a large brush size.

For specific parameter help see the Sculpt node help.

For general brush information see the brush tool help.

See also

Shelf tools

Using the shelf

  • Customize the shelf

    How to change the look of the shelf, change and rearrange its contents, and create your own shelf tools.

Shelf tabs

  • Create tab

    Tools on the Create tab let you create and place primitives, curves, and null objects in the scene view.

  • Modify tab

    Tools on the Modify tab let you easily customize objects in the scene view.

  • Model tab

    Tools on the Model tab let you edit objects in the scene view.

  • Polygon tab

    Tools on the Polygon tab let you modify polygons in the scene view.

  • Deform tab

    Tools on the Deform tab let you deform objects in the scene view.

  • Texture tab

    Tools on the Texture tab let you texture objects in the scene view.

  • Rigging tab

    The Rigging tab contains tools for creating premade rigs.

  • Muscles tab

    The Muscles tab contains tools for creating muscles.

  • Characters tab

    Tools on the Character tab let you create characters in the scene view.

  • Constraints tab

    Tools on the Constraints tab create a constraint network where you can constrain objects to each other in the scene view.

  • Hair Utils tab

    Tools on the Hair Utils tab let you quickly set up hair and fur on objects.

  • Guide Process tab

    Tools on the Guide Process tab let you influence the placement and orientation of guide hairs by painting skin attributes.

  • Guide Brushes tab

    Tools on the Grooming tab let you add and directly manipulate hair.

  • Terrain FX shelf tab

  • Cloud FX tab

    The Cloud FX tab contains tools for creating cloud effects.

  • Volume tab

    The Volume tab contains tools for creating volume effects.

  • Lights and Cameras tab

    Tools on the Lights and Cameras tab let you create and place lights and cameras in the scene view.

  • Collisions tab

    Tools on the Collisions tab let you create collision objects in the scene view.

  • Particles tab

    Tools on the Particles tab let you create dynamic particle simulations.

  • Grains tab

    The Grains tab contains tools for simulate grains of sand and other granular matter.

  • Rigid Bodies tab

    Tools on the Rigid Bodies tab let you create dynamic RBD objects in the scene view.

  • Particle Fluids tab

    Tools on the Particle Fluids tab let you create particle based liquids in the scene view.

  • Viscous Fluids tab

    Viscous fluids are FLIP simulations that use a temperature attribute to drive viscosity.

  • Oceans tab

    The Oceans tab contains tools for creating ocean simulations.

  • Fluid Containers tab

    The Fluid Containers tab contains tools for creating pyro, smoke, and liquid containers.

  • Populate Containers tab

    The Populate Containers tab contains tools for creating and removing fire, smoke, and liquid.

  • Container Tools tab

    The Container Tools tab contains tools for manipulating fire, smoke, and liquid.

  • Pyro FX tab

    Tools on the Pryo FX tab let you create simulated smoke and fire effects.

  • Cloth tab

    Tools on the Cloth tab let you create and constrain cloth objects in the scene view.

  • Solid tab

    Tools on the Solid tab let you create and modify solid objects.

  • Wires tab

    Tools on the Wires tab let you create flexible dynamic objects in the scene view.

  • Crowds tab

    The Crowds tab contains tools for creating crowds, crowd behaviors, as well as examples.

  • Drive Simulation tab

    Tools on the Drive Simulation tab let you manipulate dynamic objects in the scene view.

Technical