Houdini 16.5 Shelf tools

Waves shelf tool

Creates an ocean like surface.

On this page

This tool is useful for creating an ocean like surface. However, it is not a simulation, it is a deformer that does not use DOPs at all. You can scrub through the timeline and watch the ocean evolve without any simulation. This is useful if you want to have an ocean in the background of your shot, because it can bake out texture maps representing the ocean wave displacement, and can loop a wave set over time. For a simulated ocean, use the tools on the Oceans shelf tab.

Using Ocean Wave

  1. Create the geometry you want to animate using ocean waves, for example a Grid.

    This geometry should be in "rest" space, with points at y = 0 representing the ocean surface.

  2. Select the geometry. In the Deform shelf tab, click Waves.

    The tool will create and wire the Ocean Spectrum and Ocean Evaluate nodes necessary to control the shape and movement of the ocean.

  3. The animation is driven by the Time parameter on the Ocean Evaluate node. The default expression is $T (the current time). You can edit this expression to change the animation direction and speed (for example, $T * 2 to make the ocean move twice as fast).

Changing the look of your ocean

To...Do this

Set the height of the wave

Navigate to the Ocean Spectrum node and adjust the Wave Scale parameter on the Wave Amplitude tab.

This value is multiplied by the Speed parameter on the Wind tab.

Set the direction of the waves

Navigate to the Ocean Spectrum node and adjust the Directional Bias parameter on the Wind tab.

This controls how many frequencies are moving in the same direction as the wind. Increasing this value will cause more frequencies to travel in the same direction, which is useful for creating shoreline effects.

You can also try increasing the Directional Movement parameter. This will dampen the waves moving in the opposite direction of the wind, leaving only the ones moving in the same direction.

Control the height of the peak

Navigate to the Ocean Spectrum node and adjust the Chop parameter on the Wind tab.

Increasing this parameter creates sharp peaks on waves. However, if this value is too high waves, may invert on themselves.

Add more detail to your ocean

Increase the Resolution Exponent parameter on the Ocean Spectrum node.

Note

The Resolution Exponent parameter will not only determine the quality of your ocean, but also the size of the texture maps that you will eventually write out.

Create a large ocean

Use the Large Ocean shelf tool.

See also

Shelf tools

Using the shelf

  • Customize the shelf

    How to change the look of the shelf, change and rearrange its contents, and create your own shelf tools.

Shelf tabs

  • Create tab

    Tools on the Create tab let you create and place primitives, curves, and null objects in the scene view.

  • Modify tab

    Tools on the Modify tab let you easily customize objects in the scene view.

  • Model tab

    Tools on the Model tab let you edit objects in the scene view.

  • Polygon tab

    Tools on the Polygon tab let you modify polygons in the scene view.

  • Deform tab

    Tools on the Deform tab let you deform objects in the scene view.

  • Texture tab

    Tools on the Texture tab let you texture objects in the scene view.

  • Rigging tab

    The Rigging tab contains tools for creating premade rigs.

  • Muscles tab

    The Muscles tab contains tools for creating muscles.

  • Characters tab

    Tools on the Character tab let you create characters in the scene view.

  • Constraints tab

    Tools on the Constraints tab create a constraint network where you can constrain objects to each other in the scene view.

  • Hair Utils tab

    Tools on the Hair Utils tab let you quickly set up hair and fur on objects.

  • Guide Process tab

    Tools on the Guide Process tab let you influence the placement and orientation of guide hairs by painting skin attributes.

  • Guide Brushes tab

    Tools on the Grooming tab let you add and directly manipulate hair.

  • Terrain FX shelf tab

  • Cloud FX tab

    The Cloud FX tab contains tools for creating cloud effects.

  • Volume tab

    The Volume tab contains tools for creating volume effects.

  • Lights and Cameras tab

    Tools on the Lights and Cameras tab let you create and place lights and cameras in the scene view.

  • Collisions tab

    Tools on the Collisions tab let you create collision objects in the scene view.

  • Particles tab

    Tools on the Particles tab let you create dynamic particle simulations.

  • Grains tab

    The Grains tab contains tools for simulate grains of sand and other granular matter.

  • Rigid Bodies tab

    Tools on the Rigid Bodies tab let you create dynamic RBD objects in the scene view.

  • Particle Fluids tab

    Tools on the Particle Fluids tab let you create particle based liquids in the scene view.

  • Viscous Fluids tab

    Viscous fluids are FLIP simulations that use a temperature attribute to drive viscosity.

  • Oceans tab

    The Oceans tab contains tools for creating ocean simulations.

  • Fluid Containers tab

    The Fluid Containers tab contains tools for creating pyro, smoke, and liquid containers.

  • Populate Containers tab

    The Populate Containers tab contains tools for creating and removing fire, smoke, and liquid.

  • Container Tools tab

    The Container Tools tab contains tools for manipulating fire, smoke, and liquid.

  • Pyro FX tab

    Tools on the Pryo FX tab let you create simulated smoke and fire effects.

  • Cloth tab

    Tools on the Cloth tab let you create and constrain cloth objects in the scene view.

  • Solid tab

    Tools on the Solid tab let you create and modify solid objects.

  • Wires tab

    Tools on the Wires tab let you create flexible dynamic objects in the scene view.

  • Crowds tab

    The Crowds tab contains tools for creating crowds, crowd behaviors, as well as examples.

  • Drive Simulation tab

    Tools on the Drive Simulation tab let you manipulate dynamic objects in the scene view.

Technical