Houdini 17.0 Materials

Converting image files

On this page

Overview

Houdini can handle most image formats, but in general you should use Houdini’s image format (.pic or .rat) or OpenEXR format for textures. Those formats have additional features such as tiled loading that can save time and/or memory.

How to

To...Do this

Convert an image using MPlay

  1. Choose Render ▸ MPlay ▸ Load disk files and pick the file you want to convert.

  2. In Mplay, choose File ▸ Save frame as. Save the image with a filename ending with the file extension of the new format.

Convert an image from the command line

In a Houdini shell, use the iconvert command-line utility to convert images between formats. For example:

iconvert butterfly.pic butterfly.rat

You can type iconvert alone on the command line to see the list of supported formats. The iinfo command will print information about image files.

Convert an image using a compositing network

  1. Choose File ▸ Import ▸ Image and pick the image you want to convert.

    This will create a new compositing network with a File compositing node that loads the image.

  • If you want to convert the file procedurally (so you can run the conversion as part of a render network), choose Render ▸ Create render node ▸ Other output nodes ▸ Composite and set it to render the output of the compositing network.

  • If you just want to convert the file once, right-click the File compositing node and choose Save image. Save the image with a filename ending with the file extension of the new format.

Materials

Using materials

Textures and UVs

Creating materials

Guru level

Other renderers