Houdini 17.0 Shelf tools

Bones shelf tool

Allows you to interactively draw and manipulate bone chains before animating.

This tool is used when modeling characters.

Using Bones

  1. Click the Bones tool on the Characters tab.

  2. Click to place the chain of bones anywhere in the scene view, and continue clicking to add bones to the chain.

    • You can control interior snapping using the Placement menu in the operation toolbar. This is useful for snapping bones to the midline of character skin geometry.

      By default, if a bone intersects a geometry node it will be placed within the geometry based on the view ("View based"). Otherwise the bone will be grounded on the construction plane.

      "Normal based" snaps within geometry based on the geometry normals rather than the view.

      "Freehand" does no interior snapping.

    • You can add, remove, and change kinematics in the drop-down menu on the operations toolbar, or click the bones in the scene view.

      If you create a chain of bones with inverse kinematics a null object will appear at the end of the chain which allows you to easily move the bones while it is grounded by the chain root.

  3. Press Enter to finish the chain.

  4. Name the chain of bones in the Chain Name field on the operations toolbar.

For specific parameter help see the Bones node help.

How to draw bones

Tip

As you're drawing, use the text field in the operation controls toolbar to name the bone.

Tip

Houdini uses an optimized IK solver for bone chains with two bones. If you have a natural two-bone part of the system, try to draw it separately to take advantage of the optimized solver.

To...Do this

Draw bones with kinematics

  1. At the object level, choose the Bones tool.

  2. Use the operation controls toolbar or press to choose a kinematics solver (such as Inverse Kinematics).

  3. Click to draw bones in the viewer. Click to finish drawing.

    In the viewer, the bones are connected in a chain with a small sphere at the root. In the network editor, each bone has a node and the root and chain goals are Null objects. Houdini also creates a CHOP network containing the CHOPs that drive the kinematics.

Draw bones without kinematics

  1. At the object level, choose the Bones tool.

  2. Click to draw bones in the viewer. Click to finish drawing.

    In the viewer, the bones are connected in a chain with a small sphere at the root. In the network editor, each bone has a node and the root is a Null object.

Branch a new chain off an existing one

  • At the object level, choose the Bones tool.

  • To draw from the end of an existing bone, ⇧ Shift + the bone.

  • To parent your new chain to the end of an existing bone but not draw from it, ⌃ Ctrl + the bone.

Connect two existing chains with a new bone

  1. At the object level, choose the Bones tool.

  2. Shift-click the end bone of the first chain to start a new bone from it.

  3. Press ⌃ Ctrl + J to turn on snapping.

  4. Click the root of the start bone of the second chain.

  5. Parent the second chain to the new bone.

Split a bone into two new bones

  1. At the object level, choose the Bones tool.

  2. ⌃ Ctrl + the bone you want to split.

Create bones in the shape of an existing curve

How to edit bones

To...Do this

Examine the rotations on a bone

  • Press on a bone to show its pre-transforms and the actual rotations if the bones are driven by an IK solver.

Remove kinematics from existing bones

  1. Use the tab menu to choose the Bones tool.

  2. Press to show the Bones tool’s tool menu and choose Remove Kinematics.

  3. Select the bones you want to remove kinematics from, then click to finish.

Add kinematics to existing bones

  1. Use the tab menu to choose the Bones tool.

  2. In the operation controls toolbar , use the pop-up menu to set the kind of kinematics you want to add.

  3. Press to show the Bones tool’s tool menu and choose Add Kinematics.

  4. Select the first bone of the chain and press , then select the last bone and click to finish.

Change the kinematics solver of existing bones

  • Remove the existing kinematics, then add the new kinematics (see above).

  • If you have an existing kinematics solver CHOP you want to use for a bone, enter its path in the bone’s Kinematic solver parameter (on the Bones tab in the parameter editor).

Edit bone lengths and zero positions

  1. Use the tab menu to choose the Bones tool.

  2. Click the small squares at the joints between bones and use the translate (T), rotate (R), and scale (E) manipulators to edit them.

    You can also use the special manipulator (Y) to move a joint relative to the chain: along the upper or lower bone axis, or in and out along an axis halfway between the two bone axes.

Parent bones

  1. Houdini will move the child bone to the position of the parent and set them up as a hierarchy in the Network pane.

    If you do not want the child chain to move when it’s parented, turn on the child object’s Keep position when parenting parameter.

    (You can turn this setting off globally in the Objects and Geometry section of the Houdini Preferences window.)

  2. Use the Parent tool, or connect the output of the parent bone to the input of the child.

    If the "child" chain had a null root object, it will not be part of the chain and you can delete it.

Remove a joint

  1. Use the tab menu to choose the Bones tool.

  2. Press on the joint you want to remove and choose Delete Joint. Houdini merges the two bones on either side of the joint into one.

Note

Do not to use the transform tools to rotate joints during set-up because these will alter the Rotate values of the bone. Use the Bones tool instead.

Use the transform tool when you are animating the bone chain after setting up the rest pose.

For more information, see the Draw bones page in the Character chapter.

See also

Shelf tools

Using the shelf

  • Customize the shelf

    How to change the look of the shelf, change and rearrange its contents, and create your own shelf tools.

Shelf tabs

  • Create tab

    Tools on the Create tab let you create and place primitives, curves, and null objects in the scene view.

  • Modify tab

    Tools on the Modify tab let you easily customize objects in the scene view.

  • Model tab

    Tools on the Model tab let you edit objects in the scene view.

  • Polygon tab

    Tools on the Polygon tab let you modify polygons in the scene view.

  • Deform tab

    Tools on the Deform tab let you deform objects in the scene view.

  • Texture tab

    Tools on the Texture tab let you texture objects in the scene view.

  • Rigging tab

    The Rigging tab contains tools for creating premade rigs.

  • Muscles tab

    The Muscles tab contains tools for creating muscles.

  • Characters tab

    Tools on the Character tab let you create characters in the scene view.

  • Constraints tab

    Tools on the Constraints tab create a constraint network where you can constrain objects to each other in the scene view.

  • Hair Utils tab

    Tools on the Hair Utils tab let you quickly set up hair and fur on objects.

  • Guide Process tab

    Tools on the Guide Process tab let you influence the placement and orientation of guide hairs by painting skin attributes.

  • Guide Brushes tab

    Tools on the Grooming tab let you add and directly manipulate hair.

  • Terrain FX shelf tab

  • Cloud FX tab

    The Cloud FX tab contains tools for creating cloud effects.

  • Volume tab

    The Volume tab contains tools for creating volume effects.

  • Lights and Cameras tab

    Tools on the Lights and Cameras tab let you create and place lights and cameras in the scene view.

  • Collisions tab

    Tools on the Collisions tab let you create collision objects in the scene view.

  • Particles tab

    Tools on the Particles tab let you create dynamic particle simulations.

  • Grains tab

    The Grains tab contains tools for simulate grains of sand and other granular matter.

  • Vellum tab

    The Vellum tab contains tools for creating different types of vellum effects.

  • Rigid Bodies tab

    Tools on the Rigid Bodies tab let you create dynamic RBD objects in the scene view.

  • Particle Fluids tab

    Tools on the Particle Fluids tab let you create particle based liquids in the scene view.

  • Viscous Fluids tab

    Viscous fluids are FLIP simulations that use a temperature attribute to drive viscosity.

  • Oceans tab

    The Oceans tab contains tools for creating ocean simulations.

  • Fluid Containers tab

    The Fluid Containers tab contains tools for creating pyro, smoke, and liquid containers.

  • Populate Containers tab

    The Populate Containers tab contains tools for creating and removing fire, smoke, and liquid.

  • Container Tools tab

    The Container Tools tab contains tools for manipulating fire, smoke, and liquid.

  • Pyro FX tab

    Tools on the Pryo FX tab let you create simulated smoke and fire effects.

  • Solid tab

    Tools on the Solid tab let you create and modify solid objects.

  • Wires tab

    Tools on the Wires tab let you create flexible dynamic objects in the scene view.

  • Crowds tab

    The Crowds tab contains tools for creating crowds, crowd behaviors, as well as examples.

  • Drive Simulation tab

    Tools on the Drive Simulation tab let you manipulate dynamic objects in the scene view.

Technical