Houdini 16.5 Shelf tools

Parent Blend shelf tool

Blends between parent objects.

On this page

This tool will blend the transform of the current parent with other objects and apply the current local object local transform on top.

Using Parent Blend Constraint

  1. Click the Parent Blend tool on the Constraints tab.

  2. Choose the object you want to constrain and press Enter to confirm your selection.

  3. Select one or more parents objects in the desired order. Hold ⇧ Shift to select multiple objects.

  4. Review the Toolbar Parameters. Some of the toolbar parameters match node parameters directly (such as Mask and Weight), while other (such as Mode, Keep Position, and Add Keyframe) affect how the nodes are created.

  5. Press Enter to confirm your selection.

This tool creates a new constraints CHOP Network inside the object, or reuses an existing one.

A Parent node is added along with one Simple Blend node based on the new parent objects and blend mode. The constraint is added after the the node that has the output flag and the output flag is moved to the new node.

Toolbar Parameters

Mode

The blend mode.

Proportional

Creates a Blend node in Proportional mode. This supports multiple targets.

Difference

Creates a Blend node in Difference mode. This supports multiple targets.

Sequence

Creates a Sequence node. This supports multiple targets.

Simple Blend

Creates a Simple Blend node. This supports only a single target.

Mask

Select which transform components to blend.

Weight

The initial blend weight.

Keep Position

When Keep Position is on, applying the constraint won’t change the current object position. Targets are pulled using the Constraint Object Offset instead of the Constraint Object.

Add Keyframe

Add a transition keyframe to enable the constraint at the current time.

See also

Shelf tools

Using the shelf

  • Customize the shelf

    How to change the look of the shelf, change and rearrange its contents, and create your own shelf tools.

Shelf tabs

  • Create tab

    Tools on the Create tab let you create and place primitives, curves, and null objects in the scene view.

  • Modify tab

    Tools on the Modify tab let you easily customize objects in the scene view.

  • Model tab

    Tools on the Model tab let you edit objects in the scene view.

  • Polygon tab

    Tools on the Polygon tab let you modify polygons in the scene view.

  • Deform tab

    Tools on the Deform tab let you deform objects in the scene view.

  • Texture tab

    Tools on the Texture tab let you texture objects in the scene view.

  • Rigging tab

    The Rigging tab contains tools for creating premade rigs.

  • Muscles tab

    The Muscles tab contains tools for creating muscles.

  • Characters tab

    Tools on the Character tab let you create characters in the scene view.

  • Constraints tab

    Tools on the Constraints tab create a constraint network where you can constrain objects to each other in the scene view.

  • Hair Utils tab

    Tools on the Hair Utils tab let you quickly set up hair and fur on objects.

  • Guide Process tab

    Tools on the Guide Process tab let you influence the placement and orientation of guide hairs by painting skin attributes.

  • Guide Brushes tab

    Tools on the Grooming tab let you add and directly manipulate hair.

  • Terrain FX shelf tab

  • Cloud FX tab

    The Cloud FX tab contains tools for creating cloud effects.

  • Volume tab

    The Volume tab contains tools for creating volume effects.

  • Lights and Cameras tab

    Tools on the Lights and Cameras tab let you create and place lights and cameras in the scene view.

  • Collisions tab

    Tools on the Collisions tab let you create collision objects in the scene view.

  • Particles tab

    Tools on the Particles tab let you create dynamic particle simulations.

  • Grains tab

    The Grains tab contains tools for simulate grains of sand and other granular matter.

  • Rigid Bodies tab

    Tools on the Rigid Bodies tab let you create dynamic RBD objects in the scene view.

  • Particle Fluids tab

    Tools on the Particle Fluids tab let you create particle based liquids in the scene view.

  • Viscous Fluids tab

    Viscous fluids are FLIP simulations that use a temperature attribute to drive viscosity.

  • Oceans tab

    The Oceans tab contains tools for creating ocean simulations.

  • Fluid Containers tab

    The Fluid Containers tab contains tools for creating pyro, smoke, and liquid containers.

  • Populate Containers tab

    The Populate Containers tab contains tools for creating and removing fire, smoke, and liquid.

  • Container Tools tab

    The Container Tools tab contains tools for manipulating fire, smoke, and liquid.

  • Pyro FX tab

    Tools on the Pryo FX tab let you create simulated smoke and fire effects.

  • Cloth tab

    Tools on the Cloth tab let you create and constrain cloth objects in the scene view.

  • Solid tab

    Tools on the Solid tab let you create and modify solid objects.

  • Wires tab

    Tools on the Wires tab let you create flexible dynamic objects in the scene view.

  • Crowds tab

    The Crowds tab contains tools for creating crowds, crowd behaviors, as well as examples.

  • Drive Simulation tab

    Tools on the Drive Simulation tab let you manipulate dynamic objects in the scene view.

Technical