Houdini 17.0 Shelf tools

Sculpted Particle Fluid shelf tool

Calculates and creates particle fluid between the surface and container of fluid in a particle fluid simulation.

This tool can be used, for example, to model splashing water flowing through a riverbed. In order to use this tool, you need at least two components: a fluid surface and a terrain for the fluid to be contained in. This tool will calculate and fill in the volume between the surface and terrain. You can also place obstacles in your fluid simulation, such as rocks in a riverbed. This tool creates FLIP fluid (as opposed to SPH fluid) because FLIP fluids are better to use for fast moving, largely unconstrained fluid simulations. FLIP fluids are also better to use in simulations where new particles are injected into the system.

Using Sculpted Particle Fluid

  1. Click the Sculpted Particle Fluid tool on the Particle Fluids tab.

  2. Select the fluid surface object to convert to particle fluid, and press Enter to confirm your selection.

  3. Select the terrain object for the fluid to flow in, and press Enter to confirm your selection.

  4. Select any obstacles that will be part of the fluid simulation, and press Enter to confirm your selection.

In this example, the grid is the fluid surface object, the riverbed is the terrain object, and the rocks are the obstacles.

This tool calculates the volume of the space between the grid and river bed to create particle fluid; however, it does not continuously emit particle fluid. To create a constant flow of particles, use the Emit Particle Fluid tool and place it at the top of the river. You can also place a Sink Particle Fluid at the foot of the river to drain the water.

Note

You can also add waveform to the fluid surface object before you convert it to a particle fluid to create waves in the simulation.

By default the water will have a transparent liquid shader. You can add Basic Liquid shader from the Material Palette and give it a bluish color if you want a more visible liquid.

See also

Shelf tools

Using the shelf

  • Customize the shelf

    How to change the look of the shelf, change and rearrange its contents, and create your own shelf tools.

Shelf tabs

  • Create tab

    Tools on the Create tab let you create and place primitives, curves, and null objects in the scene view.

  • Modify tab

    Tools on the Modify tab let you easily customize objects in the scene view.

  • Model tab

    Tools on the Model tab let you edit objects in the scene view.

  • Polygon tab

    Tools on the Polygon tab let you modify polygons in the scene view.

  • Deform tab

    Tools on the Deform tab let you deform objects in the scene view.

  • Texture tab

    Tools on the Texture tab let you texture objects in the scene view.

  • Rigging tab

    The Rigging tab contains tools for creating premade rigs.

  • Muscles tab

    The Muscles tab contains tools for creating muscles.

  • Characters tab

    Tools on the Character tab let you create characters in the scene view.

  • Constraints tab

    Tools on the Constraints tab create a constraint network where you can constrain objects to each other in the scene view.

  • Hair Utils tab

    Tools on the Hair Utils tab let you quickly set up hair and fur on objects.

  • Guide Process tab

    Tools on the Guide Process tab let you influence the placement and orientation of guide hairs by painting skin attributes.

  • Guide Brushes tab

    Tools on the Grooming tab let you add and directly manipulate hair.

  • Terrain FX shelf tab

  • Cloud FX tab

    The Cloud FX tab contains tools for creating cloud effects.

  • Volume tab

    The Volume tab contains tools for creating volume effects.

  • Lights and Cameras tab

    Tools on the Lights and Cameras tab let you create and place lights and cameras in the scene view.

  • Collisions tab

    Tools on the Collisions tab let you create collision objects in the scene view.

  • Particles tab

    Tools on the Particles tab let you create dynamic particle simulations.

  • Grains tab

    The Grains tab contains tools for simulate grains of sand and other granular matter.

  • Vellum tab

    The Vellum tab contains tools for creating different types of vellum effects.

  • Rigid Bodies tab

    Tools on the Rigid Bodies tab let you create dynamic RBD objects in the scene view.

  • Particle Fluids tab

    Tools on the Particle Fluids tab let you create particle based liquids in the scene view.

  • Viscous Fluids tab

    Viscous fluids are FLIP simulations that use a temperature attribute to drive viscosity.

  • Oceans tab

    The Oceans tab contains tools for creating ocean simulations.

  • Fluid Containers tab

    The Fluid Containers tab contains tools for creating pyro, smoke, and liquid containers.

  • Populate Containers tab

    The Populate Containers tab contains tools for creating and removing fire, smoke, and liquid.

  • Container Tools tab

    The Container Tools tab contains tools for manipulating fire, smoke, and liquid.

  • Pyro FX tab

    Tools on the Pryo FX tab let you create simulated smoke and fire effects.

  • Solid tab

    Tools on the Solid tab let you create and modify solid objects.

  • Wires tab

    Tools on the Wires tab let you create flexible dynamic objects in the scene view.

  • Crowds tab

    The Crowds tab contains tools for creating crowds, crowd behaviors, as well as examples.

  • Drive Simulation tab

    Tools on the Drive Simulation tab let you manipulate dynamic objects in the scene view.

Technical