Search - User list
Full Version: Baking fails with the Simple Baker SOP
Root » Houdini for Realtime » Baking fails with the Simple Baker SOP
I'm having an issue with the simple baker where it fails with this…
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "opdef:/gamedev::Sop/sop_simple_baker::2.0?PythonModule", line 6, in render
  File "C:/PROGRA~1/SIDEEF~1/HOUDIN~1.360/houdini/python2.7libs\houpythonportion\", line 850, in decorator
    return func(*args, **kwargs)
  File "C:/PROGRA~1/SIDEEF~1/HOUDIN~1.360/houdini/python2.7libs\", line 51207, in render
    return _hou.RopNode_render(*args, **kwargs)
OperationFailed: The attempted operation failed.
Error:       Error rendering child: /obj/terrain/sop_simple_baker1/ropnet1/rop_games_baker/render_plane

Edit: It seems that it's 9/10 on the second bake. Like the same geo and increasing the resolution, or same settings and slightly different geo.

I looked into the SOP and there are errors at a couple places. I've attached screenshots with the output errors.

I have the exact same problem and error messages, any ideas?
I believe this should be bug #98361
But it should be already fixed.

From the support on 10 August:
The issue was an internal HDA (Games Baker) that was unlocked and not picking up the settings form the Simple Baker. Our developers have submitted a fix which should be available in tomorrow's daily build of the gamedev tools.
After downloading the daily build tomorrow, please try creating a new Simple Baker and testing again.

I never tested again. Do you have the most update gamedev toolset?
If so, please contact the support again

i have the same issue on 18.5.351

i achieve to have it work once, after nithing even if i restart houdini
thank you for your help
I also had a problem with this node on Houdini 18.5.596 and there was exactly the same error. After spending some time searching, I think I found a solution (at least this fix worked for me).
The error in the “Labs Simple Baker" node comes from the “Labs Game baker" node (here is such an error

This is a very simple fix. It is necessary to remove all occurrences of maxsplit= for the rsplit function in the PythonModule script (which is created inside HAD), leave only the value 1 because "named parameters" appeared only in Python 3.0, and 2.7 is used in Houdini 18.5

Save your changes as a mod in a separate hda file, install it in the project and switch to it. After that, Labs Simple Baker will also work. If it doesn't work after installation in the project and switching, then you need to delete the “Labs Game baker” node in the project and add it again.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Powered by DjangoBB