Search - User list
Full Version: Is there a defualt "don't cook" option?
Root » Houdini Engine for Maya » Is there a defualt "don't cook" option?

I was wondering if there's a “do not cook” option per default when using a HDA inside of Maya?

Right now what I always do is add the input to a switch at the end, thus creating a custom “do not cook” option. The problem is that the asset still is being run through Houdini Engine, even though it just outputs the same mesh. This is quite slow when chain linking multiple HDA's within Maya. It'd be great if there existed an option to completely ignore changes to the input of the HDA by some means.


Hi Erik,

You should be able to disable the node in the houdiniAsset node's attributes by checking “Frozen” under Maya Transform Attributes > Node Behaviour.

Unfortunately this will only work if you are not using DG-based evaluation. []

You could also try setting the Node State to “HasNoEffect”. []
Thanks for the reply, John!

Sadly I wasn't able to get this Frozen approach to work, so I'm still using the “do not cook” solution described above.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Powered by DjangoBB