Houdini 16.5 Shelf tools

Small Ocean shelf tool

Creates a small patch of ocean complete with a material and depth information.

On this page

This tool is useful for creating an ocean like surface. However, it is not a simulation, it is a deformer that does not use DOPs at all. You can scrub through the timeline and watch the ocean evolve without any simulation. For a simulated ocean, use the Wave Tank tool on Particle Fluids shelf tab.

Using Small Ocean

In the Oceans shelf tab, click Small Ocean.

The tool will create and wire the Ocean Spectrum and Ocean Evaluate nodes necessary to control the shape and movement of the ocean. It will also create an Ocean Surface shader and attach it to the newly created ocean_surface object.

The animation is driven by the Time parameter on the Ocean Evaluate node. The default expression is $T (the current time). You can edit this expression to change the animation direction and speed (for example, $T * 2 to make the ocean move twice as fast).

Tip

Change your shading mode to Smooth Shaded Mode to get a better view of the deforming ocean surface.

The ocean_preview node is used to preview your ocean surface in the viewport. The ocean_render node is used by the Ocean Surface shader at render time.

The Ocean Spectrum node has all of the tools for changing the look of your ocean. For example, on the Wind tab, the Speed will affect the amplitude of the waves, the Directional Bias lets you create waves that move more or less in one direction, and the Chop which allows you to create the sharp peaks on the waves. The Wave Amplitude tab also has some very useful parameters, such as the Scale which controls the size of the waves.

Tips

  • For rendering, this tool creates a fetch node at the output level which is connected to the compositing network inside of the ocean_render node. If you would like to generate displacement maps at render-time, you can connect this node to the input of a Mantra node. If you use the Render button on this Mantra node, you will cause the Ocean Evaluate node to generate the texture maps required by the Ocean Surface shader for the specific frame you are viewing.

    Note

    It is important to remember to use the Reset Simulation button on the ocean_render node to make sure your ocean preview and ocean render nodes are synchronized.

  • To generate spectrum geometry, click the Save to Disk button on the save_spectra node in the ocean surface network.

    Note

    Spectrum geometry will have to be re-generated if you alter the wave parameters.

  • A velocity attribute is added to the ocean surface to allow the use of motion-blur at render-time. This information is stored on the points of your input grid. If you feel that the motion-blur is not accurate enough, you can change the rows and columns on your grid to increase the number of points. Keep in mind that drastically increasing the point count on your grid could negatively affect the speed of your renders.

  • If it is important for your scene to have information below your ocean surface, you can still optimize your renders by adjusting the Volume Step Rate and Volume Shadow Step Rate settings on the Sampling tab of the Mantra node. Often the volumetric element of the ocean is used for a general sub-surface scattering and attenuation effect and does not necessarily need to be highly detailed.

  • If the space below your ocean surface is not important in your final image, you could disable refraction on the Ocean Surface shader and turn off visibility on the ocean_interior object. This will reduce the length of your render significantly.

  • Lowering the Frequency on Ocean Surface shader > Foam > Streaks subtab will create a more broken up effect of the foam.

Changing the look of your ocean

To...Do this

Set the height of the wave

Navigate to the Ocean Spectrum node and adjust the Wave Scale parameter on the Wave Amplitude tab.

This value is multiplied by the Speed parameter on the Wind tab.

Set the direction of the waves

Navigate to the Ocean Spectrum node and adjust the Directional Bias parameter on the Wind tab.

This controls how many frequencies are moving in the same direction as the wind. Increasing this value will cause more frequencies to travel in the same direction, which is useful for creating shoreline effects.

You can also try increasing the Directional Movement parameter. This will dampen the waves moving in the opposite direction of the wind, leaving only the ones moving in the same direction.

Control the height of the peak

Navigate to the Ocean Spectrum node and adjust the Chop parameter on the Wind tab.

Increasing this parameter creates sharp peaks on waves. However, if this value is too high waves, may invert on themselves.

Add more detail to your ocean

Increase the Resolution Exponent parameter on the Ocean Spectrum node.

Note

The Resolution Exponent parameter will not only determine the quality of your ocean, but also the size of the texture maps that you will eventually write out.

Create a large ocean

Use the Large Ocean shelf tool.

See also

Shelf tools

Using the shelf

  • Customize the shelf

    How to change the look of the shelf, change and rearrange its contents, and create your own shelf tools.

Shelf tabs

  • Create tab

    Tools on the Create tab let you create and place primitives, curves, and null objects in the scene view.

  • Modify tab

    Tools on the Modify tab let you easily customize objects in the scene view.

  • Model tab

    Tools on the Model tab let you edit objects in the scene view.

  • Polygon tab

    Tools on the Polygon tab let you modify polygons in the scene view.

  • Deform tab

    Tools on the Deform tab let you deform objects in the scene view.

  • Texture tab

    Tools on the Texture tab let you texture objects in the scene view.

  • Rigging tab

    The Rigging tab contains tools for creating premade rigs.

  • Muscles tab

    The Muscles tab contains tools for creating muscles.

  • Characters tab

    Tools on the Character tab let you create characters in the scene view.

  • Constraints tab

    Tools on the Constraints tab create a constraint network where you can constrain objects to each other in the scene view.

  • Hair Utils tab

    Tools on the Hair Utils tab let you quickly set up hair and fur on objects.

  • Guide Process tab

    Tools on the Guide Process tab let you influence the placement and orientation of guide hairs by painting skin attributes.

  • Guide Brushes tab

    Tools on the Grooming tab let you add and directly manipulate hair.

  • Terrain FX shelf tab

  • Cloud FX tab

    The Cloud FX tab contains tools for creating cloud effects.

  • Volume tab

    The Volume tab contains tools for creating volume effects.

  • Lights and Cameras tab

    Tools on the Lights and Cameras tab let you create and place lights and cameras in the scene view.

  • Collisions tab

    Tools on the Collisions tab let you create collision objects in the scene view.

  • Particles tab

    Tools on the Particles tab let you create dynamic particle simulations.

  • Grains tab

    The Grains tab contains tools for simulate grains of sand and other granular matter.

  • Rigid Bodies tab

    Tools on the Rigid Bodies tab let you create dynamic RBD objects in the scene view.

  • Particle Fluids tab

    Tools on the Particle Fluids tab let you create particle based liquids in the scene view.

  • Viscous Fluids tab

    Viscous fluids are FLIP simulations that use a temperature attribute to drive viscosity.

  • Oceans tab

    The Oceans tab contains tools for creating ocean simulations.

  • Fluid Containers tab

    The Fluid Containers tab contains tools for creating pyro, smoke, and liquid containers.

  • Populate Containers tab

    The Populate Containers tab contains tools for creating and removing fire, smoke, and liquid.

  • Container Tools tab

    The Container Tools tab contains tools for manipulating fire, smoke, and liquid.

  • Pyro FX tab

    Tools on the Pryo FX tab let you create simulated smoke and fire effects.

  • Cloth tab

    Tools on the Cloth tab let you create and constrain cloth objects in the scene view.

  • Solid tab

    Tools on the Solid tab let you create and modify solid objects.

  • Wires tab

    Tools on the Wires tab let you create flexible dynamic objects in the scene view.

  • Crowds tab

    The Crowds tab contains tools for creating crowds, crowd behaviors, as well as examples.

  • Drive Simulation tab

    Tools on the Drive Simulation tab let you manipulate dynamic objects in the scene view.

Technical