Houdini 17.5 基本

シーンのビュー操作

On this page

概要

Houdiniでは、ビューア内でSpaceまたはAltを押したままにすることで、常にカメラツールに切り替えることができます。そしてマウスを使ってビューを変更することができます。

3Dマウスの使い方に関しては、3Dマウス入力のページを参照してください。

(Main PreferencesUse Alt Key for View Controls を無効にすることができます。)

Note

あなたが2Dグラフィックアプリケーションのユーザーなら、Houdiniでは、"ズーム"は、ビューの大きさではなく仮想カメラレンズの 焦点距離 を変更することを意味していることを忘れないでください。

タンブル、トラック、ドリー

Space +

タンプル

Space + または

ドリー

Space +

トラック

Space + ⌃ Ctrl +

ティルト カメラを傾ける

Space + ⌃ Ctrl +

ズーム カメラのレンズをズーム

⌃ Ctrl + Alt +

ボックスズーム 左から右へ矩形ドラッグすると、その矩形内の領域にズームインします。右から左へ矩形ドラッグすると、ズームアウトします(つまり現行ビューが矩形内にフィットします)。

⌃ Ctrl + Alt +

ボックスクロップ 左から右へ矩形ドラッグすると、その矩形内の領域にクロップされます。右から左へ矩形ドラッグすると、クロップされていないビューにリセットされます。

⌃ Ctrl + Alt +

スクリーンパン 。カメラのスクリーンウィンドウをパンします(カメラの位置は変わりません)。

Space + Z

カーソルの下にあるポイントがビューの中心になります

Space + H

ホーム: すべてのオブジェクト/ジオメトリが表示されるようにビューを中心に寄せます。

Space + G

選択した オブジェクト/ジオメトリすべてが表示されるようにビューを中心に寄せます。

Tip

より細かくタンブル、ドリー、トラック、ティルトをするには⇧ Shiftを押したままにします。

ビューピボット

ビュー中心またはマウス位置に基づいて、タンブル、ドリー、ズームを選択することができます。

To...Do this

タンブル、ドリー、ズームのモードを設定します

Viewツール(ビューの左側のツールボックスの Viewツールをクリックするか、Spaceを押したままにします)では、ビューの上部にあるツールバーのアイコンをクリックします。

ビューの中心(設定されたピボット)を基準に タンブル します。(詳細は、以下参照。)

マウスポイント下のジオメトリを基準に タンブル します。(詳細は、以下参照。)

スクリーンの中心を基準に ドリー します。

マウスポイントを基準に ドリー します。

スクリーンの中心を基準にカメラレンズを ズーム します。

マウスポイントを基準にカメラレンズを ズーム します。

他にも、ビューの左側のツールボックスの Viewツールを右クリックすることで、オプションのメニューを取得することができます。

タンブル

タンブルは、(実質的に)シーンの中心を基準にを、マウスポインタ下のジオメトリを基準にをピボットにすることができます。

技術的には、これらの2つのモードの違いは以下のとおりです:

  • "Keep Pivot"モードは、マウス位置に基づいてピボットを変更しません。デフォルトのタンブルのピボットは原点なので、デフォルトでは、そのピボットは、ビューをトラックした時に移動します。これには、ビューの中心を基準にタンブルする効果があります。

  • "Set Pivot"モード(デフォルト)は、ジオメトリ上でタンブルを開始した時にピボットを設定します。これは、マウス下にあったジオメトリポイントを基準にタンブルします。何もないところをクリックすれば、以前のピボットを基準に中心をタンブルします。

    デフォルトでは、ビューをトラックするとピボットも移動するので、ジオメトリを基準にタンブルしても、ビューを動かせば、そのピボットポイントも一緒に動きます。 これは、不意に遠くのジオメトリをタンブルしてしまわないのでほとんどの場合にはOKですが、設定でピボットの追従を無効にすることができます。

Tips

  • Space + Zを押したままビューポート内をクリックすることで、手動で原点を設定することができます。"Set Pivot"モードは、ジオメトリ上でタンブルを開始した時に常にピボットを自動的に設定します。

  • ビューを原点にホーム(Space + H)させると、ビューピボットも原点にリセットされます。

  • モードを設定する時、Lを押しながらビューを変更することで、 他の モードに切り替えることができます。

    例えば、Houdiniにビュー中心の方にドリーするように設定した場合、Space + Lを押しながらドラッグすることで、ビュー中心を基準にタンブルすることができます。

オプション

  • ビュー内でタンブルピボットを可視にするには、3Dビューアの右側の Display Optionsボタンをクリックして、 Guides タブの View Pivot を有効にします。

  • デフォルトでは、 ビューをトラック(ビューを上、下、左、右に移動)すると、タンブルピボットも移動します。

    これは、"Keep pivot"モードでは、ビューの中心にピボットが維持され、"set pivot"モードでもビューを移動させた時に不意に遠くのピボット基準でタンブルしてしまわないようにするので、通常では、あなたが求めている挙動になります。

    しかし、モデルを基準にトラックした時にピボットが動かないように、あなたが作業しているジオメトリ上の特定のポイント上にピボットを設定したい時があります。

    ビューピボットに影響を与えないようにトラックを設定するには、メインメニューから Edit ▸ Preferences ▸ 3D ViewportsMaintain viewport pivot when panning を選択します。

  • 選択されたジオメトリにビューピボットを自動的に設定させるには、メインメニューから Edit ▸ Preferences ▸ 3D Viewports を選択して、 Automatically set view pivot on selection を有効にします。

  • タンブリングする時にゴーストオブジェクトテンプレートジオメトリを"マウス下のジオメトリ"として考慮するどうか設定するには、ビューポートの左側のツールボックスの Viewツールを右クリックして、オプションメニューを取得します(デフォルトでは、ゴーストオブジェクトとテンプレートジオメトリを無視します)。

ビューとカメラ

Houdiniでは、Mayaとは違って、通常ではビューはカメラオブジェクトから独立しています。とはいえ、ビューをカメラにロックすれば、ビューキーでカメラを移動させたり回転させることができます。

To...Do this

ビューをカメラやライトに一致させる

ビューポートのカメラメニュー(ビューポートオプションメニューの右側)をクリックして、カメラやライトを選択すると、その視点に切り替わります。

通常は、カメラやライトの目線でタンブルするとビューは"no cam"に戻ります。デフォルトでは、ビューはカメラとライトにはつながりがありません。カメラやライトの目線のビューに固定しておきたいならば Lock camera/light to view ボタンを使います。

Note

カメラをビューポートメニューに表示したくないなら、viewmenuという名前のスペアパラメータをカメラに追加し、その値を0にすることで非表示になります。

カメラやライトを現行ビューに一致させる

  1. ビューポートのカメラメニュー(ビューポートオプションメニューの右側)をクリックして Save view を選択します。

  2. ポップアップメニューからカメラやライトを選択して、 Accept をクリックします。

現行ビューの視点に、選択したカメラやライトが移動/回転します。

ビューキーを使ってカメラやライトを配置する

通常、Houdiniのビューアは"no cam"に設定します。これは、どのカメラやライトから見たものではないことを意味します。カメラメニューからカメラやライトを選択すると、ビューアはカメラ/ライトの視点に切り替わりますが、タンブル/トラック/ドリーを使ってビューを変更すると、また"no cam"に戻ってしまいます。ビューキーを使うと、通常は、ビューはカメラやライトを移動させません。

ビューキーを使ってカメラやライトを移動させるには、ビューをカメラやライトにロックさせる必要があります。

  1. ビューポートのカメラメニューからカメラやライトを選択します。

  2. ディスプレイツールバー(ビューアの右側)の Lock camera/light to view アイコンをクリックします。

    または

    ビューポートのカメラメニューを開き、 Tie camera (or light) to view を選択します。

  3. ビューキー(上記参照)を使ってカメラやライトを移動します。

Tip

デフォルトでは、マウスボタンが離された時に、ビューがカメラまたはライトにエクスポートされます。 ビューポートカメラメニューの Export view continuously を有効にすることで、この挙動を上書きすることができます。 ビューをエクスポートするとクックが発動されてしまうので、このオプションは注意して使用してください。

現行ビューからカメラを新しく作成する

カメラメニューから New camera を選択するか、シェルフのカメラ/ライトアイコンを⌃ Ctrlを押してクリックします。

詳細は、カメラライトの選択を参照してください。

ビューポートレイアウト

デフォルトでは、シーンビューには単一のパースビューが表示されます。

ビューをサブビューに分割して、正射投影ビューやUVテクスチャ空間などの異なるビュータイプを表示させることができます。例えば、正面、側面、正面、パースを表示した4画面ビューに切り替えることができます。

To...Do this

ビューポートレイアウトを変更する

ビューアのツールバー上のビューポートレイアウトメニューアイコンをクリックしてメニューからレイアウトを選択します。

あるビューポートを一時的に最大化する

マウスをそのビューポート上に動かして、Space + Bを押します。再度、その単一ビューポート上でSpace + Bを押すと、複数ビューポートレイアウトに戻ります。

ビューポートのビューのタイプを変更する

ビューポートの右上コーナーのビューポートオプションメニューをクリックして、 Set View サブメニューを開きます。

複数の正射投影ビューポートを同時に一緒にパン、ズームをする

ビューポートレイアウトメニューを開き、 Link ortho views にチェックを付けます。

Houdiniのシーンの表示方法を変更する

シェーディングモードを変更するには、ビューアのツールバーのシェーディングモードアイコンをクリックします。

Wireframe bounding box

ワイヤーフレームの境界ボックスだけを描画してジオメトリを表現します。

Shaded bounding box

シェーディングした境界ボックスだけを描画してジオメトリを表現します。

Wireframe

曲線、サーフェスアイソパラム、ポリゴンエッジを描画します。

Wireframe Ghost

Wireframeと同様ですが、隠線をゴースト(薄く)表示します。

Hidden Line Invisible

Hidden Line Ghost

Hidden Line Invisibleと同様ですが、サーフェスで隠れた線が、微かに表示されます。

Flat Shaded

ポリゴンをシェーディングしますが、ポリゴン間をブレンドしないので多面的な表示になります。

Flat Wire Shaded

Flat Shadedと同じですが、さらにワイヤーフレームを表示します。

Smooth Shaded

ポリゴン間が滑らかにシェーディングされるようにブレンドします。

Smooth Wire Shaded

Smooth Shadedと同様ですが、さらにワイヤーフレームを表示します。

To...Do this

ワイヤーフレームとシェーディングモードを切り替える

ビューア内でWを押します。

または

ビューポートオプションメニューを開き、 Shading ▸ Toggle Wireframe/Shaded を選択します。

すべてのディスプレイオプションのウィンドウを開く

ビューアの右側にある Display Optionsボタンをクリックするか、ビューア内でDを押します。

グリッドを非表示にする

ビューの右側にあるディスプレイオプションツールバーの Display Construction Plane/Ortho Gridボタンをクリックします。

ビューポートの背景に画像を配置する

  1. ビューアの右側にある Display Optionsボタンをクリックするか、ビューア内でDを押します。

  2. Background タブをクリックします。

  3. Display Background Image トグルをオンにします。

  4. 背景画像を設定したいビューポートタイプ(例えば、 Pesp , Top , UV など)に該当するサブタブをクリックします。

  5. Disk File フィールドの右側にあるファイル選択ボタンをクリックして、画像ファイルを選択します。

("Disk File"を"COP Image"に変更することで、代わりにコンポジットノードから画像を読み込むことができます。)

Displayツールバー

ビューポートの右側にあるツールバーには、Houdiniが3Dビューア内で描画する内容とシーンでのその描画方法を設定するためのコントロールがあります。

Display reference plane/ortho grid

Reference Plane上にグリッドを描画します。このグリッドの原点はReference Planeの中心で、Upベクトルの方向(デフォルトはXZ平面)を向きます。

このボタンを右クリックすると、Reference Planeのグリッド関連のオプションメニューが表示されます。

Display construction plane

Construction Planeを表示します。この平面は、描画しやすいように移動/回転させたり、平面にスナップさせることができます。

このボタンを右クリックすると、Construction Planeオプションメニューが表示されます。例えば、Construction Planeのハンドルを表示すれば、その平面を移動/回転させることができます。

Lock camera/light to view

カメラ(またはライト)視点で、このオプションが有効になっていると、ビューア内でタンブル/トラック/ドリーさせると、そのビューアは固定したカメラ/ライトも移動/回転させます。

Disable Lighting

ビューア内でライティングをシミュレーションしません。 シェーディングなしで一定アンビエントライトを使って、すべてのサーフェスが照らされます。

Headlight Only

ビュー原点に取り付けられたアンビエントライトとヘッドライトによって照らした感じでシーンをシェーディングします。 シーン内の実際のライトの効果をシミュレーションしません。

このボタンを右クリックすると、使用するライティングコンポーネントのメニューが表示されます。

Normal Lighting

シーン内のライトのおおよその寄与度でシーンをシェーディングします。

このボタンを右クリックすると、使用するライティングコンポーネントのメニューが表示されます。

High Quality Lighting

シーン内のライトのもっと精度の良いおおよその寄与度でシーンをシェーディングします。

このボタンを右クリックすると、使用するライティングコンポーネントと反射のシミュレーションなどの品質オプションのメニューが表示されます。

High Quality Lighting with Shadows

シーン内のライトのもっと精度の良いおおよその寄与度とシャドウのシミュレーションでシーンをシェーディングします。

このボタンを右クリックすると、使用するライティングコンポーネントとシャドウ品質などの品質オプションのメニューが表示されます。

Display materials on objects

ビューア内でOpenGLによるマテリアルの近似表示を有効にします。

このボタンを右クリックすると、表示と品質のオプションのメニューが表示されます。

Control Visibility of Object Types

このボタンをクリックすると、ビューア内で表示/非表示にする色々なオブジェクトタイプのメニューが表示されます。

Filter Visibility of Object Types during Playback

これは、アニメーション再生中に表示されるオブジェクトタイプ(現在のところ、上記のオブジェクトタイプの可視設定内の可視性のみ)のフィルターです。

このボタンを右クリックすると、特定のオブジェクトタイプを有効/無効にすることができます。

このボタンをクリックすると、フィルターを有効/無効にすることができます。 このボタンが有効な時、フィルターメニューで有効になっているオブジェクトタイプのみが再生中に表示されます。

(このフィルターが有効になっている時、これはフリップブックアニメーションにも影響しますが、単一フレームのフリップブックには影響しません。)

Points

ポイント上に小さなマーカーを描画します。

Point Normals

ポイント法線を意味したラインを描画します。

Point Trails

各ポイントのVelocity(v)アトリビュートを可視化したラインを描画します。 Trailジオメトリノードを使えば、ポイントにVelocityアトリビュートを追加することができます。

Point Numbers

各ポイントの隣にポイント番号を表示します。

Primitive Normals

フェースポリゴンの法線を意味したラインを描画します。

Primitive Numbers

各プリミティブ(例えば、ポリゴンフェース)の隣にプリミティブ番号を表示します。

Hulls

NURBSやBezierなどのタイプに対してハルを表示します。

Vertex Markers

頂点を示したマーカーを描画します。

Particle Origins

パーティクルに小さな座標系を描画して、パーティクルの向きを示します。

Display group and attribute list

ビューア内でグループリストボックスを表示/非表示にします。

Display object names

ビューア内でオブジェクトの隣にオブジェクト名を表示します。

Display background

Display Optionsでビューポート背景画像(s)をセットアップしている場合、このボタンを使用することで、その背景画像を表示/非表示にすることができます。

Visualization

このアイコンを右クリックすると、ビジュアライザメニューが表示されます。

このボタンをクリックすると、全体ですべてのアクティブなビジュアライザを表示/非表示にすることができます。

Viewport messages

このボタンを押したままにすると、現行ビューで発生したメッセージ/統計情報が表示されます。

Apply to all split views

ビューアがサブビューポートに分割されている時、このボタンをクリックすると、ツールバーがすべてのビューポートに影響を与えるのか、または、現行ビューポート(通常では、最後にクリックされたビューポート)のみに影響を与えるのか切り替えることができます。

Display options

Display Optionsウィンドウを開きます。

ビューのリセット

ホーム とは、ビューをリセットまたはデフォルトのビューに戻すという意味です。あなたは、ホームをすることで、シーン上のすべてのオブジェクトをビューポート内に収めたり、選択したオブジェクトをビューポートに収めることが。2DイラストソフトやPDF、画像ビューアなどのプログラムでいうと、"ズームしてフィット"機能と同じです。

ホームとフレームのコントロールは、ビューポートオプションメニュー(ビューポートの上部右側コーナの左のメニュー)にあります。このメニューには、ビューをホームするコマンドが用意されているので、デフォルトのビューをカスタマイズすることが可能です。または、ホットキーを使うこともできます。

目的

ビューポートメニュー

ホットキー

すべてのオブジェクトにフィットするようにズームする。

Home ▸ Home All

Space + A

選択したオブジェクトにフィットするようにズームする。

Home ▸ Home Selected

Space + G

グリッドにフィットするようにズームする。

Home ▸ Home Grid

Space + H

To...Do this

ホームビューを軸方向に変更する

ビューポートメニューを開き、 Home をクリックして、ビュー方向(X軸、Y軸、Z軸)を選択します。

ホームビューをカスタム方向に変更する

  1. タンブルキー(上記参照)を使ってビュー方向を設定します。

  2. ビューポートメニューを開き、 Home をクリックして、 Customize Home を選択します。

  3. ビューポートメニューを開き、再度 Home をクリックして、オプションのリストから Custom を選択します。

  4. ホームのホットキーを使うと、このビューになるはずです。

ジオメトリレベルで他のオブジェクトを表示する

オブジェクト内で編集している時に、 Show All/Current/Ghostedメニューを使用して、 Houdiniがシーン内の他のオブジェクトを表示するかどうか選択することができます。

Show Ghosted

他のオブジェクト/レベルを"ゴースト"(半透明)として表示します。これがデフォルトです。

Show Others

他のオブジェクト/レベルを通常のまま表示します。

Hide Others

作業しているレベルのジオメトリのみを表示し、他を非表示にします。

色々なレベル/状態に対してディスプレイオプションを設定

すべてのジオメトリ、選択したジオメトリ、マウスカーソル付近のジオメトリ、他の状態に対して、色々な特徴表示とシェーディングオプションをセットアップすることができます。 例えば、マウスカーソル付近のポイントや選択したジオメトリのポイントにのみポイント番号を表示させて、表示がゴチャゴチャしないようにすることができます。

  1. ビューアの右側にある Display Optionsボタンをクリックするか、ビューア内でDを押します。

  2. Markers タブをクリックします。

  3. Set display options for メニューから変更したい状態を選択します。

    このメニューは、以下のオプションの適用先となるジオメトリのカテゴリを制御します。

    Scene Geometry

    オブジェクトレベルでの非選択オブジェクトの見た目に関するディスプレイオプション。

    Selected Scene Geometry

    オブジェクトレベルでの選択オブジェクトの見た目に関するディスプレイオプション。デフォルトでは、これは"Scene Geometry"と同じです。

    Ghost Scene Geometry

    ジオメトリレベル(Geometryオブジェクト内)の時、オプションで他のオブジェクトを"ゴースト"(半透明)表示させることができます。

    Display Model Geometry

    ジオメトリレベル(Geometryオブジェクト内)の時、ディスプレイフラグが付いたノードの出力に関するディスプレイオプション。

    Current Model Geometry

    選択したジオメトリノードの出力に関するディスプレイオプション。 ジオメトリレベルで、ディスプレイフラグの付いていないノードを選択した時に、ビューには、ネットワークの出力と一緒に、その選択したノードの出力を(デフォルトでは、ワイヤーフレームで)表示します。 これにより、そのノードを編集すると、ビューでその効果を確認することができます。

    Template Model Geometry

    "テンプレート"ジオメトリに関するディスプレイオプション。ジオメトリノードにテンプレートフラグを設定することで、ディスプレイジオメトリと一緒に、そのノードの出力をジオメトリレベルで可視に維持することができます。

    Note

    このメニューの隣にある Use メニューを使用すれば、他の状態からの設定を使用することができます。 Use を"Unique Settings"に設定することで、選択した状態の設定を独自の設定にすることができます。

  4. この状態で可視にしたい特徴の隣にあるチェックボックスをクリックします。

    各オプションの右側にある 可視性アイコンメニューを使用すれば、指定した特徴が可視になる 時期 (常時、選択した時、マウスカーソル付近の時、マウスカーソル下の時)を制御することができます。

  5. 一番右端の列では、指定した状態のジオメトリに対するシェーディングスタイルと描画オプションを選択します。例えば、 Ghosted はジオメトリを半透明で描画し、 Faded はカラーを薄暗くして若干見づらくします。

ビューのカラー補正

カラー補正ツールバーを表示するには、ビューポートの右上コーナーにある(カメラメニューの隣の)ビュードロップダウンメニューをクリックして、 Correction Toolbar をオンにします。 または、ビューポートの右側のツールバーにある Display Options ボタンのメニューのトグルによってカラー補正ツールバーを表示することもできます。

詳細は、OpenColorIOサポートを参照してください。

マテリアルの表示

Material PaletteまたはNetwork Editorからマテリアルをオブジェクトジオメトリ上にドラッグアンドドロップすることで、マテリアルをジオメトリに割り当てることができます。 または、Material SOPMaterial Stylesheetによってマテリアルを割り当てることもできます。

ビューポートの右側のツールバーにある Display Materials トグルをクリックすることで、マテリアルの表示を無効にすることができます。 テクスチャの表示, パーティクルの表示, 透明度といったマテリアルの割り当てとオプションの詳細コントロールは、メニューにあります。

基本

はじめよう

次のステップ

カスタマイズ

導師レベル