Search - User list
Full Version: Renderman 23.2 and Ubuntu 19
Root » 3rd Party » Renderman 23.2 and Ubuntu 19
Daryl Dunlap
Been fighting for hours trying to figure out why the RM installer wont authenticate. If anyone can provide assistance, it would be greatly appreciated.

I get:
QSslSocket: cannot call unresolved function CRYPTO_num_locks

when I try to authenticate via the RM Installer.
Daryl Dunlap
To anyone else that ever gets in this jam, just copy libcrypto.so.1.0.0 and libssl.so.1.0.0 to the /bin directory of the RenderManInstaller file and that fixes it.

Edit: So I got it to install, and configured in Houdini.env like it wants too, and the RM License App says my license is valid, but, I get a stupid error when I try to render in Houdini:
Rfh: Could not initialize RenderMan
. Ugh! This is so freakin difficult on Linux.
nisgia7
Edit: So I got it to install, and configured in Houdini.env like it wants too, and the RM License App says my license is valid, but, I get a stupid error when I try to render in Houdini:
Rfh: Could not initialize RenderMan
. Ugh! This is so freakin difficult on Linux.

Hey Daryl,
i am in the same boat.I managed to install renderman ncr on Xubuntu after many tries.I had to compile the libssl cause even copying the files didn`t work.Now what about the error inside houdini.It seems to be set up correctly.All menus are there but i get this error.Searched the net and could not find any awnswers or any hint where t solve it.
So did you solve it?
Daryl Dunlap
Nope, I asked in every Social Corner I could - no one knew how to get it to work.
JoachimPaul
Daryl Dunlap
Nope, I asked in every Social Corner I could - no one knew how to get it to work.

it was solved in some social corners like discord.
For me it was enough to make a symbolic link
sudo locate libcrypto.so.1.0.0
sudo locate libssl.so.1.0.0
sudo ln -s /opt/hfs17.5/dsolib/libcrypto.so.1.0.0 /opt/pixar/RenderMan-Installer-ncr-22.6/lib/3rdparty/Qt-5.6.1/lib/libcrypto.so
sudo ln -s /opt/hfs17.5/dsolib/libssl.so.1.0.0 /opt/pixar/RenderMan-Installer-ncr-22.6/lib/3rdparty/Qt-5.6.1/lib/libssl.so
Daryl Dunlap
Correct me if I'm wrong, but, it looks like that will fix the install, which we've both also already completed.

What's still outstanding, is actually rendering from Houdini on Ubuntu.
nisgia7
So is there at least any person using another distro that had success or rendering in linux is not achievable?at least at the current state of renderman.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Powered by DjangoBB