Houdini 17.0 Networks and parameters

Laying out nodes

How to automatically clean up, align, and distribute nodes.

On this page

Tip

When you place a node, existing nodes will automatically move out of the way to preserve spacing.

Grid

To...Do this

Show the grid

In the network editor, open the Tools menu (at the top of the network editor pane) and click Grid points or Grid lines.

Snap to the grid

In the network editor, choose Tools ▸ Snap to grid.

Set the grid spacing

  1. Choose View ▸ Display options in the network editor to open the display options window.

  2. Click the General tab and set the grid spacing.

Laying out nodes

Layout Mode

Hold this key and swipe nodes with the mouse to layout or align

  • When you place a node, existing nodes will automatically move out of the way to preserve spacing.

  • The network editor shows alignment guides when you place or drag a node.

  • If you have nodes selected, the layout commands only affect the selected nodes. You can use this, for example, to select and layout only the immediate children of a node rather than all descendents.

To...Do this

Lay out upstream from a node

Hold A and drag up from the node (or left to align to the left).

or

Select the node and choose Layout ▸ Layout nodes up or Layout nodes left.

Lay out downstream from a node

Hold A and drag down from the node (or right to align to the right).

or

Select the node and choose Layout ▸ Layout nodes down or Layout nodes right.

Lay out all nodes

In the network editor, choose Layout ▸ Layout all nodes. To layout only the selected nodes, choose Layout ▸ Layout selected nodes.

Note that targeting automatic layout on individual nodes/branches using the A key will often give better results than doing a full re-layout, which can radically change the relative positions of nodes.

Spacing and aligning nodes

The layout functions (see above) are often more convenient and give better results than manually aligning nodes, but you can use the manual tools in the Layout menu to manually align nodes.

  • To align nodes with each other, select the nodes you want to align, then choose Layout ▸ Align nodes horizontally or Align nodes vertically.

    To align to a specific node, select the nodes you want to align, then hold ⇧ Shift + A and drag horizontally or vertically from the node you want to align to.

  • To space out nodes evenly, select the nodes you want to move, then choose Layout ▸ Distribute nodes horizontally or Distribute nodes vertically.

    To keep a specific node in the same place and distribute the other nodes around it, hold Alt + A and drag horizontally or vertically from the node you want to distribute around.

  • You can align and distribute at the same time by holding ⇧ Shift + Alt + A and dragging.

Networks and parameters

Networks

  • Network editor

    How to create, move, copy, and edit nodes.

  • Network navigation

    How to move around the networks and move between networks.

  • Connecting (wiring) nodes

    How to connect nodes to each other to make them work together.

  • Network types and node flags

    Flags represent some state information on the node, such as which node represents the output of the network. Different network types have different flags.

  • Badges

    Badges indicate some status information about a node. They usually appear as a row of icons below the name of the node.

  • Find nodes in a network

    How to use the Find dialog to find nodes based on various criteria.

Editing parameters

Next steps

Expressions

Guru level

Reference