Houdini 17.0 Networks and parameters

Network navigation

How to move around the networks and move between networks.

On this page

Moving around the network

To...Do this

Pan and zoom the network view

  • Drag to pan, or hold Space and drag .

  • Use to zoom in and out. Or, hold Space and drag .

  • Press O to show a small representation of the current network in the corner. Clicking or dragging on this overview pans the view around the network.

Automatically Pan and zoom to show all nodes

Right click the network background and choose Viewing controls ▸ Home all, or press H.

Automatically Pan and zoom to show the selected nodes

Right click the network background and choose Viewing controls ▸ Home selected, or press G.

Go inside a network node to see its contents

  • Double-click the node.

  • Select the node and press I or Enter.

  • on an object in the viewer and choose Edit Geometry, Edit subnetwork, etc.

Go up a level to the network above the current one

  • Click the level in the path above the network view.

    or
  • Press U in the network editor.

Select the previous (input) or next (output) node in the current chain

Press PgUp or PgDn.

Find a specific node

See finding nodes.

Zoom to the start or end of a wire

If you see a wire, and want to zoom to the input or output, right-click the wire and choose Frame input or Frame output.

Framing

To...Do this

Zoom out to show all nodes

In the network editor, choose View ▸ Zoom to show all, or press H.

Zoom to show all selected nodes

In the network editor, choose View ▸ Zoom to show selected, or press G.

Panning while dragging

  • When dragging a node to move it in the network editor, you can automatically pan by holding the mouse near the edge of the network view without

  • Hold Space while dragging to lock the cursor inside the network view. This lets you drag large distances with autoscroll, without worrying about the mouse pointer going outside the view.

Network overview

The overview shows a small schematic view of the overall network in the bottom left corner of the network view. It lets you see where the current view is in relation to the overall network, and lets you quickly move the view by clicking in the overview.

You can control when the overview appears using the Tools ▸ Show overview menu items:

When needed

The overview only appears when the entire network doesn’t fit in the view.

Always

Always show the overview.

Never

Don’t show the overview.

By default, the overview is set to show "when needed".

Quickmarks

"Quick marks" let you quickly set and return to lightweight, disposable network location "bookmarks". Unlike regular bookmarks (see below), you can use them as-needed and then override them or forget about them. They are not saved with the scene file.

Each mark records the network path, view location, and zoom level. So you can use marks to switch back and forth between two different networks, or two different areas or nodes in the same network.

To...Do this

Set a quick mark

Press ⌃ Ctrl and 1, 2, 3, 4, or 5.

On Mac, press and 1, 2, 3, 4, or 5.

Return to a quick mark

Press 1, 2, 3, 4, or 5.

Go back to the previous view

Press ` (backtick).

This lets you quickly switch back and forth between two views, possibly in different networks.

Location history and bookmarks

To...Do this

Go the previous or next network location viewed (like a browser)

  • Use the arrow buttons in the network editor toolbar.

    or
  • Press Alt + or Alt + .

Use bookmarks

Click the history dropdown menu at the end of the path gadget at the top of the editor pane, and choose Bookmarks. You can use this menu to add new ones or edit existing ones. Once you add a bookmark it will appear in the history dropdown menu.

These bookmarks are saved with the scene file, so you can use them to make a list commonly useful locations always available.

Networks and parameters

Networks

  • Network editor

    How to create, move, copy, and edit nodes.

  • Network navigation

    How to move around the networks and move between networks.

  • Connecting (wiring) nodes

    How to connect nodes to each other to make them work together.

  • Network types and node flags

    Flags represent some state information on the node, such as which node represents the output of the network. Different network types have different flags.

  • Badges

    Badges indicate some status information about a node. They usually appear as a row of icons below the name of the node.

  • Find nodes in a network

    How to use the Find dialog to find nodes based on various criteria.

Editing parameters

Next steps

Expressions

Guru level

Reference