Houdini 16.0 Reference Windows

Display Options (3D viewer)

On this page

When the Apply operations to all split views checkbox at the bottom of the window is on (the default), all changes in this window apply to all split viewports.

When using a split view, the easiest way to make viewport-specific changes is to use the viewport options menu in the top-right corner of the viewport. The menu contains most viewport-related settings you might want to change, such as shading mode.

However, if you want to change other display options in only one viewport, move the pointer over the one of the split views and press N to make it "active" (the view’s menus are drawn in yellow). Then open the display options window and turn off Apply operations to all split views before making changes.

Markers tab

Set display options for

This menu controls what category of geometry the options below apply to.

Scene Geometry

Display options for unselected objects at the object level look like.

Selected Scene Geometry

Display options for selected objects at the object level. By default this is the same as "Scene geometry".

Ghost Scene Geometry

When you are at the geometry level (inside a Geometry object), you can optionally show other objects "ghosted" (semi-transparent). This shows display options for these ghosted objects.

Display Model Geometry

At the geometry level (inside a Geometry object), display options for the output of the node with the display flag.

Current Model Geometry

Display options for the selected geometry node’s output. At the geometry level, when you select a node that doesn’t have the display flag, the view shows the output of the selected node (by default, as wireframe) along with the output of the network. This lets you edit the node and see the effects in the view.

Template Model Geometry

Display options for "templated" geometry. You can set the template flag on a geometry node to keep the node’s output visible at the geometry level alongside the display geometry.

Use

Allows you to use the marker settings from another category for the current category. To manually set options for the current category, choose "Unique settings".

Link Toolbar

When this option is on, the controls on the display toolbar (to the right of the viewport) will affect the settings for the current category.

For example, if you are editing the "Ghost scene geometry" markers, and you turn on Link toolbar, then clicking the Display Point Numbers button on the toolbar will turn point numbers on or off for ghost scene geometry. If you turn Link toolbar off, then ghost scene geometry will always use the "Point numbers" setting from the display options, ignoring the toolbar button.

Marker type visibility menu

Most marker types have a small visibility icon menu to the right of the label that allows you specify different levels of visibility for the marker type. This can be useful for reducing clutter in the viewport. Click the icon to show a menu of visibility levels:

Always visible

Show the markers on all visible components.

Only selected components

Only show the markers on selected components (points, primitives, vertices).

Area around pointer

Only show the markers near the mouse pointer.

Under pointer only

Only show the marker on the component (point, primitive, vertex) under the mouse pointer.

Points

Markers

Draw small dots showing the point locations.

Numbers

Draw the point number next to the point location. Point numbers start at 0.

Normals

Draw the point normal direction as a small line from the point location. You can change the line length using the Normal scale option on the Guides tab.

If a point does not have a normal attribute, Houdini draws a generated normal (as used by the viewport and Mantra), in a dimmer color.

UV coords

Draw each point’s UV texture coordinates next to the point location.

XYZ coords

Draw each point’s 3D coordinates next to the point location. Drawing three decimal numbers for each point can clutter the screen quickly, so you might want to use the visibility menu for this option.

Trails

Draw a trail line from the current point position back to where it was in the previous frame. This information is taken from the point’s v (velocity) vector attribute. You can scale the trail length using the Vector scale option on the Guides tab.

Coincident

Draw the number of overlapping points when multiple points overlap on the screen (for example, if three points overlap, draws a 3).

This is in screen space, so it’s most useful when the geometry you're looking at occupies a lot of the viewer. If the geometry is small/far away, you’ll get a lot of useless overlap readings.

Don’t turn this on for all geometry in the scene. It works best on the display geometry, or only the selected geometry.

Primitives

"Primitives" are polygon faces, curves, and NURBS surfaces (as well as more exotic types such as metaballs, primitive shapes, and crowd agents).

Hulls

Draw lines representing the limits of NURBS, Beziér surfaces, curves, and metaballs.

It can be useful to display hulls in place of the actual geometry when extremely large numbers of these types of geometry fill the screen, to reduce clutter and speed up the display.

Numbers

Draw the primitive number next to the primitive. Primitive numbers start at 0.

Normals

Draw the primitive normal direction as a small line from the primitive’s location (for primitives that have normals). You can change the line length using the Normal scale option on the Guides tab.

Breakpoints

Draw edit points on NURBS and Beziér curves/surfaces.

Profile curves

Draw profile (trim) curves on NURBS surfaces.

Profile numbers

Draw the profile curve number next to the start of profile (trim) curves. Profile curve numbers start at 0.

Vertices

Markers

Draw small boxes showing the vertex locations. Draws the vertices slightly offset inward on the polygon face so you can tell the vertices apart from each other and the point. Unselected vertices are hollow, and selected vertices are filled.

Numbers

Draw the vertex number next to the vertex location. Draws numbers for vertices of different polygons in slightly different shades, to make them easier to tell apart.

Normals

Draw the vertex normal direction (if the vertex has a normal attribute) as a small line from the vertex marker’s location. Draws normals for vertices of different polygons in slightly different shades, to make them easier to tell apart. You can change the line length using the Normal scale option on the Guides tab.

UV coords

Draw each vertex’s UV texture coordinates next to the vertex marker location.

UV Backfaces

In UV viewports, change the fill color of back-facing polygons to make it easy to tell them apart from front-facing polygons.

UV Overlap

In UV viewports, change the fill color of regions where multiple primitives overlap.

Draw

The options in this column control how Houdini draws geometry in the current category.

Draw

The shading mode for surfaces in the current category. For example, you can have scene geometry drawn as smooth shaded, and templated geometry drawn as wireframe.

Lock Shading Mode

Ignore the viewport shading mode control for surfaces in the current category.

For example, this is on by default for templated geometry, so (for example) changing the viewport shading mode between shaded and wireframe does not change the look of templated geometry.

Ghosted

Draw curves/surfaces with a grayed-out, less prominent look.

Faded

Ignore any color (Cd attribute) or any texture on curves/surfaces. Uses the default wireframe colors and the default material. This generally used for "templated" geometry. You can change the defaults on the Effects tab.

Draw as X-Ray

Show the wireframe of any geometry hidden behind other surfaces.

Allow Lighting

Allow lighting to affect the look of geometry in the current category. This override’s the viewport’s lighting setting.

Boundaries

Choose whether to highlight open edges.

No boundaries

Don’t highlight open edges.

3D boundaries

Draw open 3D edges in a different color.

UV boundaries

Draw open UV edges in a different color.

View-specific boundaries

Draw 3D boundaries in 3D viewports, and UV boundaries in UV viewports.

Note

"3D boundaries" requires Houdini to preprocess the geometry in the scene. It should be fast to tumble, but can slow animation playback.

Guides Tab

Floating gnomon

Draw a small gnomon in the bottom left corner of the view, showing the current orientation of the world axes.

Origin gnomon

Draw a gnomon at the world-space origin (0,0,0). (See also how to display an object’s origin/pivot.)

Particle gnomon

Draw a small gnomon at the origin of each particle system. If the particle system’s Display Particle Axes option is on, and the particles have a center of mass attribute (com), this will show the center of mass.

Group and attribute list

Show the group list in the upper right corner of the viewer.

Video safe areas

Draw rectangles showing the video "safe area" for picture and titles.

Field guides

Draw a traditional cell-animation grid overlay on top of the view. This can make it easier to align elements by eye and find points of reference between frames.

Camera view mask

Draw the view mask and overlay of the current camera.

The parameters on the camera to control the display mask are set to a 1.85 aspect ratio and hidden by default. To show them, use Edit rendering parameters in the parameter editor’s gear menu, and add the For rendering ▸ Viewport ▸ View Mask properties.

XZ, XY, and YZ Reference Planes

Draw a 20×20 reference grid centered at the origin in the XZ, XY, and/or YZ plane.

Node guides

Draw "guide geometry" created by some nodes to indicate invisible information (for example, wind direction).

Node handles

Show interaction handles created some nodes (for example, camera handles).

Follow selection mask

Automatically show components for selection. For example, when this is on and you go to select points, the viewport will automatically show point markers.

IK Critical zone

Draw the IK critical zone guides for bones.

Object names

Draw the node name of each object (for example, lamp) at its local origin.

Object paths

Draw the full path of each object (for example, /obj/subnet1/lamp) at its local origin.

Displayed nodes

Draw the display geometry of objects.

Current geometry

Draw the geometry contained in the selected geometry node (when it’s different from the display node).

Template Geometry

Draw templated geometry.

Selectable templates

Draw nodes with the selectable template flag on.

Additional information

Show Time

Draw timing information (frames per second (FPS), draw time, and elapsed time), in the corner of the viewer. This can be useful for testing scene performance. You should use the FPS as a reference for animation speed, and the elapsed time when comparing playback times.

The FPS display is limited to a maximum of 120, to avoid showing extremely high and misleading values.

Geometry information

Draw information about the current scene/model (for example, total number of polygons and number of selected polygons) in the bottom-right corner of the viewer.

Selection

Object Selection

Draw selected objects with a highlighted wireframe. If you turn this off, selected objects will look exactly the same as unselected objects.

Fill Selections

Fill selected components with the highlight color. For example, selected faces will be filled with the selection color. When this is off, Houdini only highlights the wireframe, allowing you to see the shading/texture of selected faces. This setting affects all wire-over modes: Wireframe Ghost, Hidden Line Invisible, Hidden Line Ghost, Flat Wire Shaded, and Smooth Wire Shaded. Pure Wireframe is not affected by this setting as it does not display faces, nor is Flat Shaded or Smooth Shaded, both of which always fill the face.

Closure Selections

Draw the primitive to which the selected components "belong" in a secondary highlight color. This may be useful for NURBS and Beziér surfaces, where it might not be clear which surface a control point out in space belongs to.

Hide

Do not highlighting the primitives to which the selected components belong.

Hull Geometry Only

Only highlight NURBS and Beziér surfaces with selected control points/hulls. This is the default.

Show

Highlight primitves to which the selected components belong. For example, selecting a polygonal point will draw the faces sharing that point using a secondary highlight.

Guide sizes

Auto DPI Scale

Automatically scale all guide sizes according to the monitor’s reported DPI. You can turn this off to manually scale all guide sizes (this does not affect the Guide font size).

Scale Normal

Scales the length of normal markers.

Scale Vectors

Scales the length of vector direction markers, such as velocity trails.

Point marker size

Scales the size of location "dot" markers, such as points.

Origin gnomon size

Scales the size of the large gnomon drawn at the world origin. You can turn it off completely using the Origin gnomon checkbox on this tab.

Guide font

The relative size of marker text drawn in the view, such as point numbers.

Handle highlight

Controls the amount of highlighting when the mouse pointer is over a handle. "Off" does no highlighting. "Small" brightens a handle when the mouse is over it. "Normal" draws a prominent glow around a handle when the mouse is over it.

Visualizers tab

This tab lets you arrange and save your common visualizers. The top section of this dialog shows your common visualizers and in the bottom you can see your scene visualizers. You can add or delete visualizers in each section. You can also drag-and-drop visualizers between the two sections or rearrange them within each section. Clicking Save As Default saves the arrangement of the common visualizers as your default common visualizers which will be available in all scene file.

Although this dialog allows you to add, delete, activate, and deactivate common and scene visualizers, it is mostly used to review and save your list of common visualizers. In particular, it does not display your Per-Node visualizers. The visualizer menu, accessible via over the icon on the right side of the viewport, is the recommended way to access all visualizers relevant to a scene.

Geometry tab

Tessellation

Level of Detail

Increases or decreases the display resolution of metaballs, NURBS, and Beziér surfaces.

Volume Quality

Controls the display quality of volumes in the viewer.

Very Low

Draw volumes as parallel slices along one axis. This is the fastest option but produces a visual pop as the volume rotates in the view. Overlapping volumes will produce visual artifacts.

Low

Draw volumes as slices parallel to the viewport. This is the fastest of the view-aligned, useful for working interactively with dozens of volumes. Overlapping volumes will render correctly.

Normal

Draw volumes as slices parallel to the viewport, with more tightly-spaced slices than the "Low" option. Balances quality and performance.

High

Draw volumes as slices parallel to the viewport, with even more tightly-spaced slices than the "Normal" option. Slowest but best quality option. Adds some random variation to the volume sampling to break up the slices and 3D texture sampling.

Enabling HDR Rendering will remove any banding artifacts from volumes.

Draw Wireframe Volumes As Points

Draw volumes as point clouds when in wireframe mode. When this is off, only the volume hulls are drawn in wireframe mode.

Polygon Convexing

Fixes concave polygons by tessellating them to triangles so they appear the correct shape. If you turn this off, concave polygons may not appear correctly, but geometry will update faster. You may want to turn this off if you know you have only convex polygons and need more raw polygon display performance.

When this checkbox is on, you can choose between two levels.

Fast

Only redo convexing on full topology changes. Ignore changes to point position (P).

Accurate

Redo convexing on full topology and point attribute changes.

Wireframe

Wire Width

The thickness (in pixels) of wireframe lines. The range of available values depends on the OpenGL driver.

Wire Blend

Opacity of the wireframe in "Shaded wireframe" mode, from 0 (transparent) to 1 (opaque). You may want to turn this down to keep surface color/texture visible underneath a dense wireframe.

Interior Wire Alpha

The visibility of "interior" wireframes (such as inside tetrahedrons), from 0 (not visible) to 1 (drawn the same as exterior wireframe).

Shade Open Curves

Apply lighting to curves. This is useful when using curves to represent hair.

Select wireframe surfaces as if solid

Lets you select surfaces in wireframe mode by clicking where the surface would be if it was drawn.

Particles

Display particles

How Houdini draws particles and disconnected points.

Point

Draw points as uniform dots, controlled by Point Size (in pixels). In this mode, close and far points are drawn at the same size.

Pixel

Draw points as single pixels. This may be useful for very dense particle simulations.

Line

Draw particles as streaks. This only affects particles (disconnected points are drawn as dots).

Disc

Draw particles as filled circles, with the radius controlled by Disc size (in world space units). In this mode, particles are drawn as actual geometry, so closer particles appear bigger than far particles. This only affects particles (disconnected points are drawn as dots).

Display Sprites

If particles have sprite attributes (see the Sprite node), draw the sprite image at the particle location.

Point Size

The size (in pixels) of particle and unconnected points, when Display particles is "Point".

Disc Size

The size (in Houdini units), of the filled circles, when Display particles is "Disc".

Orient Discs to N

When Display particles is "Disc", this orients the discs with the particle’s normal. If the particle doesn’t have a normal, it uses the particle’s velocity.

Sprite Texture Limit

The minimum and maximum display size of a sprite texture.

Instancing

Point Instancing

Use OpenGL point instancing to replace the points of Instance objects (and any other objects with the proper instancing properties) with the instanced geometry in the viewport. See instancing for more information.

To increase viewport performance, you can lower the percentage of the total number of points that are replaced with regerenced geometry. For example, setting it to 50 will only replace half the points with the instanced geometry. The other half will instance the Stand-in geometry.

Instancing Limit

The maximum number of OpenGL primitives (in millions) to instance before Houdini starts replacing them with the Stand-In Geometry. This prevents overloading the graphics card with a huge amount of rendering which could halt or crash the graphics driver.

You can set this to 0 to always instance the stand-in geometry instead of the referenced geometry. This can be useful to check sizes, locations, orientations, and so on, without having to instance heavy geometry.

Stand-In Geometry

What to draw for points that can’t be replaced with the referenced geometry (when the Point Instancing percentage is less than 100, or the number of points to instance exceeds the Instancing Limit). "Display off" draws nothing, "Location marker" draws a dot, and "Bounding box" draws the bounding box of the referenced geometry.

Normals

Auto Generate

The type of normal to generate when no normals exist on the geometry.

Point Normals

Normals are generated on points, which is fast but cannot visualize cusps on sharp edges (such as boxes).

Vertex Normals

Normals are generated on vertices which can visualize sharp edges. The surface will be smoothly shaded as long as the angle between two polygons is less than the cusp angle (below). Vertex normals are slower to generate and display than point normals.

Cusp Angle

The angle, in degrees, at which the surface stops smoothly shading and instead creates a cusp. The angle is measured between neighboring polygons. This has no effect if Point Normals are auto-generated.

Vertex Normal Limit

The upper limit, in millions of polygons, where normal auto-generation will switch from Vertex Normals to Point Normals. Large models often take too long to generate vertex normals and display speed is affected as well. In this case, it is better to use a Normal SOP to generate vertex normals on the geometry if vertex normals are desired, rather than have the viewport continually recalcuate them.

Scene tab

Scene

Scene

Antialiasing Samples

Smooths edges of lines and polygons in the viewport. Increasing this increases the amount of framebuffer memory Houdini uses. Only use 4× or 8× modes if your graphics card has 1 GB of RAM or more.

HDR Rendering

Produces higher quality render of volumes and transparency. This doubles the amount of framebuffer memory Houdini uses. When this is on, flipbooks will contain HDR images.

You can use this with a LUT (in the Viewport tab) to view super-white values.

Enable X-Ray Drawing

Draw objects with the X-ray flag (bones and nulls) as wireframes when they're behind solid surfaces.

X-Ray Strength

Controls the strength of the X-Ray wireframe. Values less than 1 will dim the lines, and values greater than 1 will widen the lines.

Enable Object Origins

Draw axis and pivot points at the object origin of objects with the Display Origin flag.

Onion Skinning

Allow Onion Skinning

Geometry objects are drawn with onion skins if their Onion Skinning parameter is set. This is a global toggle to quickly disable all onion skinning in the scene, without the need to turn off each individual objects' Onion Skinning parameter.

Frames Before

Shows a number of skins for frames in the future, before the action at the current frame has taken place. These skins can be tinted with the color swatch to differentiate them from the past frames.

Frames After

Shows a number of skins for frames in the past, after the action at the current frame has taken place. These skins can be tinted with the color swatch to differentiate them from the future frames.

Frame Increment

The number of frames between skins. A frame increment of 1 will show tightly packed frames, whereas higher increments will skip frames. Fast motions are easier to see with a small frame increment, while slow motions are easier to see with a larger frame increment.

Skin Opacity

Each skin can be drawn with transparency so that the main geometry and other skins can be seen more easily. A value of 1 makes the skins opaque, and values closer to zero make the skins more faint.

Color Correction

Gamma

Applies gamma correction to user geometry in the viewport. This does not affect guides, handles, and other interface elements.

LUT

Applies a Lookup Table (LUT) to the use geometry, after gamma is applied.

Apply to Background Image

Apply the gamma correction and LUT to the background image as well as the user geometry.

Viewport tab

The controls on this tab apply to the "active" split viewport. To make a split viewport active, move the mouse pointer over it and press N. The menus of the active viewport are drawn in yellow.

Name

Name for the viewport, for example persp1 for a perspective viewport.

Type

What kind of view the viewport shows – "Perspective", "UV", or an orthographic view direction such as "Front".

Information

Show Name

Show the viewport options menu (titled with the viewport name) in the top right corner of the viewport.

Show Camera Name

Show the camera options menu (titled with the name of the camera the view is looking through) in the top right corner of the viewport. If the view is not locked to a camera, the menu is titled "no cam".

Clipping

Homing automatically adjusts

Which clipping planes are automatically adjusted when you home the viewport. If you set explicit near and/or far clipping planes, this lets you prevent them from being changed by homing.

Near/Far Clipping Planes

The nearest distance to and the farthest distance from the view camera to draw geometry. That is, geometry nearer to the view camera than the near clipping plane, or farther away than the far clipping plane, is not visible in the view.

Due to GPU Z-buffering issues, the far/near ratio should never be more than one million. If you enter a larger range is selected, Houdini will simply move the near clip plane out until the far/near ratio is one million.

Minimum Home Size

When homing, treat geometry smaller than this size as if it was this size (in Houdini units). This prevents huge camera moves when you home a scene that is very small (such as a single point).

Display

Aspect Ratio

Sets the ratio of width divided by height.

View Mask Opacity

The opacity of the mask showing which areas of the view will not be rendered (when looking through a camera), from 0 (fully transparent) to 1 (full opacity black).

For example, a very low value would display a transparent mask; a medium value would display a gray mask; and a high value would display a black mask.

Stereo Display Mode

The display mode of stereoscopic images in MPlay. You can use passive polarization glasses to view the images in horizontal interlace mode.

UV Viewport

Auto Detect UV Attribute Type

Automatically detects the attribute type in a UV texture editor viewport.

UV Viewport Attribute Type

The attribute type for UV viewports, when Auto Detect Attribute Type is off.

Effects tab

Houdini may disable some controls on this tab if your graphics card does not support them.

Lighting

Lighting

How to show lighting in the viewer.

No lighting

Ignore scene lights, show objects at constant brightness.

Headlight Only

Ignore scene lights, show objects as if lit by a single virtual sunlight centered on the camera. You can set the Headlight direction below.

Normal Lighting

Use the scene lights to light objects.

High Quality Lighting

Use a slower, higher-quality lighting model that better matches how the rendered scene would look.

High Quality Lighting with Shadows

Use high quality lighting and approximate the effect of shadows for lights that have shadowing turned on. This is slower and uses more memory, but greatly increases the quality of the view.

Houdini recalculates a light’s shadow map(s) when its position, orientation, or projection changes. You may want to disable shadows while editing a light to improve interactivity.

In the High Quality Lighting modes, the Flat shading modes are not available. Smooth shading is always used. The High Quality Lighting modes only work with a perspective view. Orthographic view mode will use normal quality lighting instead.

Diffuse

Show the effect of direct lighting on surfaces.

Ambient

Show the effect of ambient lighting on surfaces.

Specular

Show the effect of specular reflection on surfaces.

Emission

Show the effect of light emission (glow) from surfaces.

Light Sampling

The number of samples to use when rendering area and environment lights when Lighting is "High Quality". Higher numbers produce more accurate results, with slightly lower performance.

Headlight Intensity

The brightness of the headlight when Lighting is "Headlight".

Headlight Direction

The headlight is treated as a distant light with parallel rays. This sets the direction of the headlight rays, relative to the camera. The default is over, behind, and to the right of the camera.

Headlight Specular

Show specular highlights caused by the headlight, when Lighting is "Headlight". When this is off, the headlight casts diffuse light only.

Material

Use Materials

Color objects in the view using their assigned materials. When this is off, Houdini draws objects using the Default Diffuse, Default Specular, Default Ambient, and Default Emission below.

Transparency

Draw objects with per-pixel alpha, texture maps with alpha, or material transparency using alpha blending. When this is off, Houdini draws any pixels with non-zero alpha as opaque.

Low

Transparent objects are only sorted by object order. Overlapping surfaces within an object may be rendered incorrectly, unless objects are sorted manually in the scene hierarchy list or a Sort SOP is used at the end of the object’s geometry network.

Medium

Transparent objects are sorted per-pixel, producing a more realistic display of complex transparent objects.

High

Transparent objects are sorted per-pixel and are shadowed, if shadows are enabled. More render passes are used to resolve transparent layering issues, if they are needed.

Displacement

Draw geometry with materials that have a displacement map as displaced surfaces using adaptive tessellation. This may cause a reduction in performance, which can be adjusted with the Level slider.

OpenGL 4.0 is required for this feature. This option will be disabled if OpenGL 4.0 is not available.

Level

Lower values produce fewer tessellated triangles, resulting better performance but lower quality results. Values greater than one produce more triangles than recommended by the adaptive tessellation, up to the OpenGL tessellation limit which is hardware-dependent.

Tip

Displacement should be turned off when attempting to select edges or polygons on a surface with a displacement material. Selection does not take the displacement into account so it will be difficult to accurately select components with displacement on.

Default Diffuse

Diffuse color to use for surfaces that have no material.

Default Specular

Specular color to use for surfaces that have no material.

Default Ambient

Ambient color to use for surfaces that have no material.

Default Emission

Emission color for surfaces that have no material. This produces a constant shading effect.

Shadows

Ambient Occlusion

Enables screen-space ambient occlusion, when Lighting is "High quality". This shadows objects based on the amount of ambient light that could reach a surface. Areas in corners and sunken areas will be shadowed. Turning this on decreases display performance.

The numeric value increases the quality and range of effect of the occlusion, softening the overall effect.

Note

Changing the scene file’s Unit Length option will change the extent of the ambient occlusion effect.

Shadow Quality

Controls the quality of shadow visualization in the view. Higher levels give better shadow approximations, especially for area and environment lights, but decrease display performance.

Point

All lights are shadowed as if they were point lights, producing hard shadow edges. This is the lowest quality setting.

Antialiased Point

Improve the shadow edges by softening jagged edges caused by light map aliasing.

Area

Area lights use many shadow maps to produce a soft shadow effect. Environment lights perform more sampling. This has no effect on other light types (point will be used in these cases). Moving an area light with this option on will result in slower interactivity.

Antialiased Area

Soften the jagged edges of shadows, which improves the soft shadow look.

Sensitivity

Correct for shadow map artifacts, which look like moiré patterns or "shadow acne" on surfaces. In general, increase the first value to fix self-shadowing artifacts on surfaces that are edge-on to the light, and the second value for surfaces perpendicular to the direction of the light.

Light Map Size

Controls the resolution of the shadow maps, based on the individual light object’s settings, or using a global setting for all lights. Increasing the shadow map size will reduce the jaggedness of shadow edges and improve fine shadow detail. Larger maps may affect performance and will use more graphics memory.

Override Light Map Size

Ignore the light object’s shadow map size and use the specified resolution. All Light maps are square.

Use Light Map Size up to

Use the light object’s shadow map size, but limit it to the maximum resolution specified. If an object’s shadow map size is not square, then the width is used for both the width and height of the viewport shadow map.

Reflections

Enable Reflections

Enable reflections using reflection cubemaps. This simulates reflections by rendering the scene to a cubemap with the reflection object removed, at the reflective object’s centroid. Reflective objects are those with a material with a GL Reflect parameter that is greater than zero.

HDR Reflections

Use a FP16 cubemap to store high-dynamic range reflections. When disabled, an 8b cubemap is used (standard 0-1 color range). HDR reflections look brighter, but use twice the texture memory.

Reflection Map Size

Resolution of the cubemap’s square images, in pixels. Larger maps produce sharper reflections at the expense of increased reflection map generation time and texture memory use.

Min Reflection

Require that a material have a GL Reflect parameter set to at least this value, otherwise do not consider the material reflective. No reflection cubemaps are generated for objects with non-reflective materials. This can reduce the number of reflection maps generated for very dull materials.

Grid tab

3D Ortho

These options control the display of the grid in orthographic viewports. To show grids in a perspective viewport, use the XZ, XY, and YZ Reference Plane options on the Guides tab.

Display Ortho Grid

Show a grid in orthographic viewports.

Grid Offset

The distance in X, Y, and Z between the grid origin and the world-space origin.

Grid Spacing

The horizontal and vertical distance between grid lines, in Houdini units.

Grid Ruler

Draw every nth grid line thicker. Set this to 0 to not draw thicker lines.

Texture Viewport

These options control the display of the grid in UV editor viewports.

Display Reference Grid

Show a grid using the given Grid spacing.

Grid Spacing

The distance between grid lines, in UV coordinate values.

Display Grid Over Image

Show a pixel grid over the texture image, using the Grid pixel spacing and Grid pixel offset.

Grid Pixel Spacing/Grid Pixel Offset

The placement and size of the pixel grid, in pixels. You can use decimal values, for example an offset of 0.5 to snap to pixel centers.

Clamp Grid to Image

Don’t show the grid outside the boundaries of the image.

Display Tile Boundaries

Draw guide lines representing the boundary around the 0-1 tiling of the image.

Background tab

Color Scheme

The background color scheme for viewports.

Display Environment Lights as Backgrounds

Display environment lights as the background in all viewports (when the environment light’s Enable light in viewport parameter is on).

Display Background Images

Show an image in the background of the viewports. This can be useful for tracing over an image, or looking at a 3D model in front of a context image.

When a viewport is looking through a camera, the camera’s Background image parameter specifies the image. For viewports that are not locked to a camera, Houdini uses the images specified in the tabs below.

Use Texture Filtering

Oversample the background image so zooming on the image looks smooth and blurry instead of blocky.

Apply Zoom to Background

Zooming the viewport changes the size of the background image. When this is off, the image remains the same size when you zoom in or out. This option is ignored when Auto-place image is on.

Disk File/COP image

Get the image from a file or a compositing node. Click the chooser button to choose a file/node.

Auto-Place Image

Automatically scale the image to fit the image inside the viewport (not available for UV viewports). When this option is off, you can use the Image Offset and Image Scale controls to place and scale the image manually.

Image Offset/Image Scale

Manually control the placement and scale of the background image in the viewport, when Auto Place Image is off. A scale of 1 uses the original image size. A scale of 0.5 would make the image half size. Not available for UV viewports.

Minimum/Maximum UV

The smallest and largest UV values display horizontally (U) and vertically (V) in the viewport.

Image Quality

Controls the fidelity of the background image by downscaling it. Lower values give lower quality background images but use less memory.

Texture tab

General

Display Textures

Show surface textures in the view. Turning this off can increase display performance.

Multi Texturing

Displays all layers of multi-layered textures. Turning this off will only display the first texture, but can increase display performance.

Projected Textures

Show spotlight projection maps in the view (see the Projector map parameter on the light object). This adds one drawing pass per spotlight in the scene. Even when this option is on, the projected maps will not affect transparent objects or volumes.

Mipmap Textures

Increase the quality of displayed textures by producing a mipmap for enhanced filtering. When this option is off, textured objects will sparkle when viewed at a smaller scale. This option causes textures to use 50% more memory on the graphics card.

Anisotropic Filtering

Higher values increase the quality of textured objects when a surface is nearly parallel to the view direction. Increasing this will slightly decrease display performance.

Texture Cache

Texture Cache Size

The maximum amount of memory to use for textures, both 2D and 3D (in megabytes).

OpenGL always stores textures in main memory and may swap them to and from the graphics card, so this setting can affect the amount of memory available to Houdini. The maximum texture cache size is limited on 32 bit computers.

Single Texture Limit

The maximum amount of memory that a single texture can consume (in MiB). Even with a large amount of available VRAM, very large textures can have performance issues. This option is automatically set based on the detected VRAM (where possible), from 64MiB to 256MiB. It is not saved to .hip files.

Viewport Texture Use

Displays the amount of texture cache currently in use. To flush the cache, use Render ▸ Update Textures from the main menu.

Dynamically reduce texture scale

When drawing the viewport, if the total size of all textures used is greater than the texture cache size, texture thrashing will result. This causes severe performance degradation as textures are continually reloaded and deleted on every redraw. If this option is on, Houdini detects this situation and on the next redraw scales textures to a size that will fit in the cache.

Reduce 2D textures

Apply dynamic texture scaling to 2D textures. The box next to the option shows the current dynamic scale.

Reduce 3D textures

Apply dynamic texture scaling to 3D textures. The box next to the option shows the current dynamic scale.

2D Textures

Limit Resolution

Limit the size of 2D textures to the specified size (if it is less than the maximum size allowed by the graphics card). When this option is off, texture sizes are only limited to the maximum size supported by the graphics card. This option can reduce graphics card memory usage and improve performance, at the expense of decreasing display quality of large textures.

This only affects new textures and will not cause updates of loaded textures (use Render ▸ Update Textures from the main menu to apply the limit to these textures).

Cube maps are also affected by this size, though it applies to their faces. The maximum size of shadow maps is controlled on the Effects tab.

HDR Textures

Show High Dynamic Range texture images. Using HDR images will give better shading on textured surfaces when lighting is on in the view.

Full HDR

All HDR formats are allowed (32 bit and 16 bit). This uses the most graphics memory, as 32 bit HDR images use 4× the amount of RAM that an 8 bit image does. This may also negatively affect performance on older graphics hardware.

16b HDR only

Use only 16 bit floating point textures images. Any 32 bit HDR images will be down-sampled. This provides a good balance between rendering quality, graphics memory use, and performance.

8b SDR

Down-sample all textures to 8 bit (Standard Dynamic Range). Any super-whites are clamped to (0,1) (black,white). HDR textures may look washed out in this mode.

8b Compressed

Compress all textures to 1/4 or 1/8 their size by reducing color resolution. This option will reduce the memory used by textures, but also reduce the color accuracy of textures.

Scale Textures

Scale all 2D textures to a percentage of their original size. You can use this to quickly improve performance of a highly-textured scene if it is stuttering on redraw.

This scale is applied before the Limit Resolution option.

3D Textures

Limit Resolution

Limit the resolution of 3D textures, which are often used to represent volumes.

If you need better quality, increase the limit values. Do not turn this off unless you really know what you're doing. Larger 3D textures can use a huge amount of graphics card RAM. High resolution (simulation) volumes can use far more memory than reasonable to display on a graphics card. (When this option is off, volumes are limited to the maximum OpenGL 3D texture size.)

This only affects new 3D textures.

Use 2D Texture Settings

Copy the HDR textures and Scale textures settings from the 2D textures options. When this is off, you can specify separate values for 3D textures below.

(8 bit Compressed is not supported for 3D textures, so if the 2D setting is "8b Compressed", 3D textures will use 8 bit SDR.)

HDR Textures

Show High Dynamic Range color and opacity for volumes and other 3D textures. This can improve the quality of volumes at the expense of performance and graphics memory use.

Scale Textures

Scale all 3D textures to a percentage of their original size. This can be useful for displaying extremely large simulated volumes.

This scale is applied before the Limit Resolution option.

Optimize tab

Culling

Remove Backfaces

In shaded view modes, do not draw polygons that face away from the camera. This can improve display speed on very heavy polygonal geometry.

For closed (airtight) surfaces, back faces are not visible anyway, but open surfaces often have visible back faces that will disappear when this option is on. For example, if you create a cylinder (without end caps) and look down at it with this option on, only the front half of the cylinder will appear in the view.

Draw Hulls Only

Draw the hulls of certain primitives instead of the normal geometry. This applies to NURBS surfaces and curves, Bezier surfaces and curves, metaballs, volumes, and VDBs.

Visible Objects

Only object names that match this pattern will be visible in the view.

Material Assignment

Apply Material Stylesheets

Evaluate and apply material assignments and overrides based on material stylesheets affecting the object and geometry. When disabled, the effects of any stylesheets will not be scene but the scene may update and draw faster.

Apply Per-primitive Stylesheets

Allow material stylesheets to be evaluated on a per-primitive basis when applied to geometry. When off, only the object assignment is used.

Apply Stylesheets to Packed Geometry

Allow material stylesheets to be applied to portions of geometry that is packed inside a packed primitive. When off, only the packed primitive assignment or object assignment will be used.

Use Material Overrides

Allow material overrides from material stylesheets or the material_override attribute. When off, material overrides are ignored.

Single Object Material Limit

The maximum number of materials and material variants allowed to be assigned to a single object by material stylesheets, overrides, or shop_materialpath attribute. When this is exceeded, the remaining primitives will be assigned either the default material, object material, or the packed primitive material. A note is made of this in the viewport information button on the right toolbar.

Material Assignments

Limit when material assignments are updated, as this can be expensive.

Always Update

Update whenever material assignments need to be updated.

Disable during Playback

Update when material assignments need to be updated unless Houdini is playing or scrubbing.

Manual

Do not update unless Update Materials is manually clicked.

Interactively Update Materials

Update materials when they change. When disabled, changes to the materials themselves will not be reflected in the viewport unless Update Materials is pressed.

Update Materials

Forcibly update all material assignments, stylesheets, and materials. This is useful for stylesheets with external script files when those files change (they are not monitored for changes), or when automatic updates have been disabled.

Crowd Agents

LOD Agent Reduction

Automatically generate a series of reduced-polygon levels of detail for agent shapes, and swap them in based on an agent’s distance to camera, to make display of far-away agents faster. Each level has half as many polygons as the previous one. The closer the slider is to the "performance" side, the more low-poly levels Houdini generates.

Shape Point Cutoff

The minimum number of polygons in a reduced-polygon model generated by LOD agent reduction. Houdini will not generate any levels of detail with fewer than this many polygons.

Max LOD Levels

The maximum number of reduced levels of detail generated by LOD agent reduction. For example, if an agent model has 100000 polygons and Max LOD levels is 4, Houdini will generate levels with polygon counts of 50000, 25000, 12500, 6250, and then stop. Note that Houdini may not actually generate this many levels if it reaches the Shape point cutoff.

Base LOD Level

Which reduced level of detail to use for the display of the closest agents. The default is 0, meaning use the original model. For example, setting this to 1 would use the first reduced level of detail (with half as many polygons as the original model) even close to the camera. This lets you quickly and drastically reduce the overall polygon count of a crowd scene for better display performance.

Single Bone Deform

Choose whether agent models are deformed by all bone weights (up to 4), or optimize performance by only deforming based on the highest-weight bone.

Disabled

Always use full deformation (best quality).

Reduced LOD Agents Only

Use full deformation for the primary level of detail, and single bone deformation for reduced levels of detail.

Enabled

Always use single bone deformation (fastest).

Wireframe Display

Agent rigs can be displayed in several ways when in wireframe mode.

Line

Rig joints are connected with a line segment. This can be faster than bone display depending on the graphics hardware.

Bone

Rig joints are connected with shaded bones (default).

Interactivity

Interactive Mode

Tells viewport plugins ("render hooks") to continuously update during user interaction (tumbling, tracking, dollying). This only affects viewport plugins, it has no effect on normal Houdini viewport drawing. The plugin must look at this option and implement its own 'performant' drawing mode, it is not automatic.

Windows