Houdini 18.5 シェルフツール

シェルフのカスタマイズ shelf tool

シェルフの見た目、内容の変更・再配置、独自のシェルフツールの作成の方法。

On this page

概要

シェルフとはメインウィンドウの上部に並んだアイコン群のことです。Houdiniでよく使う機能に素早くアクセスすることができます。シェルフは、独自のタブを作成したり、独自のスクリプト、デジタルアセットをシェルフに追加することができます。

シェルフのカスタマイズは、基本的に3つのユニットに分けられます:

Shelf Set

シェルフを区分けするタブのセット。

Tab

シェルフにツールのセットを表示します。同じタブを複数のシェルフセットに表示することができます。

Tool

スクリプトやツールを実行するアイコン。同じツールを複数のタブに表示することができます。

タブとシェルフセットは.shelfファイルに保存されます。タブではタブ名/ラベル、表示するツール、ツールの表示順を定義します。シェルフセットには、タブとタブの表示順を定義します。

ツールすべてはツールバータブに保存されます。ツールバータブは、$HOUDINI_TOOLBAR_PATHまたは$HOUDINI_PATHのツールバーディレクトリに単一の.shelfファイルを保存します。シェルフセットはツールバータブをまとめたものでツールバータブを参照する.shelfファイルに保存します。

アイコンの追加とシェルフの編集

To...Do this

ツールとタブを並べ替える

  • タブ内のツールをドラッグすると並べ替えができます。ツールを別のタブにドラッグすれば、そのタブに移動します。

  • タブをドラッグするとシェルフセット内で並べ替えができます。タブはシェルフセット間をドラッグすることができます。

スクリプトを実行する新しいシェルフアイテムを作成する

シェルフアイテムを作成する方法を参照してください。

ノードをシェルフに登録する

  1. ネットワークエディタにシェルフに登録したいノードのサンプルを作成します。必要に応じてパラメータを設定しておきます。

  2. ネットワークエディタからノードをシェルフにドラッグして、タブにドロップします。

  3. 新しく登録したシェルフアイテムをクリックすると、 ネットワークペインが正しいネットワークレベルにいれば 、Houdiniはノードのコピーを作成します。

既存ツールを編集する

ツールをクリックして、 Edit Tool を選択します。詳細は、Edit Toolウィンドウを参照してください。

タブをシェルフセットに追加する

タブオプションメニューをクリックして New Tab を選択します。

タブに、どのツールを表示させるのか編集する

タブをクリックして、 Edit Tab を選択します。

シェルフセットをシェルフに追加する

シェルフメニューをクリックして、 New Shelf Set を選択します。

シェルフセットに、どのタブを表示させるのか編集する

シェルフメニューをクリックして、 Edit Shelf Set を選択します。

グローバルホットキーをシェルフツールに割り当てる

⇧ Shift + ⌃ Ctrl + Altを押しながら、シェルフアイテムをクリックします。

詳細は、ホットキーの設定を参照してください。

シェルフセットの名前を変更する

シェルフメニューをクリックして、 Edit Shelf Set を選択します。

タブとシェルフセットの表示・非表示

To...Do this

シェルフセットのタブを表示・非表示する

タブオプションメニューをクリックして、下側にあるタブのメニューからタブをオン・オフします。

シェルフセットを表示・非表示する

シェルフメニューをクリックして、 Shelf Sets サブメニューからシェルフセットをオン・オフします。

シェルフセットのダウンロード

  1. タブオプションメニューをクリックして、 Download Shelf を選択します。

  2. Exchangeで利用可能なシェルフセットが表示されます。

  3. インストールしたいパッケージを選択して、 Download をクリックします。

Install Shelf to メニューで、ダウンロードするシェルフの保存先を指定します。

タブメニューのカスタマイズ

⇥ Tabメニューで表示されるシェルフアイテムを設定することができます。詳細は、タブメニューの章を参照してください。

シェルフツール

シェルフの使い方

シェルフタブ

  • Createタブ

    Createタブのツールは、シーンビューにプリミティブ、カーブ、Nullオブジェクトを作成、配置します。

  • Modifyタブ

    Modifyタブのツールは、 シーンビューのオブジェクトを簡単にカスタマイズします。

  • Modelタブ

    Modelタブのツールは、シーンビューのオブジェクトを編集します。

  • Polygonタブ

    Polygonタブのツールは、 シーンビューのポリゴンを修正します。

  • Deformタブ

    Deformタブのツールは、シーンビューのオブジェクトを変形します。

  • Textureタブ

    Textureタブのツールは、シーンビューのテクスチャオブジェクトを編集します。

  • Riggingタブ

    Riggingタブには、あらかじめ作成したリグを作成するためのツールが含まれています。

  • Musclesタブ

    Musclesタブには、筋肉を作成するためのツールが含まれています。

  • Charactersタブ

    Characterタブのツールは、シーンビューにキャラクタを作成します。

  • Constraintsタブ

    Constraintsタブのツールは、シーンビュー内でオブジェクトをお互いに拘束させることができるConstraint Networkを作成します。

  • Hair Utilsタブ

    Hair Utilsタブのツールは、オブジェクト上にヘアーとファーを簡単にセットアップすることができます。

  • Guide Processタブ

    Guide Processタブのツールは、スキンアトリビュートをペイントすることで、ガイドヘアーの位置と向きを変更することができます。

  • Guide Brushesタブ

    Groomingタブのツールは、ヘアーを追加したり直接制御することができます。

  • Terrain FXタブ

  • Simple FXタブ

    Simple FXタブには、ジオメトリレベルでダイナミクスシミュレーションを作成するためのツール群が含まれています。

  • Cloud FXタブ

    Cloud FXタブには、雲のエフェクトを作成するためのツールが含まれています。

  • Volumeタブ

    Volumeタブには、ボリュームエフェクトを作成するためのツールが含まれています。

  • Lights and Camerasタブ

    Lights and Camerasタブのツールは、シーンビューにライトとカメラを作成、配置します。

  • Collisionsタブ

    Collisionsタブのツールは、シーンビューに衝突オブジェクトを作成することができます。

  • Particlesタブ

    Particlesタブには、ダイナミックパーティクルシミュレーションを作成するためのツールが含まれています。

  • Grainsタブ

    Grainsタブには、砂の粒や他の粒状のものをシミュレーションするためのツールが含まれています。

  • Vellumタブ

    Vellumタブには、色々なタイプのVellumエフェクトを作成するためのツールが含まれています。

  • Rigid Bodiesタブ

    Rigid Bodiesタブのツールは、シーンビューにダイナミックRBDオブジェクトを作成します。

  • Particle Fluidsタブ

    Particle Fluidsタブには、シーンビュー内の液体に基づいてパーティクルを作成するためのツールが含まれています。

  • Viscous Fluidsタブ

    粘度のある流体は、temperature(温度)アトリビュートを使用して粘度を駆動させるFLIPシミュレーションです。

  • Oceansタブ

    Oceansタブには、海洋シミュレーションを作成するためのツールが含まれています。

  • Fluid Containersタブ

    Fluid Containersタブには、Pyro、Smoke、Liquidのコンテナを作成するためのツールが含まれています。

  • Populate Containersタブ

    Populate Containersタブには、Fire、Smoke、Liquidの作成と削除をするためのツールが含まれています。

  • Container Toolsタブ

    Container Toolsタブには、Fire、Smoke、Liquidを操作するためのツールが含まれています。

  • Pyro FXタブ

    Pryo FXタブのツールは、煙と炎の効果をシミュレーションします。

  • Sparse Pyro FXタブ

    Sparse Pyro FXタブ上のツール群は、煙と炎のシミュレーションエフェクトを作成することができます。

  • Solidタブ

    Solidタブのツールを使って、ソリッドオブジェクトの作成と修正をします。

  • Wiresタブ

    Wiresタブのツールは、シーンビューに曲げられるダイナミックオブジェクトを作成します。

  • Crowdsタブ

    Crowdsタブには、群衆の作成や群衆の挙動を定義するツールとサンプルが含まれています。

  • Drive Simulationタブ

    Drive Simulationタブのツールは、シーンビューのダイナミックオブジェクトを操作します。

テクニカル