Houdini 18.5 デジタルアセット

ファイルとアセットをテキストとして取り扱う方法

HIPファイルをプレーンテキストとして保存したり、アセットファイルをプレーンテキストとしてディレクトリに展開することができます。これによって、Houdiniファイルの差分とソースの管理が容易になります。

On this page

概要

通常では、シーンファイル(.hip)とアセットライブラリは単一のバイナリファイルとして保存します。この形式が最も効率的ですが、いくつか難点があります:

  • テキスト差分ツールを使ってファイルを比較することができません。

  • アセットをソース管理へモノリシックバイナリブロブとしてチェックすることしかできません。

  • HoudiniのPythonスクリプティングでないとアセットを制御することができません。

これらの機能を必要とする状況では、シーンファイルをプレーンテキストとして保存したり、プレーンテキストとバイナリ間でアセットを変換することができます。

変換

To...Do this

HIPファイルをプレーンテキストとして保存する

File ▸ Save as text を選択します。

ファイルをテキストとして保存してしまえば、今後の保存もテキストとして保存され、 Save as textSave as binary になります。

アセットライブラリを展開されたプレーンテキスト形式に変換する

  1. メインメニューから Assets ▸ Asset Manager を選択します。

  2. "Operator type libraries"ツリーで、変換したい.hdaライブラリを探します。

  3. そのツリー内でそのアイテムを右クリックして、 Convert to Unpacked Format を選択します。

Houdiniは、単一バイナリファイルをそれと同じ名前のディレクトリに置換し、そのディレクトリにそのライブラリ内のアセットに関する色々な情報を持ったファイルを格納します。

展開されたプレーンテキストのアセットライブラリを単一バイナリファイルに変換します

  1. メインメニューから Assets ▸ Asset Manager を選択します。

  2. "Operator type libraries"ツリーで、変換したい.hdaライブラリを探します。

  3. そのツリー内でそのアイテムを右クリックして、 Convert to Packed Format を選択します。

コマンドライン上でアセットライブラリを変換する

.hdaファイルを展開形式に変換する:

hotl -t unpacked_dir_name source_hda_file

展開ディレクトリを単一ファイルに変換する:

hotl -l source_unpacked_dir_name hda_file

hotl -mを使ってHDAをマージしている場合、展開ディレクトリとパック単一バイナリファイルをソースとして交互に使用することができます。

Houdiniでアセットを比較する方法

Houdini内から外部Diffツールを実行することができます。

シーンファイルやアセットの差分結果は、あまりはっきりせず理解できないことがありますが、うまくいけば何が変更されたのかを理解することができます。

To...Do this

Diffプログラムをセットアップする

メインメニューから Edit ▸ Preferences ▸ External tools を選択します。

お気に入りのDiffプログラムに関する情報で"File compare"と"Folder compare"のセクションをセットアップします:

  • Executable path をDiffプログラムのファイルパスに設定します。このプログラムが実行ファイルの検索パス内にあれば、プログラム名だけをタイプすることができます。

  • Diffプログラムのコマンドラインインターフェースに基づいて、 Command line arguments を設定します。これには以下の変数を使用することができます:

    $OLDPATH

    比較する1番目のファイル/ディレクトリのパス。

    $NEWPATH

    比較する2番目のファイル/ディレクトリのパス。

    $OLDTITLE

    Diffツールがタイトル表示に対応していれば、その1番目のファイル/ディレクトリのタイトル。

    $NEWTITLE

    Diffツールがタイトル表示に対応していれば、その2番目のファイル/ディレクトリのタイトル。

    典型的なコマンドラインの引数は単に$OLDPATH $NEWPATHです。

ロックされていないアセット内の変更箇所を確認する

アセットを右クリックして、 Show changes を選択します。

現行シーンファイル内の変更箇所を確認する

メインメニューから File ▸ Show changes を選択します。

アセットをバックアップバージョンと比較する

Houdiniは、アセットを変更した時に自動的にバックアップを保存します。以前のバックアップからアセット定義の変更箇所を確認することができます。

  1. メインメニューから Assets ▸ Asset Manager を選択します。

  2. "Operator type libraries"ツリーで、チェックしたいアセットを探します。

  3. そのアセットを右クリックして、 Compare を選択します。

  4. Against: Backup をクリックします。

  5. ポップアップメニューからバックアップの日付を選択します。

  6. Compare をクリックします。

2つのアセットを比較する

  1. メインメニューから Assets ▸ Asset Manager を選択します。

  2. "Operator type libraries"ツリーで、チェックしたいアセットを探します。

  3. そのアセットを右クリックして、 Compare を選択します。

  4. Against: Asset をクリックします。

  5. Against: の右側にある選択アイコンをクリックして、比較するアセットを選択します。

  6. Compare をクリックします。

ヒントとメモ

  • Houdiniでアセットライブラリに変更を加えても(例えば、アセットの Extra files タブにセクションを追加)、展開アセットライブラリの内容が更新されます。

  • 現在のところ、アセットライブラリディレクトリに含まれているファイルと使用されているファイル形式について公開しておらず、気づかないうちに変更される可能性があります。その一部は非常に単純な仕様になっていますが、その展開されるファイルを直接編集することでアセットを変更するスクリプトを開発するつもりであれば、そのスクリプトが将来のバージョンのHoudiniで壊れる可能性があることを覚えておいてください。また、同時にHoudiniでアセットライブラリを編集した場合、そのディレクトリ内に加えた変更が上書きされる可能性があることに注意してください。

デジタルアセット

はじめよう

  • デジタルアセットの紹介

    Houdiniでは、デジタルアセットと呼ばれる再利用可能なカスタムノードに作業を変更することができます。

アセットの作成

次のステップ