Houdini 16.5 Basics

Project management

The File > New Project and File > Set Project menu items let you set up project directories and associate scene files with projects.

On this page

Overview

You can save a Houdini scene (.hip) file anywhere, and use the $HIP environment variable (which contains the parent path of the scene file) to locate files relative to the scene file’s location. This lets you move the files between directories or between computers without having to change all the paths.

For projects involving more than one scene file, Houdini provides a simple project management UI based around the $JOB variable.

How to

  • Use File ▸ New Project to create a project directory with a number of common subdirectories. This sets the $JOB environment variable to that directory path.

    This creates subdirectories in the project directory for containing various artifacts involved in the project, such as renderings, digital assets, scripts, simulation files, and so on. Using the default directory names allows you maintain consistency between scene files and projects.

  • Use File ▸ Set Project to choose a project directory to work in. This sets $JOB to that directory path. You can also use the File ▸ Set Recent Project to choose from a list of recently used projects.

  • Use $JOB in paths for shared project files (for example, $JOB/textures) and $HIP in paths for scene-specific files (for example, $HIP/camera_maps).

  • When you're opening or saving files in the file picker, click $JOB on the left to quickly go to the project directory. This ensures the path you choose starts with $JOB, keeping it relative to the project.

  • Use the Render ▸ Preflight menu item to find references in the current scene file to resources outside the project (for example, explicit paths to other locations on disk). Fixing these references to be relative to $JOB or $HIP makes your scene or project more portable and able to be sent out for remote simulation/rendering.

    From the pre-flight window, you can select outside references (in red) and click the expression containing the reference to edit it right there, instead of having to hunt down the references across multiple nodes in the network editor.

Tips and notes

  • The value of $JOB is saved with the scene (.hip) file. So once you associate a given scene file with a project using File ▸ Set Project and save it, you don’t have to use File ▸ Set Project again the next time you open the scene file.

  • Setting the project does not change what scene file is loaded, it simply changes the value of $JOB.

  • For tools and resources common across all projects, the Houdini convention is to use an environment variable named $HSITE.

Basics

Getting started

Next steps

Customization

Guru-level