Houdini 16.5 Basics

Houdini user interface

On this page

Overview

1. Main menus

The main menus at the top are always the same, and provide quick access to common functionality, such as importing files and managing renders.

2. Shelf

The shelf contains a large array of useful tools for working interactively in the scene view. You can create your own custom scripted tools here for quick access.

3. 3D scene view

The Scene View pane shows a 3D representation of the current scene file. You can change the shading style and increase or decrease the display quality. The controls in the pane header let you change the viewport layout and shading style.

4. Toolbox

The toolbox is a collection of very commonly used tools, such as select, move, rotate, and scale, as well as toggles such as inspection mode and snapping.

5. Operation toolbar

The toolbar at the top of the scene view shows important controls for the currently selected node. You can use these controls if you work in the view with the parameter editor minimized.

6. Display options

The icon buttons on the right side of the view give you quick access to commonly used display options. You can click the display options button on this toolbar to open the full display options window.

7. Parameter editor

This pane lets you edit the parameters of the currently selected node to change how it works.

8. Network editor

This pane shows the nodes in the current network. You can create nodes, select them to see their parameters in the parameter editor, and wire them together.

9. Playbar

The playbar has playback controls and the timeline, which lets you scrub across the animation frames, and shows which frames have keys.

10. Help button and take controls

Click the Help button to open the online help browser in a side pane. This is very useful for viewing the help while continuing to work in Houdini. See the takes page for information about the take controls.

11. Status line

The line at the bottom of the main window displays status and progress updates as you work.

12. Cook controls

These controls let you turn off automatic refresh of the scene view if your scene is extremely complex and slow to update. See cooking for more information.

Working in Houdini

Houdini has two main complementary ways of interaction:

  • Using the shelf tools in the scene view. The scripted tools create nodes for you in the background.

  • Creating nodes directly in the network editor using the tab menu.

New users will probably be most comfortable just using the shelf tools at first, and some users (for example, character animators) will never need to create their own nodes. However, for modeling and effects work, getting the most out of Houdini usually involves shifting back and forth between the two styles. You will often use the shelf tools as easy ways to start or change a network, and also add and edit nodes to make more complex networks.

Toolbox

The toolbox is located on the left side of the scene view. It provides selection, transforming, viewing, and rendering tools, as well as snapping options and menus for starting renders.

The selection tools let you select objects or components in the scene view. See selecting objects and components.

The move, rotate, scale tools let you transform the selection using handles in the view.

The Pose tool transforms the selection with special options for manipulating character rigs.

The Handles tool shows the node-specific handles for the current node. You can also press Enter to switch to the Handles tool in the viewer.

The snapping toggles let you turn snapping to grid, curves, points, and multi-snapping on or off. See snapping for more information.

The view tool lets you track, tumble, and dolly the view. Instead of selecting this tool directly, you will usually hold Space to enter it temporarily while you work.

The render region tool lets you draw a box around part of the view and see it rendered. The rendering updates automatically as you work.

You can turn on the inspection mode to show a floating window near the mouse pointer with extra information about what’s under the pointer. This is especially useful in image views such as the render view.

The Flipbook button lets you capture playback in the viewer as an animation. See flipbooking for more information.

The Render menu button provides a quick way to render to a window. This button is less useful than in older versions of Houdini, since now you can use the Render View tab to preview renders, and the Render menu (in the main menus) to set up and launch final renders.

Operation control toolbar

When you use a tool on the shelf, or select a node in the network editor, the node’s most important parameters appear on a toolbar above the 3D scene view. These controls let you modify the tool/node’s operation even if the parameter editor is not visible. You can also click the Help button at the end of the toolbar to see the help for the current operation.

Basics

Getting started

Next steps

Customization

Guru-level