Houdini 17.0 Rendering

How to render using Mantra

On this page

Mantra user guide

Overview

Mantra is the highly advanced renderer included with Houdini. It is a multi-paradigm renderer, implementing scanline, raytracing, and physically-based rendering. You should use the physically based rendering engine unless you have a good reason to use another engine. Mantra has deep integration with Houdini, such as highly efficient rendering of packed primitives and volumes.

You can implement Mantra shaders using a VOP network or by writing a program in the VEX shading language.

Tip

Houdini also lets you integrate third-party renderers such as RenderMan™, Arnold™, Redshift™, OctaneRender™, V-Ray™, mental ray™, and Maxwell™.

In general, rendering in Houdini uses a camera defining the viewpoint to render from, lights to illuminate the scene, and a render node representing the renderer and render settings to use. However, you can still make preview renders using the current view, a headlight, and default render settings.

Preview rendering

The Render view, sometimes called the IPR (interactive photorealistic render) view, shows a rendered image that updates as you move lights and objects, change parameters, and so on.

The Render region tool lets you outline a rectangle in the 3D viewer that acts like a mini render view. It renders that part of the view and updates the rendered rectangle as you change things.

Starting a final render

You can do most of your work in the Render view to see an interactive updating render. This lets you assign materials and change render node and shader node parameters and see the results as you work.

When you want to do a final render:

  • In the render node’s parameter editor, click Render to Disk or Render to Mplay.

or
  • Choose Render ▸ Start Renderer ▸ render node in the main menus.

or
  • Click the Launch render button in the toolbox on the left side of the viewer.

    Right-click the button and choose a render output node to render, or View: Mantra to render the current view.

    After you set the default render node in the menu, clicking the icon will use that render node. The initial default renders the current view.

or
  • You can script rendering using the render HScript command or the hou.RopNode interface in Python.

Setting up a render node

Add lights to the scene and create a camera. See lights and cameras. If you don’t have lights in the scene the render will come out black.

To...Do this

Create a render node

In the main menus, choose Render ▸ Create Render Node ▸ Mantra. Mantra is Houdini’s powerful built-in renderer.

If you only have one camera in the scene, it is automatically chosen as the camera the new render node will render from.

Edit the parameters of a render node

You can edit a render node’s parameters and render properties in the parameter editor.

  • Choose Render ▸ Edit Render Node ▸ node name to open a floating parameter editor for the render node.

    or
  • In the network editor, go to the "Outputs" (/out) network. (Click the first segment of the path at the top of the network editor pane and choose out.) Select the node to open it in the parameter editor pane.

For help on the render parameters, see the Mantra node help.

Set whether to render a single frame or animation

The Valid Frame Range menu controls whether this render node renders single frames or sequences (animations). Choose Any frame to render single frames. Choose Frame range to render a sequence.

If you are rendering a sequence, make sure to include the frame number variable $F in the filename, otherwise the renderer will overwrite ever frame with the same name. See expressions in filenames.

Set the output size/resolution

The size of the rendered image is controlled by a parameter on the camera. Select the camera object and set the View ▸ Resolution parameter in the parameter editor. (For help on the other camera parameters, see the Camera node help.)

or

You can override the camera’s image size parameters in the render node by turning on Properties ▸ Output ▸ Override camera resolution.

Set the camera to render from

Click the Main tab and edit the Camera field. (Click the button to the right of the field to choose the camera from a list.)

Controlling object visibility

To...Do this

Make an object visible or invisible in the viewer

Turn the object’s Display flag on or off.

Make an object totally invisible in the render

In the object’s parameter editor, click the Render tab and turn off Renderable.

Make an object invisible but cast reflections/shadows

In the object’s parameter editor, click the Render tab and turn Renderable off and Phantom on.

Use different geometry for viewport display and rendering

In the geometry network of an object, you can set the display and render flags on different nodes to indicate different geometry output for display and rendering.

This is useful to replace low-resolution proxy geometry for display with high-resolution geometry for rendering.

Instance geometry onto points at render time

See point instancing.

Prevent an object from reflecting

  • Edit the Render ▸ Shading ▸ Reflection Mask parameter on the reflective object.

Tips

  • You can render a deep camera map to get a "2.5-D" image with depth information. (When rendering .pic or .rat, the depth information is embedded in the file. When rendering .exr it is saved to an additional output file.) The depth information lets you composite rendered images in 3D.

  • The Switcher object is a special camera that lets you animate switching between the viewpoints of several different cameras.

  • Click the Controls button on the parameter editor of the render node to open the Render Control window. This window lets you temporarily override render parameters (such as the frame range, or whether to render dependencies) per-render, without having to edit the parameters on the node (and remember to change them back).

    1. In the main menu, choose Render ▸ Edit Render Node ▸ render node.

    2. Click the Render Control button on the parameter editor of the render node.

    3. Set the Frame Range option in the Output Overrides section.

    You can also override the rendering of dependencies from the window. See how to set up a render node and the Render Control window for more information.

Mantra user guide

See also

Rendering

Mantra user guide

Basics

Lighting

Next steps

Guru-level

Other renderers