Houdini 17.0 Reference

Menus

Explains each of the items in the main menus.

On this page

File

See the file dialog reference .

New

Clears the current scene and starts a new scene.

Open

Loads a .hip file from disk.

Open Recent files

The File menu lists the last four .hip files opened. Choose a .hip file from this list to reload it quickly.

Save

Saves the current scene to disk.

Save As

Saves the current scene to a new file.

Save as Binary

Saves the current scene to a new binary scene file. See text files for more information.

Save as Text

Saves the current scene to a new plain-text scene file. See text files for more information.

New Project

Sets up a standardized directory structure and sets the $JOB environment variable. See project management for more information.

Set Project

Switches the $JOB environment variable to another project directory. See project management for more information.

Merge

Imports the data from another .hip file into the current scene.

Show Changes

Shows the changes made between the current scene and the last time the file was saved.

New Asset

Creates a new, empty digital asset.

Import

This submenu contains menu items for importing different file types.

Geometry

Import a geometry file such as a .bgeo file. The file can be in any format supported by Houdini’s IO libraries. Houdini creates an object node containing a File node to import the file.

Image

Import an image into the Houdini compositor (COPs). Houdini creates a File node in the default compositing network to import the file.

Collada

Import a Collada interchange file. Houdini creates object nodes for the objects in the Collada file. See the Collada import options.

Filmbox FBX

Import an FBX file. Houdini creates object nodes for the objects in the FBX file. See Filmbox import options.

Alembic Scene

Import an Alembic scene file. Houdini can create object nodes for Alembic nodes or import Alembic geometry into a single Houdini object. See Alembic and Alembic import options.

Soundtrack

Imports an audio file that can play with the animation in the current scene.

Houdini Digital Asset

Loads the digital assets from a .hda file on disk into the current Houdini session.

Export

The submenu contains menu items for exporting data from Houdini into different file types.

Alembic

Export the scene data to an Alembic scene file. See Alembic and Alembic export options.

Filmbox FBX

Export the scene data to an FBX file. See Filmbox export options.

Run Script

Choose a Python or Hscript file and it run it as if you typed the contents into the Python shell or Hscript textport.

Quit Application

Exits Houdini.

Edit

Undo

Reverses the previous user action.

To set the amount of memory reserved for undo, choose Edit ▸ Preferences and choose Miscellaneous from the pop-up menu at the top.

Redo

Replays an "undone" action.

Undo History

Opens a window showing the history of user actions (the "undo stack"). Click an action in the list to undo back to that action.

Cut

Copies the current selection to the clipboard and deletes it.

Copy

Copies the current selection to the clipboard.

Paste

Inserts the current contents of the clipboard at the selection.

Preferences

This submenu lets you jump to a specific page of the Houdini Preferences window.

General User Interface preferences

Open the preferences window to the General UI page.

Network Editor preferences

Open the preferences window to the Network Editor page.

3D Viewports preferences

Open the preferences window to the 3D Viewports page.

Shelf preferences

Open the preferences window to the Shelf page.

Animation preferences

Open the preferences window to the Animation page.

Rendering preferences

Open the preferences window to the Rendering page.

Handles preferences

Open the preferences window to the Handles page.

Interactive Tools preferences

Open the preferences window to the Interactive Tools page.

Objects and Geometry

Open the preferences window to the Objects and Geometry page.

Motion and Audio

Open the preferences window to the Motion and Audio page.

Compositing

Open the preferences window to the Compositing page.

Scripting

Open the preferences window to the Scripting page.

Desktops and Toolbars

Open the preferences window to the Desktops and Toolbars page.

Save and Load

Open the preferences window to the Save and Load page.

Hip File

Open the preferences window to the Hip File page.

Warning Dialogs

Open the preferences window to the Warning Dialogs page.

Notifications

Open the preferences window to the Notifications page.

Performance Monitor

Open the preferences window to the Performance Monitor page.

External Tools

Open the preferences window to the External Tools page.

Miscellaneous

Open the preferences window to the Miscellaneous page.

Hotkeys

Opens the Hotkey editor. This lets you edit the hotkeys assigned to various actions in Houdini.

Color Settings

Opens the Color Settings window. This lets you change color preferences such as the UI color scheme.

Aliases and Variables

Opens the Aliases and Variables window. This lets you interactively edit Houdini’s environment variables.

Compositing Settings

Opens the Compositing Setting window. This lets you set defaults for compositing projects.

Clear Compositing Cache

Releases any memory currently being used by the compositing cache to speed up compositing operations.

The compositing cache can grow very large, especially when compositing over multiple frames. If you're running low on memory, this command can potentially free up a large amount.

Set Keyframe

Adds or saves a keyframe for the selected object at the current frame.

Objects

The checkbox items in this submenu let you quickly change certain object animation settings.

Always Highlight Object Selection in Viewer

The selected object is highlighted (drawn in yellow) in the viewports. You may want to turn this option off when painting on an object or viewing textures to reduce distraction.

Bone Kinematic Override

None

Do not override bone kinematic defaults.

IK Rest Pose

See the position of bones as they were posed (that is, the last time they were edited in the bone state).

Capture Pose

See the position of bones at the capture frame.

Keep Position when Parenting

Never

Do not maintain world space position; objects are positioned relative to their new parent.

Always

Maintain the current world space position and orientation of objects when they are parented.

Use Object Flag

Uses the value of an object’s Keep Position When Parenting parameter.

Generally, you want to make sure "Keep Position when Parenting" is set to "Always" before parenting limbs.

To maintain an object’s world space position, Houdini may need to change one or more of the child object’s Translation Order, Translate, Rotate or Scale parameters. Because this is undesirable if you have an animation channel on one of those values, "Keep Position When Parenting"" does nothing if the child object has animation on any of those parameters.

Stereo Eye

The items in this sub-menu control which sub-camera of the stereo rig to display in the viewport. For more information, see Stereo Camera Rig.

Stereo

Use the stereo camera when looking through a stereo camera rig.

Left

Use the left eye camera when looking through a stereo camera rig.

Right

Use the right eye camera when looking through a stereo camera rig.

Center

Use the center camera when looking through a stereo camera rig.

Live Parameter Display during Playback

Toggle live parameter update on or off. When this is on, Houdini updates parameters in the parameter editor with their current values as the animation plays. For heavy scenes you may want to disable this to speed up playback.

Intercept Mode

Toggle "intercept mode" on or off. When intercept mode is active, any keypresses are routed to the Keyboard CHOP. This lets you generate channel data using keypresses.

Automatically Add Parameter to Current Take

Toggle "auto take" mode on or off. When auto take mode is on, all parameters inside a take are unlocked, and any changes to a parameter are automatically added to the current take. See takes.

Auto Save

Toggle "auto save" mode on or off. When auto save mode is on, Houdini automatically saves the scene to a disk file at a regular interval (the default is one minute, you can change it in the save options).

Auto-save is always off when you launch Houdini. If you want auto-save you must explicitly turn it on in each session.

Render

Create Render Node

The items in this submenu let you quickly create and edit a render node without having to jump to the render network.

Mantra

Create a mantra render node set to use the raytracing engine.

Mantra - PBR

Create a mantra render node set to use the Physically Based Rendering engine.

RenderMan

Create a RenderMan render node.

RenderMan - RIS

Create a RenderMan render node set to use RIS.

Alfred

Create an Alfred render node.

You can create other render nodes using the items in the Other output nodes submenu.

Composite

Create a Composite render node, which generates an image from a compositing network.

Geometry

Create a Geometry render node, which generates a geometry file from the scene.

Channel

Create a Channel render node, which generates channel data files from a CHOP network.

Dynamics

Create a Dynamics render node, which generates cached simulation state files from a simulation network.

Edit Render Node

This submenu lists all render nodes in the default render network. Choose a node to edit its parameters in a floating window.

Render

This submenu lists all render nodes in the default render network. Choose a node to start rendering the node.

Preview in MPlay

This submenu lists all render nodes in the default render network. Choose a node to render the node into an MPlay window.

Scheduler

Opens a Render Manager in a floating window. This list shows all the currently active background renders. You can pause or cancel a job, or see history of completed jobs if Clear Completed Jobs is turned off.

Update Textures

Reload cached textures from disk.

Cloud Properties

TBD.

Pre-flight Scene

TBD.

MPlay

The items in this submenu open instances of the MPlay image viewer.

Load Disk Files

Opens an MPlay window with a file browser to select files.

Listen for Renders

Opens an MPlay window that all interactive renders will be directed to.

Listen for Flipbooks

Opens an MPlay window that all flipbooks (2D, 3D) will be directed to.

Takes

See takes for more information.

New Take

Starts a new take extending the current take.

Auto Takes

Toggles "auto take" mode on or off. This is the same as Edit ▸ Automatically add parameter to current take.

Assets

New Digital Asset From Selection

Creates a digital asset from the selected subnet node. This is the same as right-clicking a subnet node and choosing Create digital asset.

Unlock asset

This submenu lists all user assets. Choosing an asset unlocks it for editing. This is the same as right-clicking an asset node and choosing Allow editing of contents.

Lock asset

This submenu lists all unlocked user assets. Choosing an asset locks it to prevent editing. This is the same as right-clicking an asset node and choosing Match current definition.

Save asset

This submenu lists all unlocked user assets. Choosing an asset saves any changes made to the unlocked asset to the node’s definition on disk. This is the same as right-clicking an asset node and choosing Save node type.

Install Asset Library

Installs the assets from a library file on disk into the current scene file. You can use this to import "one-off" scene-specific assets from a file not on the Houdini search path.

Asset Manager

Opens the Asset Manager window. This is the same as Windows ▸ Asset Manager.

Refresh Asset Libraries

Reloads the list of available asset libraries and their contents. This is useful if you want to pick up files that may have been added or changed since Houdini started, for example by an external asset management system.

Create Black Boxed Asset from Selection

Converts the selected asset node into a "black box" asset that cannot be unlocked or edited. The black box asset is a new asset type with a different name.

Orbolt Asset Store

Opens the Orbolt asset store in a browser.

Orbolt Asset Browser

Shows a pane or window allowing you to browse any assets you've downloaded from the Orbolt store.

Upload to Orbolt Asset Store

Starts the process of uploading the selected asset to the Orbolt asset store.

Other Asset Tools

This submenu contains additional items for working with assets.

Encapsulate Asset

Compile and Embed Material

Embed Internal Assets

Desktop

This menu lets you choose a "desktop" (a saved pane layout). Houdini comes with several task-based layouts. The default desktop is "Build", an all-purpose layout. You can also save your own layout as a new custom desktop using Desktop ▸ Save Current Desktop As.

See pane layouts for more information.

New Desktop

"Resets" the pane layout to a single pane with a scene viewer tab.

Save Current Desktop

Saves any changes to the current layout. This preserves the desktop’s current name.

If you want to save the current layout as a new named desktop, use Save Current Desktop As instead.

Save Current Desktop As

Saves the current layout under a new name. The name will appear in the Desktop menu, allowing you to recall the saved layout.

Save All Desktops

Saves any changes to all layouts. Use this if you've modified multiple layouts and want to keep all your changes.

Reload Current Desktop

Resets the current pane layout by re-reading the saved defintion from disk.

This is useful to discard any unsaved changes, or if you know the desktop file has changed since Houdini was started and you want to pick up the changes.

Desktops Manager

Opens the desktop manager allowing you to perform operations on saved layouts, such as duplicate, rename, or delete them.

Reset Main Menu to Top

If you've moved the menu bar into a pane, this puts them back at the top of the main window.

(You can move the menus into a pane using the Pane interface ▸ Move main menus here item in a pane menu.)

On Mac OS the menu bar is always at the top of the main screen, so this has no effect.

Reset Shelf to Top

If you have moved the shelf into a pane, this puts it back at the top of the main window.

(You can move the menus into a pane using the Pane interface ▸ Move main menus here item in a pane menu.)

Reset Playbar to Bottom

If you've moved the playbar into a pane, this puts it back at the bottom of the main window.

(You can move the menus into a pane using the Pane interface ▸ Move playbar here item in a pane menu.)

Reset Status Bar to Bottom

If you've moved the status line into a pane, this puts it back at the bottom of the main window.

(You can move the status line into a pane using the Pane interface ▸ Move status bar here item in a pane menu.)

Radial

This menu lets you choose which radial menu opens when you press the custom radial menu key. Houdini comes with several task-based radial menus. You can also create your own radial menus using the radial menu editor, and assign them to keys using the hotkey editor.

See radial menus and hotkey editor for more information.

Create New

Creates a new, blank radial menu and opens it in the radial menu editor.

Edit Current

Opens the "current" radial menu in the radial menu editor.

Pin Radial Menu

Locks or unlocks the current radial menu from changing when you change pane layouts in the Desktop menu.

Windows

Keep Floating Windows on Top

Toggles whether floating windows should always appear on top of the main window, or whether they should be allowed to go behind when they're not the current window.

New Floating Panel

Opens a new window with its own pane layout. This is especially useful for putting additional Houdini UI on multiple monitors.

See how to edit pane layouts.

Animation Editor

Opens an Animation Editor window, which lets you view and edit animated parameters and how Houdini fills in the transitions between keyframes.

Hscript Textport

Opens an Hscript Textport window, which lets you type HScript commands and prints the results.

Python Shell

Opens a Python shell window.

Python Source Editor

Opens a window that lets you edit the contents of the hou.session module. This module is a place for scene-specific Python code.

Python Panel Editor

Opens the Python Pane editor window, which lets you duplicate, edit, and rename custom pane types defined in Python.

Bundle List

Opens a Bundle List window, which shows all bundles in the current scene.

Take List

Opens a Take List window, which lets you switch between and edit takes.

Parameter Spreadsheet

Opens a Parameter Spreadsheet window, which lets you edit multiple values on multiple nodes at once.

Tree View

Opens a Tree View windows, which shows a hierarchical list of all nodes in the scene.

Houdini Engine Debugger

Opens a Houdini Engine Debugger window, which lets you start and stop the Houdini Engine debugger. The server will remain active when the floating window is closed.

Asset Manager

Opens the Asset Manager window, which lets you edit, unload, and delete digial asset libraries.

Gallery Manager

Opens a Gallery Manager window, which lets you view and edit gallery entries for any node type.

Persistent Handle Editor

Opens a Persistent handle window.

Material Palette

Opens a Material Palette window, which lets you create and assign materials from the gallery.

Code Viewer

Opens a Code Viewer window, which lets you view the VEX code inside a VOP node.

You can drop a VOP node on the window or select a node using the chooser to view the VEX code inside the node. This is the same as right-clicking the node and choosing View Code.

Performance Monitor

Opens a performance monitor window, which lets you record cook times and display the results to identify slow parts of your scene.

Audio Panel

Opens an audio panel window, which lets you control the audio output of Houdini.

Cache Manager

Opens a cache manager window, which lets you set cache sizes, see cache usage, and clear caches.

Shell

Opens a new system command line window.

Autorigs

Opens an auto rigs builder window.

Character Picker

Opens a character picker window.

Pose Library

Opens a pose library window.

Pose-Space Deform

Opens an pose-space deform builder window.

Help

Start Here

Opens a Houdini tutorials page in a browser.

Contents

Opens Houdini’s online help in an embedded browser.

Example Files

Opens Houdini’s online help to show the list of example files.

Sidefx.com

Opens the sidefx.com website in a browser.

Online Tutorials

Opens a Houdini tutorials page in a browser.

Houdini Forum

Opens the Houdini forum in a browser.

Online Support

Opens the Houdini support page in a browser.

Updates

Opens the Houdini downloads page in a browser.

Tooltip Help

Toggles whether to show tooltips when you hover the mouse over something in the Houdini UI.

Open "Start Here" Pane at Startup

Toggles whether to show a window containing links to learning materials when Houdini starts up.

About Houdini

Lets you know which version of Houdini you are running.

Reference

User interface

  • Menus

    Explains each of the items in the main menus.

  • Viewers

    Viewer pane types.

  • Panes

    Documents the options in various panes.

  • Windows

    Documents the options in various user interface windows.

Programming

  • Expression functions

    Expression functions let you compute the value of parameters.

  • Expression cookbook

    Tips and tricks for writing expressions to accomplish various effects.

  • Python Scripting

    How to script Houdini using Python and the Houdini Object Model.

  • VEX

    VEX is a high-performance expression language used in many places in Houdini, such as writing shaders.

  • HScript commands

    HScript is Houdini’s legacy scripting language.

Command line

Guru level