Houdini 19.0 レンダリング

Mantraによるレンダリングの方法

On this page

Mantraユーザガイド

概要

Mantraは、Houdiniにインストールされている非常に高度なレンダラーです。 これは、 複数の方法論 を持ったレンダラーで、スキャンライン、レイトレーシング、物理ベースのレンダリングを実装しています。 他のエンジンを使用する理由が特にない限りは、 物理ベースのレンダリング を使用してください。 MantraはHoudiniと密接に統合されており、パックプリミティブボリュームに対して非常に効率の良いレンダリングをします。

VOPネットワークまたはVEXシェーディング言語でプログラムを記述することで、Mantraシェーダを実装することができます。

Tip

Houdiniは、RenderMan™, Arnold™, Redshift™, OctaneRender™, V-Ray™, mental ray™, Maxwell™ などのサードパーティ製のレンダラーとも統合することができます。

一般的に、Houdiniのレンダリングには、レンダリングするビューポートを定義したカメラ、シーンを照明するライト、レンダラーを意味するレンダーノード、使用するレンダリング設定が必要です。 とはいえ、今でも現行ビュー、ヘッドライト、デフォルトのレンダリング設定を使ってレンダーをプレビューすることができます。

プレビューレンダリング

Render Viewは、時には IPR (Interactive Photorealistic Render)ビューと呼ばれ、ライトやオブジェクトを移動したり、パラメータを変更したりすると更新されるレンダリング画像を表示します。

Render Regionツールは、3Dビューア内を矩形ドラッグすると、その部分が、小さいRender Viewのように動作します。これは、ビューの指定した矩形範囲のみをレンダリングし、変更があっても、その矩形範囲だけが更新されます。

最終レンダリングの開始

Render Viewでほとんど作業していれば、インタラクティブに更新されるレンダー結果を見ることができます。 このビューでは、マテリアルを割り当て、レンダーノードとシェーダノードのパラメータを調整して、その作業の結果を見ることができます。

最終レンダリングを実行したい時:

  • レンダーノードのパラメータエディタで、 Render to Disk または Render to Mplay をクリックします。

または
  • メインメニューから Render ▸ Start Renderer ▸ render node を選択します。

または
  • ビューアの左側にあるツールボックスの Launch Render ボタンをクリックします。

    現行ビューをレンダリングするなら、ボタンを右クリックしてレンダリングするレンダー出力ノードを選択するか、 View: Mantra を選択します。

    メニューでデフォルトのレンダーノードを設定した後に、そのアイコンをクリックすると、そのレンダーノードを使用します。初期のデフォルトは、現行ビューをレンダリングします。

または
  • renderHScriptコマンドまたはPythonのhou.RopNodeインターフェースを使用して、レンダリングをスクリプト化することができます。

レンダーノードのセットアップ

シーンにライトを追加して、カメラを作成します(ライトとカメラ)。シーン内にライトがない場合は、レンダリング結果は黒になります。

To...Do this

レンダーノードを作成する

メインメニューから Render ▸ Create Render Node ▸ Mantra を選択します。MantraはHoudiniの強力な組み込みレンダラーです。

シーン内にカメラが1つしかない場合、新しいレンダーノードは、自動的にそれをレンダーノードのカメラとして選択します。

レンダーノードのパラメータを編集する

パラメータエディタでレンダーノードのパラメータとレンダリングプロパティを編集することができます。

  • Render ▸ Edit Render Node ▸ node name を選択して、レンダーノードのフローティングパラメータエディタを開きます。

    または
  • ネットワークエディタで、“出力”(/out)ネットワークに移動します(ネットワークエディタペインの上部のパスの最初のセグメントをクリックしてoutを選択します)。ノードを選択して、パラメータエディタを開きます。

レンダーパラメータのヘルプは、Mantraノードのヘルプを参照してください。

レンダラーが単一フレームまたはアニメーションのどちらをレンダリングするかに設定する

Valid Frame Range メニューでは、このレンダーノードが単一フレームかシーケンス(アニメーション)のどっちをレンダリングするのか制御します。 Render Any Frame を選択すると単体フレームを、 Render Frame Range はシーケンスをレンダリングします。

シーケンスをレンダリングする場合、ファイル名にフレーム番号変数である$Fが含まれていることを確認してください。そうしないと、レンダラーは各フレームを同じ名前で上書きしてしまいます。ファイル名のエクスプレッションを参照してください。

出力サイズ/解像度を設定する

レンダリングする画像のサイズは、 カメラ のパラメータで設定します。カメラオブジェクトを選択して、パラメータエディタで View ▸ Resolution パラメータを設定します(カメラの他のパラメータは、Cameraノードのヘルプを参照してください)。

または

レンダーノードの Properties ▸ Output ▸ Override Camera Resolution を有効にすることでカメラの画像サイズのパラメータを上書きすることができます。

レンダリングするカメラを設定する

レンダーノードの Main タブをクリックして、 Camera フィールドを編集します(フィールドの右隣にあるボタンをクリックして、リストからカメラを選択します)。

オブジェクトの表示制御

To...Do this

ビューアのオブジェクトを表示・非表示する

オブジェクトのディスプレイフラグをオン・オフします。

レンダリングでオブジェクトを完全に非表示にする

オブジェクトのパラメータエディタの Render タブで、 Renderable をオフにします。

オブジェクトを非表示にしても、オブジェクトの反射/シャドウの投影をする

オブジェクトのパラメータエディタの RenderRenderable をオフにして、 Phantom をオンにします。

ビューポート表示とレンダリングで、別のジオメトリを使用する

オブジェクトのジオメトリネットワークでは、ディスプレイ用とレンダリング用に別々にノードのディスプレイフラグとレンダーフラグを設定することができます。

これは、ディスプレイ用に低解像度のプロキシジオメトリ(代用ジオメトリ)を使用し、レンダリングで高解像度のジオメトリを使用するのに役に立ちます。

レンダリング時にジオメトリをポイントにインスタンス化する

ポイントインスタンスを参照してください。

オブジェクトが反射しないようにする

反射オブジェクトの Render ▸ Shading ▸ Reflection Mask パラメータを編集します。

役立つ情報

  • ディープカメラマップをレンダリングすることで奥行き情報を持つ“2.5-D”画像を取得することができます(.picまたは.ratへレンダリングする時は、奥行き情報がそのファイルに埋め込まれます。.exrへレンダリングする時は、奥行き情報は追加で出力ファイルが保存されます)。奥行き情報は3Dでレンダリング画像をコンポジットすることができます。

  • Switcherオブジェクトは、別々のカメラ間でビューポートを切り替えるアニメーションが可能な特殊なカメラです。

  • レンダーノードのパラメータエディタで Controls ボタンをクリックすれば、Render Controlウィンドウが開きます。このウィンドウでは、ノードのパラメータを編集することなく(パラメータを覚える必要なく)、レンダリング毎に一時的にレンダリングパラメータ(フレーム範囲やレンダリング依存関係の設定)を上書きすることができます。

    1. メインメニューから、 Render ▸ Edit Render Node ▸ render node を選択します。

    2. レンダーノードのパラメータエディタの Render Control ボタンをクリックします。

    3. Output Overrides セクションの Frame Range オプションを設定します。

    そのウィンドウで依存関係のレンダリングを上書きすることもできます。詳細は、レンダーノードのセットアップの方法Render Controlウィンドウを参照してください。

Mantraユーザガイド

See also

レンダリング

Mantraユーザガイド

基本

ライティング

次のステップ

導師レベル

他のレンダラー