Houdini 19.0 レンダリング

ワイヤーフレームをレンダリングする方法

On this page

このメソッドはポリゴン、プリミティブ、NURBS、メタボールで機能します。

シーンの作成

  1. Create シェルフタブのGridツールをクリックしてグリッドを作成します。

  2. シェルフのPlatonic Solidsツールをクリックして、 Solid TypeUtah Teapotに変更してティーポットを作成します。

  3. Lights and Cameras シェルフタブのEnvironment Lightをクリックしてソフトライティングを追加します。

  4. Material Palletteでシェーダをグリッドとティーポットにドラッグします。

    この例では、Clay Materialを使用しています。

シーンのレンダリング

  1. Lights and Cameras シェルフタブのCameraでCtrlクリックしてカメラを作成します。

  2. Houdiniのメニューから Render ▸ Create Render Node ▸ Mantra をクリックしてMantraレンダーノードを作成します。

  3. 画像をレンダリングします。 以下の画像が、デフォルトのレンダリング画像です。

  1. Environment Lightの Light タブから Area Light Options サブタブをクリックして、 Area Samples パラメータを256に上げてレンダリング品質を上げます。

  2. 画像を再度レンダリングします。 以下の画像が、新しくレンダリングした画像です。

  1. 画像を保存して、MPlayを閉じます。

ワイヤーフレーム付きのシーンのレンダリング

  1. Environment Lightのような表示したくないオブジェクトの表示をオフにします。

    Note

    ライトのハンドルの表示をオフにするには、 ⎋ Escを押します。

  2. ビューアツールバーの右側にある Shading Mode ボタンをクリックして、 Hidden Line Invisible を選択します。

  3. Flipbookアイコンをクリックして、 Flipbook with New Settings を選択します。

  4. 静止画なので、 Output タブで Frame Range/Inc1, 1, 1に変更します。

  5. Effects タブで、 Depth of Field を有効にして、 Quality16のような高い値に変更します。

  6. Size タブで、 Resolution をカメラの View タブの Resolution と同じに設定します。この例では、640x480です。

    また、 Crop Out View Mask Overlay を有効にします。

  7. Accept を押して画像をレンダリングします。

    このレンダーでは良い感じのアルファチャンネルも生成します。

  8. 画像を再度保存して、MPlayを閉じます。

2つのレンダーの合成

  1. ビューを Composite View に切り替えて、imgネットワークに切り替えます。

  2. コンポジットネットワークの中に入り、TabメニューFileノードを作成します。

  3. Filedefault.picをワイヤーレンダーに変更します。

  4. TabメニューFileノードをもう1つ作成して、 Filedefault.picを元のレンダーに変更します。

  5. Multiplyノードを挿入して、2つのFileノードを入力に接続します。

    これは、全体のカラーチャンネルを乗算するので、画像全体が暗くなります。

  6. アルファチャンネルにワイヤーファイルを使うために 、ワイヤーファイルをマスクの入力に接続します。

レンダリング

Mantraユーザガイド

基本

ライティング

次のステップ

導師レベル

他のレンダラー