Houdini 17.5 ノード ジオメトリノード

Box geometry node

立方体または6面の矩形ボックスを作成します。

On this page

Tip

ジオメトリをBox SOPの入力に接続すると、そのジオメトリの境界ボックスが作成されます(これは、Boundノードの機能と重複しています)。 この機能を利用すれば、Latticeノードと併せて使用するケージを作成することもできます。

ビューアにボックスを配置

To...Do this

シーン内のどこかにボックスを配置する

  1. Create タブの Boxツールをクリックします。

  2. カーソルをシーンビューに移動します。

    Note

    ⇧ Shiftを押しながらカーソルを動かすと、基準平面からボックスを離すことができます。

  3. シーンビューで配置したい場所でクリックします。

    クリックしないでEnterを押せば、ボックスは原点に配置されます。

原点にボックスを配置する

シェルフ Boxツールを⌃ Ctrl + クリックします。

Note

シーンビューでボックスをドラッグするか、パラメータエディタの値を変更すれば、ボックスを移動することができます。

詳細は、Boxハンドルを参照してください。

パラメータ

Primitive Type

作成するジオメトリのタイプ。

Polygon

ボックスと同じサイズの四角形ポリゴンでボックスを構築します。

Polygon Mesh

ボックスよりも小さいサイズのポリゴンでボックスを構築します。このポリゴンの数は、 Axis Divisions パラメータで制御します。

Mesh

メッシュプリミティブ を作成します。メッシュプリミティブとは、本来のUVマップを持っていて、それを分離できない 単一プリミティブ のことです。反対にポリゴンメッシュは、個々のポリゴンで構成されています。

ほとんどの場合、 Mesh ではなく Polygon Mesh の方を使います。

NURBS

6枚のNURBSサーフェスでボックスを構築します。ボックスのCVの数を制御するには、 Axis Divisions パラメータを使います。

Bezier

6枚のBezierパッチでボックスを構築します。

Points

ジオメトリなしでポイントだけを作成します。 Divisions を設定すれば、Polygonモードと同じ数のポイントが作成されます。 設定しなかった場合は、Polygon Meshモードと同じ数のポイントが作成されます。

Connectivity

Primitive TypePolygon でない時に利用可能です。ボックスを構築する方法を制御します。 Primitive Type がNURBSまたはBezierの時は、"Triangles"と"Quadrilaterals"のオプションは無視されます。

"Rows"と"Columns"のオプションは、サーフェスではなくラインを作成します( Primitive Type に応じて、ポリラインまたは直線カーブ)。

Rows

水平ラインを作成します。

Columns

垂直ラインを作成します。

Rows and Cols

RowsとColumnsの両方。

Triangles

ボックスの各フェースを三角形で構築します。

Quadrilaterals

ボックスの各フェースを四角形で構築します。

Alternating Triangles

別の方法の三角形でボックスを構築します。各四角形は、2つの背中合わせの三角形になるように半分に分割して、分割線の方向が交互になるように分割していきます。

Reverse Triangles

逆三角形でボックスを構築します。各四角形は、2つの背中合わせの三角形になるように半分に分割して、分割線の方向が同じになるように分割していきます。

Consolidate Corner Points

ボックスのフェースのコーナーポイントを結合します。

Size

XYZ軸に沿いのボックスのサイズ。

Center

ボックスの中心の位置。

Rotate

ボックスの中心を基準とした回転。

Uniform Scale

均一スケール。

Axis Divisions

各軸沿いの分割数。 Primitive TypePolygon Mesh または Mesh の時に利用可能です。

Axis Orders

各軸でのサーフェスの階数。

Divisions

Primitive TypePolygon または Points の時に利用可能です。 LatticeデフォーマSOPまたはSpring SOPと併せてラティスを作成します。 ラティスを作成するには、チェックボックスをオンにして、そのフィールドを使って各軸のポイントの数を制御します。

内部のポイントが不要であれば、 Axis DivisionsPolygon Mesh または Mesh のモードを使用してください。

Enforcement Bars

Primitive TypePolygonDivisions がオンの時に利用可能です。 ラティス内のポイント間に対角線を描きます。これは、Spring SOPを併せてラティスを使用する時に役に立ちます。

Oriented Bounding Box(ポイントのみ)

ジオメトリをBoxノードの入力に接続した時に利用可能です。境界ボックスをワールド軸ではなくて、入力ジオメトリの軸に向けます。

このアルゴリズムはポイントに基づいているので、頂点ハルを持つプリミティブが必要です。 例えば、プリミティブ球またはパックジオメトリでは動作しません。 プリミティブの球の境界ボックスを取得するには、まずConvert SOPを使ってポリゴンに変換します。

Add Vertex Normals

明示的に角のある外観になるようにボックスに頂点法線を追加します。

入力

Bounding Source

ジオメトリをこの入力に接続すると、Boxは、その入力ジオメトリの境界ボックスを作成します(接続しなかった場合は、パラメータを使ってボックスのサイズと位置を制御します)。

境界ボックスの向きをワールド軸ではなく入力ジオメトリにするには、 Oriented Bounding Box パラメータを使います。

Examples

BoxSpring Example for Box geometry node

Box SOPは、ボックスの作成以外のことにも使用します。これは、特定の目的で既存のジオメトリを囲むこともできます。 Box SOPは、単純な六面体のポリゴンボックスを作成したり、ジオメトリの境界ボックスを計算したり、Lattice SOPと組み合わせて使用します。 box.hipファイルには、以下の事を説明するために、2つのオブジェクトがあります:

  • animated_bounding_box

    animated_bounding_boxオブジェクトでは、アニメーションするオブジェクトを単純なボックスで囲む方法を説明しています。 これは、複雑なジオメトリを表示するときに、ボックスを表示フラグに設定し、複雑なジオメトリをレンダーフラグに設定したい場合に役に立ちます。

  • box_spring_lattice

    これは、Box SOPとLattice SOPを組み合わせて使用したサンプルです。 Box SOPは、あるジオメトリ、この場合は球を囲む時に使用します。Box SOPのDivisionsにチェックを付けて、その値にLattice SOPの分割数を参照するように設定することで適切なジオメトリを作成します。

ボックス上面のポイントは、Group POPでグループ化しています。Spring POPは、そのグループのポイントをFixed Pointsに設定して、ボックスを変形しています。

この方法でBox SOPを使用すれば、入力のジオメトリ(この場合は、basic_sphere)が変わると、自動的にボックスとラティスもサイズが変わります。

The following examples include this node.

CopyAnimation Example for Copy channel node

このサンプルでは、Copy CHOPを使って、チャンネルをコピーして、それらのチャンネルをジオメトリに適用する方法を説明しています。

CountImpacts Example for Count channel node

このサンプルでは、Count CHOPを使って、DOPシミュレーションのインパクトを数える方法を説明しています。

このサンプルでは、Count CHOPの値を使って、ティーポットのコピーを生成します。

DelayPosition Example for Delay channel node

このサンプルでは、オブジェクトの位置を取得して、Delay CHOPを使って、アニメーションを遅延させる方法を説明しています。

ExtractTransforms Example for Dynamics channel node

このサンプルでは、Dynamics CHOPを使って、DOPシミュレーションからトランスフォーム情報を引き出し、その情報をオブジェクトに適用する方法を説明しています。

Export Example for Export channel node

このサンプルでは、Export CHOPについて説明しています。 Export CHOPは、チャンネルをエクスポートするのに便利なツールです。 このツールを使えば、CHOPのチャンネルをチャンネル名を変更することなく、別のチャンネルに合わせることができます。 このサンプルでは、CHOPのチャンネルをモデルのtyパラメータにエクスポートする方法を説明しています。

GeometryMethods Example for Geometry channel node

このサンプルでは、Geometry CHOPのAnimatedとStaticの別々の使い方を説明しています。

Lookup Example for Lookup channel node

このサンプルでは、Lookup CHOPを使って、イベントまたはトリガーに基づいてアニメーションを再生する方法を説明しています。

NoiseTransform Example for Noise channel node

このサンプルでは、Noise CHOPを使ってアニメーションを生成して、それをジオメトリに適用する方法を説明しています。

ObjectBasic Example for Object channel node

このサンプルでは、Object CHOPについて説明しています。

Object CHOPを使って、オブジェクトからチャンネル情報を取り込みます。

このデータは、CHOPネットワーク内で操作することができ、オブジェクトまたは別のオペレータに戻すことができます。

AnimationSequence Example for Sequence channel node

このサンプルでは、3つの別々のオブジェクトからアニメーションを取得して、4つ目のオブジェクトへ1つのアニメーションとしてシーケンス化させる方法を説明しています。

AutoFreezeRBD Example for Active Value dynamics node

このサンプルでは、RBDオブジェクトがRest状態になる時を自動的に検知して、Active状態をオフにするシステムを説明しています。 これは、計算時間とジッターを軽減するためにRBDオブジェクトをフリーズします。

ClipLayerTrigger Example for Agent Clip Layer dynamics node

このサンプルでは、Agent Clip Layer DOPを使って、エージェントの上半身にクリップを適用する方法を説明しています。 このクリップは、そのエージェントが境界ボックス内にある時にアクティブになります。

BridgeCollapse Example for Apply Relationship dynamics node

このサンプルでは、Apply Relationship DOPを使って、自動的に拘束を伝搬させて、崩壊する橋のRBDシミュレーションを作成する方法を説明しています。

ClothAttachedDynamic Example for Cloth Object dynamics node

このサンプルでは、RBDオブジェクトのダイナミクスポイントに布を接続する方法を説明しています。

AnchorPins Example for Constraint Network dynamics node

このサンプルでは、異なるアンカー位置がピン拘束に影響を与える方法を説明しています。

BreakingSprings Example for Constraint Network dynamics node

このサンプルでは、SOP Solverを使用して、遠くに引き伸ばされたConstraint Network内のスプリング拘束を切る方法を説明しています。

ControlledGlueBreaking Example for Constraint Network dynamics node

このサンプルでは、Constraint Networkの接着ボンドを徐々に弱くして、ビルの崩壊を制御する方法を説明しています。

Hinges Example for Constraint Network dynamics node

このサンプルでは、ピン拘束でオブジェクト間にヒンジを作成する方法を説明しています。

SoftConstraintNetwork Example for Constraint Network dynamics node

このサンプルでは、単純なソフト拘束のネットワークを作成する方法を説明しています。このネットワークを使用することで、オブジェクトを曲げた後に粉砕させることができます。

SpringToGlue Example for Constraint Network dynamics node

このサンプルでは、近くのオブジェクト間にSpring拘束を作成して、シミュレーションで、その拘束を接着拘束に変更する方法を説明しています。

AutoFracturing Example for Copy Objects dynamics node

このサンプルでは、Multi Solverと併せてCopy Object DOPを使って、他のオブジェクトと衝突した際に自動的にRBDオブジェクトを半分に割る方法を説明しています。

CrowdHeightField Example for Crowd Solver dynamics node

このサンプルでは、Crowd SolverのTerrain AdaptationとBullet SolverのラグドールのコリジョンにHeight Fieldを使用する方法について説明しています。

PinnedRagdolls Example for Crowd Solver dynamics node

このサンプルでは、ラグドールを外部オブジェクトに取り付ける拘束のセットアップ方法と、モーターを使ってアニメーションクリップを持つアクティブラグドールを駆動させる方法について説明しています。

Stadium Crowd Example Example for Crowd Solver dynamics node

スタジアムのセットアップを説明した群衆サンプル。

このセットアップは、スタジアムの群衆を作成します。 回転するcheer_bboxオブジェクトをエージェントの境界ボックスとして使用しています。 エージェントがそのオブジェクトの中に入ると、座っている状態から応援している状態へ推移します。 数秒後には、応援している群衆がまた座っている状態に戻ります。

Note

アニメーションクリップは、シーンを再生する前にベイクするのに必要です。これは、サンプルをCrowdsシェルフから作成した場合に自動的に行なわれます。 そうでない場合は、シーンファイルを希望の場所に保存し、'/obj/bake_cycles' ROP NetworkのRenderをクリックして、ファイルを書き出します。 それらのファイルのデフォルトのパスは、${HIP}/agentsです。

Tip

群衆の一部だけをもっと高速にプレビューしたいのであれば、/obj/crowdsource/switch_all_subsectionにSwitchノードがあります。 そのスイッチを0に設定すると、すべてのエージェントが表示され、1に設定すると、一部のみが表示されます。

Street Crowd Example Example for Crowd Solver dynamics node

2つのエージェントグループによるストリートのセットアップを説明した群衆サンプル。

このセットアップは、2つのエージェントグループを作成します。 黄色のエージェントがゾンビで、ストリートのパスに沿います。青色のエージェントがぶらついている歩行者で、ゾンビが近づくと走ります。

エージェントの状態を変更するトリガーは、crowd_sim DOPNETでセットアップします。 ゾンビのグループは、信号との距離と信号の色を使用し、信号が赤になると停止状態に変わります。 生存者のグループは、ゾンビが近づくと走行状態に変わります。

Note

アニメーションクリップは、シーンを再生する前にベイクするのに必要です。これは、サンプルをCrowdsシェルフから作成した場合に自動的に行なわれます。 そうでない場合は、シーンファイルを希望の場所に保存し、'/obj/bake_cycles' ROP NetworkのRenderをクリックして、ファイルを書き出します。 それらのファイルのデフォルトのパスは、${HIP}/agentsです。

FromRBD Example for Field Force dynamics node

このサンプルでは、他のActive RBDオブジェクトをField Force DOPのソースとして使用する方法を説明しています。 2つのボールが立方体内を跳ね返り、それらのボールの1つが、ジオメトリに記録されたForceの値に応じて片方のボールを跳ね返すように設定しています。

SimpleField Example for Field Force dynamics node

このサンプルでは、Field Force DOPの使い方を説明しています。 RBDオブジェクトのグループが最初にフィールドに引き寄せられて、フィールドを通過して引き離されます。

DensityViscosity Example for FLIP Solver dynamics node

このサンプルでは、ソリッドオブジェクトと作用する異なる密度と粘度を持つ2つの流体について説明しています。

SpinningFlipCollision Example for FLIP Solver dynamics node

このサンプルでは、ジオメトリのVelocityベクトルに基づいて、 ジオメトリ上に撒き散らしたポイントから新しいパーティクルを生成して FLIP流体を作成する方法を説明しています。 また、流体用の衝突オブジェクトとして動作するように、 ジオメトリをセットアップする方法も説明しています。

VariableViscosity Example for FLIP Solver dynamics node

このサンプルでは、粘度が変化する3つの流体と移動するオブジェクトの間での作用を説明しています。

FillGlass Example for Fluid Object dynamics node

他のRBDオブジェクトからのシミュレーションをソースとした流体でRBDコンテナを満たします。

RiverBed Example for Fluid Object dynamics node

単純な河床に流体ソースと流体シンクをセットアップすることで、液体が川のように急流します。

HotBox Example for Gas Calculate dynamics node

このサンプルでは、ボリューム表現のオブジェクトを取得して、それをTemperature(温度)フィールドに追加する方法を説明しています。 オブジェクトの温度は、Smoke Densityの値の調整、またはGas CalculateマイクロソルバDOPのPre-Multフィールドを調整することで変更することができます。

EqualizeFlip Example for Gas Equalize Volume dynamics node

このサンプルでは、Gas Equalize Volume DOPを使用して、流体シミュレーションの体積を維持する方法を説明しています。

EqualizeLiquid Example for Gas Equalize Volume dynamics node

このサンプルでは、Gas Equalize Volume DOPを使用して、流体シミュレーションの体積を維持する方法を説明しています。

TeapotUnderTension Example for Gas Surface Tension dynamics node

このサンプルでは、ティーポットの形をした液体のブロッブを作成しています。 そして、表面張力によって、ブロッブを球状に平滑化しています。

パーティクル流体の浮力

このサンプルでは、Particle FluidとRBDオブジェクトを組み合わせることで、相互に影響し合うようにする方法を説明しています。 その結果、球が浮きます。

ViscousFlow

このサンプルでは、パーティクルベースの流体によって高い粘度の流れを作成する方法を説明しています。 この流体によって、溶岩や泥のような遅い流れの流体をシミュレーションすることができます。

WorkflowExample

この少し複雑なサンプルでは、パーティクル流体のシミュレーション、保存、サーフェス化、レンダリングの単純なワークフローを説明しています。 サンプルにある3つのジオメトリノードの名前は、それぞれ使用する順番としてStep 1、Step 2、Step 3という名前にしています。 各ノードは、パーティクルジオメトリをディスクに書き出したり、ディスクからジオメトリを読み込んだり、ディスクからサーフェス化したジオメトリを読み込みます。 このサンプルでは、さらにシェーダとカメラを組んでいるので、簡単にレンダリングすることができます。

このシーンでアニメーションする流体は、高い弾力を持つゼラチンのようなブロッブです。

TargetSand Example for POP Grains dynamics node

このサンプルでは、モデルの表面上のポイントに引き寄せられる粒のシミュレーションを説明しています。

VaryingGrainSize Example for POP Grains dynamics node

このサンプルでは、まったく異なるサイズの粒で引き寄せられるシミュレーションを説明しています。

DampedHinge Example for RBD Angular Spring Constraint dynamics node

このサンプルでは、RBD Angular Spring Constraintを使って、緩んだヒンジを作成する方法を説明しています。

RagdollExample Example for Cone Twist Constraint dynamics node

このサンプルでは、単純なぬいぐるみにRBD Cone Twist Constraintを使っています。

ShatterDebris Example for RBD Fractured Object dynamics node

このサンプルでは、破壊の方法を説明しています。 RBD Fractured ObjectやDebrisのシェルフツールを使えば、破壊されたジオメトリの破片から発生する瓦礫を作成することができます。

まず最初に破壊の定義をするために、Shatterツール(Modelシェルフ)をグラスに使用します。 次にRBD Fractureツールをグラスに使用して、その破壊された破片をRBDオブジェクトにします。 最後にDebrisツールをそのRBD Fractureオブジェクトに使用してデブリ(瓦礫)を作成します。

StackedBricks Example for RBD Fractured Object dynamics node

このサンプルでは、1個のSOPからたくさんのRBDオブジェクトを作成する方法を説明しています。 さらに、Velocity Pointアトリビュートを使って、オブジェクトの初期速度を設定する方法も説明しています。

BlendSolverWithRBDGlue

このサンプルでは、RBD Glueオブジェクトからアニメーションキーフレームデータを取り込んで、 それを立方体のシミュレーションにブレンドして、衝撃によって複数の破片に砕く方法を説明しています。

BreakingRock

このサンプルでは、RBD Glue Objectノードを使って、 衝突で自動的に砕けるRBDオブジェクトを作成する方法を説明しています。 さらに、モデルをこのようなシミュレーションで適切に砕くテクニックも説明しています。

ChoreographedBreakup

このサンプルでは、RBD Stateノードを使って、接着したオブジェクトの分解を制御する方法を説明しています。

たくさんの球を接着してトーラス形状を作成し、さらに、水平に移動する平面を追加しています。 この平面が通過した後の球が分解されていきます。

Pendulum Example for RBD Hinge Constraint dynamics node

このサンプルでは、RBD Hinge Constraintを使って、 RBDオブジェクトとワールド空間位置または他のRBDオブジェクトとの間にヒンジのジョイントを設定して振り子を作成する方法を説明しています。

SimpleKeyActive Example for RBD Keyframe Active dynamics node

このサンプルでは、RBD Keyframe Activeノードを使って、キーフレームアニメーションからRBD Solverに切り替え、 そしてキーフレームアニメーションに戻す方法を説明しています。 Switch SolverやBlend Solverでも同じアニメーションを作成することができますが、 この手法は、2,3個のRBDオブジェクトに対して、キーフレームアニメーションをシミュレーションによる動きに切り替えるだけであれば、最もシンプルです。

RBDInitialState Example for RBD Object dynamics node

このサンプルでは、RBDオブジェクトのInitial Stateパラメータの使い方を説明しています。

GravitySlideExample Example for Slider Constraint dynamics node

このサンプルでは、Slider Constraintを使って、1軸だけでスライドと回転をするボックスを作成する方法を説明しています。

PaddleWheel Example for RBD Solver dynamics node

このサンプルでは、たくさんのエレメントとRBD機能を組み合わせて、落下するたくさんのオブジェクトにぶつかる水掻きホイールのシミュレーションを作成しています。

このサンプルでは、RBD SolverのResolve Penetrationパラメータなどを設定し、衝突するオブジェクトをグループ化し、拘束を作成する方法を説明しています。

ReferenceFrameForce Example for Reference Frame Force dynamics node

水で満たされたRBDの花瓶を使って、花瓶の参照フレーム内で水のシミュレーションをします。

DelayedSmokeHandoff Example for Smoke Object dynamics node

このサンプルでは、RBDオブジェクトが何かに当たった数フレーム後に、RBDを煙に変換する方法を説明しています。

SourceVorticlesAndCollision Example for Smoke Object dynamics node

このサンプルでは、Smoke Source、キーフレームを打ったRBDオブジェクト、Gas Vorticle Geometryなどを使って、単純なSmokeシステムを説明しています。

rbdsmokesource Example for Smoke Object dynamics node

ぼんやりとした四面体がボックス内を跳ね回って、その煙の連続的な放出で臨場感を出しています。

FractureExamples Example for Voronoi Fracture Solver dynamics node

このサンプルでは、実際にHoudiniでボロノイ破壊を使う7つの方法を含んでいます。 特に、破壊シミュレーションでVoronoi Fracture SolverとVoronoi Fracture Configure Objectのノードの使い方を説明しています。 アニメーションを再生するなら、それらのサンプルのディスプレイフラグをオンにし、セットアップをテストするなら、各サンプルの中に入ってください。

CurveAdvection Example for Wire Solver dynamics node

このサンプルでは、Pyroシミュレーションに基づいて、カーブを移流させる方法を説明しています。 Attribute Wrangle SOPを使って、ボリュームのVelocityをサンプリングして、それをワイヤーオブジェクトに適用しています。

PortalBox Example for Environment Light object node

このサンプルでは、窓の形状を使って、ポータルライトを作成する方法を説明しています。 ボックスをモデリングして、窓と壁の2つのSOPに分割しています。 環境光のPortal Geometryパラメータに窓を指定して、壁をレンダリングします。 Portal Geometryパラメータをオン・オフして、Render Viewでのレンダリング品質の違いを確認してみてください。

extracttransform Example for Extract Transform object node

このサンプルでは、ジオメトリを、事前にベイクした.bgeoシーケンスで定義された移動するジオメトリの子にする方法を説明しています。

TransparentShadows Example for Light object node

このサンプルでは、ディープシャドウマップを使って透明シャドウを設定する方法を説明しています。 シーンには、影を落とす透明なグリッドを配置しています。 レンダラーには、マイクロポリゴンレンダリングを使用しています。

IndirectLightBox Example for Indirect Light object node

このサンプルでは、間接Diffuse照明用の間接光オブジェクトをセットアップする方法を説明しています。 シーンは、何回も押し出して作成したボックスと、光源とカメラで構成されています。 カメラの範囲に入るすべてのライトが、カメラに到達する前にシーン内で2度以上跳ね返るようにライトを配置しています。 間接光オブジェクトは、100万個のフォトンを生成するように設定されています。 フォトンマップを可視化するには、ライトのレンダリングモードを"Direct Global Photon Map"に変更します。 サンプリング品質を調整するには、Mantra ROPのPixel SamplesまたはRay Samplesを修正します。 このサンプルで使用するレンダリングエンジンは、PBRです。

AmbientOcclusion Example for Mantra render node

アンビエントオクルージョンは、レイトレーシングによって開いた空間内に柔らかいDiffuseライティングを高速に生成するための技術です。 これは、あるポイントを中心にどれだけの大きさの半球がシーン内の他のサーフェスで塞がるのか調べて、塞がる箇所が多い場所ほど、より暗いライティングを生成する方法で計算されます。 この技術は、完全なグローバルイルミネーションほどの負荷をかけずに、そのGI(グローバルイルミネーション)のような効果が必要な時に役に立ちます。

これに特化したサンプルとして、アンビエントオクルージョンのライトといくつかのジオメトリをデジタルアセットの形式で用意しています。 このサンプルでは、Environment Lightを使用し、そのパラメータにアクセスしやすいように、そのパラメータをプロモートしています。

サンプル数を減らすことで、レンダリングでノイズが発生する代わりにレンダリング時間を短くすることができます。 以下のレンダリングでは、上図と同じシェーダを使用していますが、サンプル数をデフォルトの256から16に減らしています。 この値は、LightのRender Optionsタブの Sampling Quality で設定しています。

環境マップ

滑らかな環境マップを持っていれば、グローバル背景カラー(ホワイト)を環境マップの値に置き換えることができます。 また、Sky Environment MapタブのSky Environment Mapも有効にすることができます。

AtmosphereShader

このサンプルでは、ボリュームシャドウありのAtmosphereシェーダを作成する方法を説明しています。 FogオブジェクトにはVEX Lit Fogシェーダを追加し、SpotlightのDepth Map Shadowsを有効にしています。 シーン内のオブジェクトには、matteシェーダを接続しています。

Basic RIS Shading Example Example for RIS Shader Network shader node

このファイルでは、私達はシンプルなジオメトリを作成し、そこにBxDFシェーダを割り当てています。 シェーディングネットワークは、BxDFシェーダに接続されたパターンシェーダで構成されています。

AddItUp Example for Add geometry node

このネットワークでは、Add SOPによるジオメトリの構築と操作に関するたくさんの使用方法を説明しています:

  • 空間内にポイントを作成する時に使用します。そして、指定したパターンでポイントからポリゴンを作成することができます。そのポリゴンはオープンまたはクローズにすることができます。さらに、各ポイントはエクスプレッションやキーフレームを使ってアニメーションすることもできます。

  • ポイントの作成と同時に他のプリミティブからポイントを取り出す時に使用します。これらのポイントはポリゴンを作成する時に使用します。

  • Add SOPは他のポリゴンオブジェクトから抽出したポイントを使ってポリゴンを作成する時に利用します。Group SOPでは、Add SOPが参照するポイントグループを作成することができます。

  • Add SOPはアニメーションするNullオブジェクトのグループからポリゴンを作成する時に使用します。Object Merge SOPはポリゴンの生成時にAdd SOPに取り込まれているSOPの中にあるNullポイントを参照します。 Fit SOPは参照したNullポイントから順番に補間スプラインを作成する時に使用します。

  • Add SOPプリミティブを作成しないでポイントを生成する時に使用します。また、Add SOPを使って他のオブジェクトのポイントを抽出することができます。

  • 最後に、Add SOPではさらに縦の列と横の列のポイントを作成することもできます。

LayerVariations Example for Agent Layer geometry node

このサンプルは、いろいろなジオメトリのバリエーションを持ついくつかのレイヤーを作成して、 それらのレイヤーをエージェントにランダムに割り当てる方法を説明しています。

AgentRelationshipBasic Example for Agent Relationship geometry node

このサンプルでは、単純な親子エージェントのセットアップ方法について説明しています。

DeformVolume Example for Attribute from Volume geometry node

このサンプルでは、ボリュームを変形する方法を説明しています。 最初に、ボリュームの解像度に合った分割数でBox SOPを作成し、そこからポイントの3Dグリッドを作成します。 次に、ボリュームの密度アトリビュート名の"dens"をそれらのポイントに転送します。 最後に、好きなようにポイントを変形して、空っぽのボリュームを作成すれば、そのボリュームをポイントの密度で満たすことができます。

BoxSpring Example for Box geometry node

Box SOPは、ボックスの作成以外のことにも使用します。これは、特定の目的で既存のジオメトリを囲むこともできます。 Box SOPは、単純な六面体のポリゴンボックスを作成したり、ジオメトリの境界ボックスを計算したり、Lattice SOPと組み合わせて使用します。 box.hipファイルには、以下の事を説明するために、2つのオブジェクトがあります:

  • animated_bounding_box

    animated_bounding_boxオブジェクトでは、アニメーションするオブジェクトを単純なボックスで囲む方法を説明しています。 これは、複雑なジオメトリを表示するときに、ボックスを表示フラグに設定し、複雑なジオメトリをレンダーフラグに設定したい場合に役に立ちます。

  • box_spring_lattice

    これは、Box SOPとLattice SOPを組み合わせて使用したサンプルです。 Box SOPは、あるジオメトリ、この場合は球を囲む時に使用します。Box SOPのDivisionsにチェックを付けて、その値にLattice SOPの分割数を参照するように設定することで適切なジオメトリを作成します。

ボックス上面のポイントは、Group POPでグループ化しています。Spring POPは、そのグループのポイントをFixed Pointsに設定して、ボックスを変形しています。

この方法でBox SOPを使用すれば、入力のジオメトリ(この場合は、basic_sphere)が変わると、自動的にボックスとラティスもサイズが変わります。

ClipVariations Example for Clip geometry node

このサンプルでは、ジオメトリに対してClip SOPの色々な使用方法を説明しています。

クリップ平面で制限したジオメトリの部分に依存して、効果が生成されています。

Clip SOPはクリップ平面でグループ境界を指定することで、グループツールとしても使用することができます。

クリップ平面はアニメーション可能です。アニメーションを再生して、その結果を確認してください。

StampRandom Example for Copy Stamp geometry node

このサンプルでは、Copy SOPを使って、色々なオブジェクトを指定したテンプレートジオメトリにランダムにコピーしています。それをするためにCopy SOPのStamp機能を使っています。さらに、全体のプロセスがプロシージャルなので、コピーするジオメトリのタイプと数、使用するテンプレートの種類を決めるオプションがあります。

Copy SOPのStampタブ内に"switch"という名前の変数を作成しています。この変数はSwitch SOPのSelect Inputパラメータの入力値を駆動します。同様に、Copy SOPは入力ジオメトリをランダムな数だけテンプレートのポイントにコピーすることができます。

CreaseBasic Example for Crease geometry node

このサンプルでは、Crease SOP, Vertex SOP, Attribute Create SOP, Subdivide SOPの4つの方法を使って、creaseweightアトリビュートをポリゴンジオメトリに追加しています。

また、MantraとRenderManでレンダリングした際にも違いが出てきます。Mantraは著作権の問題でcreaseをレンダリングできないことを知っておいてください。

Note

Mantraでcreaseをレンダリングするには、そのジオメトリを計算できるようにSubdivision SOPを追加する必要があります。オブジェクトレベルでRenderタブのGeometryパラメータをGeometry As Isに設定してください。

RenderManを使用していれば、Subdivide SOPは単なる結果のプレビュー用にすぎません。RenderManはレンダリング中にcreaseを計算します。オブジェクトレベルでRenderタブのGeometryパラメータをPolygons as Subdivision Surfacesに設定してください。

DissolveBox Example for Dissolve geometry node

このサンプルでは、Dissolve SOPでジオメトリのポイント、エッジ、プリミティブを削除する方法を説明しています。 Dissolve SOPは色々なエレメントを削除した後に残る穴に自動的にパッチを当てます。

DuplicateBox

このサンプルでは、Duplicate SOPを使ってboxジオメトリをスケールとオフセットを累積させながらコピーを複数回繰り返しています。現行コピー番号を意味するグローバルパラメータの$CYを使ったエクスプレッションを使ってパラメータを制御しています。

PackedPoints Example for File geometry node

このサンプルでは、File SOPを使って、ディスクのパックプリミティブの遅延ロードを実行して、 モーションブラーのレンダリングでフレーム毎に複数ジオメトリのサンプリングを行なう方法を説明しています。 パックジオメトリをディスクに保存すると、参照付きでポイントジオメトリのみがディスクファイルに保存されます(ディスクファイルは非常に軽いです)。

PackedSamples Example for File geometry node

このサンプルでは、File SOPを使って、パックプリミティブの遅延ロードを実行して、 モーションブラーのレンダリングでフレーム毎に複数ジオメトリのサンプリングを行なう方法を説明しています。

PathAnalysis Example for Find Shortest Path geometry node

これは、FindShortestPathとAttribWrangleによる測定に基づいた"中心軸"パスを優先にする高度なサンプルです。これは、壁への近接を回避するのに役に立ちます。

空間内でもっと簡単に確認するには、Display OptionsダイアログのOptimizationタブにあるCulling > Remove Backfacesをオンにします。 Switchノードを使って別の中心軸測定を可視化してみてください。パスの中心軸を考慮しない同じサンプルを、違いがわかるようにSOPネットワーク内の端に置いています。

cutup

このサンプルでは、ForEach SOPを使って、あるオブジェクトが他のオブジェクトの各パートと交差して、結果を一緒にマージする方法を説明しています。

GroupCopyBox Example for Group Copy geometry node

このサンプルでは、他のネットワークのグループに基づいて、ジオメトリをグループ化する方法を説明しています。

TransferProximity Example for Group Transfer geometry node

このサンプルでは、Group Transfer SOPによって、グループのプリミティブの近接度から、グループを新しいジオメトリセットに転送する方法を説明しています。

BallBounce Example for Lattice geometry node

このサンプルでは、Lattice SOPを使って跳ね返るボールの作成方法を説明しています。

DeformLattice Example for Lattice geometry node

Lattice SOPは、ソースジオメトリを囲んだ単純なジオメトリを操作することでアニメーションする変形を作成することができます。

このサンプルでは、Lattic SOPでアニメーションするBOX SOPを使用してソースジオメトリを変形する方法を説明しています。 このケースでは、ソースジオメトリは球を使用しています。

LsystemBuilding Example for L-System geometry node

このサンプルは、L-System SOPを使って窓のあるビルを生成する方法を説明しています。

SimpleMDD

このサンプルでは、MDD SOPとMDD File Writer ROPの使い方を説明しています。

BoxNormals Example for Normal geometry node

このサンプルでは、Normal SOPを使用して、5つのタイプのボックスと押し出されたテキストに対して、ポイント法線と頂点法線の見た目の違いを説明しています。

ParticleCollisionBasic

これは、Particle SOPを使ってSOPレベルでパーティクルを発生し、ジオメトリと衝突さる基本的なサンプルです。

ParticleExamples

このサンプルでは、Particle SOPの色々な使い方を5つの説明しています。

  • Creep Creep SOPを使ってサーフェス沿いにパーティクルを這わせます。

  • Group サーフェス上のポイントのグループからパーティクルを発生します。

  • Bounce パーティクルを跳ね返らせます。

  • Split 接触時にパーティクルを分割します。

  • Collide 衝突オブジェクトからパーティクルを発生します。

  • Moving Object 移動オブジェクトからパーティクルを発生します。

  • Force メタボールを使ってパーティクルに力を加えます。

TwistyCube Example for Point Cloud Iso geometry node

このサンプルでは、Point Cloud Iso Surface SOPを使って点群からポリゴンを構築する方法を説明しています。

PolybevelBox Example for PolyBevel geometry node

このサンプルでは、Poly Bevel SOPを使ってジオメトリを面取りする方法を説明しています。

PolyStitchBasicSmooth Example for PolyStitch geometry node

このサンプルでは、Poly Stitch SOPでUVが一致しないポリゴン間の継ぎ目を縫い合わせたり、改良する方法を説明しています。 このノードは継ぎ目を滑らかにしたり、裂け目を除去するのに役に立ちます。

RBDConstraints Example for RBD Constraints From Lines geometry node

このサンプルでは、RBD Constraints from Lines、RBD Constraints from Curves、RBD Constraints from RulesのSOPの使い方を説明しています。

DoorWithPolkaDots Example for Scatter geometry node

このサンプルでは、入力ジオメトリを再修正したり壊すことでトポロジーが変わってしまっても、整合性を保つようにポイントをばら撒くScatter SOPの使い方を説明しています。 これは、テクスチャ空間にポイントをばら撒くオプションで実現しています。

SubdivideCrease Example for Subdivide geometry node

このサンプルでは、ボックスの底面を細分化すると同時に上面の折り目を保持する方法を2つ説明しています。

SurfsectBasic Example for Surfsect geometry node

このサンプルでは、Sursect SOPのブーリアン演算の使い方を説明しています。

球からボックスを減算して、6つの円盤を残し、ボックスから球を減算して、角だけを残しています。

ProjectionTypes Example for UV Project geometry node

このサンプルでは、UV Project SOPでサポートされている色々な投影タイプを説明しています。

VoronoiSplitWeights Example for Voronoi Split geometry node

このサンプルでは、Voronoi Split SOPのWeight Attributeオプションを使って、パワーダイアグラム(ラゲールボロノイ図)を作成する方法について説明しています。

example_top_geometryimport Example for Geometry Import TOP node

このサンプルでは、Geometry Importノードを使ってDetail、Primitive、Point、Vertex毎にワークアイテムを作成して、それらをSOPネットワークで作用させる方法について説明しています。

example_top_invoke Example for Invoke TOP node

このサンプルでは、PDGデータを入力としてコンパイルブロックを実行する方法について説明しています。

example_top_partitionbytile Example for Partition by Tile TOP node

このサンプルでは、PDG/TOPのPartition by Tileノードの使い方について説明しています。

See also

ジオメトリノード

  • Adaptive Prune

    全体的な外観の維持を試みつつエレメントを削除します。

  • Add

    点、ポリゴンを作成、または点/ポリゴンを入力に追加します。

  • Agent

    エージェントプリミティブを作成します。

  • Agent Clip

    エージェントプリミティブに新しいクリップを追加します。

  • Agent Clip

    エージェントプリミティブに新しいクリップを追加します。

  • Agent Clip Properties

    エージェントのアニメーションクリップの再生方法を定義します。

  • Agent Clip Transition Graph

    アニメーションクリップ間で可能なトランジション(遷移)を表現したジオメトリを作成します。

  • Agent Collision Layer

    衝突検出に適した新しいエージェントレイヤを作成します。

  • Agent Configure Joints

    エージェントのジョイントの回転制限を指定するPointアトリビュートを作成します。

  • Agent Constraint Network

    コンストレイントネットワークを構築して、エージェントの手足をまとめます。

  • Agent Definition Cache

    エージェント定義ファイルをディスクに書き出します。

  • Agent Edit

    エージェントプリミティブのプロパティを編集します。

  • Agent Layer

    エージェントプリミティブに新しいレイヤを追加します。

  • Agent Look At

    エージェントの頭が、指定したオブジェクトや位置に向くように調整します。

  • Agent Look At

    エージェントの頭が、指定したオブジェクトや位置に向くように調整します。

  • Agent Prep

    他の群衆ノードで使用する色々な共通Pointアトリビュートをエージェントに追加します。

  • Agent Prep

    他の群衆ノードで使用する色々な共通Pointアトリビュートをエージェントに追加します。

  • Agent Proxy

    エージェントに対してシンプルなプロキシジオメトリを用意します。

  • Agent Relationship

    エージェント間に親子関係を作成します。

  • Agent Terrain Adaptation

    エージェントの足を地形に順応させて、滑りを回避します。

  • Agent Transform Group

    新しいトランスフォームグループをエージェントプリミティブに追加します。

  • Agent Unpack

    エージェントプリミティブからジオメトリを抽出します。

  • Agent Vellum Unpack

    Vellumシミュレーション用にエージェントプリミティブからジオメトリを抽出します。

  • Alembic

    Alembicシーンファイル(.abc)からジオメトリをジオメトリネットワークに読み込みます。

  • Alembic Group

    Alembicプリミティブ用のジオメトリグループを作成します。

  • Alembic Primitive

    Alembicプリミティブの組み込みプロパティを修正します。

  • Alembic ROP Output Driver

    シーンをAlembicアーカイブとしてエクスポートします。

  • Align

    プリミティブのグループをお互いに整列または補助入力に揃えます。

  • Assemble

    一連の分解処理をキレイにしてその結果の破片を作成します。

  • Attribute Blur

    メッシュまたはポイントクラウドのポイントをブラー(または"リラックス")します。

  • Attribute Cast

    Houdiniが以前に保存したアトリビュートのサイズ/精度を変更します。

  • Attribute Composite

    2つ以上の選択要素間で頂点/ポイント/プリミティブ/Detailアトリビュートを合成します。

  • Attribute Copy

    頂点/ポイント/プリミティブのグループのアトリビュートをコピーします。

  • Attribute Create

    ユーザー定義アトリビュートを追加・編集します。

  • Attribute Delete

    Point/Primitiveアトリビュートを削除します。

  • Attribute Expression

    単純なVEXエクスプレッションでアトリビュートを修正することができます。

  • Attribute Fade

    Pointアトリビュートが時間に合わせてフェードイン・アウトします。

  • Attribute Interpolate

    ウェイトなどに基づいてアトリビュートを補間します。

  • Attribute Mirror

    平面の片側から反対側にアトリビュートをコピー・反転します。

  • Attribute Noise

    入力ジオメトリのアトリビュートにノイズを追加します。

  • Attribute Promote

    アトリビュートをあるジオメトリレベルから他のジオメトリレベルへ昇進または降格します。

  • Attribute Randomize

    多様に分布したランダムなアトリビュート値を生成します。

  • Attribute Rename

    ポイント/プリミティブのアトリビュートの名前変更・削除をします。

  • Attribute Reorient

    2つのモデル間の違いに基づいてPointアトリビュートを修正します。

  • Attribute String Edit

    文字列アトリビュートの値を編集します。

  • Attribute Swap

    アトリビュートの内容をコピー、移動、スワップします。

  • Attribute Transfer

    2つのモデル間で頂点/ポイント/プリミティブ/Detailのアトリビュートを転送します。

  • Attribute Transfer By UV

    UVの近接度に基づいて、2つのジオメトリ間でアトリビュートを転送します。

  • Attribute VOP

    VOPネットワークを実行してジオメトリアトリビュートを修正します。

  • Attribute Wrangle

    VEX Snippetを実行して、アトリビュートの値を修正します。

  • Attribute from Map

    テクスチャマップ情報をPointアトリビュートにサンプリングします。

  • Attribute from Volume

    ボリュームからの情報を追加で再マップして他のジオメトリの一部にコピーします。

  • Bake ODE

    ODE/Bulletソルバ用にプリミティブを変換します。

  • Bake Volume

    ボリュームプリミティブ内のライティングの値を計算します。

  • Basis

    NURBS曲線/サーフェスのパラメトリック空間の範囲内でノットを移動させる操作をします。

  • Bend

    ベンド、テーパ、スクァッシュ/ストレッチ、ツイストといった変形を適用します。

  • Blast

    プリミティブ/ポイント/エッジ/ブレークポイントを削除します。

  • Blend Shapes

    同じトポロジーの形状間で3Dモーフィングを計算します。

  • Blend Shapes

    同じトポロジーの形状間で3Dモーフィングを計算します。

  • Block Begin

    ループブロックの開始。

  • Block Begin Compile

    コンパイルブロックの開始。

  • Block End

    ループブロックの終了/出力。

  • Block End Compile

    コンパイルブロックの終了/出力。

  • Bone Capture

    キャプチャーウェイトをボーンに割り当てることで Bone Deformに対応します。

  • Bone Capture Biharmonic

    四面体メッシュのBiharmonic(重調和)関数に基づいてキャプチャーウェイトをポイントに割り当てることによる変形をサポートします。

  • Bone Capture Lines

    適切なアトリビュートを使ってボーンからラインを作成することで、Bone Capture Biharmonicをサポートします。

  • Bone Capture Proximity

    キャプチャーウェイトをボーンまでの距離に基づいたポイントに割り当てることで、Bone Deformに対応します。

  • Bone Deform

    ボーンから作成されたキャプチャーアトリビュートを使用して、そのボーンの動きに合わせてジオメトリを変形します。

  • Bone Link

    ボーンオブジェクト用にデフォルトのジオメトリを作成します。

  • Boolean

    2つのポリゴンオブジェクトをブール演算で組み合わせたり、2つのポリゴンオブジェクト間の交線を検索します。

  • Boolean Fracture

    切断サーフェスを使って入力ジオメトリを粉砕します。

  • Bound

    入力ジオメトリ用に境界ボックス、球、矩形を作成します。

  • Box

    立方体または6面の矩形ボックスを作成します。

  • Bulge

    1番目の入力のポイントを2番目の入力の1つ以上のマグネットを使って変形します。

  • Cache

    プレイバックを高速化するために入力ジオメトリを記録してキャッシュ化します。

  • Cap

    開口部を平面または丸めて閉じます。

  • Capture Attribute Pack

    配列アトリビュートを単一のIndex Pairのキャプチャアトリビュートに変換します。

  • Capture Attribute Unpack

    単一のIndex Pairのキャプチャアトリビュートを、ポイント単位のDetail配列アトリビュートに変換します。

  • Capture Correct

    キャプチャー領域とキャプチャーウェイトを調整します。

  • Capture Layer Paint

    キャプチャーアトリビュートを直接ジオメトリにペイントすることができます。

  • Capture Mirror

    対称モデルの片半分のキャプチャーアトリビュートをもう片方にコピーします。

  • Capture Override

    個々のポイント上にキャプチャーウェイトを上書きします。

  • Capture Region

    ポイントがボーンにキャプチャーされる範囲内でボリュームを作成することでCaptureとDeformに対応します。

  • Carve

    プリミティブからポイントや断面をスライス、カット、抽出します。

  • Channel

    CHOPからサンプルデータを読み込み、それをポイントポジションとPointアトリビュートに変換します。

  • Circle

    開閉の円弧、円、楕円を作成します。

  • Clay

    NURBSフェース/NURBSサーフェス上のポイントを直接引っ張ることでそれらを変形します。

  • Clean

    汚れたモデルをクリーンアップします。

  • Clip

    平面の片側のジオメトリを削除します。

  • Cloth Capture

    低解像度でシミュレーションしたClothオブジェクトをキャプチャーします。

  • Cloth Deform

    Cloth Capture SOPでキャプチャーしたジオメトリを変形します。

  • Cloud

    ソースジオメトリのボリューム表現を作成します。

  • Cloud Light

    Diffuseライトでボリュームを充たします。

  • Cloud Noise

    雲のようなノイズをFogボリュームに適用します。

  • Cluster

    ポジション(またはベクトルアトリビュート)に基づいたクラスタポイントへの低レベル機械言語。

  • Cluster Points

    ポジション(またはベクトルアトリビュート)に基づいたクラスタポイントへの高レベルノード。

  • Collision Source

    DOP衝突で使用するジオメトリとVDBのボリュームを作成します。

  • Color

    カラーアトリビュートをジオメトリに追加します。

  • Comb

    ペイントでサーフェスポイントの法線を調整します。

  • Connect Adjacent Pieces

    隣接する破片間にラインを作成します。

  • Connectivity

    繋がったプリミティブまたはポイントの各セットに対して固有の値でアトリビュートを作成します。

  • Control

    コントロールシェイプとして利用する単純なジオメトリを作成します。

  • Convert

    ジオメトリをあるジオメトリタイプから他のタイプに変換します。

  • Convert HeightField

    2D Heightフィールドを3D VDBボリューム、ポリゴンサーフェス、ポリゴンスープサーフェスに変換します。

  • Convert Line

    ジオメトリを線分に変換します。

  • Convert Meta

    メタボールジオメトリをポリゴン化します。

  • Convert Tets

    指向性の四面体メッシュサーフェスを生成します。

  • Convert VDB

    Sparse(疎らな)ボリュームを変換します。

  • Convert VDB Points

    Point CloudとVDB Points Primitiveを相互変換します。

  • Convert Volume

    ボリュームのアイソサーフェスをポリゴンサーフェスに変換します。

  • Convex Decomposition

    入力ジオメトリを、近似した凸セグメントに分割します。

  • Copy Stamp

    入力ジオメトリのコピーを複数作成します。またはジオメトリを2番目の入力のポイントにコピーします。

  • Copy and Transform

    ジオメトリをコピーして、それらのコピーにトランスフォームを適用します。

  • Copy to Points

    1番目の入力のジオメトリを2番目の入力のポイント上にコピーします。

  • Crease

    手動でポリゴンエッジからcreaseweightアトリビュートを追加/削除します。Subdivide SOPと組み合わせて使用します。

  • Creep

    サーフェス上の一部のジオメトリを変形/アニメーションします。

  • Crowd Source

    エージェントプリミティブの群衆を集めます。

  • Crowd Source

    Crowd Solverと一緒に使用される群衆エージェントを作成します。

  • Curve

    ポリゴン/NURBS/Bezier曲線を作成します。

  • Curveclay

    サーフェス上の曲線を編集することでスプラインサーフェスを変形します。

  • Curvesect

    2つ以上の曲線/フェース間の交線(または最小距離間の点)を検索します。

  • DOP I/O

    DOPシミュレーションからフィールドを取り込み、それをディスクに保存、そして再度読み込み直します。

  • DOP Import Fields

    DOPシミュレーションからスカラーとベクトルフィールドを取り込みます。

  • DOP Import Records

    DOPシミュレーションからオプションとレコードデータをPointアトリビュート付きでポイントに取り込みます。

  • DOP Network

  • Debris Source

    分離して破壊されたリジッドボディオブジェクトのDebris(瓦礫)に対してポイントエミッションソースを生成します。

  • Deformation Wrangle

    ジオメトリを変形させるVEXスニペットを実行します。

  • Delete

    要素番号、境界ボリューム、プリミティブ/ポイント/エッジの法線、Degeneracy(縮退)を基準に入力ジオメトリを削除します。

  • DeltaMush

    ポイント変形を平滑化(または"リラックス化")します。

  • Detangle

    ジオメトリを変形させた時に干渉の回避を試みます。

  • Dissolve

    入力ポリゴンジオメトリからエッジを削除して、共有エッジを持ったポリゴンを結合します。

  • Dissolve

    入力ジオメトリからポイント/プリミティブ/エッジを削除し、それによってできた穴を修復します。

  • Divide

    ポリゴンを分割、スムーズ、三角化します。

  • Dop Import

    DOPシミュレーションから抽出した情報に基づいたジオメトリを取り込み、トランスフォームします。

  • Draw Curve

    ビューポートでユーザー入力からカーブを作成します。

  • Draw Guides

  • Each

    For Each SOPの仕様に応じて入力ジオメトリを抜粋します。

  • Edge Collapse

    エッジとフェースを中点に折り畳みます。

  • Edge Cusp

    エッジの点を固有化し、ポイント法線を再計算することで、エッジをシャープにします。

  • Edge Divide

    ポリゴンのエッジ上にポイントを挿入し、任意で接続します。

  • Edge Flip

    ポリゴンのエッジの方向を反転します。

  • Edge Fracture

    ガイドカーブを使ってエッジ沿いにジオメトリをカットします。

  • Edge Transport

    エッジネットワークやカーブに沿ってアトリビュート値をコピーしたりオプションで修正します。

  • Edit

    ポイント/エッジ/フェースをインタラクティブに編集します。

  • Ends

    端点を開閉したり、塞ぎます。

  • Enumerate

    選択したポイント/プリミティブのアトリビュートの値を連番に設定します。

  • Error

    親アセット上で表示させることができるメッセージ、警告、エラーを生成します。

  • Exploded View

    中心から外側に向かってジオメトリを押し出して、展開ビューを作成します。

  • Exploded View

    中心からジオメトリを押し出して展開ビューを作成します。

  • Extract Centroid

    ジオメトリの各ピースの重心を計算します。

  • Extract Transform

    2つのジオメトリ間で最適なトランスフォームを計算します。

  • Extrude

    ジオメトリを法線に沿って押し出します。

  • Extrude Volume

    サーフェスジオメトリを押し出してボリュームを作成します。

  • FEM Visualization

  • FLIP Source

    FLIPシミュレーションのソースとなるサーフェスまたはdensity VDBを作成します。

  • Facet

    サーフェスのファセットの滑らかさを制御します。

  • Falloff

    滑らかな距離アトリビュートをジオメトリに追加します。

  • Filament Advect

    ポリゴンカーブを渦巻くフィラメントにします。

  • File

    ファイルの読み込み、書き込み、ジオメトリのディスクへキャッシュ化します。

  • File Cache

    ジオメトリシーケンスをディスクに書き出したり、ディスクから読み込みます。

  • File Merge

    ディスクからデータを読み込み、まとめます。

  • Fillet

    2本の曲線/サーフェス間を繋いだ滑らかなジオメトリを作成します。

  • Filmbox FBX ROP出力ドライバ

  • Find Shortest Path

    開始点から終了点までのサーフェスのエッジに沿った最短パスを検索します。

  • Fit

    スプライン曲線をポイントに、スプラインサーフェスをポイントのメッシュにフィットします。

  • Fluid Compress

    流体シミュレーションの出力を圧縮してディスクサイズを軽減します。

  • Font

    Type1、TrueType、OpenTypeのフォントから3Dテキストを作成します。

  • Force

    メタボールを使ってポイントやスプリングを引き寄せたり引き離します。

  • Fractal

    入力ジオメトリからボコボコの山のような分割を行ないます。

  • Fur

    サーフェス上に髪のような曲線を作成します。

  • Fuse

    ポイントを結合します。

  • Fuse

    ポイントを結合/分離(個別化)します。

  • Glue Cluster

    クラスタの値に応じてGlue Constraint Networkに強度を加えます。

  • Grain Source

    パーティクルベースのGrain(粒)シミュレーションのソースとして使用するパーティクルを生成します。

  • Graph Color

    隣接コンポーネントと被らないように各コンポーネントに固有の整数アトリビュートを割り当てます。

  • Grid

    平面を作成します。

  • Groom Blend

    2つのグルームのガイドとスキンをブレンドします。

  • Groom Fetch

    グルーミングオブジェクトからグルームデータを取得します。

  • Groom Pack

    グルームのコンポーネントをディスクに書き出すために、それらを名前付きパックプリミティブのセットにパックします。

  • Groom Switch

    2本のグルームストリームのすべてのコンポーネント間を切り替えます。

  • Groom Unpack

    パックしたグルームからグルームのコンポーネントをアンパックします。

  • Group

    色々な条件に応じてポイント/プリミティブ/エッジ/頂点のグループを作成します。

  • Group Combine

    ブーリアン演算に応じて、ポイント/プリミティブ/エッジのグループを組み合わせます。

  • Group Copy

    ポイント/プリミティブ番号に基づいて2つのジオメトリの断片間にグループをコピーします。

  • Group Delete

    パターンに応じて、ポイント/プリミティブ/エッジ/頂点のグループを削除します。

  • Group Expression

    VEXエクスプレッションを実行して、グループメンバーシップを修正します。

  • Group Paint

    ペイントでインタラクティブにグループを設定します。

  • Group Promote

    ポイント/プリミティブ/エッジ/頂点のグループをポイント/プリミティブ/エッジ/頂点のグループに変換します。

  • Group Range

    範囲指定でポイント/プリミティブをグループ化します。

  • Group Rename

    パターンに応じてグループの名前を変更します。

  • Group Transfer

    近接する2つのジオメトリの断片間にグループを転送します。

  • Guide Advect

    Velocityボリュームによってガイドポイントを移流させます。

  • Guide Collide With VDB

    ガイドカーブの衝突をVDB符号付き距離フィールドを使って計算します。

  • Guide Deform

    アニメーションスキンとオプションのガイドカーブを使ってジオメトリを変形させます。

  • Guide Groom

    ビューポート内でガイドカーブの直感的操作を可能にします。

  • Guide Group

    グルーミングツールで使用する標準のプリミティブグループを作成します。

  • Guide Initialize

    ヘアーガイドの初期方向を簡単に設定します。

  • Guide Mask

    他のグルーミング操作をするためのマスクアトリビュートを作成します。

  • Guide Partition

    Hair Generateで使用できる分け目を作成します。

  • Guide Skin Attribute Lookup

    ガイドカーブの根元ポイント下のスキンジオメトリアトリビュートを照会します。

  • Guide Tangent Space

    カーブ沿いに一貫した接線空間を構築します。

  • Guide Transfer

    ジオメトリ間でヘアーガイドを転送します。

  • Hair Card Generate

    密集したヘアーカーブを、そのグルームのスタイルと形状を維持しつつポリゴンカードに変換します。

  • Hair Clump

    ガイドカーブをClump(凝集)します。

  • Hair Generate

    サーフェス上またはポイントからヘアーを生成します。

  • Hair Growth Field

    ストロークプリミティブに基づいてVelocityフィールドを生成します。

  • HeightField

    Terrainツールと併用するための初期Height Fieldボリュームを生成します。

  • HeightField Blur

    TerrainのHeight Fieldまたはマスクをブラーします。

  • HeightField Clip

    Height値を特定の最小/最大値に制限します。

  • HeightField Copy Layer

    Height Fieldまたはマスクのコピーを作成します。

  • HeightField Crop

    大きなHeightボリュームから特定の幅/長さの正方形を抽出したり、Heightフィールドの境界のサイズ変更/移動をします。

  • HeightField Cutout by Object

    ジオメトリに基づいて地形上にカットアウト(切り抜き)を作成します。

  • HeightField Distort by Layer

    他のフィールドによってHeight Fieldを変位させます。

  • HeightField Distort by Noise

    ノイズパターンで入力ボリュームを移流させることで、ハードエッジを崩してバリエーションを加えます。

  • HeightField Draw Mask

    シェイプを描画して、Height Fieldツールのマスクを作成することができます。

  • HeightField Erode

    より現実的な地形を作成するために、時間軸(フレーム)にわたって融解侵食と流体侵食を計算します。

  • HeightField Erode

    より現実的な地形を作成するために、時間軸(フレーム)にわたって融解侵食と流体侵食を計算します。

  • HeightField Erode Hydro

    あるHeight Fieldから別のHeight Field上を滑る侵食を短時間でシミュレーションします。

  • HeightField Erode Precipitation

    Height Fieldに沿って水を分流させます。強度、変動性、降雨の位置を調整するためのコントロールが備わっています。

  • HeightField Erode Thermal

    短時間で地形の熱侵食の効果を計算します。

  • HeightField File

    ファイルまたはコンポジットノードから2D画像をHeight FieldまたはMaskにインポートします。

  • HeightField Flow Field

    入力のHeightレイヤーに応じて、流れレイヤーと流れ方向のレイヤーを生成します。

  • HeightField Isolate Layer

    マスクレイヤー上に他のレイヤーをコピーし、オプションでHeight Fieldを平坦化します。

  • HeightField Layer

    2つのHeight Fieldを合成します。

  • HeightField Layer Clear

    Height Fieldレイヤーのすべての値を固定値に設定します。

  • HeightField Layer Property

    Height Fieldボリュームに境界ボクセルポリシーを設定します。

  • HeightField Mask by Feature

    Heightレイヤーの異なる特徴部分に基づいてマスクを作成します。

  • HeightField Mask by Object

    他のジオメトリに基づいてマスクを作成します。

  • HeightField Mask by Occlusion

    入力地形の空洞/陥没の部分、例えば河床や谷の部分にマスクを生成します。

  • HeightField Noise

    Height Fieldに垂直ノイズを追加して、山と谷を作成します。

  • HeightField Output

    Height/マスクのレイヤーを画像としてディスクにエクスポートします。

  • HeightField Paint

    ストロークを使って、Heightまたはマスクのフィールドに値をペイントすることができます。

  • HeightField Patch

    あるHeightFieldの外観を他のHeightFieldに継ぎ当てます。

  • HeightField Pattern

    ランプ、段状、縞模様、Voronoiセル、他のパターンの形式でディスプレイスメントを追加します。

  • HeightField Project

    3DジオメトリをHeight Fieldに投影します。

  • HeightField Quick Shade

    テクスチャに接続できるマテリアルを別々のレイヤーに対して適用します。

  • HeightField Remap

    Height Fieldまたはマスクレイヤーの値を再マップします。

  • HeightField Resample

    Height Fieldの解像度を変更します。

  • HeightField Scatter

    Height Fieldの表面上にポイントをばら撒きます。

  • HeightField Scatter

    Height Fieldの表面上にポイントをばら撒きます。

  • HeightField Slump

    斜面を滑り落ちて麓に堆積する緩いマテリアルをシミュレーションします。

  • HeightField Terrace

    地形の勾配から段丘を作成します。

  • HeightField Tile Splice

    Height Fieldのタイルを接合します。

  • HeightField Tile Split

    Height Fieldのボリュームを縦横に分割します。

  • HeightField Transform

    Height Field固有のスケールとオフセット。

  • HeightField Visualize

    カスタムランプマテリアルを使って標高を可視化し、色を付けてマスクレイヤーを可視化します。

  • Hole

    サーフェスに穴を開けます。

  • Inflate

    1番目の入力のポイントが膨らむように変形します。

  • Instance

    ジオメトリをポイント上にインスタンス化します。

  • Intersection Analysis

    三角形/カーブメッシュ間、またはオプションの三角形/カーブ間の入力の交差した箇所にアトリビュート付きのポイントを作成します。

  • Intersection Stitch

    三角形サーフェスとカーブを1枚に繋がったメッシュに接合します。

  • Invoke Compiled Block

    参照したコンパイルブロックのオペレーションを使って、入力を処理します。

  • IsoOffset

    ジオメトリからオフセットサーフェスを作成します。

  • IsoSurface

    陰関数からアイソサーフェスを作成します。

  • Join

    一連のフェース/サーフェスを、アトリビュートを引き継いだ単一のプリミティブに繋げます。

  • Knife

    インタラクティブに描いた線でジオメトリを分割/削除/グループ化をします。

  • L-System

    ルールに基づいて再帰的に相似したジオメトリを作成します。

  • Lattice

    コントロールジオメトリを変形させることで、それに応じてジオメトリを変形します。

  • Lidar Import

    Lidarファイルを読み込み、そのデータからポイントクラウドをインポートします。

  • Line

    位置/方向/距離でポリゴン/NURBSラインを作成します。

  • MDD

    MDDファイルを使ってポイントをアニメーションさせます。

  • Magnet

    ジオメトリの他の断片を使ってジオメトリを引き寄せたり引き離して変形します。

  • Match Axis

    入力ジオメトリを指定した軸で整列します。

  • Match Size

    参照ジオメトリに応じてジオメトリのサイズを変更し、中央に配置します。

  • Match Topology

    入力ジオメトリのプリミティブ/ポイントの番号を参照ジオメトリと一致するように並べ替えます。

  • Material

    1つ以上のマテリアルをジオメトリに割り当てます。

  • Measure

    個々のエレメントまたは複数枚のジオメトリから面積、体積、曲率を測定し、その結果をアトリビュートに格納します。

  • Measure

    ポリゴンの体積、面積、周囲の長さを測定し、結果をアトリビュートに保存します。

  • Merge

    入力からジオメトリを結合します。

  • MetaGroups

    メタボールのグループを定義することで、それらが結合されても、別々のグループが別々のサーフェスとして処理されます。

  • Metaball

    メタボールとメタサーフェスを作成します。

  • Mirror

    ミラー平面を基準にジオメトリをコピーし対称化します。

  • Mountain

    フラクタルノイズに基づいて、ポイント法線に沿ってポイントを変位させます。

  • Mountain

    フラクタルノイズに基づいて法線方向にポイントを変位します。

  • Muscle Capture

    指定したプリミティブからの距離に基づいてキャプチャーウェイトをポイントに割り当てることによるMuscle Deformをサポートします。

  • Muscle Deform

    スキンを表現したサーフェスメッシュを変形させて、筋肉を表現したジオメトリを引き締めたり弛ませたりします。

  • Name

    ポイント/プリミティブにnameアトリビュートを作成することで、グループと同様に簡単にそれらのコンポーネントを参照することができます。

  • Normal

    サーフェス法線アトリビュートを計算します。

  • Null

    シーンで位置決めに利用するNullオブジェクトを作成します。レンダリングはされません。

  • Object Merge

    複数のソースのジオメトリを結合して、それらのソースのグループ化とトランスフォームの方法を定義することができます。

  • Object_musclerig@musclerigstrokebuilder

  • Object_riggedmuscle@musclestrokebuilder

    投影サーフェス上にストロークを描画できるようにすることで、MuscleまたはMuscle Rigの作成を補助します。

  • Ocean Evaluate

    Ocean Spectrumボリュームに基づいて入力ジオメトリを変形します。

  • Ocean Evaluate

    Ocean Spectrumボリュームに基づいて入力ジオメトリを変形します。

  • Ocean Foam

    パーティクルベースのFoam(泡沫)を生成します。

  • Ocean Source

    シミュレーションで使用するための海の"スペクトル"ボリュームからパーティクルとボリュームを生成します。

  • Ocean Source

    シミュレーションで使用するための海の"スペクトル"ボリュームからパーティクルとボリュームを生成します。

  • Ocean Spectrum

    海の波をシミュレーションするための情報を含んだボリュームを生成します。

  • Ocean Waves

    それぞれの波形を入力ポイントとそこから生成されたポイント上にインスタンス化します。

  • OpenCL

    ジオメトリに対してOpenCLカーネルを実行します。

  • Output

    サブネットワークの出力としてマークします。

  • Pack

    ジオメトリを組み込みプリミティブにパックします。

  • Pack Points

    ポイントをパックプリミティブのタイル化されたグリッドにパックします。

  • Packed Disk Edit

    パックディスクプリミティブの編集

  • Packed Edit

    パックプリミティブを編集します。

  • Paint

    ジオメトリにカラーや他のアトリビュートをペイントすることができます。

  • Paint Color Volume

    描画したカーブに基づいてカラーボリュームを作成します。

  • Paint Fog Volume

    描画したカーブに基づいてFogボリュームを作成します。

  • Paint SDF Volume

    描画したカーブに基づいてSDFボリュームを作成します。

  • Particle Fluid Surface

    パーティクル流体シミュレーションのパーティクルまわりにサーフェスを生成します。

  • Particle Fluid Tank

    タンクを満たしたひとまとまりの通常のポイントを作成します。

  • Partition

    ポイントとプリミティブをユーザーのルールに基づいてグループに格納します。

  • Peak

    プリミティブ/ポイント/エッジ/ブレークポイントを法線方向に動かします。

  • Planar Patch

    平面ポリゴンパッチを作成します。

  • Planar Patch from Curves

    2Dカーブ網を三角形で埋めます。

  • Planar Pleat

    平坦なジオメトリをひだ状に変形させます。

  • Platonic Solids

    凸状で頂点とフェースすべてがまったく同じ形式の多面体である5つのプラトン立体と、サッカーボール、ティーポットのどれかを作成します。

  • Point

    手動でPointアトリビュートを追加・編集します。

  • Point Cloud Iso

    入力ポイントからアイソサーフェスを構築します。

  • Point Deform

    ポイントクラウドに基づいてジオメトリを変形します。

  • Point Generate

    任意で入力ジオメトリのポイントポジションに基づいて新しくポイントを作成します。

  • Point Jitter

    ポイントをランダムな方向に動かします。

  • Point Relax

    お互いに指定した半径領域と重ならないようにポイントを動かします。

  • Point Replicate

    入力ポイントまわりにポイントクラウドを生成します。

  • Point Velocity

    ジオメトリのポイントに対してVelocityを計算して制御します。

  • Points from Volume

    ボリュームを満たすひとまとまりの通常のポイントを作成します。

  • Poly Bridge

    ブリッジの形状に対するコントロールを使って、SourceエッジループとDestinationエッジループの間に平坦またはチューブ状のポリゴンサーフェスを作成します。

  • Poly Expand 2D

    平面ポリゴンのグラフに対して、オフセットしたポリゴンジオメトリを作成します。

  • Poly Extrude

    ポリゴンのフェースやエッジを押し出します。

  • PolyBevel

    エッジやコーナーに沿って真っ直ぐ、丸い、または独自の面取りを作成します。

  • PolyBevel

    ポイントやエッジに面取りを作成します。

  • PolyCut

    アトリビュートが閾値を超えている箇所でカーブを分割します。

  • PolyDoctor

    例えばClothシミュレーションで無効なポリゴンジオメトリを修正します。

  • PolyExtrude

    ポリゴンのフェースとエッジを押し出します。

  • PolyFill

    ポリゴンパッチで穴を埋めます。

  • PolyFrame

    ポイントや頂点に対して座標フレームアトリビュートを作成します。

  • PolyLoft

    既存ポイントを使ってポリゴンを新しく作成します。

  • PolyPatch

    プリミティブから滑らかなポリゴンパッチを作成します。

  • PolyPath

    ポリゴンカーブのトポロジーをクリーンアップします。

  • PolyReduce

    形を保持しようとしつつポリゴンの数を減らします。このノードは、ポリゴン削減時に、形状、アトリビュート、テクスチャ、四角形トポロジを維持します。

  • PolySoup

    たくさんのポリゴンをもっと効率化させるためにポリゴンを単一プリミティブに結合します。

  • PolySpline

    スプライン曲線をポリゴン/ハルにフィットさせて、スプラインをポリゴン近似にして出力します。

  • PolySplit

    既存ポリゴンを複数の新しいポリゴンに分割します。

  • PolySplit

    既存ポリゴンを新しい複数ポリゴンに分割します。

  • PolyStitch

    隙間を埋めながらポリゴンサーフェスを縫い合わせます。

  • PolyWire

    ポリラインから滑らかに曲がって交差したレンダリング可能なポリゴンチューブを作成します。

  • Pose Scope

    チャンネルパスやピックスクリプトをジオメトリに割り当てます。

  • Pose-Space Deform

    駆動側の値に基づいてポーズ形状間を補間します。

  • Pose-Space Deform Combine

    Pose-Space Deformの結果と静止ジオメトリを合成します。

  • Pose-Space Edit

    ポーズ空間変形用のパックジオメトリ編集。

  • Pose-Space Edit Configure

    Pose-Space Edit SOPで使用する共通アトリビュートを作成します。

  • Primitive

    プリミティブ/Primitiveアトリビュート/プロファイル曲線を編集します。

  • Primitive Split

    Primitiveアトリビュートを受け取り、そのアトリビュートに指定されたトレランスよりも大きいプリミティブのポイントを分割します。

  • Profile

    プロファイル曲線を抽出、操作します。

  • Project

    サーフェス上にプロファイル曲線を作成します。

  • Pyro Source

    PyroやSmokeのシミュレーションのソースとなるポイントを作成します。

  • Python

    Python Snippetを実行して、入力のジオメトリを修正します。

  • RBD Cluster

    粉砕ピースまたは拘束を大きなクラスタにまとめます。

  • RBD Constraint Properties

    リジッドボディ拘束を意味したアトリビュートを作成します。

  • RBD Constraints From Curves

    ビューポート内で描画したカーブからリジッドボディ拘束ジオメトリを作成します。

  • RBD Constraints From Lines

    ビューポート内でインタラクティブに描画したラインからリジッドボディ拘束ジオメトリを作成します。

  • RBD Constraints From Rules

    ルールと条件のセットからリジッドボディ拘束ジオメトリを作成します。

  • RBD Interior Detail

    粉砕ジオメトリの内側サーフェス上にディテールを追加します。

  • RBD Material Fracture

    材質タイプに基づいて入力ジオメトリを粉砕します。

  • RBD Material Fracture

    材質タイプに基づいて入力ジオメトリを粉砕します。

  • RBD Pack

    RBDジオメトリ、拘束、プロキシジオメトリを単一ジオメトリにパックします。

  • RBD Paint

    ストロークを使ってジオメトリまたは拘束に対して値をペイントします。

  • RBD Unpack

    RBDセットアップを3つの出力にアンパックします。

  • RMan Shader

    RenderManシェーダをフェースグループに割り当てます。

  • ROP Geometry Output

    SOP/DOP Networkからジオメトリファイルを生成します。

  • Rails

    2つのガイドレール間で断面を伸縮させてサーフェスを作成します。

  • Ray

    サーフェスをもう片方のサーフェスに投影します。

  • Refine

    形を変えないで曲線/サーフェスのポイント/CVの数を増やします。

  • Reguide

    新しくガイドをばら撒いて、既存ガイドのプロパティを補間します。

  • Remesh

    入力サーフェスの形状を"高品質な"(ほぼ等辺の)三角形を使って再作成します。

  • Repack

    ジオメトリを埋め込まれたプリミティブとして再パックします。

  • Resample

    1つ以上の曲線/サーフェスを均一長さのセグメントでサンプリングし直します。

  • Rest Position

    ソリッドテクスチャの並びをジオメトリに設定することで、サーフェスが変形してもテクスチャの並びはそのサーフェス上に乗ります。

  • Retime

    時間依存の入力ジオメトリの時間を変更します。

  • Reverse

    フェースの頂点順を逆順または周回させます。

  • Revolve

    中心軸で曲線を回転させてサーフェスを作成します。

  • Rewire Vertices

    頂点をアトリビュートで指定した別々のポイントに再接続します。

  • Ripple

    指定した方向に沿ってポイントを動かすことで波形を生成します。

  • Scatter

    サーフェス上に/ボリューム内に新しいポイントをランダムにばら撒きます。

  • Script

    クックされる時にスクリプトを実行します。

  • Sculpt

    ブラシでインタラクティブにサーフェスの形状を変えます。

  • Sequence Blend

    3D形状のシーケンスからジオメトリとアトリビュートを補間しながらモーフィングを行ないます。

  • Sequence Blend

    形状間で3次元モーフィングをして、ポイントポジション、カラーなどを補間します。

  • Shape Diff

    同じトポロジーを持つ2つのジオメトリ間の変形後または変形前の差分を計算します。

  • Shrinkwrap

    入力ジオメトリの凸状のハルを計算し、そのポリゴンを法線方向に沿って内側に動かします。

  • Shrinkwrap

    入力ジオメトリの凸状のハルを受け取り、そのポリゴンを法線方向に沿って内側に動かします。

  • Skin

    複数の曲線間にスキンサーフェスを作成します。

  • Sky

    ボリュームクラウドで満たされた空を作成します。

  • Smooth

    ポリゴン、メッシュ、曲線をポイントの数を増やさないで滑らか(または"リラックス")にします。

  • Smooth

    ポリゴン、メッシュ、曲線をポイントの数を増やさないで滑らかにします。

  • Soft Peak

    選択したポイントとそこからスムースロールオフの範囲のポイントを法線方向に動かします。

  • Soft Transform

    選択したポイントとそこからスムースロールオフの範囲のポイントを動かします。

  • Solid Conform

    可能な限り繋がったメッシュに適合するように四面体メッシュを作成します。

  • Solid Embed

    繋がったメッシュを覆う四面体メッシュを作成します。

  • Solid Fracture

    有限要素による破壊に使用することができる四面体メッシュのパーティションを作成します。

  • Solver

    入力ジオメトリに対して前のフレームの ネットワークの出力を現行フレームのネットワークの入力にしながら、SOPネットワークを繰り返し処理します。

  • Sort

    色々な方法(ランダムを含む)でポイント/プリミティブを並べ替えます。

  • Sphere

    球または卵型サーフェスを作成します。

  • Split

    プリミティブやポイントを2つのストリームに分岐させます。

  • Spray Paint

    サーフェス上にランダムにポイントを吹き付けます。

  • Sprite

    ポイントに対するスプライト表示を設定するSOPノード。

  • Starburst

    ポリゴンフェース上にポイントをインセット(内側に挿入)します。

  • Stash

    このノード内の入力ジオメトリをコマンドでキャッシュ化し、それをノードの出力として使用します。

  • Stitch

    2つのカーブ/サーフェスを縫い合わせて滑らかにします。

  • Stroke

    インタラクティブなアセットを構築するための低レベルツール。

  • Subdivide

    ポリゴンをより滑らかに、より高解像度のポリゴンに細分化します。

  • Subnetwork

    複数のノードをまとめた単一ノードを作成します。

  • Super Quad

    アイソ2次関数サーフェスを作成します。

  • Surfsect

    NURBS/Bezierサーフェス間の交差に対して曲線を作成します。

  • Sweep

    背骨曲線に断面を沿わせてサーフェスを作成します。

  • Switch

    エクスプレッションやキーフレームアニメーションに基づいてネットワークの分岐を切り替えます。

  • TOP SOP

    入力ジオメトリをTOPサブネットに送信して、そこから出力されたジオメトリを取得します。

  • Table Import

    CSVファイルを読み込み、一行毎にポイントを作成します。

  • Test Geometry: Crag

    テストジオメトリとして利用可能な岩のキャラクタを作成します。

  • Test Geometry: Pig Head

    テストジオメトリとして使用可能な豚の頭を作成します。

  • Test Geometry: Rubber Toy

    テストジオメトリとして使用可能なゴムのおもちゃを作成します。

  • Test Geometry: Shader Ball

    テストシェーダに使用することができるシェーダボールを作成します。

  • Test Geometry: Squab

    テストジオメトリとして使用可能なイカ蟹を作成します。

  • Test Geometry: Tommy

    テストジオメトリとして使用可能な兵士を作成します。

  • Test Simulation: Crowd Transition

    アニメーションクリップ間のトランジションをテストするための簡単な群衆シミュレーションを備えています。

  • Test Simulation: Ragdoll

    ラグドールの挙動をテストするためのシンプルなBulletシミュレーションを備えています。

  • Tet Partition

    指定した四面体メッシュを、指定したポリゴンメッシュで分離された四面体のグループに区分けします。

  • Tetrahedralize

    ポイントをドロネー四面体で繋げます。

  • TimeShift

    入力を異なる時間に処理します。

  • Toon Shader Attributes

    Toon Color ShaderおよびToon Outline Shaderで使用されるアトリビュートを設定します。

  • TopoBuild

    既存のジオメトリに自動的にスナップさせて少ない数の四角形メッシュをインタラクティブに描くことができます。

  • Torus

    トーラス(ドーナツ)状のサーフェスを作成します。

  • Trace

    画像ファイルから曲線をトレースします。

  • Trail

    ポイントから軌跡を作成します。

  • Transform

    変換行列を使って"オブジェクト空間"でソースジオメトリをトランスフォームします。

  • Transform Axis

    指定した軸に合わせて入力ジオメトリをトランスフォームします。

  • Transform By Attribute

    入力ジオメトリをPointアトリビュートによってトランスフォームします。

  • Transform Pieces

    テンプレートジオメトリ上のトランスフォーメーションアトリビュートに応じて入力ジオメトリをトランスフォームします。

  • Tri Bezier

    三角Bezierサーフェスを作成します。

  • TriDivide

    色々な方法で三角形メッシュを精密化します。

  • Triangulate 2D

    ポイントが良い三角形になるように繋げます。

  • Trim

    プロファイル曲線でスプラインサーフェスをトリムしたり、以前の状態にトリム解除します。

  • Tube

    開/閉チューブ、円錐、ピラミッドを作成します。

  • UV Autoseam

    UV空間でポリゴンモデルを平坦化するのに提案されるシーム(継ぎ目)を表現したエッジグループを生成します。

  • UV Brush

    ペイントでUVビューポートのテクスチャ座標を調整します。

  • UV Edit

    テクスチャビューでインタラクティブにUVを編集します。

  • UV Flatten

    3Dジオメトリのテクスチャ空間に平坦化されたピースを作成します。

  • UV Flatten

    3Dジオメトリのテクスチャ空間に平坦化されたピースを作成します。

  • UV Fuse

    UVを結合します。

  • UV Layout

    UV島を効率的に制限領域内に詰め込みます。

  • UV Pelt

    テクスチャ領域の端側に引っ張ることでUVを緩めます。

  • UV Project

    UVをある方向でサーフェス上に投影します。

  • UV Quick Shade

    テクスチャシェーダとして画像ファイルをサーフェスに割り当てます。

  • UV Texture

    テクスチャとバンプマッピング用にUV座標をジオメトリに割り当てます。

  • UV Transform

    ソースジオメトリのUVテクスチャ座標を変形します。

  • UV Transform

    ソースジオメトリのUVテクスチャ座標を変形します。

  • UV Unwrap

    UVを合理的に平坦化、重複なしのグループに分離します。

  • Unix

    外部プログラムを使ってジオメトリを処理します。

  • Unpack

    パックプリミティブを展開します。

  • Unpack Points

    パックプリミティブからポイントをアンパックします。

  • VDB

    1つ以上の空っぽ/均一なVDBボリュームプリミティブを作成します。

  • VDB Activate

    より高度な処理をするためにVDBのボクセル領域を活動化します。

  • VDB Activate SDF

    VDBボリュームプリミティブに記録された符号付き距離フィールドを拡張/収縮します。

  • VDB Advect

    入力ジオメトリ内のVDBをVDB Velocityフィールドに沿って動かします。

  • VDB Advect Points

    入力ジオメトリ内のポイントをVDB Velocityフィールドに沿って動かします。

  • VDB Analysis

    勾配や曲率などのVDBボリュームの解析プロパティを計算します。

  • VDB Clip

    境界ボックスや他のVDBをマスクにしてVDBボリュームプリミティブを切り取ります。

  • VDB Combine

    色々な方法で2つの整列したVDBボリュームの値を結合します。

  • VDB Diagnostics

    VDBの不良値をテストして修復します。

  • VDB Fracture

    レベルセットVDBボリュームプリミティブを複数の破片に分割します。

  • VDB LOD

    VDBからLOD Pyramidを構築します。

  • VDB Morph SDF

    ソースとターゲットのSDF VDB間をブレンドします。

  • VDB Occlusion Mask

    VDBプリミティブに対してカメラから見て影となる部分にボクセルのマスクを作成します。

  • VDB Points Delete

    VDB Pointsプリミティブ内部のポイントを削除します。

  • VDB Points Group

    VDB Points Primitiveから内部グループを作成します。

  • VDB Potential Flow

    VDB障害物周辺の定常状態の気流を計算します。

  • VDB Project Non-Divergent

    Vector VDBからDivergence(発散)を除去します。

  • VDB Renormalize SDF

    VDBボリュームプリミティブに保存されているSDF(符号付き距離フィールド)を修復します。

  • VDB Resample

    VDBボリュームプリミティブを再サンプリングして新しい方向とボクセルサイズのVDBボリュームプリミティブにします。

  • VDB Reshape SDF

    VDBボリュームプリミティブ内のSDF(符号付き距離フィールド)の形状を変更します。

  • VDB Segment by Connectivity

    SDF VDBを繋がったコンポーネントに分割します。

  • VDB Smooth

    VDBボリュームプリミティブの値を平滑化します。

  • VDB Smooth SDF

    VDBボリュームプリミティブ内のSDF値を平滑化します。

  • VDB Topology to SDF

    他のVDBのアクティブセットに基づいてSDF VDBを作成します。

  • VDB Vector Merge

    3つのスカラーVDBを1つのベクトルVDBに結合します。

  • VDB Vector Split

    ベクトルVDBプリミティブを3つのスカラーVDBプリミティブに分けます。

  • VDB Visualize Tree

    VDBボリュームをその構造を可視化するジオメトリに置換します。

  • VDB from Particle Fluid

    符号付き距離フィールド(SDF)VDBボリュームを生成して、パーティクル流体シミュレーションのパーティクルセットのサーフェスを表現します。

  • VDB from Particles

    ポイントクラウド/PointアトリビュートをVDBボリュームプリミティブに変換します。

  • VDB from Polygons

    ポリゴンサーフェス/サーフェスアトリビュートをVDBボリュームプリミティブに変換します。

  • VDB to Spheres

    VDBボリュームを最適なサイズの球で埋めます。

  • Vellum Configure Grain

    Vellum Grain拘束用ジオメトリを設定します。

  • Vellum Constraints

    Vellum Solver用ジオメトリに対して拘束を設定します。

  • Vellum Drape

    キャラクタに布地がまとわりつくようにVellum Solverをセットアップします。

  • Vellum I/O

    Vellumシミュレーションをパックしてディスクに保存し、それを読み直します。

  • Vellum Pack

    Vellumジオメトリと拘束を単一ジオメトリにパックします。

  • Vellum Post-Process

    一般的なポスト処理効果をVellum Solverの結果に適用します。

  • Vellum Rest Blend

    現在の拘束のrest値と、外部ジオメトリから計算された静止状態をブレンドします。

  • Vellum Solver

    Vellumダイナミクスシミュレーションを実行します。

  • Vellum Unpack

    Vellumシミュレーションを2つの出力にアンパックします。

  • Verify BSDF

    必要なインターフェースに準拠しているかBSDFを検証します。

  • Vertex

    手動で頂点(ポイントではなく)にアトリビュートを追加/編集します。

  • Vertex Split

    Vertexアトリビュートを受け取り、そのアトリビュートのトレランスよりも大きい頂点のポイントを分割します。

  • Visibility

    3DビューアとUVエディタでプリミティブを表示/非表示にします。

  • Visualize

    ジオメトリネットワーク内の色々なノードを可視化することができます。

  • Volume

    ボリュームプリミティブを作成します。

  • Volume Analysis

    ボリュームの解析プロパティを計算します。

  • Volume Arrival Time

    ソースポイントからボクセルまでの速度を定義したトラベルタイムを計算します。

  • Volume Blur

    ボリュームのボクセルをぼかします。

  • Volume Bound

    ボクセルデータの境界を設定します。

  • Volume Break

    SDF(符号付き距離フィールド)ボリュームを使ってポリゴンオブジェクトをカットします。

  • Volume Compress

    ボリュームプリミティブを再圧縮します。

  • Volume Convolve 3×3×3

    ボリュームを3×3×3カーネルで畳み込みます。

  • Volume FFT

    ボリュームの高速フーリエ変換を計算します。

  • Volume Feather

    ボリュームのエッジをぼかします。

  • Volume Merge

    たくさんのボリュームを1つのボリュームに平坦化します。

  • Volume Mix

    ボリュームプリミティブのスカラーフィールドを結合します。

  • Volume Optical Flow

    2つの"画像"ボリューム間のモーションをディスプレイスメントベクトルに変換します。

  • Volume Patch

    あるボリュームの外観を他のボリュームの領域に継ぎ当てます。

  • Volume Ramp

    Rampに応じてボリュームを再マッピングします。

  • Volume Rasterize

    ラスター化してボリュームにします。

  • Volume Rasterize Attributes

    PointアトリビュートをサンプリングしてVDBを生成します。

  • Volume Rasterize Curve

    カーブをボリュームに変換します。

  • Volume Rasterize Hair

    レンダリング向けにファーやヘアーをボリュームに変換します。

  • Volume Rasterize Particles

    ポイントクラウドをボリュームに変換します。

  • Volume Rasterize Points

    ポイントクラウドをボリュームに変換します。

  • Volume Reduce

    ボリューム値を単一値に減らします。

  • Volume Resample

    ボリュームのボクセルを新しい解像度にサンプリングし直します。

  • Volume Resize

    ボクセルを変更せずにボリュームの境界サイズを変更します。

  • Volume SDF

    ボリュームのアイソ等高線からSDF(符号付き距離フィールド)を生成します。

  • Volume Slice

    ボリュームから2D断面を抽出します。

  • Volume Splice

    重複したボリュームプリミティブを接合します。

  • Volume Stamp

    ポイント上にインスタンス化したボリュームを単一のターゲットボリュームにスタンプ(入れ込み)します。

  • Volume Surface

    正三角形メッシュでボリューム階層を最適化してサーフェス化します。

  • Volume Trail

    Velocityボリュームからポイントの軌跡を計算します。

  • Volume VOP

    ボリュームプリミティブに対してCVEXを実行します。

  • Volume Velocity

    Velocityボリュームを計算します。

  • Volume Velocity from Curves

    カーブの接線を使ってVolume Velocityフィールドを生成します。

  • Volume Velocity from Surface

    サーフェスジオメトリ内にVelocityフィールドを生成します。

  • Volume Visualization

    複数ボリュームの可視化に関するアトリビュートを調整します。

  • Volume Wrangle

    VEX Snippetを実行して、ボリュームのボクセル値を修正します。

  • Volume from Attribute

    Pointアトリビュートからボリュームのボクセルを設定します。

  • Voronoi Fracture

    入力セルポイントまわりの空間でボロノイ分割を実行して入力ジオメトリを粉砕します。

  • Voronoi Fracture

    入力セルポイントまわりの空間でボロノイ分割を実行して入力ジオメトリを破壊します。

  • Voronoi Fracture Points

    Voronoi Fracture SOPで使用する入力ポイントを生成します。

  • Voronoi Split

    ポリラインで定義された切断線に応じて、ジオメトリを小さい破片に分割します。

  • Vortex Force Attributes

    Vortex Force DOPに必要なPointアトリビュートを作成します。

  • Whitewater Source

    Whitewaterシミュレーションのソースとして使用するボリュームを生成します。

  • Whitewater Source

    白く泡立った水のシミュレーションのソースとして使用する放出パーティクルとボリュームを生成します。

  • Winding Number

    照会ポイントにおいてサーフェスの一般化回転数を計算します。

  • Wire Blend

    曲線の長さを維持しながら曲線形状間をモーフィングします。

  • Wire Capture

    サーフェスをワイヤーにキャプチャーすることで、ワイヤーを編集するとサーフェスが変形します。

  • Wire Deform

    Wire Captureノードを通った曲線にキャプチャーされたジオメトリを変形します。

  • Wire Transfer

    曲線の形状を他の曲線に転送します。

  • Wireframe

    ポリラインからレンダリング可能なポリゴンチューブを作成します。

  • glTF ROP出力ドライバ