Houdini 18.5 Reference Stand-alone utilities

hkey / License Administrator

Opens a graphical user interface for viewing and managing licenses and license server options.

Mac

On macOS this application is in the Houdini install folder, in the Administrative Tools folder, as Licence Administrator X.X.X.

Windows

On Windows this application is in Start menu ▸ Side Effects Software ▸ License Administrator X.X.X.

Linux

On Linux this application is bin/hkey inside the install directory.

Warning

The Houdini License Administrator requires all connected license servers version to be 18.0.287 or greater.

You can use this application to view and manage licenses and license server options using a graphical user interface. To manage licenses and set options from the command-line, use sesictrl.

Using the interface you can:

If you have licensing problems, try launching this application. It may be able to show the problem. You can email diagnostic information and crash reports to SideFX Support from within this application.

Login Licensing Support

Note

Login based licensing requires an active internet connection.

In Houdini 18.5 and later, Houdini has the option to use login licensing. Login licensing requires the user to be constantly logged in with their sidefx account otherwise it works similar to traditional licensing setups.

The recommended users for login licensing are indie and education users. In a studio setup the requirement to be constantly logged in may pose as a challenge and a traditional license server does not have this requirement.

Follow these steps to start using login licensing:

  1. Open hkey.

  2. Login to your sidefx account File menu ▸ Login….

  3. Change the license server to https://www.sidefx.com/license/sesinetd File ▸ Change License Server….

All uninstalled entitlements act as login licenses. This gives you freedom to customize your configuration to use all licenses in the cloud, on-site, or a mix using server chaining.

Browser based Houdini License Administrator

In addition to login licenses, you can view your licenses through the browser and control your license setup.

If you go to https://www.sidefx.com/services/sesinetd, this page uses your currently logged in profile as the login licensing profile. This webpage will also display all of your licenses both from your server list prior to visiting sidefx.com and all of your unredeemed entitlements.

Note

Browser based Houdini License Administrator requires an active internet connection and a running hserver.

API Key licensing

API key licensing gives you the freedom of login licensing without the need login through hkey. This is a great option for render farms or other setups that do not have an artist sitting at the machine that can keep logging in when required. To generate api keys either open hkey to Help ▸ View Api Keys Online or go to https://www.sidefx.com/oauth2/applications/ and select Register a new application.

Note

These keys will get refreshed when needed as long as the credentials are valid.

To enable api key support for hkey and sesictrl add HOUDINI_API_KEY_FILE="<file location>" to the houdini.env file. The format of the file is www.sidefx.com <client id> <client secret>.

Note

To use API keys with hserver place the api key in the options file. See hserver for further details on how to setup API keys for hserver.

Stand-alone utilities

  • abcconvert

    Convert between Alembic formats.

  • abcecho

    Print information about an Alembic file.

  • abcinfo

    Print information about an Alembic file.

  • chchan

    Copies channel collection to/from action channel format.

  • chcp

    Copies channel collection file to another format.

  • chinfo

    Prints information about a channel collection file.

  • claudio

    Copies CHOP data (clip) to/from audio formats.

  • clchan

    Copies CHOP data (clip) to/from action channel format.

  • clchn

    Copies CHOP data (clip) to/from channel collection format.

  • clcp

    Copies CHOP data (clip) to another format.

  • clinfo

    Prints information about a CHOP data (clip) file.

  • dsmconvert

  • dsmmerge

  • dsparse

    Parses and displays dialog scripts.

  • gabc

    Convert between Alembic and Houdini geometry.

  • gconvert

    Convert between Houdini polygon formats.

  • gdxf

    Converts DXF polygons to/from Houdini format.

  • geodiff

    Display Geometry Differences.

  • geps

    Converts EPS files to Houdini polygon format.

  • giges

  • ginfo

    Prints polygon file statistics.

  • glightwave

    Converts LightWave files to/from Houdini format.

  • gpdb

    Converts .pdb files to/from Houdini format.

  • gplay

    Geometry viewer.

  • gply

    Converts .ply files to/from Houdini format.

  • gptex

    Makes a ptexture image file from a geometry file.

  • greduce

    Reduces polygons in a file.

  • gwavefront

    Converts .obj files to/from Houdini format.

  • hbrickmap

    Converts an i3d file or volume primitive geo/bgeo file into a Pixar brickmap file.

  • hcollapse

    Collapses a directory structure.

  • hcpio

  • hexpand

    Expands hip files into a directory structure.

  • hkey / License Administrator

    Opens a graphical user interface for viewing and managing licenses and license server options.

  • hrender

  • hsc

  • hscript

    Command line HScript interpreter.

  • hserver

    Houdini communicates through this proxy server to the sesinetd licensing daemon.

  • husk

    Command line utility for rendering a USD file using Karma or some other Hydra client.

  • i3dconvert

  • iautocrop

    Crops images based on pixel values.

  • icineon

    Convert images from 10-bit Cineon format to an 8 bit format.

  • icomposite

  • iconvert

    Converts image formats.

  • icp

    Isolate a region of an image in a new image.

  • idenoise

    Removes noise from an image file.

  • idiff

    Display Image Differences.

  • iflip - Flip Image

  • iinfo

    Outputs information about an image.

  • ilut

    Generates a lookup table (LUT) from standard channel formats or another LUT.

  • ilutcomp

    Generates a single lookup table (LUT) from from two LUTs.

  • ilutinfo

    Prints information about a lookup table (LUT) file.

  • imaketx

    Creates mipmapped .exr or .rat textures from image files.

  • imdisplay

    Sends an image to an mdisplay window.

  • iprint

    Prints the RGBA values for an image as text.

  • iquantize

    Reduces the number of colors in an image.

  • isixpack

    Generates an environment/reflection map from six images representing the six sides of a cube, or a cross image.

  • itilestitch

    Assemble a series of image files with crop windows into a single image.

  • izg

    Converts Z-depth images to 8-bit grayscale images.

  • Launcher

    The Houdini Launcher downloads, installs, upgrades, and uninstall Houdini and its components.

  • mcacclaim

    Converts an Acclaim motion file to a Houdini script and channel file(s).

  • mcbiovision

    Converts a BioVision motion file to a Houdini script and channel file(s).

  • mcmotanal

    Converts a Motion Analysis TRC motion file to a Houdini script and channel file(s).

  • mcp

    Convert an image sequence to a movie file.

  • minfo

    Prints information about movie files.

  • mqserver

    Message Queue Server for PDG/TOPs

  • sesictrl

    Sets Houdini license server options from the command line.

  • sesinetd

    The Houdini license server. This program runs in the background managing Houdini licenses.

  • siminfo

    Prints simulation cache file statistics.

  • spiff

    Display Text Differences.

  • spy

    Shell utility for navigating the UNIX filesystem.

  • vexcache

    Query or modify the VEX compile cache.

  • vexexec

    Execute a cvex shader.