Houdini 18.5 ネットワークとパラメータ

ネットワーク ナビゲーション

ネットワーク内の移動とネットワーク間の移動の方法。

On this page

ネットワーク内の移動

To...Do this

ネットワークビューをパン・ズームする

  • パンするには、ドラッグまたはSpaceを押しながらドラッグします。

  • を使うとズームイン・アウトします。またはドラッグします。

  • Oを押すと左下に現在のネットワークの小さい概要が表示されます。

すべてのノードを表示するように自動的にパン・ズームをする

ネットワークの背景でクリックして Viewing Controls ▸ Home All を選択するか、Hを押します。

選択したノードを表示するように自動的にパン・ズームする

ネットワークの背景でクリックして Viewing Controls ▸ Home Selected を選択するか、Gを押します。

ネットワークノードの内容を見るために中に入る

  • ノードをダブルクリックします。

  • ノードを選択してIEnterを押します。

  • ビューア内のオブジェクト上でクリックして Edit GeometryEdit Network などを選択します。

現行ノードより上のレベルに移動する

  • ネットワークビューの上部にあるパスで移動するレベルをクリックします。

    または
  • ネットワークエディタでUを押します。

現行チェーンから前(入力)または次(出力)のノードを選択する

PgUpまたはPgDnを押します。

特定のノードを検索する

ノードの検索方法を参照してください。

ワイヤーの始点または終点にズームする

ワイヤーの入力または出力にズームさせたい場合、そのワイヤーをクリックして、 Frame input または Frame output を選択します。

ビューに収める

To...Do this

すべてのノードが表示されるようにズームアウトする

ネットワークエディタで、 View ▸ Zoom to show all を選択するか、Hを押します。

選択したノードすべてが表示されるようにズームする

ネットワークエディタで、 View ▸ Zoom to show selected を選択するか、Gを押します。

ドラッグ中にパン

  • ネットワークエディタ内でノードをドラッグして動かす時に、ネットワークビューの境界付近までマウスを押したままにすることで自動的にパンさせることができます。

  • ネットワークビュー内でカーソルを固定するには、Spaceを押しながらドラッグします。これによって、マウスポインタがビューの外にはみ出ずに自動スクロールで遠い距離までドラッグすることができます。

Network Overview

Overviewは、ネットワークビューの左下コーナーにネットワーク全体の小さな概略図を表示します。 これは、現在のビューがネットワーク全体に対してどの位置にいるのか確認したり、そのOverview内をクリックすることで、特定のビューに迅速に移動することができます。

Tools ▸ Show overview メニューアイテムを使うことで、このOverviewを表示させるタイミングを制御することができます:

When needed

ネットワーク全体がビュー内に収まらなかった時にのみOverviewを表示します。

Always

常にOverviewを表示します。

Never

Overviewを表示しません。

デフォルトでは、Overviewは"When needed"に設定されています。

Quickmarks

"Quickマーク"とは、手軽で使い捨てのネットワークロケーションの"ブックマーク"であり、簡単に設定して、そのブックマークに戻ることができます。 通常のブックマーク(以下参照)とは違い、必要な時だけ使用し、必要な時に上書きし、そのことを忘れることができます。このブックマークは、シーンファイルに保存されません。

各マークは、ネットワークのパス、ビューの位置、ズームレベルを記録します。 そのため、そのマークを使用することで、異なる2つのネットワーク間を行き来したり、同じネットワーク内の別の2つの領域またはノード間を行き来することができます。

To...Do this

Quickマークを設定する

⌃ Ctrlを押しながら1, 2, 3, 4, 5のどれかを押します。

Macでは、を押しながら1, 2, 3, 4, 5のどれかを押します。

Quickマークに戻る

1, 2, 3, 4, 5のどれかを押します。

前のビューに戻る

` (バッククォート)を押します。

これにより、2つのビュー間もしくは別々のネットワーク間を簡単に行き来することができます。

ロケーションの履歴とブックマーク

To...Do this

(ブラウザのように)前または次のネットワークロケーションにビューを切替える

  • ネットワークエディタツールバーの矢印ボタンを使用します。

    または
  • Alt + またはAlt + を押します。

ブックマークを使用する

ネットワークエディタの上部にあるパスガジェットの右端にあるヒストリードロップダウンメニューをクリックし、 Bookmarks を選択します。 このメニューによって、新しいブックマークの追加や既存のブックマークの編集をすることができます。ブックマークを追加すれば、それがヒストリードロップダウンメニューに表示されます。

これらのブックマークは、シーンファイルに保存されるので、よく使用するロケーションを常に利用することができます。

ネットワークとパラメータ

ネットワーク

パラメータの編集

次のステップ

エクスプレッション

導師レベル

リファレンス