Houdini 18.5 ネットワークとパラメータ

ネットワークエディタ

ノードを作成、移動、コピー、編集する方法。

On this page

ネットワーク内を移動する方法ノードを接続する方法ノードを整理する方法も参照してください。

ビュー操作

ネットワークの移動を参照してください。

ノードの追加

To...Do this

新しくノードを作成する

  1. ネットワークエディタ内で⇥ Tabを押すと、利用可能なノードタイプのメニューが開きます。

  2. ノードの名前をタイプし始めてEnterを押すか、メニューアイテムからノードタイプを選択します。

  3. ネットワークエディタ内をクリックして、その新しいノードを配置します。

Tip

ノードをワイヤー上にドロップすると、そのワイヤーの入力と出力の間にそのノードを自動的に挿入することができます。

新しいノードを既存の入力/出力に接続された状態で作成する

  • 入力コネクタまたは出力コネクタから新しくワイヤーを分岐させるには、ワイヤーを開始したいコネクタをクリックしてから、⇥ Tabを押して表示されるメニューから作成したいノードのタイプを選択してEnterを押します。

  • 接続されている入力の直前または出力の直後に新しいノードを挿入するには、コネクタをクリックして表示されるメニューから挿入したいノードのタイプを選択します。

  • ⇥ Tabを押してノードタイプを選択してからノードを配置する時に、コネクタをドラッグすることで、そのノードを接続すると同時にそのノードを配置することができます。

  • ⇥ Tabを押してノードタイプを選択してから⇧ Shift + Enterを押すことで、"現行"ノード(パラメータエディタに表示されているノード、通常では直近で選択したノード)の出力に新しいノードを自動的に接続することができます。

ノードを簡単にコピーする

Altを押しながらノードをドラッグすると、そのコピーが生成されます。

ノードの扱い方

To...Do this

ノードを選択する

  • ノードの"ボディ"(フラグ以外の部分)をクリックします。

  • Sを押したままにすると、"select-only"モードになります。そのキーを押している間は、クリックやドラッグの操作が選択のみになります。これによって、ノードを動かしてしまったり、不意にワイヤー、フラグ、他のUIをクリックしてしまうことを気にすることなくノードを簡単に選択することができます。

ノードを接続する

ノードのワイヤー接続を参照してください。

ノードを削除する

ノードを選択して、 Edit ▸ Delete または⌦ Delを押します。

ノードを削除する時、ネットワークは削除したノードから下流のノードと上流のノードつなげ直そうとします。

ノードを移動させる

  • ノードをドラッグします。

  • ノードとその下流のノードすべてを同時に移動させるには、⇧ Shiftを押しながらドラッグします。

  • ノードとその上流のノードすべてを同時に移動させるには、⌃ Ctrlを押しながらドラッグします。

1つ以上のノードをカット、コピー、ペーストする

  • ノードを選択します。

  • 選択したノードをクリックして、 CutCopyPaste を選択します。

    または
  • Edit メニューを使用するか、標準のホットキーを使用します。

コピーと参照も参照してください。

ノードに関連したコマンドのコンテキストメニューを表示する

  • ノード上でを押します。

  • ペインの上部に表示されているパス内のノードの名前上でを押すと、そのノードのコンテキストメニューを取得することもできます。

ノードの名前を変更する

ノードの隣の名前をクリックすることで、ノード名を編集することができます。

(検索と置換を使って一度に複数のノードの名前を変更する方法は、ノードの名前変更を参照してください。)

ノードを削除する

ノードを選択して、⌦ Delを押します。

ノードに関する詳細情報を表示する

以下のノード情報ウィンドウを参照してください。

ノードリング

マウスカーソルをノード上に置くと、そのノードのフラグへのアクセスとノード情報ウィンドウを開くボタンが付いた"リング"が表示されます。 これによって、大きくズームアウトした時にノードのフラグインジケータが小さくなりすぎてクリックできなくなっても、フラグを操作しやすくなります。

リングのフラグをクリックする事は、ノードのフラグ領域をクリックする事と同じです。 例えば、同じキーボード修飾キーを使用して、ジオメトリネットワーク内のディスプレイとレンダーのフラグを分けることができます。

Tip

リングで隠れてしまっているノードを指定する時は、⌃ Ctrlを押したままにすることで、一時的にリングを非表示にすることができます。

ネットワークエディタのオプションでは、ノードリングを無効にしたり、ズームレベルを変更することができます。

ノード情報ウィンドウ

特定のノードに関する統計情報は、 情報ウィンドウ で取得することができます。 例えば、ジオメトリノードの情報ウィンドウは、ポイント、プリミティブ、頂点の数だけでなく、ノードのジオメトリ内のグループとアトリビュートも表示します。 これは、ノードで起きている事を調べるのに非常に役立つことが多いです。

To...Do this

いくつかの情報をすぐにチェックするために一時的に情報ウィンドウを表示する

ノード上でを押したままにします。マウスボタンを離すと、そのウィンドウが自動的に閉じます。

フォーカスを失なった時に閉じる一時ウィンドウを開く

  • マウスカーソルをノード上に置いて、そのリングの ボタンをクリックします。

    または
  • ノードを⌃ Ctrl + クリックします。

    または
  • ノードをクリックして、 Show node information を選択します。

その情報ウィンドウは、フォーカスを失なう(例えば、ウィンドウ外のどこかをクリックした時)とすぐに閉じます。 これによって、ウィンドウが乱立することなく、その情報をチェックしてコントロールを操作することができます。

Linux

Linuxでは、デフォルトでそのウィンドウのフォーカスを失なっても情報ウィンドウが保持されるようになっているので、手動でウィンドウを閉じる必要があります。 Linuxユーザによっては、"focus follows mouse"設定を有効にしていると、その情報ウィンドウのフォーカスが失なうと直ぐにウィンドウが閉じます。 ウィンドウマネージャの"focus follows mouse"が無効になっているなら、それを有効にすることができます。

情報ウィンドウを開いたままにする

情報ウィンドウのピンアイコンをクリックします。再度ピンアイコンをクリックすれば"ピンが外れて"、そのウィンドウを閉じることができます。

ウィンドウの情報の更新を維持する

  • Keep updated チェックボックスをオンにすると、そのウィンドウの情報はネットワークが再クックされると自動的に更新されます。このため、クックされる度に情報ウィンドウが再描画されるので、再生やインタラクティブな更新が遅くなってしまいます。

  • Keep updated チェックボックスがオフの時、そのウィンドウの情報は(ノードがクックされて)古くなると灰色になり、Refreshボタンが黄色くハイライトします。

  • 情報ウィンドウの Refreshボタンをクリックすることで、その情報を更新することができます。

情報ウィンドウに追加情報を表示する

情報ウィンドウの Verboseボタンをクリックします。

ノードや情報のタイプすべてにおいて表示できる追加情報があるわけではありません。場合によっては、"追加情報"は、単に略語を展開するだけだったり、まったく何も変更がなかったりします。

  • ピン留めされていない情報ウインドウのフォーカスが失なわれも消えずに、常にそのウィンドウを手動で閉じるようにするための設定があります。メインメニューから Edit ▸ Preferences ▸ Network editor を選択して、 Node info windows close when losing focus を無効にします。

  • ⇧ Shift + を使用すれば、ノードをクックせずに情報ウィンドウを見ることができます。

Tips

  • 複数起動したHoudiniインスタンス間でコピーとペーストをすることができます。それぞれのHoudiniでコピーを別々のクリップボードに持たせるには、SESI_COPY_SUFFIX環境変数を使用します。

ネットワークとパラメータ

ネットワーク

パラメータの編集

次のステップ

エクスプレッション

導師レベル

リファレンス