Houdini 18.5 ネットワークとパラメータ

ノードのレイアウト

ノードを自動的に整理、整列、分散させる方法。

On this page

Tip

ノードを配置する時に、既存ノードがそのノードと間隔を維持するために自動的に移動します。

グリッド

To...Do this

グリッドを表示する

ネットワークエディタで、(ネットワークエディタペインの上部の) Tools メニューを開いて、 Grid points または Grid lines をクリックします。

グリッドにスナップさせる

ネットワークエディタで、 Tools ▸ Snap to grid を選択します。

グリッドの間隔を設定する

  1. ネットワークエディタで View ▸ Display options を選択して、Display Optionsウィンドウを開きます。

  2. General タブをクリックして、グリッドの間隔を設定します。

ノードのレイアウト

Layout Mode

このキーを押したままマウスでノードをスワイプさせると、ノードがレイアウトまたは整列します。

  • ノードを配置する時に、既存ノードがそのノードと間隔を維持するために自動的に移動します。

  • ノードを配置またはドラッグすると、ネットワークエディタは、整列ガイドを表示します。

  • ノードを選択しておけば、レイアウトコマンドは、その選択されたノードにのみ影響します。これを使用すれば、例えば、ノードのすべての子孫ではなく、直接の子だけを選択してレイアウトするといったことができます。

To...Do this

ノードの上流を整列する

Aを押したままノードを上にドラッグ(左に整列させるなら、左にドラッグ)。

または

ノードを選択して、 Layout ▸ Layout nodes up または Layout nodes left を選択します。

ノードの下流を整列する

Aを押したままノードを下にドラッグ(右に整列させるなら、右にドラッグ)。

または

ノードを選択して、 Layout ▸ Layout nodes down または Layout nodes right を選択します。

すべてのノードを整理する

ネットワークエディタで、 Layout ▸ Layout all nodes を選択します。選択したノードだけを整理するには、 Layout ▸ Layout selected nodes を選択します。

Aキーを使ったそれぞれのノード/ブランチに対する自動整列の方が、すべての再整理よりも良い結果が得られることが多いです。すべての再整理をすると、根本的にノードの相対的な位置関係を変えてしまいます。

ノードの間隔と整列

レイアウト機能(上記参照)は、手動でノードを整列させるよりも便利なことが多くて結果も良いですが、 Layout メニューの手動ツールを使用することでノードを手動で整列することができます。

  • お互いにノードを整列するには、整列させたいノードを選択してから、 Layout ▸ Align nodes horizontally または Align nodes vertically を選択します。

    特定のノードに整列するには、整列させたいノードを選択してから、⇧ Shift + Aを押しながら、整列先となるノードから水平または垂直にドラッグします。

  • ノードを等間隔に配置するには、移動させたいノードを選択してから、 Layout ▸ Distribute nodes horizontally または Distribute nodes vertically を選択します。

    特定のノードをそのままの位置に維持させて、そのノードを基準に他のノードを分散させるには、Alt + Aを押しながら、その分散の基準となるノードから水平または垂直にドラッグします。

  • ⇧ Shift + Alt + Aを押しながらドラッグすることで、同時にノードの整列と分散をすることができます。

ネットワークとパラメータ

ネットワーク

パラメータの編集

次のステップ

エクスプレッション

導師レベル

リファレンス