Houdini 18.5 ネットワークとパラメータ

ノードの接続(ワイヤリング)

ノードをお互いに接続して動作させる方法。

On this page

概要

Houdiniのネットワークでは、ノードに入力と出力の コネクタ があり、それを ワイヤー で接続します。

ネットワークタイプによって、ノードの接続は、それぞれ意味が異なっています:

  • オブジェクト(OBJ)ネットワーク内では、ノードの接続は親子関係を意味します(子オブジェクトは親オブジェクトの出力に接続します)。

  • ジオメトリ(SOP)、コンポジット(COP)、ダイナミクス(DOP)、VOPネットワーク内では、ノードの接続は、ネットワークを通じたデータの流れを制御します。

  • レンダー出力(ROP)ネットワーク内では、ノードの接続は、レンダーパス間(前提条件となるレンダー出力の後にレンダーを接続します)の依存関係を制御します。

How to

To...Do this

ノードの入力と出力を接続する

  • ノードの出力をクリックして、他のノードの入力をクリック(逆も然り)して、ノード間を接続します。

    または

  • 別々にクリックする方法以外にも、コネクタを別のコネクタに ドラッグ することでノード間を接続することができます。

(接続の操作を中断したいのであれば、何もない空間をクリックします。)

新しいノードを既存の入力/出力に接続された状態で作成する

  • 入力コネクタまたは出力コネクタから新しくワイヤーを分岐させるには、ワイヤーを開始したいコネクタをクリックしてから、⇥ Tabを押して表示されるメニューから作成したいノードのタイプを選択してEnterを押します。

  • 接続されている入力の直前または出力の直後に新しいノードを挿入するには、コネクタをクリックして表示されるメニューから挿入したいノードのタイプを選択します。

  • ⇥ Tabを押してノードタイプを選択してからノードを配置する時に、コネクタをドラッグすることで、そのノードを接続すると同時にそのノードを配置することができます。

  • ⇥ Tabを押してノードタイプを選択してから⇧ Shift + Enterを押すことで、"現行"ノード(パラメータエディタに表示されているノード、通常では直近で選択したノード)の出力に新しいノードを自動的に接続することができます。

ノードを既存ワイヤー上に挿入する

ノードを既存ワイヤー上にドラッグすると、そのワイヤーの入力と出力の間にそのノードが挿入されます。

ワイヤーを接続解除する

ワイヤーを接続解除する方法が、いくつかあります。

  • ノードを振ることで、そのノードの入力と出力が接続解除されます。

  • ワイヤーを選択して⌦ Delを押すと、そのワイヤーが削除されます。

  • 接続の 入力 をクリックしてから、何もない空間をクリックします。

  • ワイヤーをクリックして Disconnect を選択します。

既に接続した出力を他の入力に分岐する

  1. 既に何かに接続している出力コネクターをクリックします。

  2. 接続したい入力コネクターをクリックします。

ノード間を描画してそれらのノード間を接続する

  • Jを押しながら2つ以上のノード間をドラッグすると、それらのノードが接続されます。

  • 1入力1出力だけのノードに対しては、 それらのノード上のどの位置でも描画 することができます。 複数の入力または出力を持つノードに対しては、接続したいコネクタ上で描画するようにしてください。

  • このツールは最初の描画の方向を記憶するので、ノードを一直線でなくともジグザグにドラッグすることができます。

線を引いてワイヤーをカットする

Yを押したまま1つ以上のワイヤーを横切るように線を引くと、それらのワイヤーの接続が解除されます。

ワイヤーをカットする

このキーを押したままドラッグすると、ドラッグ上のワイヤーが切断されます。

接続のTips

  • ワイヤーをクリックすると、そのワイヤーに対して実行できる操作のメニューが表示されます。

  • 接続先のノードをビュー内に表示させたいのであれば、Spaceを押したままにすることで、ネットワークビューをパンまたはズームさせることができます。

  • ノード上でAlt + すると、接続を開始するコネクタのメニューが表示されます。これは、コネクタをクリックし難いほどにズームアウトしている時に役立ちます。

  • ノードを複数選択した状態で、そのどれかの出力を複数入力に接続すれば、Houdiniは、選択したノードすべての出力を自動的に接続します。これは、たくさんのノードをMergeノードに接続したい時に役立ちます。

  • 入力上にマウスカーソルを置くと、(ノード作成者がその入力のヘルプを記述していた場合に)その入力の目的を説明したツールチップが表示されます。

ドットを使ったワイヤーのまとめ方

ネットワークエディタでは、"ドット"を追加することで、出力から入力までのワイヤーを直線ではなく、特定の経路で経由させることができます。

To...Do this

ドットを既存ワイヤーに追加する

Altを押しながらワイヤーをクリックします。

新しいワイヤーを作成すると同時にドットを追加する

出力/入力のコネクタをクリックしてワイヤーを作成し、複数回Alt-clickしてドットを追加し、目的のコネクタをクリックして、ワイヤーの作成を終了します。

ドットから再接続する

ドット上にマウスカーソルを置いたままにすると、入力と出力のコネクタが表示されます。それらのコネクタを通常のノードのコネクタと同様に接続することができます。

複数のワイヤーをまとめてドットに接続する

Altを押しながらドットをドラッグすると、まるで蜘蛛の巣を歩いているかのように、ドットがその横切ったワイヤーを"ピックアップ"していきます。これによって、たくさんのワイヤーを簡単にまとめることができます。

ドットをピン留めする方法

ドットには、ピン留め状態とピンなし状態の2つがあります。ドットをAltクリックすることで、その状態を切替えることができます。 ピン留め状態のドットは単独で存在することができます。つまり、そのドットの接続をすべて解除しても存続します。 ピン留め状態のドットはNukeのドットに非常に似ており、後で接続可能な足場としてドットをとりあえず配置しておいて膨大なネットワークを構築することができます。

ピンなし状態のドットは、無駄のない簡素なワイヤー接続を可能にするために用意しています。 ピンなし状態のドットは、その入力または出力のワイヤーすべてが削除されると(このドットによるワイヤー接続が意味を持たなくなるので)自動的に削除されます。

入力の並べ替え

  • MergeSOPなどのノードには"マルチ入力"があり、これは複数の入力を接続することができます。

  • マルチ入力を持つノードでは、その入力の順番が重要になることがあります。例えば、レンダーノード(ROP)は、その順番通りに入力をレンダリングします。

To...Do this

入力の順番を変更する

  1. ネットワークエディタでノードを選択します。

  2. パラメータエディタで、そのパネルの下の方にスクロールします。

    マルチ入力を持つノードでは、そこに入力のリストがあります。

  3. そのリストの入力をドラッグアンドドロップするか、上矢印アイコンをクリックして、入力の順番を変更します。

入力の順番を簡単に循環させる

  1. ノードを選択します。

  2. ネットワークエディタで、 Edit ▸ Rotate input connections を選択または⇧ Shift + Rを押します。

See also

ネットワークとパラメータ

ネットワーク

パラメータの編集

次のステップ

エクスプレッション

導師レベル

リファレンス