On this page

グラフビューはアニメーションパラメータを時間軸での値のグラフとして閲覧・編集することができます。これはアニメーションエディタのビューの1つです。ほかにもテーブルビュードープシートビューを使ってアニメーションを編集することができます。これらのビューの切り替えは、ペインの左上にあるボタンを使います。

チャンネルには一連のセグメントが含まれています。各セグメントは2つの端点で構成されています。各端点はキー上にあり、value(値)、slope(傾き)、acceleration(加速度)の特性を持ちます。セグメントには全体として、それに依存したセグメントに関連するセグメントファンクションがあり、端点でいくつかの特性を使用します。例えば、constant()セグメント関数は、最初の端点の値のみを使います。一方、Bezierセグメント関数は両端点で3つの特性すべて(slope、acceleration、value)を使います。

操作

To...Do this

ビューをパン・ズームする

  • ズームは、ドラッグ、パンはドラッグします。

  • グラフのデータすべてを表示するには、グラフの上部にあるツールバーの Home Channels(All Graphs) アイコンをクリックするか、 View ▸ Home Channels(All Graphs) を選択します。

  • データすべてを表示するには、 View ▸ Home Global Range(All Graphs) を選択します。

  • データすべてが見えるように自動的にパン・ズームをするには、 View ▸ Horizontal AdaptView ▸ Vertical Adapt を有効にします。

現行時間を変更する

  • グラフ上の白い垂直線は、現行時間を意味しています。ラインをドラッグすれば現行時間を変更することができます。ドラッグすればチャンネルリスト内のパラメータの値をそのまま保持して現行時間を変更することができます。

  • グラフの下部にある青いフレーム番号をクリックまたはドラッグすれば、再生位置をそこに移動することができます。

  • 標準のプレイバーのコントロールも使うことができます。

キーの追加と削除

To...Do this

キーを追加する

  • グラフをAlt + クリックすれば、そのフレームにキーフレームを作成することができます。これはキーフレームを既存チャンネルに追加する時にだけ動作します。またクリックしたままドラッグすれば、カーブ上の挿入点が動くので正確な位置に合わせることができます。キーが既に選択した場所に存在すれば、キーは作成されません。

  • グラフ上にマウスを動かして⌃ Ctrl + Kすると、選択したチャンネルにキーフレームを追加します。

  • Kまたはプレイバーのキーフレームボタンをすると、 Global Set Key アニメーションプリファレンスに基づいてキーフレームを追加します。

  • パラメータ編集ボックス上でAlt + してもキーフレームが追加されますが、選択したボックスにのみキーフレームが追加されます。

  • グラフ上でして、 Set Keyframe at Current Time を選択します。

  • パラメータ上でして、 Keyframes > Set Keyframe を選択します。

キーを削除する

  • キーハンドルを選択して⌦ Delを押します。

  • グラフ上でして、 Delete を選択します。

  • パラメータ上でして、 Keyframes > Remove Keyframe を選択します。

カーブの編集

以下の図では、キーフレーム毎のハンドルを示しています。 それらのハンドルは、グラフ下のテキストボックス(Value, Frame, Slope, Accel)に相当し、そこで正確な数値を設定することができます。 (いくつかのインジケータは、選択したキーにのみ表示されます。)

セグメントを選択すれば、“segment function”を選択できるようになります。これは、Houdiniがセグメントの両端点を接続する方法を制御します。

フレーム毎に Slope を自動または手動で制御したり、 Value / Accel をTie/Untieすることができます。

To...Do this

グラフのセグメントの形を変更する

  1. 変更したいセグメントを選択します。

    セグメントが破線で描画されていたら、ViewメニューのShow Functionsを有効にして、セグメントを選択可能にします。

  2. グラフの下部にあるFunctionテキストボックスの右端のポップアップメニューからFunctionを選択したり、直接 Function ボックスに独自のエクスプレッションをタイプします。

    また、Functionツールバーから欲しい機能のボタンをクリックしてグラフのセグメントの形を変更することもできます。

  3. グラフビューで選択したキー上のハンドル(もしあれば)を使ってカーブの形状を調整することもできます。ハンドルを複数選択した状態でYを押せばスケールハンドルに切り替わります。

    cubicbezierquintic関数では、キーフレーム上のスロープハンドルをドラッグ、またはハンドルをクリックして Slope テキストボックスに値をタイプすることで、カーブの形を調整することができます。

    bezierquintic関数では、スロープハンドルの端にある丸いアクセラレーションハンドルをドラッグ、またはハンドルをクリックして Accel. テキストボックスに値をタイプすることでカーブの形を調整することもできます。

    グラフの下にある SlopeAccel. (加速度)、 Value のテキストボックスで選択したハンドルの正確な値をタイプすることもできます。

キーフレームの時間を移動する

  • 値のハンドル上にある短い垂直線を左右にドラッグするとキーフレームが移動します。

    グラフ上の時間の値がその垂直線の下に表示されます。 Snap Selected Keys to Nearest Frame オプションを有効にすると、ドラッグ後にキーが一番近いフレームに移動します。

簡単にカーブの傾斜を編集する

  • 接線ハンドルを選択して、0を押すと傾斜が水平になり、9を押すと傾斜が接線になります。

値を“保持”する

  • キーフレームを選択して、Alt + Cまたは⌃ Ctrl + Cを押してキーフレームをコピーし、貼り付けたい時間にタイムラインを移動し、Alt + Vまたは⌃ Ctrl + Vを押してコピーの内容を貼り付けます。

キーフレームの値を変更する

  • キーフレームハンドルを上下にドラッグします。

  • キーフレームハンドルをクリックして、グラフ下の Value フィールドに正確な値を入力して、Enterを押します。

同時に複数の値を変更する

  • 複数のハンドルを選択するには、⇧ Shift + クリック、または矩形ドラッグします。

  • 2つ以上の値を選択すると、 Value フィールドは---の表示になります。このフィールドに値をタイプすれば同時に同じ値に設定することができます。 複数の現在の値に数値を加算する場合は+数値、減算する場合は+-数値、乗算する場合は*数値、割算する場合は/数値をタイプします。

XとYで同時にキーを動かす

⌃ Ctrlを押したままValueのハンドルをドラッグします。

Accelにのみ影響を与え、Slopeの方向をそのまま保持する

⌃ Ctrlを押したままAccelのハンドルをドラッグします。

チャンネル上の同じタイプのハンドルすべてを選択する

ハンドルをダブルクリックします。

同じタイプのハンドルすべてを既存選択に追加する

⇧ Shiftを押したままハンドルをダブルクリックします。

Note

⌃ Ctrl + ⇧ Shiftを押したままダブルクリックすると、同じタイプのハンドルが選択から解除されます。

ボックス選択にハンドルを追加する

⇧ Shiftを押したままドラッグします。

Note

⌃ Ctrl + ⇧ Shiftを押したままドラッグすると、ハンドルが解除されます。

ギアメニュー

次のメニューにアクセスするには、Channelグラフの右上コーナーにあるギアメニューをクリックします。 また、グラフ内でクリックしたり、 View メニューの Show Menu Bar を有効にすることでもそれらのメニューにアクセスすることができます。

Channelsメニュー

チャンネルを表示すれば、アニメーションエディタのグラフ、テーブル、ドープシートのペインでチャンネルを閲覧・編集することができます。

Set Keyframes at Current Time

現行時間でチャンネルにキーフレームを追加します。

Sample Values at Current Time

現行時間でのパラメータの値をクリップボードにコピーします。別の時間に移動して、 Paste Sampled Values at Current Time を選択すれば、他のフレームで同じ値を使うことができます。

Paste Sampled Values at Current Time

Sample Values at Current Time でコピーした値を現行時間に貼り付けます。

Import into Displayed Parameters

Export Displayed Channels as で以前保存したアニメーションデータを現在表示しているパラメータに読み込むダイアログが開きます。

Export Displayed Channels as

表示しているチャンネルからデータを保存することができるダイアログが開きます。

Isolate Channels

選択したグラフのチャンネルのみを表示します。

Include Channels

Isolate Channels と反対です。チャンネルすべてを表示します。

Editメニュー

Cut/Copy/Paste

Paste Settings を使用して、選択したハンドルすべてをカット、コピー、ペーストします。

Paste Settings

チャンネルのコピーアンドペーストは、選択したチャンネルを一時ファイルに保存することで動作します。現在表示されているチャンネルに基づいて、アニメーション範囲、チャンネル名、フルパス、行の順番もファイルに保存されます。 この情報を使用することで、コピーするチャンネルリストとターゲットのチャンネルリストの間でマッピングを実行することができます。

Using Channel Names

チャンネルのマッピングは、チャンネル名に基づいて実行されます。これは、同じタイプで同じパラメータレイアウトの2つのノードのアニメーションの転送が上手く動作します。

Note

同時に複数のトランスフォームノードをコピーする時には、これはチャンネル名で最初に該当するチャンネルだけをペーストするので、注意してください。

Using Full Paths

チャンネルのマッピングは、フルパスに基づいて実行されます。これは、同じチャンネルのコピー/ペーストをする時に上手く動作します。これは、チャンネルのリストが変わっても正しく動作します。 このモードは、コピー/ペーストが異なるチャンネル間でのアニメーションの転送に使用することを許可しません。

Using Row Order

チャンネルのマッピングは、コピー操作をした時の表示チャンネルの列の順番と、ペースト操作をした時の列の順番を使用して実行されます。 これは、チャンネルを持たないノード、または異なるチャンネルセットを持つノードに対してコピー/ペーストできるように、有効なチャンネルを持たないパラメータを考慮します。

At Current Time

コピーしたハンドルを現行時間の後にペーストします。

At Original Time

コピーしたハンドルを元々の時間にペーストします。

On Parameters with Existing Channels

既存チャンネルを持つパラメータに対してのみペーストします。

On All Parameters

表示されたパラメータすべてに対してペーストし、見つからないチャンネルを作成します。

Delete

選択したキーフレームを削除します。

Select All Handles

表示されたチャンネルのハンドルすべてを選択します。

Select No Handles

ハンドル選択をクリアします。

Invert Handle Selection

選択したハンドルが非選択になります。非選択のハンドルが選択されます。

Snap Selected Keys to Nearest Frame

選択したキーが一番近い整数のフレームにスナップします。

Tie/Untie

Tieはキーフレームの左側と右側の値を一致させます(片方が変更すると、もう片方も追従する)。チャンネルをUntieにすると、キーフレームの左側と右側の値を独立して修正することができます。

Set Selection to Default Values

選択したキーの値をデフォルト値に設定します。この値はチャンネルのパラメータに依存します。

Set Selection Slopes to Zero

選択したスロープの値を0(つまり、水平)にします。

Set Selected Slopes to Manual/Automatic/Toggle Selected Slopes Mode

これは、inとoutのスロープ上で新しいAutomatic Slopeフラグを制御します。 自動スロープフラグが Automatic の時、キーフレーム値や時間を動かすと、その接線に影響を与え、接線を滑らかに維持します。 自動スロープフラグが Manual の時、キーフレームを動かすと、そのスロープが同じ向きを維持します。

Note

Automaticに設定したスロープを持つキーフレームは、ひし形で描画されます。

Smooth Selected Slopes

選択したスロープの値をオーバーシュートしないように設定します。チャンネルのキーのスロープは0に設定され、他のスロープすべては隣接するキー間が滑らかに補間されるように近似値が設定されます。 平滑化すると、アクセラレーション値も正規化されます。

Set Selected Segments to…

セグメント関数を変更することができます。詳細は、Functionフィールドのセクションを参照してください。

Filter Euler Rotations of Selected Channels

オイラーフィルターは、オイラー角を使用して大きな角度による回転をアニメーションさせた時に起きる悪い回転補間を修正します。よくある問題は、キーフレーム間で間違った方向に回転が反転してしまうことです。

このフィルターを適用するには、3つの回転チャンネルすべてのハンドルを選択して、オイラーフィルターを適用します。フィルター処理は、選択したハンドルを持つチャンネルすべてに適用され、チャンネル全体に影響を与えます。 オブジェクトノードのRotation Orderは、このフィルター処理に影響を与えます。

このフィルターは、回転チャンネルにのみ使用してください。複数オブジェクトの回転を同時にフィルター処理することができます。

Match Keyframes of Selected Timemarks

選択したTimeマークに基づいて、チャンネル上に見つからないキーフレームを作成します。これは、チャンネルが選択内で合致するキーフレームを持っている必要があります。

Bake Keyframes of Selected Segments

選択したセグメントに対してcubicカーブの再フィットと再サンプリングを実行するためのオプションを持つモーダルダイアログを表示します。 再サンプリングすることで、セグメントエクスプレッションとCHOPエクスポートをキーフレームにベイクすることができます。 チャンネルの最初と最後のキーフレームの外側の範囲を指定すると、チャンネル外挿(cycles, cycle offset)をキーフレームにベイクすることができます。

Enable Refit Segments

再フィットを有効/無効にします。再フィットはキーフレームの数を減らすと同時に同じカーブ形状を維持しようとします。

Refit Preserve Extremas

ローカルの最小値と最大値を維持します。

Refit Set Bezier function on segments

再フィットで3次カーブを作成しても、これはセグメントを強制的にベジェセグメントにします。

Refit Tolerance

キーフレーム値の結合に使用する許容値。これは絶対値で、実際のキーフレーム値に基づいて指定してください。

Enable Resample Segments

再サンプリングを有効/無効にします。再サンプリングは、カーブの形状を変更せずにキーフレームを追加します。

Resample at every (frame)

Nフレーム毎または浮動小数点フレームでキーフレームを追加します。

Resample Tolerance

再サンプリングする際に、キーフレームの結合に使用する許容値。

Enable Override Range of Selected Segments

明示的な範囲を有効/無効にする。無効にすると、チャンネル範囲は、選択したセグメント範囲になります。有効にすると、チャンネル範囲は、開始値と終了値で上書きされます。 これは、チャンネル外挿、CHOPエクスポート、エクスプレッションをベイクするのに役立ちます。

Start/End frames

Enable Override Range of Selected Segments が有効な時に使用する開始と終了の範囲を定義します。

Bake CHOP Exports to Channels

パラメータがCHOPエクスポートで駆動されている時に行なう事を定義します。

Off

CHOPエクスポートをベイクしません。

Bake, Keep Export Flags

ベイクを実行しますが、CHOPエクスポートフラグをそのままにします。 そのパラメータは、まだCHOPエクスポートで駆動されますが、そのベイクされたアニメーションがチャンネル上に存在します。

Bake, Disable Export Flags

ベイクを実行し、すべてのCHOPノードのCHOPエクスポートフラグを無効にします。 これは、それらのCHOPノードが他のパラメータにエクスポートしているかどうか考慮しません。 CHOPノードからエクスポートされているすべてのチャンネルをベイクしようとしていることが分かっている時のみ使用してください。

Bake Create Delete CHOPs and Move Export Flags

ベイクを実行し、Delete CHOPノードを作成して、エクスポートされているチャンネルをそれぞれ無効にします。

Viewメニュー

Home Channels (Current Graph/All Graphs)

現行グラフや全グラフのすべてのキーが表示されるようにグラフをパン・ズームします。

Home Playback Range (All Graphs)

グラフをプレイバック範囲までズームします。プレイバック範囲とは、Start FrameからEnd Frameまでの範囲です。

Home Global Range (All Graphs)

チャンネルグラフすべてが.hipファイルのグローバルアニメーション範囲で表示されるようにズームを調整します。

Frame Selection

チャンネルグラフが選択したキーのみが表示されるようにズームを調整します。

Horizontal/Vertical Adapt

これらのチェックボックスがオンの時、グラフは自動的に水平・垂直の値が表示されるようにパン・ズームします。

Show Values

キーフレームのハンドルを表示・非表示します。ハンドルをドラッグすれば、そのキーフレームでのパラメータの値を変更することができます。もしキーの値がTieになっていれば、ハンドルの表示はボックスに、そうでないなら、独立した2つの三角形になります。

Show Time Marks

キーフレーム上にある短い垂直線を表示・非表示します。この垂直線を左右にドラッグするとキーフレームの時間を修正することができます。

Show Slopes and Acceleration

セグメントのスロープと加速度を意味する短い線を表示・非表示します。スロープのラインや加速度のハンドルをドラッグすると、セグメントの形を変更することができます(スロープや加速度を使うファンクションでセグメントをコントロールしている場合)。

Show Functions

セグメントの形状を制御するファンクションを選択可・不可することができます。

Show Time Groups

Time Groupsを表示・非表示します。Time Groupsは黄色い垂直線として表示されます。Time Groupsに属するハンドルとキーフレーム間には黄色い破線が接続されます。この線を左右にドラッグすると時間軸に沿ってグループ化したキーフレームが動きます。

Show Time Bar

グラフ上に現行フレームを意味する垂直線を表示します。

Show Box Handles

キーのブロックを移動/スケールさせることができるハンドルを表示します。 Channel Graph内のキーのグループを選択して、Yを押すことでもこれをオンにすることができます。

ボックスのエッジをドラッグすれば、上下左右にキーフレームのグループを移動させることができます。 その軸はロックされているので、同時に1方向にのみキーフレームを動かすことができます。 両方の軸を一緒に動かすには、ボックスのエッジをドラッグする時に⇧ Shiftを押したままにします。

スケールするには、そのボックスのコーナーを選択してドラッグします。

Show Box Handle Pivot

ボックスハンドルの中心にピボットハンドルを表示します。 Channel Graph内で⇧ Shift + Yクリックすることで、これをオンにすることもできます。 スケールは、ピボット位置を基準に実行されます。

ピボットの移動は、単にそれを他の位置へドラッグするだけです。 ピボットの位置を中心に戻すには、⇧ Shift + Y + Yクリックします。 これは、ピボットを無効にしてから、再度有効にして、ピボットを中心に戻します。

Show Handles

ハンドルすべて、または選択したハンドルをグラフ上に表示するかどうか選択します。

Show Full Channel Names

グラフ上にチャンネルのフルネームを表示します。例えば、box_object1/tx、box_object1/ty、box_object1/tz。

Show Channel Names

グラフ上にチャンネルの名前を表示します。例えば、tx、ty、tz。

Show Times for Selected Marks

選択したTime Markのフレーム番号を表示します。

Show Values for Selected Keys

選択したキーのグラフ値を表示します。

Show Only Attached Time Groups

このオプションをオンにすると、グラフは表示されたキーフレームに接続しているTime Groupsのみを表示します。

Draw Past Channel Ends

最後のキーフレームの後に破線の水平線を描画します。

Show Color Mode Field

hou.ChannelEditorPane.registerColorsCallback()を使用して独自のカラースキームをスクリプト化した場合は、このメニューをオンにすることでそれを選択することができます。

Show Channel Lister

アニメーションエディタの左側にChannel Listerを表示します。 グループリスト、Channel Chooser、パラメータを表示するには、このチェックボックスを有効にしなければなりません。

Show Channel Chooser

アニメーションエディタの左側のChannel Lister内にChannel Chooserを表示します。

Show Group List

アニメーションエディタの左側のChannel Lister内にグループリストを表示します。

Show Layers

左のペイン内にAnimation Layer Editorを表示します。

Show Menu Bar

ペインの上部にメニューバーを表示させることができます。このオプションは、ギアメニューでも利用可能です。

Show Bottom Values Toolbar/Top Timeline/Right Toolbar

ディスプレイからツールバーを非表示にすることができます。これはデフォルトでオンになっています。

Snapshotsメニュー

Enable Channel Snapshot

キーフレームアニメーションが変わる度に、一時的なチャンネルコピーを作成します。これを使えば、簡単にキーフレームアニメーションを前の状態に戻すことができます。

Persistent Channel Snapshot

アニメーションエディタが更新された時に新しいチャンネルを表示するようにスナップショットを保持します。

Revert Active Channels to Snapshot

キーフレームアニメーションをスナップショットの状態に戻します。

Swap Active Channels and Snapshots

キーフレームアニメーションとスナップショットの状態を入れ替えます。

Clear Channel Snapshot

スナップショットをクリアしたり、変更を受け入れます。

Time Groupメニュー

Time Group はキーの集合体です。Time Groupは複数のキーの時間を同時に修正するのが楽になります。

To...Do this

キーを時間単位でグループ化する

  1. キーを選択します。

  2. ペインのメニューから Time Group ▸ Create Time Group on Selected Keys を選択します。

キーを既存のTime Groupに追加する

  1. キーを選択します。

  2. ⇧ Shiftを押しながらTime Groupラインを選択します。

  3. ペインのメニューから Time Group ▸ Attach/Detach Selected Keys を選択します。

キーをTime Group単位で移動する

  • 黄色いTime Groupラインを左右にドラッグします。

Time Groupラインをキーを動かさずに移動する

  • Time Groupラインをでドラッグします。

Time Groupを削除する

  1. 黄色いTime Groupラインをクリックします。

  2. ⌦ Delを押します。

Settingsメニュー

Show Audio in Timeline

有効にすると、チャンネルグラフの下部に読み込んだオーディオソースがグラフィカルに表示されます。

Synchronize Group Selection From Channel List

現在のチャンネルに合うようにチャンネルグループ選択を調整します。

Grid Line Density

グリッドの密度を選択、またはグリッドをオフにします。

Slope Handle Length

チャンネルグラフのスロープのハンドルの長さを設定することができます。プリセットの長さは短、中、長ですが、 Custom を選択すればユーザ指定で長さを設定することもできます。

Curve Quality

カーブの精度を選択します。ディテールのレベルを低くすると、非常に複雑なグラフの表示が軽くなります。最小ディテールはカーブを描画せず、キーフレームを繋いだラインを描画します。

Add Keys

Alt + を使ってキーを作成した時のチャンネルグラフの挙動をカスタマイズします。 At Mouse Click Position に設定すると、グラフのマウスの位置の値で新しいキーがチャンネルに作成されます。 At Curve Value に設定すると、チャンネルの現在の値で新しいキーが作成されます。

Auto-Smooth Slopes

スロープを自動的に滑らかにするか選択します。 平滑化すると、アクセラレーション値も正規化されます。

Toggle Auto-Slope Mode Preference

自動スコープのプリファレンスをトグルします。これは、キーフレームを作成した時の新しいスロープの自動スロープフラグを定義します。

Snap Moved Keys to Nearest Frame

有効にすると、チャンネルグラフのキーを移動すると、常に整数フレームに移動するようになります。

Snap Scaled Keys to Nearest Frame

有効にすると、チャンネルグラフのキーをスケールする (つまり、スケールハンドルを使う) と、常に整数フレームにスケールするようになります。

Bold Non-Integer Keys

有効にすると、整数でないフレームのキーが太字と白で描画されます。

Reset Channels Settings

すべてのチャンネル設定をデフォルト設定にリセットします。

Editフィールド

Frame

選択したキーのフレーム番号またはTime Group。2つ以上のキーまたはTime Groupを選択すると、フィールドには---が表示され、値を設定すれば、選択したキーすべてがその値に編集することができます。

Value

選択したキーのInまたはOutの数値。

Slope

選択したキーのInまたはOutのラインの傾斜。これは、スロープの値を使うcubicのようなファンクションにのみ有効です。

Accel

選択したキーのInまたはOutのラインの加速度。これは、アクセラレーションの値を使うbezierのようなファンクションにのみ有効です。

Tip

フィールドの現行の値に足し算、掛け算、割り算を使うことができます。例えば、以下のようにすれば、現行の値に数字を足し算することができます:

+ 1.25

Enterを押します。掛け算は*、割り算は/を使います。引き算に関しては、以下のようにマイナスの値を足し算します:

+ -0.5

Functionフィールド

セグメントのファンクションは、キーフレーム間の補間方法をコントロールします。

テキストボックスの右端にあるポップアップメニューからファンクションを選択、またはテキストボックスに直接エクスプレッションファンクションをタイプします。

ファンクション 効果

constant

セグメント全体にInの値を使い、終点でOutの値にジャンプします。

linear

InとOutの値の間を直線で繋ぎます。これはセグメントに沿って均一なスピードでアニメーションします。

ease

セグメントの始点で値を徐々に加速し、終点で減速する動きを生成します。値は停止からアニメーションを開始し、最後に停止します。

easein

セグメントの始点で停止から徐々に加速して終点まで加速を続ける動きを生成します。

easeout

値を徐々に減速してセグメントの終点で停止する動きを生成します。

easep(2) easeinp(2) easeoutp(2)

これらは基本的にはeaseファンクションと同じですが、さらに2乗することで、より急な傾斜になっています。

カーブをもっと急な傾斜にするには、 Function テキストボックスに手動で累乗を変更します(例えば、3, 4, 5など)。

match

OutのカーブのスロープをInのカーブのスロープと同じにします。

上記の例では、キーの右側のセグメントはCubic補間ファンクションを使いました。そのセグメントを選択して、補間タイプをMatchに変更した後は、そのスロープはキーの左側のカーブセグメントに一致するように調整されます。

matchin, matchout, vmatch

これらのファンクションはエクスプレッションのリファレンスのページを参照してください。

cubic

InとOutのスロープを制御します。

bezier

InとOutのスロープとアクセラレーションを制御します。

quintic

bezierファンクションと同様ですが、より高い次数のカーブを使います。

spline

qlinear

InとOutの値の間をクォータニオン空間で球状の線形補間を生成します。これは、回転チャンネルではデフォルトです。

このファンクションは、回転チャンネル用です。3つの回転チャンネルすべてがqlinear()を使っていて、同じフレームにキーがあることを確認してください。

クォータニオン補間によるセグメントはグラフエディタでは直線として表示されます。なぜなら、オイラー角として表現した中間値は、ほとんど意味がないからです。もし興味があれば、エクスプレッションqlinear() + 0を使ってみてください。グラフエディタで実際の値を表示するのが無駄なのがわかります。

2つのキーフレーム間の補間に基づいたクォータニオンを実行するには、qlinear()ファンクションでは3つのオイラー角が必要です。隣接するチャンネルが何であるか把握することで、これを行ないます。チャンネルを把握するために、xyzで終わるチャンネルまたは数字で終わるチャンネルを検索します。それにより、“rx ry rz”が1グループになり、“test0 test1 test2”が他のグループになります。

cycle

repeat

ペイン

一般

アニメーション

レンダリング

上級

その他