On this page

General User Interface

Draw Lines Smoothly

HoudiniのUIと3Dビューポートを含むベクトルすべてをアンチエイリアスするOpenGLオプションを有効にします。これは、ノードタイル間を接続しているワイヤーで直ぐに違いを確認することができます。

また、Display Optionsウィンドウの Effects タブのSceneセクションにあるSmooth Linesオプションも参照してください。

Color Pane Headers with Network Contexts

ペインのヘッダ部はペインタブとパスガジェットで構成されていて、デフォルトでは背景が灰色です。このオプションをオンにすると、ペインのヘッダの色は典型的なネットワークタイプカラーになります。

Show Images for Image Files in File Browsers

画像選択用のファイルダイアログのデフォルト設定に Show Images を有効にします(オフの場合は、ファイルダイアログでクリックのメニューから有効にします)。

Left-hand Menus

マウスカーソルの右側ではなく、左側にメニューを構築します。これは画面を左利き用で使っている人に役に立ちます。

Play Audio with Popup Notifications for

メッセージ、警告、エラーのダイアログウィンドウが開いた時に音を鳴らします。

File Choosers

ファイル選択ダイアログの形式を選択します。

Note

このオプションはMacだけ利用可能です。

Houdini Chooser Only

Houdiniは、すべてのファイルブラウザーで独自の選択ダイアログを使用します。

Mix of Houdini and Native Choosers

Houdiniは File ▸ Open ではOSのネイティブのファイル選択ダイアログを使用し、それ以外は独自の選択ダイアログを使用します。

Native Chooser Only

Houdiniは、すべてのファイルブラウザーでOSのネイティブのファイル選択ダイアログを使用します。

Startup in Desktop

Houdini起動時に表示するデスクトップを指定します。デフォルトは Build です。

Icon Size and Layout

UIのアイコンのサイズと間隔を変更することができます。このパラメータを変更すると次のHoudiniセッションで反映されます。

Small

ビューア領域を最大化するために設計された非常にコンパクトなサイズ。

Compact

Normal サイズより少しコンパクトなサイズで、余白とアイコンサイズを小さくしています。

Normal

デフォルトのHoudini UIサイズ。

Large

少しだけ大きいUIサイズ。アイコンボタンが約10%ほど大きいです。

Extra Large

アイコンとアイコンの間隔が非常に大きいUIサイズ。

Global UI Scale

UI全体のサイズを変更するグローバルスケール。 高解像度スクリーンでは、このスケールを上げるのが望ましいです。 デフォルトのスケールは1.0です。 1.75のスケールは、LinuxとWindowsの高DPIスクリーンで望ましいです。 2.0のスケールは、MacOSの高DPIスクリーンで望ましいです。

Network Editor, Nodes, and Trees

Animate network changes

ネットワークエディタ内の特定の変更と遷移をわかりやすくするためにアニメーションさせます(例えば、新しくノードが配置された時にノードを移動させるなど)。アニメーションを無効にするには、これをオフにします。

Use simplified shape when node shapes off

ネットワークエディタの View メニューでは、カスタムノードシェイプの表示を無効にすることができます。 そのオプションとこのオプションの両方がオンになっている場合、Houdiniは、より単純なデフォルトのノードシェイプ(丸みのある四角形ではなく単純な四角形)を使用します。これにより、 極度に 複雑なネットワークの表示が高速化されます。

Display full comments and descriptive parameters

デフォルトでは、ネットワークエディタは、特定の行数の後の(ノード名の下に表示される)長いノードコメントと説明的なパラメータ値を削除します。 これをオンにすると、常にその長さに関係なくそのコメントと説明的なパラメータをすべて表示します。

Display VOP input and output descriptive labels

VOPノードに対して、その入力と出力のラベルを内部名ではなく人が解読可能なラベルで表示します。

Stacked look for nodes with interesting contents

デフォルトでは、中に潜入できるノード(例えば、ロックされていないアセット、Geometryオブジェクト、サブネットなど)は、そのノードの中に潜入できることを初心者でも理解しやすいように、積み重なったルックで描画します。 このオプションをオフにすると、どのノードも積み重なったルックで描画されなくなります。

Node info windows close when losing focus

このオプションがオンの時、ノードリングに対してInfoボタンを使ってInfoウィンドウを開くと、そのウィンドウはそのノードの焦点が外れると閉じるので、手動で閉じる必要はありません。 これをオフにすると、そのウィンドウは、閉じるまで常に開いたままになります。

Linux

MacとWindowsでは、このオプションがデフォルトでオンになっています。Linuxでは、デフォルトでオフになっています。その理由は、ウィンドウマネージャーで"focus follows mouse(フォーカスがマウスに追従)"をセットアップしているユーザがいると、これは常にInfoウィンドウが直ぐに閉じてしまうからです。

Flag hotkeys work on existing node selections

このオプションがオフ(デフォルト)の時、フラグホットキーは、キーを押しながらノードをクリックすることでフラグを設定することができます。 このオプションがオンの時、フラグホットキーを押すことで、選択したノードにフラグが設定されます。

Allow diving into locked assets

これがオフの時、ダイブするターゲットノードを指定しない限り、ロックされたアセットの中に入ることができません。 アーティストが不意にアセットの中に入って迷子になってしまわないように、スタジオではこのオプションをオフに指定した方が良いでしょう。

Snap radius

他のノードに整列するようにノードをスナップさせて移動/配置させるための半径。この距離を大きくすると、ノードをドロップした時に他のノードと整列するように動く距離が大きくなります。

Connection snap radius

コネクタにワイヤーをスナップさせる半径。この半径を大きくすると、ワイヤーが遠くからコネクタ上にジャンプします。この半径を小さくすると、ワイヤーをコネクタに近づけないとジャンプしなくなります。

Shake distance

ノードを振ると、ノード間のワイヤーが切れます。このスライダは、マウスを左右に動かした時にHoudiniがそれを振ったと認識する距離を制御します。 Houdiniがノードを振ったと認識して不意に接続解除するようであれば、この距離を小さくしてください。スライダをすべて下げれば、振ることによる接続解除が無効になります。

Show previews on new COP nodes

個々のコンポジットノードに対するプレビューサムネイルを表示または非表示にします。このチェックボックスは、新しく作成されたコンポジットノードのプレビューを表示するのか非表示にするのかどうかを制御します。

Initial VOP detail level

個々のVOPノードに対してコンパクトレベルを設定することができます。このメニューは、新しく作成されたVOPノードの初期レベルを制御します。

Display icons in operator tree views by default

Houdini内の色々なインターフェース(例えば、ノードピッカーまたはTree Viewペイン)は、ノードのリストを階層で表示します。それらのツリービューでノード名の隣にアイコンを表示したくないのであれば、これをオフにします。

Display Embedded Visualizer Editor

1つ以上のビジュアライザをノードに取り付けた時、パラメータエディタの別タブにビジュアライザの設定が表示されます。

3D Viewports

Orientation

Y Up

プラスのY軸が上方向を指すHoudiniの標準の方向です。

Z Up

プラスのZ軸が上方向を指す右手座標系の方向です。

Tumbling Method

Standard Houdini Tumbling

標準のHoudiniのディスプレイのタンブルのメソッド(を使用)です。これはタンブルがマウスに接続されているかのように回転し、スクリーン上の同じ位置に戻すと、以前の位置と同じ状態に戻ります。これは、ほとんどのユーザで直感的に操作できます。

Classic Houdini Tumbling

典型的なタンブルのメソッドで、回したい方向と逆方向に小さい円を描くようにマウスを動かします。そうすればマウスで動かしている方向とは逆に連続して移動するタンブルの方向がわかるでしょう。これは、一度コツを覚えてしまえばタンブルでより多くの制御が実際には可能です。

80's Style Euler Tumbling

80’s Style Eulerタンブルのメソッドです。これはほとんどの人に好まれています。

90's Style Euler Tumbling

垂直にタンブルしても、Y軸でロックされませんが、右にタンブルすると、モデルが逆さまに表示されます。 これにより、固定されたUp方向を維持したまま、より流体の制御が可能になります。

Use Alt Key for View Controls

Altキーを使って、タンブル、ドリー、トラック、ティルト、ボックスズームをすることができます。詳細は、シーンのビュー操作を参照してください。

Panning Method

Move Pivot when Panning

ビューポートの回転基準となるピボットは常にビューポートの中心になります。これは、ジオメトリを外側にパンしても変わりません。

Maintain Viewport Pivot when Panning

ビューポートの回転基準となるピボットは該当するジオメトリ周りに維持されます。これはジオメトリをビューポートの中心から遠ざけた時でさえも維持されます。

Default Tumble Pivot

新しいビューアのデフォルトのタンブルの挙動を決定します。

Keep Pivot on Tumble

タンブルは、現行ビューピボットを使用します。

Set Pivot on Tumble

タンブルは、ビューピボットをタンブル操作開始時のマウス下にジオメトリがあれば、そのジオメトリ上に設定します。 なければ、ビューピボットをそのままにします。

Default Dolly Direction

新しいビューアのデフォルトのドリーの挙動を決定します。

Dolly along View Direction

ビュー方向にカメラを動かします。

Dolly along Projected Direction

ドリー操作開始時のマウス位置から投影された方向に沿ってカメラを動かします。

Default Zoom Center

新しいビューアのデフォルトのズームの挙動を決定します。

Zoom about View Center

中心を基準にビューをズームします。

Zoom about Mouse Position

ズーム操作開始時のマウス位置を基準にビューをズームします。

Default Homing Method

Homeホットキーを入力したときの動作を設定します。デフォルトのObliqueでは、これは45度の値を持ちます。

Wire Toggle Mode

シェーディングモードを変更することができます。ビューポートでWホットキーを押すと、この設定と同じシェーディングモードになります。

Delay Inactive Viewport Redraws

このオプションをオンにすると、Houdiniは4面ビューで非アクティブなビューポートの再描画を遅らせます。4面ビューでは1つのビューがアクティブで、それ以外は非アクティブです。アクティブビューポートでアクションを実行すると、積極的に更新が行なわれ、非アクティブビューポートはそれに遅れて更新されます。アクティブビューポートを完全に更新した後に、非アクティブビューポートが再描画されます。このオプションをオンにするとパフォーマンスが改善されます。

Highlight component under mouse when selecting

ビューポートでマウス下のコンポーネントのハイライト表示を無効にすることができます。

Shelves and TAB Menu

Tool History Length

Tabメニューで使用したアイテムの履歴を保持する数。

Tab Menu Operator Namespace Filtering

Tabメニューに表示する同じオペレータのバリアントを指定します。オペレータのバリアントは同じ基本オペレータ名を共有しますが、スコープ、ネームスペース、バージョンが異なります。

Show All Operators

利用可能なオペレータのバリアントすべてを表示します。

Show Only Operators with Preferred Versions

いくつかのオペレータのバリアント(指定したオペレータに定義した各ネームスペース毎に1つ)を表示します。各ネームスペースに対して、オペレータバリアントは優先バージョン(通常は一番高い番号)を表示します。

Show Single Operator from the Preferred Namespace

オペレータの1つのバリアントのみを表示します。表示されるバリアントは、最優先のネームスペースのバリアントです。この優先度はHOUDINI_OPNAMESPACE_HIERARCHY環境変数で設定することができます。同じネームスペースでバリアント候補がいくつかあれば、優先バージョンが使われます。

Takes

Allow Auto Take Mode for Locked Assets

自動テイクモードでロックしたアセットの内容を編集して、現行テイク内の内部パラメータを上書きすることができます。

Note

このパラメータは自動テイクモードに影響があり、通常モードではテイクしません。

Animation

Keying

Auto-Key: Add Keyframes on Parameter Change

チェックがオンの場合、パラメータを変更すると直ぐにキーフレームに反映されます。

Auto-Key Tuples Parameters

このチェックボックスがオンで、Auto-Keyが有効な時、すべてのタプルパラメータにキーフレームが挿入されます。これは、マニピュレータを使用してアニメーションする時に非常に重要です。

Auto-Commit: Save Parameter Change at Keyframes

キーフレーム上のパラメータを変更すると、新しい値が自動的にそのキーフレームの値になります。そのため明示的に値をキーする必要がありません。

Set Auto-Add to Channel List Flag when Creating Channels

チャンネルを作成した時にチャンネルリストへのAuto-Addフラグを自動的に有効にします。これは、 Add Parameters with Animation では物足りない上級ユーザ向けです。

Set Additional First Key at Frame

最初に(キーフレームが未設定の状態)キーフレームを追加する時、指定したフレーム(通常はフレーム1)にもキーフレームが追加されます。空っぽのままにすると、キーフレームが余分に追加されません。

1に設定すると、Houdiniの古いバージョン(H6以前)の挙動に近づけます。これは自動的に最初のフレームにキーを追加します。

Global Set Key

Set Keys on Pending Channels

変更のあったチャンネルにキーを設定します。

Set Keys on All Channels

チャンネルリスト内のチャンネルすべてにキーを設定します。

Set Keys on Selected Channels

チャンネルリスト内の選択チャンネルにキーを設定します。

Initial Segment

Default / Rotation Function

ここで指定したタイプ(例:cubic)が最初のセグメントのデフォルト補間になります。また回転で使うデフォルトの関数も設定することができます。

Added Segments

Auto Function

追加したキーフレーム間で最良の関数を自動的に決めようと試みます。無効の場合、キーフレームを追加すると、ここで指定したタイプのセグメントを挿入します。

Auto Slope

チャンネルの入力側・出力側の傾斜を自動的に合わせようと試みます。無効の場合、キーフレームを追加すると、新規セグメントの傾斜が指定した値に設定されます。

Hold Last Key

チャンネルの最後のセグメントにキーフレームを追加すると、最後のセグメントが最後のキーフレームとアニメーションの終わりの間が同じ値になるように修正されます。このパラメータを有効にすると、最後のセグメントの補間を変更することなくキーフレームを繰り返して挿入することができます。

Animation Editor and Motion FX Viewer

Update Channel List When Nodes are Selected

選択ノード(s)のパラメータがチャンネルリストに追加されます。

Add Parameters With Auto-Add to Channel List flag

autoaddとしてマークされた選択ノード(s)のパラメータがチャンネルリストに追加されます。

Add Parameters With Animation

このチェックボックスを有効にすると、アニメーションを持ったパラメータがチャンネルリストに追加されます。 auto-addフラグを設定することも手動でチャンネルを追加することもなく、選択ノードにアニメーションパラメータがあるかどうか簡単に確認することができます。

Add Parameters from Descendants

このチェックボックスを有効にすると、選択ノードとその子ノードすべてのパラメータがチャンネルリストに追加されます。

Add Parameters from Constraints

このチェックボックスを有効にすると、選択ノードとその拘束ノードすべてのパラメータがチャンネルリストに追加されます。

View Overridden Parameters in Motion FX View

CHOPで現在上書きされている選択ノードのパラメータをMotion FX Viewペインに表示します。

When Parameters are Added to Channel List

Keep Channel List Selection

ノードを再選択する時にチャンネルリスト選択を維持します。 オフの時、チャンネル選択状態がリセットされて、自動選択フラグの状態に戻ります。

Open Animation Editor if Closed

有効にすると、デスクトップ内で現在アニメーションエディタが表示されていなければ、新しいアニメーションエディタウィンドウが開きます。

Follow Channel References

有効にすると、チャンネルリストがチャンネル参照とCHOPエクスポートに追従します。 このチェックボックスをオフにすると、グラフエディタ内にエクスプレッションの結果が表示されますが、何もキーフレームを編集することはできません。

Underline in the Parameter Editor

チャンネルリスト内のパラメータがパラメータエディタ内で下線付きで表示されます。

Use Channel Color

チャンネルリスト内のパラメータがチャンネルカラーと同じ下線カラーで表示されます。

Lighting

これらのプリファレンスは、LOPネットワークでのUSDの扱い方に関連しています。

Display Options

Load Payloads by Default in New LOP Networks

新しくLOPネットワークを作成する時に、デフォルトでそのLOPネットワークがペイロードをビューア内にロードするように設定するかどうかを指定します。

いつでもScene Graph Treeペイン内で個々にペイロードをロードまたはアンロードに変更することができます。 とはいっても、非常に膨大/複雑なUSDファイルを扱う場合、これを無効にした方が良いでしょう。 そうすることで、レイヤーを参照した時に、すべてのペイロードがデフォルトでアンロードになります。 これを有効にした状態で非常に複雑なレイヤーを参照すると、手動でペイロードをアンロードにしない限りHoudiniが重くなります。

Note

Payloads can be unloaded an opinion the USD level, as authored by a Configure Stage node, and also at the viewer level, as controlled by the Load column in the scene graph tree. This option only affects the viewer level.

Tip

See the Loft Payload Info LOP for how to store metadata about payloads (when they are loaded) so when they are unloaded you can still see their type and bounding box.

Panes Follow Current Node

Panes other than the viewer, such as the scene graph tree, follow the current (selected) LOP node rather than the LP node with the display flag.

Panes Show Viewport Stage

You can create overrides in the scene graph tree pane, such as toggling visibility. These overrides, indicated by a red dot in the pane, only affect an internal "viewport stage" used by the viewer, overlayed on the "real" stage. When this is off (the default) other panes (such as the scene graph details pane) show the state of the "real" USD stage, not the "viewport" stage. For example, when this is off, if you hide a prim from the viewer using the scene graph tree, the details pane will still show it as visible.

Turn this on to have the other panes show the state of the overlayed viewport stage, rather than the underlying stage constructed by the network.

Use Simplified Linker Interface

Displays a simpler tree-like interface in the light linker and material linker, rather than the graphical card-based interface. Turn this on if you have a very complex scene with a large number of links that make the linker interface slow.

Display Resolved Layer Paths

When this is off, the scene graph layers pane shows the layer identifier as it appears in the USD. When this is on, the pane shows the "resolved" path to an actual layer file on disk, as returned by the asset resolver.

This is off by default since the file path of the layer may be less meaningful than the original identifier, which may have more user-readable information in a URI or similar format, such as an asset tag, version number, and so on.

Set Asset Resolver Context From LOP Node Parameters

When this is off (the default), Houdini gets the asset resolver context based on parameters on the LOP network.

However, in some cases the asset resolver context is most easily specified as the first layer loaded onto the stage. If your pipeline uses this style you can turn this option on.

When this is on, Reference and Sublayer LOPs that don’t have their first input connected use the file they reference/layer as the asset resolver context.

Default Authoring Options

New Primitive Path

The default path for prims, in new LOP nodes. The default expression /$OS puts the prim at the root level and names the prim after the node ($OS means the name of the current node).

It’s a good idea for people working in LOPs to edit the primitive path whenever they put down a LOP that creates a prim, because the default is not a very good general policy.

You may want to craft a different expression for your studio, or for different departments (for example, /Layout/$OS, but it’s a good idea for it to include $OS, to help avoid (but not prevent) namespace collisions.

Collections Primitive Path

In USD, collections are stored using properties on a prim. LOP nodes that create collections will generally put them on this prim (creating the prim if it doesn’t exist), though some will allow you to choose a different prim.

The default is /collections.

You may want to choose a different default place to keep collections for your studio, or for different departments.

Collection Primitive Type

If a LOP node needs to store a collection and a prim doesn’t exist at the default collection path above, the node will create it. In that case, it will create a prim of this type.

Lights Primitive Path

LOP nodes that create lights will generally put them under this prim (creating the prim if it doesn’t exist), though some will allow you to choose a different prim.

The default is /lights.

You may want to choose a different default place to create lights for your studio, or for different departments.

Transform Suffix

The default value for the Transform Description parameter on Transform LOP nodes. This value is appended to the transform attribute name. The default is $OS (the node name), to avoid collisions of attributes created by different nodes. Collisions can cause unexpected results, where the Transform node overwrites an existing transform rather than creating a new one.

A studio may want to customize this based on their own transform attribute naming conventions.

Default Metrics

Use USD Standard Default Meters Per Unit

When this is on, new LOPs get their "meters per unit" value from the current Houdini unit length preference (usually 1 unit = 1m). (You can override this on a given layer using a Configure Layer LOP.)

When this is off, you can specify a different "meters per unit" value below as the default for new layers.

Default Meters Per Unit

When Use USD Standard Default Meters Per Unit is off, this is the value to use as the default "maters per unit" setting on new layers. (You can override this on a given layer using a Configure Layer LOP.)

Use USD Standard Default Up Axis

When this is on, Houdini uses the USD API to get the default "Up Axis" value.

When this is off, you can specify an axis below to use as the default for new layers.

(The USD API usually returns Y as the default up axis, but users/studios can override this using an entry in a plugInfo.json file loaded by the USD plugin system.)

Default Up Axis

When Use USD Standard Default Up Axis is off, the default axis to set as the up-axis on new layers.

Rendering

Available Render Nodes

Houdiniで利用可能なレンダーノードがリスト表示されます。ここで利用するレンダーノードの有効・無効の設定をします。HOUDINI_DEFAULT_RENDERERS環境変数での優先度を上書きすることが可能です。上書きしたレンダーノードはプリファレンスではグレー表示になります。このリストで有効になっていないレンダーノードがシーン内に存在すると Enabled By の項目で一時的に有効な状態であることが記されます。その仕組によって有効になったレンダーノードは、セッションからセッションに切り替わってもプリファレンスには影響を与えません。

Make All Render Nodes Available in Tool Palette and Tab Menu

有効にすると、すべてのレンダーノードが出力ドライバツールパレットとタブメニューに表示されます。無効にすると、 Available Render Nodes で選択したレンダーノードのサブセットのみが表示されます。

Handles

Hide Locked Handle Parts

ロックしたハンドルパーツを表示しないようにします。既存のハンドルに影響を与えるにはファイルを再読み込みする必要があります。

Color Transform Handles By Axis

このオプションをオンにすると、3Dビューアのトランスフォームハンドルの各軸が別々の色で表示されます。

Keep handle alignment when reselecting

このオプションをオンにすると、3Dビューアのトランスフォームハンドルが、別のオブジェクトを選択した時に同じ方向を保持します。

Default Handle Alignment

3Dビューアのトランスフォームハンドルの初期方向を決めます。

Object

ローカル空間に揃えます。

World

ワールド空間に揃えます。

View

ビューに揃えます。

Parent Object

オブジェクトの1番目の入力に揃えます。

C-Plane

コンストラクション平面に揃えます。

Handle Scale

ビューポートの固定サイズハンドルをスケールします。

Pick Distance (Pixels)

マウスカーソルがハンドルをピックして操作できるそのハンドルとの距離を指定します。

Show Negative Axes for Translate Handles

移動ハンドルの軸をマイナス方向に拡張します。

Show Planar Dragging Targets for Translate Handles

ハンドルの中心から外にドラッグ可能な小さい移動平面を表示します。

Allow Planar Dragging of Translate Handles Between Axes

3Dビューア内の移動ハンドル軸間のドラッグ平面が選択できるようになります。

Prefer Planar Dragging Between Axes Over Back Facing Axes

ドラッグ平面をドラッグする時に間違えてドラッグ平面の後方にある移動矢印を選択しないように、その後方の移動矢印を無効にします。

Allow Dragging of Rotate Handles Between Rings

移動ハンドルが利用できない時に、3Dビュー内の回転ハンドルのリング間をクリックしてドラッグできるようになります。 これにより、3軸すべてを同時に回転させることができます。

Allow Indirect Handle Dragging with MMB

ハンドル自体をドラッグしなくても、でハンドルをドラッグできるようになります。

すべてのハンドルが、このオプションに対応しているわけではありません。複数のハンドルを表示させた時、このオプションに対応したマウスカーソルに一番近いハンドルが選択されます。

Translate Handle

移動ハンドルを使った間接ドラッグの挙動を制御します。

Map Drag to Axis

マウスの動きにうまく一致させながらハンドル軸に沿ってドラッグします。

Map Drag to Construction Plane

基準平面上をドラッグします。基準平面が表示されていない時のデフォルトはビュー平面です。

Map Drag to View Plane

基準平面の表示の有無に関係なく、ビュー平面上をドラッグします。

Spider Handle

ジョイントで利用可能なスパイダーハンドルを使った間接ドラッグの挙動を制御します。

Map Drag to Axis

マウスの動きにうまく一致させながらハンドル軸に沿ってドラッグします。

Map Drag to Construction Plane

基準平面上をドラッグします。基準平面が表示されていない時のデフォルトはビュー平面です。

Map Drag to View Plane

基準平面の表示の有無に関係なく、ビュー平面上をドラッグします。

Prefer Indirect Translate Over Indirect Rotate

移動と回転の両方のパラメータを表示するハンドルの間接ドラッグで行なわれる操作を制御します。

Prefer Indirect Translate Over Indirect Vector Rotate

移動とベクトル回転の両方のパラメータを表示するハンドルの間接ドラッグで行なわれる操作を制御します。

Prefer Indirect Translate Over Indirect Scale

移動とスケールの両方のコンポーネントを表示するハンドルの間接ドラッグで行なわれる操作を制御します。

Hide Rotate Handle Rings Parallel to the View Direction

このオプションをオンにすると、回転ハンドルは、現行ビュー方向に平行なリングを非表示にします。このオプションをオフにすると、移動軸を持たない回転ハンドルのみに効果があります。

Show View Axis Ring for Rotate Handles

このオプションをオンにすると、現行ビュー軸を基準に回転させるための外側リングが回転ハンドルに描画されます。

Default Transform Handles to Gimbal Mode

このオプションをオンにすると、3Dビューアでの回転ハンドルの初期モードがジンバルモードになります。ジンバルモードでは、回転サークルハンドルは常に整列した状態なので、それらのハンドルを操作すると、個々の軸の回転角度だけに影響を与えることができます。

Default 2D Orientation Handle Transform is Global

この設定は、Lights and Camerasの操作で使用する方向ハンドルに影響があります。ハンドルの操作には、ローカル空間またはグローバル空間の2通りがあります。

この設定をオンにすると、デフォルトモードがグローバル空間になります。ローカル空間で操作するには、ハンドル操作時に⇧ Shiftキーを押したままにします。この設定をオフにすると、デフォルトモードがローカル空間になり、グローバル空間で操作するには⇧ Shiftキーを押す必要があります。

Open Animation Editor If Closed When Scoping From Handles

ハンドルからスコープする時、新しいAnimation Editor(まだ開かれていない場合)が開きます。

Add to Channel List When Setting Keyframes

Do not Modify Channel List

チャンネルリストの内容を変更しません。

Add to Channel List

既存チャンネルを維持しつつチャンネルリストにチャンネルを追加します。

Isolate in Channel List

既存チャンネルを入れ替えてチャンネルリストにチャンネルを追加します。

Scale Handle Style

スケールハンドルのスタイルを切り替えます。

Cloverleaf

移動ウィジェットを組み込み可能な従来のHoudiniの丸みの付いたボックスのスケールハンドル。

Axis

一部のユーザに馴染みのあるより単純なスケールハンドルですが、移動ウィジェットを組み込むことができません。

Interactive Tools

Use Cook Selection to Update Geometry Selection Type in SOP States

SOPツールがコンポーネント選択タイプをそのツールが操作するコンポーネントのタイプに合うように更新するかどうかを指定します。

あるコンポーネントタイプ、例えばエッジを選択している時に、ノードがそのエッジ選択を受け取り、別のタイプ、例えばフェースを出力すると仮定します。 その場合、ビューポート内でフェースが選択されますが、選択を再開すると、まだエッジが選択されたままになっています。 このオプションが有効な時、ノードがフェースを生成する場合、Houdiniは自動的に選択モードをフェースに切り替えます。

この設定を変更して、ツールをアクティブにする場合、それを反映させるには、そのツールから抜けて、再度そのツールを有効にする必要があります。すべてのツールがこの設定に対応しているわけではありません。

Automatically Turn Construction Plane On

インタラクティブツールを開始する時に、Construction PlaneがオフでReference Planeがオンの場合、Construction Planeを自動的にオンにします。

Objects and Geometry

Preferences

Highlight Object Selections in Viewport

ビューポートでオブジェクトを選択した時の視覚的な反応を設定します。

Automatic Parameter Folder Flipping when Picked in Viewer

参照が存在すれば、選択したオブジェクトの任意のチャンネルで参照される最初のパラメータを含むフォルダにパラメータペインフォルダを飛ばします。

Default Geometry Display

3Dビューアのデフォルトのジオメトリディスプレイモードを指定します。これはジオメトリ選択モードでの3Dビューアにのみ影響があります。

Show Current Operator

ジオメトリが現行(最後に選択した)ノードから表示・選択されます。

Show Display Operator

ジオメトリがディスプレイフラグが有効なノードから表示・選択されます。

Default Context Creation

デフォルトのコンテキスト作成モードを指定します。3Dビューアで、そのモードを変更するには、右上コーナーにあるアイコンを使います。

Create at Object Level

シェルフから新しくジオメトリ(例:Boxツール)を作成すると、そのジオメトリを含んだオブジェクトを新しく作成します。

Create in Context

ジオメトリが現行コンテキスト内に作成されます(例:同じオブジェクト内にジオメトリがもう1つ作成される)。

Use Existing Selection to Complete Actions

有効にすると、ツールを呼び出した時にアクションが実行できるなら既存選択を使います。

Secure Selection On by Default

デフォルトで安全な選択を有効にします。有効にすると、間違えてクリックしても選択が解除されないようになります。

Create Full Loop Selections Through Any Topology

有効な時、ビューポートで実行されるループ選択は、不正なトポロジーの領域を通過してまでも完全ループを作成します。 このオプションを無効にすると、ループは、複数の可能性のあるパスのポイントで終了します。 例えば、ポリゴンメッシュの球の長手のエッジを選択したとします。 このオプションをオンにすると、球の極座標を通過してエッジループが作成されます。 このオプションをオフにすると、ループは、その極座標で停止します。

Select Entire Subnets On by Default

有効にすると、デフォルトの挙動がコンテナノードを選択するときにサブネットを選択するようになります。

Set Highlight Flag on Viewer Generated Nodes

有効にすると、ビューア内でインタラクティブに生成したノードのハイライトフラグが有効になります。 SOPsに関しては、これは、そのノードがクック選択を作成するかどうかを制御します。 このフラグを無効にすると、クック選択が利用可能かどうかに依存したインタラクティブな挙動に影響を与える可能性があります。 例えば、コンポーネントセレクターは、ノードのクック選択からブートストラップ(自動実行)することが多いです。

Popup Menu Selection

このオプションがオンの場合、複数オブジェクトを選択している状態で3Dビューア内で位置をクリックするとメニューがポップアップ表示されるので、そこからどれを選択するのか指定することができます。

Geometry Pick Distance (Pixels)

マウスカーソルがジオメトリをピックできるそのジオメトリからの距離を指定します。

Keep Position when Parenting

Never

Neverに設定すると、オブジェクトを子にした時に、オブジェクトの位置は、ワールド座標を維持せず、親のオブジェクトからの相対的な位置に配置されます。

Always

Alwaysに設定すると、オブジェクトを子にしても、オブジェクトの位置は、ワールド座標の位置と方向を維持します(これは、オブジェクトのTransform/Rotate/Scaleパラメータを修正して行なっています)。

Use Object Flag

この設定では、個々のオブジェクトのKeep Position When Parentingパラメータに応じてオブジェクトのワールド座標を維持します。

Bone Kinematic Override

None

Noneの場合、キネマティックの上書きはありません。

IK Rest Pose

Restの場合、すべてのボーンはRest Position(静止位置)でクッキングされます。ボーンRest Position(静止位置)はInverse Kinematicsの解決方法を制御します。

Capture Pose

Captureの場合、すべてのボーンはキャプチャー位置でクッキングされます。ボーンキャプチャーはCapture and Capture Proximity SOPによってスキンジオメトリをキャプチャーする時に使われます。

Keep Position When Moving

このオプションがオンの場合、オブジェクトを移動しても、子のオブジェクトの位置と向きには何も影響を受けません。これは、子のオブジェクトのpre-transformsまたはtransformパラメータを修正して行なっています。

Read-Only Pre-Transforms

このオプションがオンの場合、オブジェクトのpre-transformsを操作することができなくなります。

SOP Caching

Cull Level

値を大きくするほど、Houdiniはキャッシュサイズを抑えようとし、速度を犠牲にしてメモリを節約するようにします。

Memory Limit

ジオメトリ変換をキャッシュ化するのに使用するメモリ量。

Unloading

Never

決してSOPをアンロードしません。

Flag

アンロードフラグが設定されているSOPのみをアンロードします。

Always

常にSOPをアンロードします。

Memory

Never

Memory Limitを無視します。

Always

Memory Limitに到達した時にSOPをアンロードします。

OBJ Caching

Houdiniは、オブジェクトのCache dataオプションを有効にした時にすでに計算済みの個々のオブジェクトに対してオブジェクト変換をキャッシュ化することができます。これは特にワールド空間座標の計算が重いようなオブジェクト(例えば、Stickyオブジェクト)、長い親子チェーンの最後のオブジェクト(例えば、Bones)で役に立ちます。このオプションはStickyとBoneオブジェクトではデフォルトでオンになっています。

Memory limit

オブジェクト変換をキャッシュ化するのに使用するメモリ量。

Enforce Limit

Houdiniが Memory Limit に従うが否か制御します。

Clear cache

直ぐにキャッシュを空っぽにします。

Tip

個々に Cache data オプションを設定しないで、オブジェクト全てに対してキャッシュ化をオフにするには、Memory Limitを0に設定して、 Clear Cache をクリックします。

Tip

objcacheコマンドをHScriptで使うことでOBJキャッシュを管理することができます。

Particles

Skip Particle Info Generation (Faster)

POPタイルの情報ポップアップ(タイル上でクリック)の生成を止めます。これによって、より多くの情報を取得できなくなりますが、パーティクルシミュレーションを高速化することができます。

Motion and Audio

Maximum Time Slice Size (Frames)

このオプションでは、フレーム単位によるTime Sliceのサイズを制限することができます。デフォルトの最大は60フレームです。これは履歴の数フレームだけを必要とする場合に役に立ち、そして、プレイバーは大きな間隔で前にジャンプします。Time Sliceが、この最大サイズより大きい場合、現行フレームから後へクリップされます(このスライスと前のスライスにギャップが生じるので)。スライスは常に現行フレームで終わります。

Enable Time Slice Flag when Creating CHOP

CHOPをレイアウトエリアに配置する時のデフォルトの挙動を設定します。

このオプションがオンの時に作成されたTime Slice機能付きのCHOPすべては、デフォルトでTime Sliceフラグが有効になります。オフの時は、Time Sliceフラグは無効になります。大きなTime Sliceのネットワークを作成して処理するときは、このオプションをオンのままにするのが良いです。このオプションはデフォルトではオフになっています。

Minimal Time Slice Cooks

Time SliceのCHOPのいくつかは、フレーム毎のクッキングとは違い、クッキングを最小にすることができます。クッキングが不要な時、または同じ出力を生成する時は、これらのCHOPは入力が変わるまでクッキングを停止します。

この機能を持つCHOPは以下の通り:

  • Copy chop

  • Count chop

  • Envelope chop

  • Lag chop

  • Spring chop

  • Trigger chop

最小クッキングは、これらのTime SliceのCHOPが一定ではないCHOPの入力や時間依存のCHOPの入力を持っていれば、適用されません。このオプションはデフォルトではオフです。これは操作性と独立した入力またはイベントに反応するCHOPネットワークを高速化することができます。

Compositing

Cache

Interactive Cache Size

タイルキャッシュのサイズをMBで設定します。コンポジターを常に使用するのであれば、この値を非常に大きな値に設定するべきです(256MB以上でシステムで利用可能なメモリの半分)。これはインタラクティブアプリケーションにのみ適用されます。

Non-interactive Cache Size

タイルキャッシュのサイズをMBで設定します。これはコンポジターをインタラクティブに使わない時(hbatch、hython)に使います。

Reduce Cache Size when Idle

Houdiniのようなインタラクティブアプリケーションでは、コンポジターが短い時間(5分)でアイドル状態になると、キャッシュをこのサイズにまでゆっくりと下げます。これによって他のアプリケーションで使用できるメモリを解放することができます。

Clear Cache

コンポジットキャッシュすべてをクリアにします。

Cooking

Multi-threaded Cooking

オンにすると、マルチスレッド処理が有効になります。オフにすると画像の処理(メインのHoudiniプロセス)は1個のスレッドだけで使われます。

Threads

クッキングで使うスレッドの数を指定します。1に設定すると、メインのHoudiniスレッドのみが画像を処理します(Multi-threaded Cookingをオフにするのと同様)。マルチプロセッサーコンピュータをフルに使用するには、プロセッサーの2倍の数でたくさんの処理スレッドを使ってください。

Use GPU to Assist Compositing

あるCOPではOpenGLを使ってアクセラレーションすることができます。このプリファレンスの変更を反映するには、Houdiniを再起動する必要があります。以下のCOPがアクセラレーションの利用が可能です。*のマークが付いたCOPはアクセラレーションの効果が大きいです。

  • モーションブラー*を含む、2Dトランスフォーム

  • フォグ(ノイズのあるフォグ*)

  • Zコンポジット

  • ライティング(すべて、ボリューム*)

  • 環境マップ

  • 全ての基本カラー補正(輝度、ガンマ、カラーカーブ、HSV、色相カーブ*、カラー補正など)

  • Expand*

  • Convolve*

  • Deform*

  • Corner Pin & Unpin

  • Noise(perlin、imp. perlin、sparse*、alligator*、no random)

Use Collapsible Pixel Operators

オンにすると、直列の折り畳み可能なピクセルオペレータ(青いCOPs)を1つのオペレーションに結合されます。オフにすると、それらのオペレータはすべて個々に処理されます。

Tile Size

タイルのサイズ。画像がこれらのタイルに分割されて、まとめて処理されます。常に特定の解像度で作業していれば、水平・垂直の解像度を正確に分割するタイルサイズを指定したい場合があります。この値を変更すると、すべてのキャッシュをクリアします。タイルの中は最低でも1024ピクセル必要です。

Resolution Limit

コンポジターの最大解像度を指定することができます。

Interactive

Cook Displayed Operators on Startup or Load

このオプションをオンにすると、hipファイルをロードした時に、まず最初に表示するCOPを処理します。このオプションをオフにすると、それらのCOPは処理されないでビューポートがブラックのままになります。

Use Fast Interactive Cooking

オンにすると、画像の解像度はインタラクティブに編集している間(ハンドルのドラッグ、スライダやXCFスライダのスライディング)は自動的に低解像度にスケールダウンします。これによって品質を犠牲にして、より高速な反応が得られます。オフにすると、画像は標準の解像度で処理されます。

Only Use Fast Cooking On Slow Operations

オンにすると、高速オペレーション(例えば、Bright、Gamma、Timing COP)はインタラクティブに画像をスケールダウンしません。オフにすると、すべてのオペレーションがユーザ操作中に画像をスケールダウンします。

Use Fast Cooking on Images Larger Than

ユーザ操作中にダウンスケールする画像の低解像度の限度を設定します。この制限よりも画像が小さくなるとダウンスケールしなくなります。画像が、このプリファレンスのアスペクト比に一致しない場合、画像のピクセル数が比較されて、限度として使われます。

Interactive Rendering Fraction

ダウンスケール係数を指定します。係数を小さくするほど画像品質を犠牲にしてユーザ操作中の更新がより速くなります。

Cooking Feedback

1枚の画像の処理中に受け取るフィードバックのタイプを設定します:

None

画像の処理が終わるまで何も更新しません。

Progress Bar

画像ビューアの上部にあるプログレスバーが画像処理中に定期的に更新します。

Image Update

処理中の画像を含んだビューポートを定期的に更新し、実際の処理状況を表示します。これはわずかにパフォーマンスの影響があります。

Selectors

Never Prompt for Optional Inputs

オンの場合、最低限の数のソースが接続されると、入力選択が完了したものと見なされます。Always Placeオプションを指定すれば、COPはすぐに選択したビューポートに配置されます。

Never Prompt for a Generator’s Input(s)

オンの場合、ジェネレータの入力が決してプロンプトされません。

Always Place the New COP in the Current Viewport

オンの場合、すべての入力の選択が完了すると、COPが目的のビューポートをプロンプトしないで現行ビューに配置されます。

Always Place New Generators in a New Viewport

オンの場合、ジェネレータは利用可能であれば(そうでなければ現行ビューポートが使われます)、新しいビューポートに追加されます。オフの場合、目的のビューポートがプロンプトされます。

Names

このページでは共通の平面タイプの名前をカスタマイズすることができます。デフォルトの名前は英語の平面の名前の頭文字で、大文字です。これらの名前はスコープフィールドや平面リスト、VEXスクリプト、Houdini.picファイルの出力で使用される名前です。

Colors

COPはファミリータイプで色付けすることができます。そのファミリー内の新規COPは、そのタイルをファミリーカラーに色付けして、識別しやすくなります。

Enable COP Auto Coloring

すべてのCOPタイプに対して、この機能を有効・無効にします。あなたにとって重要でないファミリータイプは個々に無効にすることもできます。

Generators

すべてのジェネレータに対する色。ジェネレータは入力を受け取り、平面を"インライン"(ネットワークの途中で)で生成することができるので、これは作成またはマスクされるネットワーク平面内の場所を特定するのに役に立ちます。

Pixel Functions

すべての折り畳み可能なピクセルオペレーションに対する色。折り畳み可能なピクセルオペレーションはチェーンをグループにしたときのみ機能するので、これらのタイプのオペレーションを最適化するのに役に立ちます。

Timing

すべての時間関係のオペレーションと画像に関係しないオペレーション(例えばMergeやDelete)に対する色。これらのオペレーションは通常は画像をクッキングせず、またはキャッシュメモリを使用しません。これは大きなネットワーク内で時間の変化を突きとめるのに役に立ちます。

VEX

すべてのVEXベースのオペレーションに対する色。VEX COPは、VEXスクリプトのパラメータ名に一致するすべての平面の名前がピクセル単位基準で、それらのパラメータを上書きする特性を持ちます。つまり、これらのCOPを認識することが重要です。

Cineon

このページでは、すべての新規File COPとCompositor出力ドライバのCineonパラメータすべてのデフォルト値を定義します。また、Cineonファイルをロードまたはこれらの2つのコンテキスト外(例えば、Save Image…COPタイルメニューから)に保存する時に使われるCineonパラメータも定義します。Cineonファイルの拡張子は、.cinです。

Convert from 10 bit Log

オンの場合、Cineonファイルが線形空間に変換されます。オフの場合、Cineonファイルは10ビットの対数空間(0 - 1024の範囲の値)のままになります。

LUT File

10ビットCineon変換を含む LookUp Table ファイル(.lut)。このファイルは手動またはスタンドアローンのCineonやilutツールを使って作成します。

Black Point

リニアカラー空間に変換される時にブラックにマッピングするCineonの値(0-1023)。これと White PointFilm Gamma がCineonファイル(.cin)をロードした時に使われます。これは LUT File フィールドが指定されていない時にのみ影響があります。指定されていれば、変換にはLUTが使われます。

White Point

Cineonのホワイトポイントで、90%の画像の明度を意味するCineon値(0-1023)を定義します。このパラメータはLUTが指定されていれば使われません。

Film Gamma

Cineonフィルムガンマで、Cineon空間を線形画像空間(コンポジターが操作する空間)に変換するときに使用するガンマを定義します。このパラメータはLUTが指定されていれば使われません。

Scripting

Expression Language

hscript

新規ノードのデフォルトエクスプレッションをHScriptに変更します。

python

新規ノードのデフォルトエクスプレッションをPythonに変更します。

Parameter Fields

パラメータエディタに配置されているようなパラメータの入力ボックス。

Syntax Highlighting

テキストの色付けを有効にすることで、構文の区別をしやすくします。

Parenthesis and Quote Matching

括弧や引用符にマウスカーソルを移動させた時に、それに呼応する括弧や引用符をハイライトします。 これによって、複雑なエクスプレッションの開始位置と終了位置だけでなく、適切に閉じているかどうかが分かりやすくなります。

Context Sensitive Popup Help

有効な関数名またはオペレータパスのタイピングを開始した時に、その候補となる補完名を表示します。 また、その関数のパラメータに関するヘルプも表示します。

Edit Strings and Expressions using External Editor

パラメータのコンテキストメニューからEdit StringコマンドやEdit Expressionsコマンドを実行、または、マウスカーソルをパラメータフィールド上に置いてAlt+Eを実行すると、EDITOR環境変数で設定されている外部テキストエディタが直接開きます。 この外部テキストエディタを終了させない限りHoudiniはブロックされます。

Text Editors

Edit Commentsに配置されているような複数行のテキストエディタ。

Syntax Highlighting

テキストの色付けを有効にすることで、構文の区別をしやすくします。

Parenthesis and Quote Matching

括弧や引用符にマウスカーソルを移動させた時に、それに呼応する括弧や引用符をハイライトします。 これによって、複雑なエクスプレッションの開始位置と終了位置だけでなく、適切に閉じているかどうかが分かりやすくなります。

Editor Toolbar

テキストエディタの上部にツールバーを表示します。

Textport

Textport

Syntax Highlighting

構文の違いがわかるようにテキストカラーを有効にします。

Parenthesis and Quote Matching

カーソルを移動した時に一致する括弧や引用符をハイライトします。これは、括弧や引用符が適切に書かれているのか、また複雑なエクスプレッションの前と後が合っているのかわかります。

Context Sensitive Popup Help

有効な関数名またはオペレータパスをタイプしている時に、候補となる名前を表示します。関数のパラメータに関しても用意されています。

Desktops and Toolbars

Save Desktops Automatically

デスクトップ内のペインに変更があれば、自動的に保存されます。

Show Hidden Files

非表示としてマークしたファイルを表示します(ファイル名がピリオドで始まる)。

Show All Files

ファイルのタイプに関係なく、すべてのファイルを表示します。

Path Menu Behavior

常にプロンプト(デフォルトの挙動)されるのではなく、Desktop Managerウィンドウを開いて、デスクトップの位置を切り替えるドロップダウンメニューを使う時のパスメニューの挙動を定義します。

Save and Load Options

Save Method

Overwrite File

hipファイルの現在の状態で開いた既存ファイルを上書きします。

Increment Filename

有効にすると、番号を含んだファイルの名前で、その番号がファイルを保存する度に上がります。これはSave Asではなく、Saveのみで機能します( Scripting の章で mwrite コマンドの -i オプションも参照してください)。

Make Numbered Backup

この設定をすると、.hipファイルのファイル名は変わりませんが、バックアップファイルが番号を上げて作成されます。デフォルトのバックアップディレクトリは./backupで、バックアップファイルの名前の後に_bak{num}が付きます。

Save View Commands For

このプリファレンスはファイルの肥大化を減らすのに役に立ちます。

All Viewers

すべての既存ビューアのビューコマンド(現在の開閉の状態)、まだ作成していないビューの隠れビューコマンドを保存します。

Existing Viewers

すべての既存ビューアのビューコマンド(現在の開閉の状態)を保存し、まだ作成していないビューの隠れビューコマンドを保存しません。

Open Viewers

現在開いているビューアのビューコマンドのみを保存します。

Auto Save Every Minutes

自動保存機能の間隔を指定します。

Auto Save Method

Overwrite File

hipファイルの現在の状態で、開いた既存ファイルを上書きします。

Increment Filename

有効にすると、番号を含んだファイルの名前で、その番号がファイルを保存する度に上がります。

Make Numbered Backup

この設定をすると、.hipファイルのファイル名は変わりませんが、バックアップファイルが番号を上げて作成されます。デフォルトのバックアップディレクトリは./backupで、バックアップファイルの名前の後にauto{num}が付きます。

Note

Edit メニューの Auto Save チェックボックスをオンにして自動保存を有効にする必要があります。 Auto SaveはHoudiniを起動すると、自動的に無効になります。その理由は、Houdiniが遅くなり、意図しないでその設定のままになっているとディスクスペースを多く占有してしまうからです。セッション毎に手動で有効にしなければなりません。

Warn About Deprecated Operators

有効にすると、Houdiniは、廃止予定にマークされているオペレータを使用しているノードのリストと一緒に警告ダイアログボックスを開きます。 そのような警告を表示させたくない場合は、これをオフにします。

Note

廃止予定にマークされているオペレータは、将来のバージョンのHoudiniで削除される予定です。

Hip File Options

Unit Length

Houdiniの1単位の長さをメートルで指定します。この値は、単位固有のDOPパラメータで使われます。

Unit Mass

Houdiniの1単位の重さをキログラムで指定します。この値は、単位固有のDOPパラメータで使われます。

Note

Houdiniの1単位の時間は常に1秒です。

Notifications

Notification Area

エラー、警告、プロンプトなどの通知とヘルプのTipsをビューポート内に直接表示するか、ステータスバーに表示するかどうか指定することができます。 ビューポート関連のメッセージのみがビューポートに表示されます。Cookメッセージと進捗に関してはステータスバーに報告されます。

Viewport

ビューポートの下部に通知が表示されます。

Status Bar

Houdiniのメインステータスバーに通知が表示されます。

Help Tip Area

単にヘルプのTipsとして動作し、アクションを指示せず、または警告やエラーをレポートしない通知を、他の通知とは別に扱うことができます。

Viewport

ヘルプのTipsをビューポートの下部に表示します。

Status Bar

ヘルプのTipsをHoudiniのメインステータスバーに表示します。

Suppress

ヘルプのTipsを表示しません。

Echo Hotkey Commands

ホットキーで実行されるコマンドのアクションをビューポートやステータスバーに表示します。

Message Time Limit

このオプションを有効にすると、ヘルプのTips、メッセージ、ホットキーが短い間で表示されます。 無効にすると、次のメッセージが表示されるまで表示されます。 表示の時間も指定することができます。

Warning Dialogs

このウィンドウ内のオプションは警告のオン・オフを切り替えることができます。デフォルトでは、すべての警告ダイアログがオンになっています。

Performance Options

Percentage Thresholds

ここでは、パフォーマンスモニタを使用するときにノードの相対的な処理時間を表示するのに使用するカラー値を設定します。

ランプの使い方の詳細は、ランプパラメータを参照してください。

External Tools

File Compare

外部のGUI比較(diff)プログラム。

Executable Path

実行ファイルのフルパス。

Command Line Arguments

これは、外部の比較(diff)プログラムを起動する時に使用する引数です。 以下の変数は、そのコマンドラインを構築する時に使用することができます:

$OLDPATH

(必須)'古い'ファイルのパスに置換します。これが'左側'のファイルとして扱われます。

$NEWPATH

(必須)'新しい'ファイルのパスに置換します。これが'右側'のファイルとして扱われます。

$OLDTITLE

一時ファイル名の代わりに、左側に使用するタイトルに置換します。

$NEWTITLE

一時ファイル名の代わりに、右側に使用するタイトルに置換します。

Folder Compare

フォルダの比較に対応した外部のGUI比較プログラム。詳細は、File Compareを参照してください。

Miscellaneous

Restrict Web Browser to Safe Commands

Houdiniの組み込みウェブブラウザから実行可能なHScriptコマンドを制限します。 このオプションをオンにすれば、悪意のあるプログラムがHoudiniを通じてコマンドが実行されることを防止することができます。

Use External Help Server

Houdiniの組み込みブラウザではなく、システムのデフォルトのウェブブラウザでHoudiniヘルプドキュメントが開きます。

Reserve MB for the Undo System

HoudiniのUndoシステムで使用するメモリ量を指定します。割り当てるメモリ量が多いほど、Houdiniがより多くのUndoができます。

Delete Channels When Reverting to Defaults

Revert to Defaultsオペレーションを実行すると、変更したパラメータのチャンネルが削除されます。

Revert Invisible Parameters to Defaults

不可視パラメータがRevert to Defaultsオペレーションによって影響を受けるか否か指定します。

Make Spare Parameters for Unknown Channels

このオプションをオンにすると、あなたのHoudiniのバージョンに存在しない特別なパラメータの値を保持するためにSpareパラメータ(ユーザパラメータ)が作成されるので、ビットバケット(データを破棄する仮想上の場所)にその特別なパラメータを破棄せずに、何が変わったのか確認でき、その値を復旧することができます。これは、古いバージョンのhipファイルや古いノードを含んだOTLを読み込む時に役に立ちます。しかし、廃止されたパラメータで混乱したくないのであれば、このオプションをオフにします。

Spare/HDA Parameter Deletion

Type Propertiesでパラメータの1つを削除する時、アセット内のパラメータがそのパラメータを指している場合があります。

デフォルトは、Automatically Delete all Referencesです。Automatically Delete only Simple Channel Referencesは、参照をいくつか残す保守的なJOBをして、複雑なエクスプレッションをあまり破壊しません。Do Not Automatically Delete any Referencesは、ぶらさがっている参照をそのままにしますが、エクスプレッションが影響を受ける可能性を除去します。

ウィンドウ