Houdini 18.5 基本

プロジェクト管理

File > New Project and File > Set Projectメニューの項目からプロジェクトディレクトリを設定して、シーンファイルをプロジェクトに関連付けることができます。

On this page

概要

Houdiniのシーン(.hip)ファイルは任意の場所に保存が可能で、(シーンファイルの親パスを含む)$HIP環境変数を使用して、シーンファイルの場所に対してファイルを位置付けることができます。これにより、すべてのパスを変更しなくてもディレクトリ間やコンピュータ間でファイルの移動が可能になります。

2つ以上のシーンファイルを含むプロジェクトに対して、Houdiniは、$JOB変数を中心としたUIベースのシンプルなプロジェクト管理を提供します。

使用方法

  • File ▸ New Project のメニューから多数の共通サブディレクトリを持つプロジェクトディレクトリを作成します。このディレクトリは$JOB環境変数をそのディレクトリパスに設定します。

    これにより、レンダリングやデジタルアセット、スクリプト、シミュレーションファイルなど、プロジェクトに関連するいろいろなアーチファクトを含むサブディレクトリが、プロジェクトディレクトリに作成されます。デフォルトのディレクトリ名を使用すると、シーンファイルとプロジェクト間で一貫性を維持できます。

  • File ▸ Set Project のメニューから作業を行なうプロジェクトディレクトリを選択します。このディレクトリは、$JOBをそのディレクトリパスに設定します。 File ▸ Set Recent Project のメニューを使用して、最近使用したプロジェクトの一覧から選択することもできます。

  • $JOBは、共有プロジェクトファイルのパス(例えば$JOB/textures)で使用し、$HIPはシーン固有のファイルのパス(例えば$HIP/camera_maps)で使用します。

  • ファイルピッカーでファイルを開いたり、保存している場合、左側の$JOBをクリックすると、プロジェクトディレクトリへすぐに移動できます。これにより、選択するパスが必ず$JOBから始まるようになり、プロジェクトに対してそのパスが保持されます。

  • Render ▸ Preflight のメニュー項目を使用して、プロジェクト外のリソース(例えば、ディスク上の他の場所への明示パス)に関するリファレンスを現在のシーンファイルで探します。これらのリファレンスを$JOBまたは$HIPに関連するように修正すると、シーンやプロジェクトを移動しやすくなり、リモートシミュレーション/レンダリング用に送ることができます。

    プリフライトウィンドウから、外部のリファレンス(赤で表示)を選択し、リファレンスを含むエクスプレッションをクリックすると、その場で編集ができます。ネットワークエディタの複数のノード内でリファレンスを探し当てる必要はありません。

ヒントとメモ

  • $JOBの値は、シーン(.hip)ファイルと一緒に保存されます。したがって、指定されたシーンファイルを File ▸ Set Project でプロジェクトに関連付けて保存すると、次にシーンファイルを開く時に File ▸ Set Project のメニューを再度使用する必要はありません。

  • プロジェクトを設定しても、ロードしたシーンファイルの内容に変更はなく、$JOBの値が変化するだけです。

  • すべてのプロジェクトに共通するファイルの場所およびリソースに関して、Houdiniの慣例としては、$SITEという名前の環境変数を使用します。

基本

はじめよう

次のステップ

カスタマイズ

導師レベル