Houdini documentation through the app does not load

   3995   6   2
User Avatar
Member
8 posts
Joined: 9月 2016
Offline
Being able to open the docs through houdini with F1 is very useful, unfortunately it seems to only work the first time after I launch Houdini. Every time after, the web page load just hangs.

It seems to load a page in the browser @ 127.0.0.1:48626, but it just hangs.

I have tried using an external browser as well by setting the HOUDINI_EXTERNAL_HELP_BROWSER=1 environment variable. This does not resolve the issue (the issue is with the local webserver that houdini seems to be running).

Is there a way to fix this? It would be unfortunate if I would have to instead google for all the docs instead of using this nice feature of jumping to docs within houdini.
Edited by RodrigoSalazar - 2016年9月21日 13:42:24
User Avatar
Member
2566 posts
Joined: 6月 2008
Offline
Does Houdini behave the same way when you click on the question mark icon? I mainly select any node and then click on the question mark to bring up the help. Once in the help I type what I am looking for in the search field. I rarely use F1.
Edited by Enivob - 2016年9月21日 20:02:29
Using Houdini Indie 20.0
Windows 11 64GB Ryzen 16 core.
nVidia 3050RTX 8BG RAM.
User Avatar
Member
7754 posts
Joined: 7月 2005
Offline
Where are you hitting F1?

It works for me when I repeatedly hit F1 over different shelf tools.
Edited by edward - 2016年9月22日 07:35:52
User Avatar
Member
8 posts
Joined: 9月 2016
Offline
This bug doesn't seem to repro for me anymore. I will post an update with houdini console logs if it repros again!
User Avatar
Member
18 posts
Joined: 5月 2018
Offline
I'm having the same problem as the original poster while using Houdini Apprentice 18.0.416

Whenever I use F1 to try to bring up help, Houdini opens a window with 127.0.0.1:48626 filled in as the URL, but nothing else happens; it just stays there empty.

Sometimes Houdini will give a fuller path based on what I clicked F1 over, such as http://127.0.0.1:48626/nodes/sop/metaball [127.0.0.1] when I tried to get help with metaball from the shelf menu

I'm on a Windows 10 Pro PC. Had been using this feature without difficulty previously. I upgraded to .416 recently, but not sure if this problem happened with that update or something else.

Is there a preference I need to set? Or something with Envelope / Path (if so would appreciate details on what I need to do since haven't messed with environmental paths in quite some time and don't want to mess anything up)

Thanks for any suggestions.
User Avatar
Member
28 posts
Joined: 12月 2018
Offline
No way, I am from the future 2022.
On Houdini 19.5 the problem is still there.
I have reported the bug.

Surely it will be fixed by 2030.
Edited by MarquisDeSang - 2022年9月5日 12:44:04
User Avatar
Member
27 posts
Joined: 3月 2021
Offline
same problem here
  • Quick Links