Houdini 19 Unity curve problem

   1623   6   0
User Avatar
Member
14 posts
Joined: June 2020
Offline
Hello i have various problems with curves after update to 19 (indie license) I am using object merge as input (worked in previous versions) but now i end up with something completely different then in Houdini after connecting the curve. And idea what is wrong and how to fix it?
Unity 2021.2.3f + Houdini 19.0.383
Edited by Gand - Nov. 28, 2021 16:58:32

Attachments:
hindie.steam_Fa89ftPk5W.png (23.6 KB)
hindie.steam_9MvmWmLeRI.png (456.6 KB)
Unity_1gl1sw37sF.png (113.6 KB)
Unity_TJt6eqGr6y.png (30.8 KB)
curves_test.hdalc (13.3 KB)

User Avatar
Staff
100 posts
Joined: Dec. 2020
Offline
Hi, I took a quick look at your HDA. If you close the curve, it should produce what you are expecting I believe. If this is not the case, let me know your exact reproduction steps.
User Avatar
Member
14 posts
Joined: June 2020
Offline
anthonyt2
Hi, I took a quick look at your HDA. If you close the curve, it should produce what you are expecting I believe. If this is not the case, let me know your exact reproduction steps.
Unfortunately it is not, it was first thing I checked. These error make my old tool incompatible with new version and I checked if it works on Houdini engine 18.

Attachments:
Unity_cThU3JROUT.png (233.0 KB)

User Avatar
Member
36 posts
Joined: March 2016
Offline
I have a same problem.
Unity 2021.1.28f
Houdini 19.0.383

I've struggled to handle this problem so much.
PolyExtrude node acts like it receives an open curve even if "Closed" parameter is checked in Unity.

Is this proper specification or glitch?

This is my workaround.
Edited by aoi36e - Nov. 30, 2021 23:56:02

Attachments:
スクリーンショット 2021-12-01 134502.png (19.1 KB)
スクリーンショット 2021-12-01 134519.png (19.5 KB)
スクリーンショット 2021-12-01 134530.png (27.8 KB)
スクリーンショット 2021-12-01 134545.png (45.1 KB)
スクリーンショット 2021-12-01 134809.png (209.6 KB)

User Avatar
Member
14 posts
Joined: June 2020
Offline
aoi36e
I have a same problem.
Unity 2021.1.28f
Houdini 19.0.383

I've struggled to handle this problem so much.
PolyExtrude node acts like it receives an open curve even if "Closed" parameter is checked in Unity.

Is this proper specification or glitch?

This is my workaround.

Thx for workaround it will work for now, but i hope they will fix it so my old graph will bo compatible.
User Avatar
Member
36 posts
Joined: March 2016
Offline
This problem is fixed in Houdini 19.0.455.

Thank you so much!
User Avatar
Member
14 posts
Joined: June 2020
Offline
I confirm, work after update, but it needs to reexport asset and Unity plugin. Thx developers. I think this thread can be closed.
  • Quick Links